Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: problemen met partitie 2  (gelezen 1033 keer)

jpl

  • Gast
problemen met partitie 2
« Gepost op: 2008/11/29, 12:43:00 »
Hallo,
Mijn probleem lijkt (denk ik) op dat de eerdere draad van Fonny. Vandaar dezelfde titel.
Mijn harde schijf heb ik (onder windows XP) opgedeeld in 2 partities.
Op de C: staat windows en programma's

op de 2e (f:) mijn documenten.
Op deze partitie heb ik ook Ubuntu 8.4 geïnstalleerd (gewoon volgens het installatieproces
op de CD).
In Ubuntu kan ik de C: schijf gewoon in.
De f: schijf is echter onvindbaar. Hier kom ik niet "hoger" dan de Ubuntu map.

Met windows kan ik gewoon naar de f: schijf gaan en werkt alles prima.

Wat is er mis?

Bedankt,
Johan

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: problemen met partitie 2
« Reactie #1 Gepost op: 2008/11/29, 12:45:06 »
Wat voor bestandssysteem heb je gebruikt op de F-schijf?

jpl

  • Gast
Re: problemen met partitie 2
« Reactie #2 Gepost op: 2008/11/29, 12:47:05 »
Wat voor bestandssysteem heb je gebruikt op de F-schijf?
NTFS

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: problemen met partitie 2
« Reactie #3 Gepost op: 2008/11/29, 16:48:35 »
Open eens de terminal (Hulpmiddelen - Terminal), voer het commando "sudo fdisk -l" uit en post het resultaat hier. Dan zal het voor ons misschien duidelijk worden en kunnen we je vertellen hoe de vork aan de steel zit.

jpl

  • Gast
Re: problemen met partitie 2
« Reactie #4 Gepost op: 2008/11/29, 20:18:49 »
Open eens de terminal (Hulpmiddelen - Terminal), voer het commando "sudo fdisk -l" uit en post het resultaat hier. Dan zal het voor ons misschien duidelijk worden en kunnen we je vertellen hoe de vork aan de steel zit.

Schijf /dev/sda: 160.0 GB, 160041885696 bytes
255 koppen, 63 sectoren/spoor, 19457 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0xd8bed8be

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1        6369    51158961    7  HPFS/NTFS
/dev/sda2            6370       19457   105129360    7  HPFS/NTFS

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: problemen met partitie 2
« Reactie #5 Gepost op: 2008/11/30, 10:55:46 »
Het gaat hier om een wubi installatie, t.t.z een installatie van Ubuntu in een Windows partitie. Als je eens de terminal opent en dan het commando "mount" geeft, kijk dan naar de lijntjes die beginnen met /dev/sda1 en /dev/sda2. Daarachter wordt dan het koppelpunt vermeldt. Dat is de weg waarlangs je de partitie kunt bereiken.

Als een partitie niet vermeld is, dan betekent dat dat hij niet gekoppeld is, en moet je hem vooralsnog koppelen om erop te kunnen (als dat nodig is).

jpl

  • Gast
Re: problemen met partitie 2
« Reactie #6 Gepost op: 2008/12/01, 19:24:58 »
Het gaat hier om een wubi installatie, t.t.z een installatie van Ubuntu in een Windows partitie. Als je eens de terminal opent en dan het commando "mount" geeft, kijk dan naar de lijntjes die beginnen met /dev/sda1 en /dev/sda2. Daarachter wordt dan het koppelpunt vermeldt. Dat is de weg waarlangs je de partitie kunt bereiken.

Als een partitie niet vermeld is, dan betekent dat dat hij niet gekoppeld is, en moet je hem vooralsnog koppelen om erop te kunnen (als dat nodig is).

met " mount" krijg ik volgens mij helemaal geen /dev/sda1 of dev/sda2.
hierbij wat ik wel krijg:
mount
/host/ubuntu/disks/root.disk on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
/dev/sda2 on /host type fuseblk (rw,nosuid,nodev,user_id=0,group_id=0,allow_other,blksize=4096)
lrm on /lib/modules/2.6.27-9-generic/volatile type tmpfs (rw,mode=755)
/host/ubuntu/disks/boot on /boot type none (rw,bind)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/janpiet/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=janpiet)
/dev/sdb1 on /media/disk type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

ik  heb nog geen idee hoe ik een koppelpunt moet maken, maar dat is waarschijnlijk
wel ergens op dit fantastische forum te vinden.
al vast bedankt
Johan

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: problemen met partitie 2
« Reactie #7 Gepost op: 2008/12/01, 19:57:20 »
Citaat
met " mount" krijg ik volgens mij helemaal geen /dev/sda1 of dev/sda2.
Goed kijken ;) :
/dev/sda2 on /host type fuseblk (rw,nosuid,nodev,user_id=0,group_id=0,allow_other,blksize=4096)
Dat is je tweede ntfs partitie op je eerste schijf, en dat is de partitie waarop je Windows geinstalleerd is, en waar dus ook je wubi Ubuntu op staat.

Je ziet dat die gemount is op /host. Je kan dus naar je Windows systeempartitie gaan kijken door in bestandsbeheer op "File System" te klikken (t.t.z.  de Nederlandse vertaling). Dat is de top, "root" van je bestandssysteem, aangeduid met "/". Daar vind je de directory "host", en als je die klikt zal je de vertrouwde inhoud van je Windows systeem zien (de "c:" schijf). ...nu ik je vraag herlees, zie ik dat je dat allemaal al wist ...

Je data partitie moet dan /dev/sda1 zijn (vind ik wat eigenaardig: ik zou denken dat Win op de eerste partitie staat). Die is niet aangekoppeld, want verschijnt niet in de output van mount. Kijk eens in "Computer": de partitie moet daar tussenstaan, en zou als je er probeert in te gaan, automatisch gekoppeld moeten worden.



jpl

  • Gast
Re: problemen met partitie 2
« Reactie #8 Gepost op: 2008/12/01, 21:35:36 »
Citaat
met " mount" krijg ik volgens mij helemaal geen /dev/sda1 of dev/sda2.
Goed kijken ;) :
/dev/sda2 on /host type fuseblk (rw,nosuid,nodev,user_id=0,group_id=0,allow_other,blksize=4096)
Dat is je tweede ntfs partitie op je eerste schijf, en dat is de partitie waarop je Windows geinstalleerd is, en waar dus ook je wubi Ubuntu op staat.

Je ziet dat die gemount is op /host. Je kan dus naar je Windows systeempartitie gaan kijken door in bestandsbeheer op "File System" te klikken (t.t.z.  de Nederlandse vertaling). Dat is de top, "root" van je bestandssysteem, aangeduid met "/". Daar vind je de directory "host", en als je die klikt zal je de vertrouwde inhoud van je Windows systeem zien (de "c:" schijf). ...nu ik je vraag herlees, zie ik dat je dat allemaal al wist ...

Je data partitie moet dan /dev/sda1 zijn (vind ik wat eigenaardig: ik zou denken dat Win op de eerste partitie staat). Die is niet aangekoppeld, want verschijnt niet in de output van mount. Kijk eens in "Computer": de partitie moet daar tussenstaan, en zou als je er probeert in te gaan, automatisch gekoppeld moeten worden.


Het is allemaal anders dan het lijkt, maar ik ben wel een stuk verder gekomen:
windows staat op C: en kan ik gewoon in
filesystem staat op F: of dev/sda2  de schijf waar de data op staat (+Ubuntu) hier kon ik niet inkomen maar via host lukt dat nu wel

Nu nog slechts 1 vraag. hoe kan ik nu gemakkelijker bij mijn data komen dan de enige manier waarop dat nu lukt
locaties-> computer -> bestandssyteem ->host

ontzettend bedankt, ik ben nog veel enthousiaster over Ubuntu geworden dan ik al was
(al moet ik nog wel heel veel leren)
Johan