Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 804 kan swap niet vinden  (gelezen 2819 keer)

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
804 kan swap niet vinden
« Gepost op: 2008/11/23, 12:43:01 »
In tegenstelling tot wat ik gewend ben komt er nu tekst voorbij bij het opstarten.
Ik kan net lezen dat ie de swapspace kwijt is en er wordt iets gemeld dat er verwarring is tussen hda0 en hda1.
Verder start het systeem gewoon op.

Ik weet wel waardoor het komt;
Mijn hele systeem lag in puin, heb vanuit een (acronis) backupimage alles weer teruggezet (aparte root en home partitie) en daarbij ook 'even' de partities bijgewerkt (de een wat groter etc.) waarbij de swap van de laatste naar een partitie tussenin is veranderd.

Wie kan me even helpen?
Hoe laat ik m 'n systeem weten waar de swappartitie is?
Hoe zet ik de opstarttekst stil.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #1 Gepost op: 2008/11/23, 12:47:00 »
De swap partitie wordt aangeduid in /etc/fstab
Kan je hiervan de inhoud even laten zien.
toepassingen > hulpmiddelen > terminal venster
gedit /etc/fstab
En vervolgens de uitkomst van het commando.
blkid

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #2 Gepost op: 2008/11/23, 12:59:50 »
Hallo, bedankt voor de reactie,
gedit /etc/fstab
geeft de volgende info;

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=4428510b-fa0b-d27e-97f3-09653c35afde /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda7
UUID=98255fba-72b3-e3db-2b89-c56f4722e9ce /home           ext3    relatime        0       2
/dev/sda8       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

#Added by diskmounter utility
/dev/sda1 /media/sda1 ntfs rw,user,fmask=0111,dmask=0000 0 0
#Added by diskmounter utility
/dev/sda6 /media/sda6 ntfs rw,user,fmask=0111,dmask=0000 0 0


blkid levert niets op (?)

o, wacht even;

<device DEVNO="0x0801" TIME="1227375735" UUID="5F5FF2DBAA327AF1" LABEL="No Escape" TYPE="ntfs">/dev/sda1</device>
<device DEVNO="0x0805" TIME="1227438087" LABEL="linuxroot" UUID="4428510b-fa0b-d27e-97f3-09653c35afde" TYPE="ext3">/dev/sda5</device>
<device DEVNO="0x0806" TIME="1227375735" TYPE="swap">/dev/sda6</device>
<device DEVNO="0x0807" TIME="1227375735" UUID="1361C106BF541F4F" LABEL="Escape" TYPE="ntfs">/dev/sda7</device>
<device DEVNO="0x0808" TIME="1227375735" LABEL="linuxhome" UUID="98255fba-72b3-e3db-2b89-c56f4722e9ce" SEC_TYPE="ext2" TYPE="ext3">/dev/sda8</device>
<device DEVNO="0x0700" TIME="1209067742" TYPE="squashfs">/dev/loop0</device>
« Laatst bewerkt op: 2008/11/23, 13:03:57 door GerardZZ »

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #3 Gepost op: 2008/11/23, 13:33:58 »

# /dev/sda5
UUID=4428510b-fa0b-d27e-97f3-09653c35afde /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda7
UUID=98255fba-72b3-e3db-2b89-c56f4722e9ce /home           ext3    relatime        0       2
/dev/sda8       none            swap    sw              0       0


blkid levert niets op (?)

o, wacht even;

<device DEVNO="0x0808" TIME="1227375735" LABEL="linuxhome" UUID="98255fba-72b3-e3db-2b89-c56f4722e9ce" SEC_TYPE="ext2" TYPE="ext3">/dev/sda8</device>

Goed, er vallen me hier 2 dingen op:
1) Je /dev/sda5 en sda7 zijn 'commented out' (met # voor dus, wat wil zeggen dat die regels genegeerd worden)? Vreemd, aangezien dat die je root en /home partities zijn
2) Met het commando blkid krijg je te zien dat /dev/sda8 linuxhome is met als formattering ext3. Aangezien in je fstab vermeld word dat /dev/sda8 je swap is, dan kan dit zeker geen ext3 zijn.
Het is duidelijk dat je ergens met een fout zit, en ik vrees dat een herinstallatie de enige (goede) oplossing zal zijn.
Wat je natuurlijk wel kan doen is een backup maken van je home en die na de herinstallatie grotendeels terugzetten. Normaal gezien kan je als je opstart via de Live-cd nog aan je schijven om data te kopiëren!

° Bezoek mijn blog Digital (in)Sanity °

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #4 Gepost op: 2008/11/23, 13:56:20 »
Hallo,
Ik zal me wat meer moeten inlezen om te snappen wat er te repareren valt.
Het systeem start op en doet wat ie moet doen, dus...
Alhoewel, als de swap wordt aangesproken moet ie er wel zijn.
Zo te zien geeft blkid de situatie nu aan en de fstab zoals de situatie was in de teruggezette image.
De fstab klopt dus niet.
sda 6-7-8 liggen door elkaar.

Kan ik niet de regels voor 6-7-8 corrigeren naar de nieuwe situatie in een nieuwe fstab?
(Ik heb al vast in 'media' een map gemaakt sda7 en sda6 weggehaald).

Overigens staat al m 'n data op de ntfs op sda6(oud) sda7(nieuw)

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #5 Gepost op: 2008/11/23, 15:26:38 »
Ik heb er een nieuwe fstab ingezet;

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=4428510b-fa0b-d27e-97f3-09653c35afde /               ext3    relatime        0       1
# /dev/sda8
UUID=98255fba-72b3-e3db-2b89-c56f4722e9ce /home           ext3    relatime        0       2
/dev/sda6       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

#Added by diskmounter utility
/dev/sda1 /media/sda1 ntfs rw,user,fmask=0111,dmask=0000 0 0
#Added by diskmounter utility
/dev/sda7 /media/sda7 ntfs rw,user,fmask=0111,dmask=0000 0 0

Bij de opstart deed ie fsck check forced van / en /home.
Swap had ie gevonden, zo te zien.

Zou het probleem zijn verholpen!? Lijkt er wel op...

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #6 Gepost op: 2008/11/23, 23:02:34 »
Weet iemand misschien hoe ik van die stroom van tekst afkom tijdens de opstart?
Het is niet het belangrijkste, maar een ubuntulogo met voortgangsbalk is toch mooier :-)

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #7 Gepost op: 2008/11/24, 10:56:04 »
Laat de inhoud van /boot/grub/menu.lst eens zien

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #8 Gepost op: 2008/11/24, 13:24:31 »
Wanneer ik in de opstartmanager tussen tekst of splash kies verandert er niets.
Wel als ik in menu.lst quiet splash (en splash in kernelregel) verander in noflash, dan heb ik alles tijdens de opstart in tekst.
Met quiet splash zie ik een keer even het logo en niet de tweede keer met voortgangsbalk, die is dan in tekst.

Denk dat het een ubuntubug is, maar als je nog een idee hebt hoor ik dat natuurlijk graag.



# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      2

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
color red/black blink-green/black

#A splash image for the menu
#splashimage=(hd0,4)/boot/grub/splashimages/ABSTRACT-WaterVapor_1280x1024.xpm.gz

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,4)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=false

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 8.04.1, kernel 2.6.24-19-generic
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.24-19-generic root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro quiet splash
initrd      /boot/initrd.img-2.6.24-19-generic
quiet

title      Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.24-19-generic root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro single
initrd      /boot/initrd.img-2.6.24-19-generic

#title      Ubuntu 8.04.1, memtest86+
#root      (hd0,4)
#kernel      /boot/memtest86+.bin
#quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1


Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #9 Gepost op: 2008/11/24, 18:10:24 »
Het probleem ligt hem denk ik bij de swap partitie die verhuist is.
Ubuntu kijkt bij het opstarten naar de swap partitie om te zien of hierop een slaapstand image file staat.

De fix vind je op https://bugs.launchpad.net/ubuntu/+source/usplash/+bug/205990
Citaat van: lauchpad
. Make sure you have the initramfs-tools update
 2. sudo blkid
 3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
 4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
 5. sudo update-initramfs -u
 6. Restart

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #10 Gepost op: 2008/11/24, 19:48:12 »
Als ik het goed begrijp moet de UUID die ik met sudo blkid vind in de fstab en de /etc/initramfs-tools/conf.d/resume terugkomen.
Ik heb geen UUID voor de swap!
Als ik in /etc/initramfs-tools/conf.d/resume de UUID vervang door none maakt dat geen verschil....




gvdvd@gvdvd-desktop:~$ sudo blkid
/dev/sda1: UUID="5F5FF2DBAA327AF1" LABEL="No Escape" TYPE="ntfs"
/dev/sda5: LABEL="linuxroot" UUID="4428510b-fa0b-d27e-97f3-09653c35afde" TYPE="ext3"
/dev/sda6: TYPE="swap"
/dev/sda7: UUID="1361C106BF541F4F" LABEL="Escape" TYPE="ntfs"
/dev/sda8: LABEL="linuxhome" UUID="98255fba-72b3-e3db-2b89-c56f4722e9ce" SEC_TYPE="ext2" TYPE="ext3"


# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=4428510b-fa0b-d27e-97f3-09653c35afde /               ext3    relatime        0       1
# /dev/sda8
UUID=98255fba-72b3-e3db-2b89-c56f4722e9ce /home           ext3    relatime        0       2
/dev/sda6       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

#Added by diskmounter utility
/dev/sda1 /media/sda1 ntfs rw,user,fmask=0111,dmask=0000 0 0
#Added by diskmounter utility
/dev/sda7 /media/sda7 ntfs rw,user,fmask=0111,dmask=0000 0 0

/etc/initramfs-tools/conf.d/resume
RESUME=UUID=8c577f36-9bf1-4624-b7d7-c68cccf6d55e

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #11 Gepost op: 2008/11/24, 19:52:26 »
Je kan in /etc/initramfs-tools/conf.d/resume ook de partitie zetten.
bv
RESUME=/dev/sda6

Maar ik vind het raar dat die /dev/sda6 geen uuid heeft...

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #12 Gepost op: 2008/11/24, 20:34:53 »
Ik heb RESUME=/dev/sda6 erin gezet, geen verschil.
Ik zet wel nosplash in menu.lst ziet er wel nostalgisch uit :-)

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #13 Gepost op: 2008/11/24, 21:18:01 »
Ik kan even niet volgen nosplash?

Anyway laat nu eens de volledige inhoud van  /etc/initramfs-tools/conf.d/resume en /boot/grub/menu.lst zien.

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #14 Gepost op: 2008/11/24, 21:50:21 »
Ik bedoel nosplash in grub, opstarten met alleen tekst.

Hier is tie;

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      2

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
color red/black blink-green/black

#A splash image for the menu
#splashimage=(hd0,4)/boot/grub/splashimages/ABSTRACT-WaterVapor_1280x1024.xpm.gz

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,4)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=nosplash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=false

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 8.04.1, kernel 2.6.24-19-generic
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.24-19-generic root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro nosplash
initrd      /boot/initrd.img-2.6.24-19-generic
quiet

title      Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.24-19-generic root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro single
initrd      /boot/initrd.img-2.6.24-19-generic

#title      Ubuntu 8.04.1, memtest86+
#root      (hd0,4)
#kernel      /boot/memtest86+.bin
#quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1



en de /etc/initramfs-tools/conf.d/resume;

RESUME=/dev/sda6


Hier stond RESUME=UUID=8c577f36-9bf1-4624-b7d7-c68cccf6d55e
Ik heb deze nog eens teruggezet en ook in de fstab gezet en geherstart.
Maar daar trapt het systeem niet in :-)
In rood komt iets voorbij dat de swap niet gevonden is en het probleem (of schoonheidsfoutje) blijft.
Wel eigenaardig is ook een korte groene flits net na 'starting up' net voor het ubuntu logo opkomt.
Deed me even denken aan wat ik wel eens bij een pupy opstart zie, een nvidialogo.
Is misschien wat tever gezocht.

Hier staat ook nog een en ander over een soortgelijk geval;
http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2008-08/msg01913.html

Als ik (3) fix /etc/initramfs-tools/conf.d/resume in terminal ingeef is het antwoord,
bash: fix: opdracht niet gevonden
(ik ben niet echt handig met dit soort dingen...).

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #15 Gepost op: 2008/11/24, 23:10:21 »
Ik zal eens overlopen wat er stap voor stap moet gebeuren.

1) Vervang in /boot/grub/menu.lst
kernel      /boot/vmlinuz-2.6.24-19-generic root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro nosplash
door
kernel      /boot/vmlinuz-2.6.24-19-generic root=UUID=4428510b-fa0b-d27e-97f3-09653c35afde ro quiet splash

2)Zorg dat in je fstab terug /dev/sda6 staat voor de swap. Controleer dit ook door even te herstarten en te kijken of in systeem > beheer > systeem monitor, de swap partitie een grote heeft.

3)Zorg dat in /etc/initramfs-tools/conf.d/resume enkel volgend lijntje staat
RESUME=/dev/sda6

4)Voer het volgende commando uit.
sudo update-initramfs -u

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #16 Gepost op: 2008/11/24, 23:31:12 »
Dat laatste is ook geen commando. Er staat dat je de goede gegevens in dat bestand moet zetten, en daarna het commando "sudo update-initramfs -u" moet uitvoeren.

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #17 Gepost op: 2008/11/25, 08:26:41 »
gvdvd@gvdvd-desktop:~$ sudo update-initramfs -u
[sudo] password for gvdvd:
update-initramfs: Generating /boot/initrd.img-2.6.24-21-generic

en na even geduldig gewacht te hebben,
na herstart;
gvdvd@gvdvd-desktop:~$ sudo blkid
/dev/sda1: UUID="5F5FF2DBAA327AF1" LABEL="No Escape" TYPE="ntfs"
/dev/sda5: LABEL="linuxroot" UUID="4428510b-fa0b-d27e-97f3-09653c35afde" TYPE="ext3"
/dev/sda6: TYPE="swap"
/dev/sda7: UUID="1361C106BF541F4F" LABEL="Escape" TYPE="ntfs"
/dev/sda8: LABEL="linuxhome" UUID="98255fba-72b3-e3db-2b89-c56f4722e9ce" SEC_TYPE="ext2" TYPE="ext3"
gvdvd@gvdvd-desktop:~$

Jammer, maar het werkt dus niet.
Ik denk dat de swapUUID pas gegenereert wordt bij de update van een nieuwe kernel, of een herinstallatie natuurlijk.
Bedankt voor het meedenken!

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #18 Gepost op: 2008/11/25, 17:09:04 »
Zie je eigenlijk een grote voor de swap partitie in systeem > beheer > systeem monitor.

Het is vanop afstand moeilijk te bepalen waar de fout zit, dat het te maken heeft met de swap partitie is voor mij redelijk duidelijk.

Offline GerardZZ

  • Lid
  • Steunpunt: Nee
Re: 804 kan swap niet vinden
« Reactie #19 Gepost op: 2008/11/25, 18:40:53 »
De swap doet het gewoon hoor.
Wordt vermeld in Systeemmonitor, 533,4 MiB.
Soms geeft hij ook aan dat er een tiental MB's van worden gebruikt.
Ach, het werkt, en als er nog 's een kernelupdate voor 804 komt zal ik eens kijken of de quietsplash het weer doet.