Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: mad-wifi wil niet builden  (gelezen 533 keer)

Charlo

  • Gast
mad-wifi wil niet builden
« Gepost op: 2008/11/18, 13:19:47 »
Daarnet wou ik na een kernel-update madwifi terug installeren, maar ik krijg dit:

charlo@mobile:~$ cd madwifi-ng-r2756+ar5007
charlo@mobile:~/madwifi-ng-r2756+ar5007$ make
cd: 1: can't cd to /lib/modules/2.6.24-21-rt/build
Makefile.inc:66: *** /lib/modules/2.6.24-21-rt/build is missing, please set KERNELPATH.  Stop.
charlo@mobile:~/madwifi-ng-r2756+ar5007$

Ik heb het al nagekeken in Synaptic, en build-essentials is wel degelijk geïnstalleerd. Heb voor de zekerheid een reinstall gedaan,
maar ook dat hielp niet.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: mad-wifi wil niet builden
« Reactie #1 Gepost op: 2008/11/18, 13:26:31 »
Hé Charlo, je moet de kernel headers installeren via Synaptic. Zie dat je de realtime kernel gebruikt, dan moet je ook de daarbijbehorende kernel headers installeren.
En voor de zekerheid een herinstallatie doen is echt zonde van je tijd!

Charlo

  • Gast
Re: mad-wifi wil niet builden
« Reactie #2 Gepost op: 2008/11/18, 13:34:28 »
Neenee, niet het hele systeem herinstalleren, maar de build-essentials.
Ik zit nou op kernel 2.6.24-21 en alles met rt is ook aangeduid, dus volgens mij kan het dat niet zijn.
Of moeten àlle kernelheaders van een bepaalde kernel geïnstalleerd worden?

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: mad-wifi wil niet builden
« Reactie #3 Gepost op: 2008/11/18, 13:43:12 »
linux-headers-2.6.24-21-rt moet je hebben. Is die geïnstalleerd?

Charlo

  • Gast
Re: mad-wifi wil niet builden
« Reactie #4 Gepost op: 2008/11/18, 14:15:55 »
Yup, die heb ik.

Even een recap van de laatste 15 minuten:
Nadat ik de restricted drivers had uitgeschakeld, wou madwifi wel builden. resetje gedaan, wlan kaart werd herkend door het systeem (iwconfig) maar niet door de netwerk monitors. Die liepen er namelijk op vast.
Op den duur wilden ook andere programma's (opera, firefox, etc) niets meer doen, juist een terminalvenster werkte nog. Op één of andere manier ben ik er in geslaagd om madwifi te corrumperen, en na een reset werkte alles weer als vanouds (kind of).

Voorlopig dan maar geen wifi.