Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Geen beeld in Xubuntu  (gelezen 1712 keer)

Offline petervs

  • Lid
  • Steunpunt: Nee
[opgelost] Geen beeld in Xubuntu
« Gepost op: 2008/11/16, 21:06:00 »
Ik heb xubuntu 8.10 geïnstalleerd, maar ik krijg geen beeld. Indicatielampje van het crt-scherm wordt dan inactief (oranje). Met ctrl+alt+f1 enz. kom ik wel in 'n ander scherm, maar dan geen beeld dus, indicatielampje van 't scherm wordt dan weer groen.
Intern geheugen is 256MB, kaart is intel 82815 (i815).
Feisty heeft hierop 'n tijd gewerkt en dat ging redelijk met goed beeld.
Ik kreeg met de livecd van ubuntu 8.04 en xubuntu 8.04 ook al geen beeld. (wel met de livecd van 7.04 goed beeld).
« Laatst bewerkt op: 2008/11/27, 11:25:06 door petervs »
Ubuntu MATE 16.04

Offline visser

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #1 Gepost op: 2008/11/17, 10:51:59 »
Je kan misschien eens met feisty cd opstarten en je xorg.conf van feisty wanneer alles goed staat, over dat van je 8.10 plakken. Wel eerst je 8.10 xorg.config backuppen. Als het niet werkt je back-up terug zetten. Je moet dit wel met rootrechten doen. Dus gksudo nautilus naar je xorg.config van feisty navigeren (etc/x11/xorg.config) en dan gewoon copy/paste naar je 8.10.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #2 Gepost op: 2008/11/17, 11:04:31 »
Ik heb xubuntu 8.10 geïnstalleerd, maar ik krijg geen beeld. Indicatielampje van het crt-scherm wordt dan inactief (oranje). Met ctrl+alt+f1 enz. kom ik wel in 'n ander scherm, maar dan geen beeld dus, indicatielampje van 't scherm wordt dan weer groen.
Intern geheugen is 256MB, kaart is intel 82815 (i815).
Feisty heeft hierop 'n tijd gewerkt en dat ging redelijk met goed beeld.
Ik kreeg met de livecd van ubuntu 8.04 en xubuntu 8.04 ook al geen beeld. (wel met de livecd van 7.04 goed beeld).


Verhoog de hoeveelheid toegewezen RAM-geheugen voor de videokaart eens, in het BIOS? Het Intel-kaartje werkt namelijk met gedeeld geheugen. 128 MB is ideaal, maar je hebt slechts 256 MB RAM. Dus zet het kaartje in het BIOS eens op 64 MB.

Overigens: overweeg eens om er wat RAM-geheugen bij te prikken.... Kost niet veel meer en helpt enorm in de prestaties.

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #3 Gepost op: 2008/11/17, 22:17:41 »
Pjotr : Ik heb in het bios gekeken en het kaartje in de bios stond al op 64MB ( kon kiezen uit 32MB en 64MB). Ik heb er 128MB geheugen bijgezet maar deze wordt niet herkend, ook niet als ik ze omwissel.

visser :Met gksudo nautilus kan ik wel de xorg.conf kopiëren van 7.04 maar niet plakken in 8.10. Ik heb in 8.10 geen rechten,ik kan het zelfs niet naar de home map kopiëren.

Overigens beiden bedankt voor de reactie en suggesties.
Ubuntu MATE 16.04

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #4 Gepost op: 2008/11/17, 22:40:48 »

Met gksudo nautilus kan ik wel de xorg.conf kopiëren van 7.04 maar niet plakken in 8.10. Ik heb in 8.10 geen rechten,ik kan het zelfs niet naar de home map kopiëren.

Misschien weet je dit al maar in 8.10 moet je ook de xorg.conf openen met gksudo nautilus en dan pas 'Plakken'
En anders zet je het op een usb of cd(-rw)

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #5 Gepost op: 2008/11/18, 19:42:52 »
Het geheugen bijplaatsen is gelukt, had het niet goed aangedrukt :|
Dat heeft echter niets veranderd aan de situatie.

Alle ubuntu/xubuntu versies vanaf 8.04 geven geen beeld, nadat de gekleurde balk vol is wordt het scherm zwart.

Ik kan met de live-cd van 7.04 en 7.10 wel gksudo nautilus uitvoeren, maar ik kan/weet niet hoe dat moet met de geïnstalleerde xubuntu 8.10.
Wat heb ik geprobeerd: Locaties > Computer > en dan mount ik de partitie (denk ik dan). Maar ik kan niet in de terminal. Met alt+F2 en optie uitvoeren in de terminal met commando "gksudo nautilus" kom ik weer in de bestandstructuur van de live-cd.
Ik snap dat niet.

Ubuntu MATE 16.04

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #6 Gepost op: 2008/11/19, 00:15:15 »
Ctrl+Alt+Backspace misschien (herstarten van de X als ik me niet bedrieg)
Of met:  Ctrl+Alt+F7  (dan kom je normaal in je grafische omgeving)

Offline visser

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #7 Gepost op: 2008/11/19, 00:27:23 »
petervs ik heb het zelf effe getest met een gutsy live-cd en je hebt gelijk, standaard kan je niet schrijven op je geinstalleerd systeem. Op de manier die ik het had uitgelegd werkt het niet, sorry daarvoor. Eerst moeten de rechten verhoogd worden op je partitie.
Koppel eerst je schijf aan via places computer en dan op je schijf dubbelklikken en sluit daarna deze map. Nu geef je in de terminal het commando gksudo nautilus in. Dan browse je naar bestandssysteem/media. Hierin zie je je schijf staan als disk waarschijnlijk. Klik hier rechts op en ga naar properties permissions. De eigenaar verander je naar live-sessionuser en file acces zet je op read en write. Ik weet niet of dit genoeg is maar ik had alles op read en write gezet. Nu kopieer je eerst je xorg.config van je 8.10 en schrijf deze ergens veilig weg, zodanig dat je er later terug bij kan als je het bestand terug nodig hebt. Nu ga je terug naar bestandsysteem van de je gutsy live sessie en kopiëer dan je gutsy xorg.config. Navigeer dan terug naar media/disk/etc/x11 en nu kan je wel plakken. Dan naar terminal gaan en exit intypen, schijf terug unmounten en herstarten naar 8.10.  Als je in 8.10 nu nog geen beeld krijgt, kan je je backup via de live-cd weer terug zetten.

Veel Succes.

Offline visser

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #8 Gepost op: 2008/11/19, 00:43:12 »
Je kan ook zoals heir4c enkele posts geleden zei via een usb disk werken. Gewoon je xorg.config naar een usbstick plakken en daarna met een puppy-cd van je stick naar je intrepid plakken nadat je eerst een back-up gemaakt hebt. Met puppy heb je altijd rootrechten.

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #9 Gepost op: 2008/11/19, 20:37:40 »
Bedankt voor de duidelijke uitleg! Het is gelukt om mijn xorg.conf bestand over te zetten van 7.10 naar 8.10 en na herstarten krijg ik het inlogscherm, dus dat is goed!

Echter na het inloggen krijg ik het volgende probleem, er verschijnt 'n bericht:

Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem.

View details ( ~/.xsession-errors file) geeft het volgende:
/etc/gdm/Xsession: Beginning session setup
Setting IM through im-switch for locale=nl_NL
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default
mkdtemp : private socket dir : Permission Denied

Na het eerste sudo commando kreeg ik dit bericht:  /etc/sudoers is mode 0666, should be 0440
(opgelost in recoverymode met: chmod 0440 /etc/sudoers)

Toen heb ik het volgende gedaan:
sudo chown peter:peter /home/peter
sudo chown 755 /home/peter

Wat kan ik verder doen?  (de foutmelding komt nog steeds)


« Laatst bewerkt op: 2008/11/19, 20:47:15 door petervs »
Ubuntu MATE 16.04

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #10 Gepost op: 2008/11/19, 21:05:13 »
OPGELOST!

Ik ben blij! Dit commando heeft het opgelost: sudo chmod a+w /tmp

Al met al weer 'n hoop bijgeleerd.

Bij deze allen bedankt voor het meedenken en de aangedragen oplossingen.

Mvg Peter
Ubuntu MATE 16.04

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #11 Gepost op: 2008/11/19, 22:42:51 »
Jij blij, wij blij, iedereen blij  =D

Offline visser

  • Lid
  • Steunpunt: Nee
Re: Geen beeld in Xubuntu
« Reactie #12 Gepost op: 2008/11/19, 23:37:21 »
Fijn dat het uiteindelijk toch nog gelukt is. Misschien geen slecht idee om deze xorg.config ergens te backuppen voor later want je weet maar nooit.