Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 2 Videokaarten, een probleem dus.  (gelezen 3374 keer)

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Gepost op: 2006/09/11, 15:37:28 »
Ik had al eerder een topic gemaakt, omdat mijn Ubuntu niet opstarte. Maar nu heb ik dus een ander probleem. Dat over hetzelfde onderwerp gaat.

Ik heb dus 2 videokaarten (1 onboard, en 1 is een NVIDIA RAVE TNT2). De onboard videokaart staat als standard ingestelt op ubuntu, op de pci@01:00.0. Mijn NVIDIA Videokaart staat op pci@01.0b.0.

Het was een heel gedoe om het te laten werken. Ik moest in Bios mijn NVIDIA kaart uitschakelen, En onboard kaart inschakelen. Om ubuntu te laten doen, (Want hij werkte niet met de NVIDIA kaart)

Wat ik dus wil, is dat mijn ubuntu werkt via de NVIDIA videokaart, in plaats van mijn onboard videokaart.

Naar mijn vermoede, moet ik nu dus weer in Bios de NVIDIA kaart inschakelen, en Onboard kaart uitschakelen. En moet ik sudo dpkg-reconfigure xserver-xorg opstarten. Waarbij ik bij mijn 2e configuratie de nv Driver moet selecteren (in plaats van i814), en bij de 4e configuratie pci@01.0b.0 moet intypen (in plaats van de standard pci@01:00.0).

Maar om te voorkomen dat ik iets verkeerd doe, wou ik het vragen of dit goed zou zijn?
En hoe ik precies de pci@01.0b.0 moet neerzetten bij de 4e configuratie. (Want nu staat daar: PCI:0:1:0)

Mijn eerdere topic: http://forum.ubuntu-nl.org/topic/3372/1 (Wat ik dus nu wel tewerk kreeg, aleen dan op de onboard videokaart)

Alvast bedankt!
Met vriendelijke groeten,
Thanatios

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
2 Videokaarten, een probleem dus.
« Reactie #1 Gepost op: 2006/09/11, 18:13:06 »
@ Thanatios, ik heb je draadje verplaatst naar hier omdat dit een hardware probleempje is.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

blubber

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #2 Gepost op: 2006/09/11, 18:22:58 »
Wat zegt
lspci -X | grep TNT
cat /ect/X11/xorg.conf | grep BusID
?

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #3 Gepost op: 2006/09/11, 19:10:00 »
Ja sorry voor de fout. Ookal vind ik mezelf nogsteeds een beginner. Maarja :P
Bedankt voor de verplaatsing.

@blubber

Bedankt voor je antwoord!

Als ik lspci -X | grep TNT doe, krijg ik:
PCI:1:11:0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]

Heel raar...

En als ik cat /ect/X11/xorg.conf | grep BusID doe, krijg ik:
cat: /ect/X11/xorg.conf: Onbekend bestand of map

Ookal weet ik toch zeker dat mijn beeldscherm nu op de onboard videokaart is ingeplugt en ik de forum nu bekijk via die videokaart. O.o

Enige suggesties?

blubber

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #4 Gepost op: 2006/09/11, 19:19:21 »
Doh, mijn fout, sorrie!
Dat moet natuurlijk
cat /etc/X11/xorg.conf | grep BusIDzijn.

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #5 Gepost op: 2006/09/11, 21:16:28 »
natali@ubuntu:~$ cat /etc/X11/xorg.conf | grep BusID
        BusID           "PCI:0:1:0"

Zo, nu doet ie het wel.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
2 Videokaarten, een probleem dus.
« Reactie #6 Gepost op: 2006/09/11, 21:28:26 »
probeer eens om via
sudo dpkg-reconfigure xserver-xorg

de nv driver te kiezen
en bij BusID PCI:1:11:0 te nemen

succes he :)
ik heb nog geen ervaring met meerdere vidkaarten
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

blubber

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #7 Gepost op: 2006/09/11, 21:31:27 »
Ok, eerst even een back-up maken van xorg.conf
cp /etc/X11/xorg.conf /etc/X11/xorg.conf-buen dan kun je de TNT2 drivers zo installeren (ik geloof dat die de legacy driver nodig heeft):
sudo apt-get install nvidia-glx-legacy nvidia-kernel-common
sudo nvidia-glx-config enable
Xorg aanpassen
sudo gedit /etc/X11/xorg.confMijn device setcion:
Section "Device"
        Identifier      "NVIDIA Corporation NV43 [GeForce 6600 GT]"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
Bij jou zou dat "PCI:1:11:0" moeten zijn.

Alle programma's afsluiten, ctrl+alt+backspace indrukken en opnieuw inloggen.

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #8 Gepost op: 2006/09/11, 22:51:00 »
Yap, het is gelukt, hartstikke bedankt!

Aleen, het probleem nu is, dat opeens mijn Internet het niet meer doet O.o
Netwerk kaart zit er wel gewoon goed in. Kan ik niet mijn internet verbinden opnieuw checken, zo als toen ik Ubuntu instaleerde?

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
2 Videokaarten, een probleem dus.
« Reactie #9 Gepost op: 2006/09/11, 23:02:15 »
Zijn je instellingen nog goed in Systeem->beheer->netwerk ?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #10 Gepost op: 2006/09/11, 23:09:59 »
Dat weet ik dus niet, omdat ik niet eens wist hoe ze waren. Kan ik het niet gewoon opnieuw dedecteren?

frans van der star

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #11 Gepost op: 2006/09/11, 23:42:28 »
Thanatios,

Ik ben een nieuweling. Dit is alleen een suggestie:

wat je kunt doen is dit in Konsole onder System Tools:
wget http://(internetadres) typen en kijken wat ie geeft.

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #12 Gepost op: 2006/09/12, 00:00:19 »
Na, ik ging gewoon naar netwerk, en liet m daar weer vinden. hij doet het nu prima.

Maar bedankt he jongens!

Nu heb ik dus nog maar 1 vraag over. En dat is of ik Compiz kan runnen op een:
Pentium 3 800 MHZ PC
512 MB RAM
NVIDIA RAVE TNT2

Zou het laggen? Of denk je dat ik problemen erme zal hebben?

Alvast bedankt.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
2 Videokaarten, een probleem dus.
« Reactie #13 Gepost op: 2006/09/12, 00:13:43 »
Je kan het wel runnen, maar ik kan niet garaneren dat het vlot zal lopen :) op mijn Nvidia Geforce 3 ti 200 loopt het best wel vlot, divx/xvid video met gl2 output gaat ook, maar andere video output of grote DVD films spelen te traag af

maarja, ik heb altijd een aparte X sessie voor films/games ;)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #14 Gepost op: 2006/09/12, 00:21:08 »
Ik vind het maar raar, dat het "vlot" loopt bij jouw O.o
Bij mij is het namelijk zo, dat alles al zo-wie-zo lagt. Alles gaat beetje sloom. Als hij opstart, ist bijna hetzelfde als in windows. Je moet nog even wachten voor hij GAIM heeft opgestart. En de Firefox browser start ook pas its van 5 seconde na dat ik erop heb geclickt.

Ik heb dus ook beetje lopen googlen, en vroeg me af of ik kan kijken, of 1 van de volgende dingen aan staan:

3d video acceleration (Geen idee of mijn ouderwetse videokaart dit support)
DMA

Want volgens mij kan het daaraan liggen.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
2 Videokaarten, een probleem dus.
« Reactie #15 Gepost op: 2006/09/12, 00:30:21 »
dat wachten tot iets opstart ligt niet aan je grafische kaart, maar eerder aan je processor, maar 800mhz zou wel voldoende moeten zijn..

3D video acceleratie nakijken:
glxinfo | grep direct

DMA op je HD nakijken:
(als je harde schijf /dev/hda is)
sudo hdparm /dev/hda | grep using_dma
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Thanatios

  • Gast
2 Videokaarten, een probleem dus.
« Reactie #16 Gepost op: 2006/09/12, 00:50:06 »
Ik ben eens even op een andere PC gegaan, Hier heb ik nu een GeForce FX 5600 Videokaart staan. Die hoort toch wel 3D video acceleratie te hebben.

Maar blijkbaar hierzo staat hij niet aan (De computer waaraan ik eerst werkte staat in mijn moeders kamer, en die is dus gaan slapen nu).

thanatios@thanatios-desktop:~$ glxinfo | grep direct
direct rendering: No
thanatios@thanatios-desktop:~$ sudo hdparm /dev/hda | grep using_dma
Password:
 using_dma    =  1 (on)

Dma staat blijkbaar wel aan. Maar Direct Rendering niet. Enig idee hoe ik die aan krijg?

Alvast bedankt

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
2 Videokaarten, een probleem dus.
« Reactie #17 Gepost op: 2006/09/12, 01:10:17 »
Je moet dan de nvidia-glx driver installeren voor een geforce fx (nvidia-glx-legacy voor een TNT2)

die levert men niet standaard vanwege een of ander licentieprobleem :(

* extra repositories toevoegen
terminal manier
Citaat
sudo gedit /etc/apt/sources.list
je krijgt nu een tekstbewerker met een bestand in:
zorg ervoor dat de lijnen waar de woorden restricted, universe, multiverse in voorkomen GEEN # voor de lijn hebben staan (verwijder die #)

opslaan en tekstbewerker sluiten

typ nog dit laatste commando om alles opnieuw in te lezen:
sudo apt-get update
of grafische manier
Citaat
open Synaptic via Systeem -> Beheer -> Synaptic pakketbeheer en schakel alle pakketbronnen in:
Citaat
Kies hier Pakketbronnen in het Instellingen-menu.

Je ziet nu een lijst met pakketbronnen. Klik op Settings, en vink dan Show disabled software sources. Klik dan op Sluiten.

Nu zie je naast de pakketbronnen aanvinkhokjes staan. Scroll nu naar beneden en schakel de Universe pakketbron in door de aanvinkhokjes naast de Door de gemeenschap beheerd (Universe) bronnen aan te vinken.

Om de Multiverse en restricted pakketbronnen in te schakelen, zul je bij elke Universe bron wat toe moeten voegen. Selecteer hiervoor een Universe bron, en klik op Bewerk. Bij Sections verander je nu universe in universe multiverse restricted. Dit doe je bij elke Universe bron. Als je klaar bent, klik je op OK om de instellingen toe te passen.

Nu zul je nog de nieuwe pakketbronnen in moeten laden, klik hiervoor op Herladen bovenin het scherm.
* nvidia-glx en nvidia-kernel-common installeren
terminal manier
Citaat
sudo apt-get install nvidia-glx nvidia-kernel-common
of grafische manier
Citaat
zoek in synaptic naar nvidia-glx en nvidia-kernel-common, vink ze allebei aan voor installatie (rechtermuisknop -> markeren voor installatie) en klik op de grote knop Toepassen bovenaan.
* nvidia driver inschakelen
terminal manier
Citaat
sudo nvidia-glx-config enable
of: grafische manier
Citaat
Geen -- De terminalmanier is hier sterk aanbevolen, omdat je bij een eventuele grafische manier geen foutmelding krijgt wanneer het misloopt!!
* X herstarten
terminal manier
Citaat
sudo /etc/init.d/gdm restart
of: grafische manier
Citaat
druk gewoon op Ctrl+Alt+Backspace -- dit werkt in de meeste gevallen wel
**************

Probeer na het opnieuw opstarten van de grafische desktop het commando nog eens om te kijken of je video acceleratie hebt (direct rendering)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)