Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Bestand openen  (gelezen 3570 keer)

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Gepost op: 2008/11/01, 21:05:08 »
Als ik inlog op mijn NAS over het internet, dan krijg ik toegang tot al mijn mappen. Als ik PDF bestanden open geeft dat geen probleem. Text bestanden vraagt om een wachtwoord, als ik dat intik opent document prima. Allen open office bestanden willen niet open na ingeven wachtwoord. Iemand een idee wat hier gaande is?
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Bestand openen
« Reactie #1 Gepost op: 2008/11/01, 21:11:44 »
Dat lijkt mij een rechten probleem, wie is de eigenaar van deze files ?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #2 Gepost op: 2008/11/01, 21:18:41 »
ik ben de eigenaar. heb alle rechten hetzelfde staan op alle documenten. Zoals ik al zei pdf's gaan zonder problemen, txt files met wachtwoord gaat ook prima. ik vraag me alleen af waarom hij wachtwoord vraag. Doc files gaan niet. Ik log in onder SSH (sftp)
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #3 Gepost op: 2008/11/01, 22:15:43 »
Probeer je ze remote te openen met OOo ??
Of met MS office ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #4 Gepost op: 2008/11/01, 22:18:16 »
Remote with OO.

Niets met open office wil geopend worden. Doc, odt ppt, niets helemaal niets.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #5 Gepost op: 2008/11/02, 03:02:57 »
Hmz duister ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline rja

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #6 Gepost op: 2008/11/02, 07:42:49 »
Als je de file kopieert naar de Linux machine.

Werkt het dan wel ?

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #7 Gepost op: 2008/11/02, 09:30:31 »
Ja als ik hem kopieer gaat het prima, geen enkel probleem.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #8 Gepost op: 2008/11/02, 11:34:25 »
Je geeft wat weinig informatie, en door zo'n algemene topic titel zullen weinig mensen het lezen. Met wat voor systeem log je in op je NAS? Een linux machine? Opende je tekstbestanden en Open Office documenten beide met openOffice? Opende ze je vanuit Nautilus of rechtstreeks? Misschien moet je NAS schijf eerst mounten, ik weet niet of je anders afhankelijk bent van de sftp capaciteiten van individuele applicaties.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #9 Gepost op: 2008/11/02, 11:55:06 »
Linux machine Ubuntu 8.04.

Verbind met netwerk via nautilus ssh (sftp). Directorie op de NAS is gemount.

Alles werkt prima, alleen als ik met iets met open office wil open, gaat het mis. De rest pdf's en text files zonder open office gaat prima.

Open Office is hier het probleem.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline rja

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #10 Gepost op: 2008/11/02, 12:10:24 »
Citaat van: flyerman
Linux machine Ubuntu 8.04.

Verbind met netwerk via nautilus ssh (sftp). Directorie op de NAS is gemount.

Alles werkt prima, alleen als ik met iets met open office wil open, gaat het mis. De rest pdf's en text files zonder open office gaat prima.

Open Office is hier het probleem.
Krijg je nog foutmeldingen als open office van de commandline opstart en dan zo´n document opent ? .

met : openoffice.

Wat voor merk en type NAS heb je ?

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #11 Gepost op: 2008/11/02, 12:20:32 »
Citaat van: flyerman
Verbind met netwerk via nautilus ssh (sftp). Directorie op de NAS is gemount.
.
Bedoel je alleen gemount op de NAS zelf of ook op de pc waarmee je toegang tot de nas wil (met fuse)?

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #12 Gepost op: 2008/11/02, 12:31:37 »
Directorie van de NAS (Freenas) is gemount op mijn eigen computer.

Open Office via command line zelfde probleem. OO vraagt om wachtwoord, geef het in en na twee keer geeft OO interne fout.


Tussen twee haakjes, hoe kan ik hier een plaatje posten, dan kan ik laten zien wat ie zegt?
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #13 Gepost op: 2008/11/02, 12:41:10 »
Het lijkt een bevestigde bug in Open Office. Had je zelf ook met een beetje googlen kunden vinden trouwens.
Volgens mij moet je als workaround ofwel bestanden heen en weer kopieren vanuit Nautilus en lokaal bewerken, danwel de sftp schijf lokaal mounten zodat je het kunt benaderen vanuit OO als een 'gewone' schijf, zoals gezegd met fuse.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #14 Gepost op: 2008/11/02, 12:45:24 »
Blijft raar dat pdf's  en text files wel goed gaan. Alleen oo wil niet. Ligt dus aan open office.

Ik heb me rot gegoogled maar heb niets kunnen vinden, anders had ik het hier niet gepost.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Bestand openen
« Reactie #15 Gepost op: 2008/11/02, 14:46:16 »
Citaat van: flyerman
Blijft raar dat pdf's  en text files wel goed gaan. Alleen oo wil niet. Ligt dus aan open office.

Ik heb me rot gegoogled maar heb niets kunnen vinden, anders had ik het hier niet gepost.
Ik zocht op:  nautilus sftp "open office"

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Bestand openen
« Reactie #16 Gepost op: 2008/11/22, 10:01:37 »
Ik vermoed dat het vooral wel aan gnome virtual file system zal liggen. Grafisch mounten werkt voor mij maar half. Ik mount met sshfs via de commandolijn: werkt via de aloude robuste commandolijn en werkt perfect en transparant. Hier staat hoe je het installeert:

http://www.howtogeek.com/howto/ubuntu/how-to-mount-a-remote-folder-using-ssh-on-ubuntu/

Met een eenvoudig scriptje mount of unmount ik:

#!/bin/bash
if [ "$1" == "umount" ] ; then
fusermount -u ~/mnt/desktop ;
else
if [ "$1" == "mount" ] ; then
sshfs $USER@desktop:/ ~/mnt/desktop/ ;
else
echo "Usage: $0 [mount, umount]"
fi ;
fi ;

"desktop mount" koppelt de desktop, "desktop umount" ontkoppelt.

Offline Paul

  • Lid
  • Steunpunt: Nee
Re: Bestand openen
« Reactie #17 Gepost op: 2009/04/30, 22:40:02 »
Hoi,

Ik ben ook al geruime tijd aan het worstelen met dit euvel. Had ook dezelfde problemen. Echter ik vond dat sshfs inderdaad goed werkt en bij mij het rechten probleem ook oploste.
Echter ik heb de commandline in de .bashrc file geplaatst hetgeen me niet zo'n handige plek lijkt daar het mounten telkens gedaan word als je een nieuwe terminal opent. En doordat hij hem voor de tweede keer wil mounten ziet hij dat de mount dir niet leeg is en foutmeldingen genereert. Dit schijn je o te kunnen lossen met de nonempty parameter. Echter deze is niet te plaatsen in de bashrc file daar er telkens fouten gegenereerd worden.

Het scriptje wat je hierboven plaatste is misschien wel een oplossing.

Alleen zou ik het ergens in het systeem willen plaatsen zodat het eenmalig automatisch gemount word met opstarten.

Kan iemand me hierin een advies geven? ???

Alvast bedankt

Paul