Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Intel Corp Pro Wireless 3945ABG  (gelezen 2241 keer)

Offline rvtasd

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Gepost op: 2008/11/01, 17:05:38 »
Ik heb inmiddels de diverse items die over "geen draadloos internet" gaan gelezen. Inclusief de korte en heldere cursus van Pjotr. Dus via het Terminalvenster "lspci" gedraaid. Volgens opgave van de Sony Vaio Laptop zit er een 3945ABG in. Enfin, "sudo modprobe -r iwl3945" ingevoerd en daarna "sudo modprobe iwl3945". Maar er wordt nog steeds geen draadloos internet gevonden.
Vreemd dat het als een fout in 8.04 wordt beschouwd. In mijn 8.04 deed het draadlose internet het vanzelf na de eerste installatie. Nooit problemen mee gehad.
En nu ik er 8.10 overheen (via schone lei) heb gezet, is draadloos internet onbereikbaar. Jammer.
Mogelijk dat iemand even stap-voor-stap kan aangeven hoe je een nieuwe verbinding maakt. Er worden pakweg 6 draadlose netwerken gesignaleerd (van de diverse buren), maar ik krijg geen contact met mijn eigen Netgear WPN824. Wel via een vaste kabel, maar dat is niet wat ik graag wil.
Caio,
Roberto.

Offline rvtasd

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Reactie #1 Gepost op: 2008/11/02, 10:20:12 »
Beste Arie,

Dank voor je verwijzing. Ik heb Ibex opgestart met en zonder wlan-aan/uit, maar het mocht niet baten. Maar ik denk dat daarin het probleem niet schuilt. Ik zie zo´n 4 tot 6 andere draadloze netwerken (van de buren uit de straat), waar ik uiteraard niet in kan komen, want die zijn beveiligd. Er is dus weldegelijk contact tussen de laptop en de router. Ik krijg het allen niet voor elkaar om een "eigen" netwerk te vervaardigen. Wat ik waar ook invul, het wormpje blijft een tijdje vrolijk draaien rechts in de bovenbalk, maar verklaart naar een tijdje dat er geen verbinding totstand is gekomen en kapt er na een keer of 3 mee met de mededeling dat er geen netwerk is.

Ik ga vandaag nog wat met "ndisgtk" en "ndiswrapper" in de weer. Mocht dat alles niet lukken, dan heb ik gewoon pech.
Ciao,
Roberto

Offline ChillyWilly

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Reactie #2 Gepost op: 2008/11/02, 22:25:38 »
Ik heb hier ook een 3945 en die werk bij mij out of the box, al sinds Feisty. Vreemd dat hij het bij jou niet doet.

Wat geeft "lsmod | grep iwl"?

Offline lizardman

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Reactie #3 Gepost op: 2008/11/03, 12:43:38 »
3945 zou het inderdaad out of the box moeten doen.
Hier werkt dat al sinds Dapper.
Heb je al een geprobeerd je router te rebooten? : stroom eraf.... ff wachten.... stroom er weer op.?

En inderdaad moet je de computer opstarten met de killswitch uit. (8.10 bug)
Als je een dual boot hebt dan kun je eens in windows opstarten en dan er voor zorgen dat ie zeker afsluit met de killswitch uit... Dus met werkende verbinding.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Reactie #4 Gepost op: 2008/11/06, 00:41:05 »
Aan rvtasd
In topic 33706 waren 2 mensen bezig met de 3945. Die konden het probleem van geen internet oplossen door van kanaal te veranderen. Allicht het proberen waard. Dat moet in je modem of router gebeuren, en je kan in de praktijk kiezen voor kanaal 1, 6 of 11. De computer volgt automatisch na een reboot. Tussenliggende  kanalen geven kans op overspraak, vooral voor anderen in de buurt niet zo leuk, als je een sterke zender hebt.
Misschien helpt het bij jou ook.
Vr.groet, peter

Even ter verduidelijking: de router instelling is veranderd van Automatisch (sterkste kanaal kiezen) naar een vaste kanaal instelling. Ik denk dat dat het verschil maakt.

Offline rvtasd

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Reactie #5 Gepost op: 2008/11/07, 21:51:25 »
Beste ChillyWilly,

De uitkomst van het commando "lsmod ¦ grep iwl is
iwl3945      112116  0
rfkill            19364  2  iwl3945
mac80211  253440  1  iwl3945
led_class     13192  1 iwl3945
cfg80211     37136  2 iwl3945,mac80211
(het staat in werkelijkheid mooier uitgelijnd, maar ik heb het moeten overtikken, want ik kan van de laptop niet knippen en dan plakken op de desktop).

Beste lizardman,

Alles (kabelmodem, router, 2 desktops, 2 laptops) is al meedere keren aan en uit geweest is allerlei combinaties.
De dual-booter Win XP doet het draadloos gewoon en voorheen de Hardy Heron 8.04 ook. Had ik die maar laten staan.

Beste Petervdw,

Ik ga morgen eens proberen of de kanaalwisseling iets oplevert.

Allemaal hartelijk bedankt voor de suggesties.
Wie weet doet ie het binnenkort.
Wordt vervolgd.

Offline rvtasd

  • Lid
  • Steunpunt: Nee
Intel Corp Pro Wireless 3945ABG
« Reactie #6 Gepost op: 2008/11/07, 22:39:37 »
Aan allen,

Goed nieuws.
Ik kon niet wachten tot morgen en heb even het kanaal van 12 naar 11 gezet. Kleinigheidje tenslotte.
En zie, ik ben er in. Er werd om een wachtwoord gevraagd en .......... het internet kan weer draadloos worden benaderd.

Nogmaals dank voor alle tips en trucs.

Ik ben nog wel benieuwd naar de conclusie(s) naar aanleiding van de uitkomst van lsmod | grep iwl.

Ciao,
Roberto

Offline Jessr

  • Lid
  • Steunpunt: Nee
Re: Intel Corp Pro Wireless 3945ABG
« Reactie #7 Gepost op: 2008/11/26, 16:05:04 »
Ook ik heb de overstap van 8.04 naar 8.10 gemaakt. Onder 8.04 hebben de commando's

modprobe -r iwl3945
modprobe iwl3945

in de /etc/rc.local altijd gewerkt. Tot na upgrade 8.10. Aangezien ik mijn notebook ook zakelijk gebruik, was ik genoodzaakt om - helaas - terug naar 8.04 te gaan.

Wat mij opviel onder 8.10:
- de wifi verbinding kwam even tot stand en vervolgens (na 2 of 3 pings) viel die weg. Van alles geprobeerd met netwerkinstellingen DHCP, Static IP, om te verbinding weer op te krijgen maar niets hielp. Ook opnieuw de modprobe commando's geprobeerd, maar verbinding veel weer na enkele seconden uit.
- wifi verbinding wlan0 (in 8.04) is vervanderd in eth1 (in 8.10).

Het idee van bijv. kanaal 11 kiezen i.p.v. automatisch blijf ik in mijn situatie raar vinden, aangezien mijn notebook onder Windows XP (dual-boot) geen enkel probleem heeft om draadloos verbinding te maken.

Heeft iemand een idee? Alvast bedankt voor jullie hulp.
___________________________________________________________________
Toshiba Satellite A110, Intel Pro/Wireless 3945ABG, dual boot: XP / Ubuntu 8.04

Offline jemark

  • Lid
  • Steunpunt: Nee
Re: Intel Corp Pro Wireless 3945ABG
« Reactie #8 Gepost op: 2008/11/26, 16:46:58 »
zie: http://www.ubuntu.com/getubuntu/releasenotes/810
dit is een bekend probleem en kan makkelijk opgelost worden:
deze regel zal je aan het bestand /etc/modprobe.d/options  toe moeten voegen:

options cfg80211 ieee80211_regdom=EU

dat wegvallen van de verbinding kan ook duiden op een verkeerd ingevulde wpa beveiligingssleutel. dit heb ik zelf ervaren. ik raad dan aan om voor de zekerheid de sleutel nauwkeurig opnieuw in te voeren.
« Laatst bewerkt op: 2008/11/26, 16:56:44 door jemark »

Offline Jessr

  • Lid
  • Steunpunt: Nee
Re: Intel Corp Pro Wireless 3945ABG
« Reactie #9 Gepost op: 2008/11/27, 11:38:24 »
Ik heb het volgende uitgeprobeerd:

1. onderstaande regel toegevoegd aan /etc/modprobe.d en laptop opnieuw gestart
options cfg80211 ieee80211_regdom=EU

Het is mij hierna een keer gelukt om verbinding te krijgen. Echter, na een volgende herstart niet meer gelukt om verbinding te krijgen. Van alles geprobeerd aan instellingen.
Via Systeem - Voorkeuren - Network Configuration zie ik op het tabblad Draadloos ifupdown(wlan0) staan. Ik heb geprobeerd om deze wijzigingen aan te passen, maar krijg de foutmelding 'Bijwerken verbinding is mislukt: nm-ifupdown-connection.c.82 - connection update not supported (read-only)..'


2. Router Channel op 6 en op 11 uitgeprobeerd. Ook hiermee lukt het niet om een wifi-verbinding te krijgen.

Ik vrees dat ik nogmaals terug ga naar 8.04  :(. Mijn conclusie is dat 8.10 m.b.t. de Pro/Wireless 3945ABG nog te nieuw is.

Offline jemark

  • Lid
  • Steunpunt: Nee
Re: Intel Corp Pro Wireless 3945ABG
« Reactie #10 Gepost op: 2008/11/27, 14:58:00 »
had je de laatste kernel update uit de proposed al geprobeerd? dan moet je wel even de proposed aanzetten bij je pakket bronnen. (laatste optie voordat je terug gaat naar Hardy, lijkt me). Wel vreemd...  bij mij werkt de 3945ABG in Intrepid goed.

Offline Jessr

  • Lid
  • Steunpunt: Nee
Re: Intel Corp Pro Wireless 3945ABG
« Reactie #11 Gepost op: 2008/11/27, 17:01:06 »
Ik heb bij pakket bronnen 'proposed' gekozen. Met de nieuwe kernel kom ik iets verder.

Het is mij nu 1 keer gelukt om de DNS van planet internet 195.121.1.34 te pingen, waarmee duidelijk is dat de internetverbinding tot stand komt. Echter, als ik Firefox opstart krijg ik de melding 'Adres niet gevonden'.
Vervolgens verschillende keren opnieuw opgestart, maar zit geen draadloos internet.

Helaas, ik ga weer terug met mijn laptop naar 8.04. Gelukkig draai ik om een multimedia center en een desktop wel - bedraad - 8.10.

In ieder geval dank voor jullie hulp.

Offline jemark

  • Lid
  • Steunpunt: Nee
Re: Intel Corp Pro Wireless 3945ABG
« Reactie #12 Gepost op: 2008/11/27, 17:28:46 »
graag gedaan. jammer dat het nog niet werkt voor je laptop.