Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: kan geen internetverbinding krijgen  (gelezen 4401 keer)

Offline daanhoog

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Gepost op: 2008/10/31, 21:03:30 »
Gisteren Xubuntu 8.10 geinstalleerd op een laptop met PIII 650 MHz en 576 MB RAM.
Na de koppeling met het LAN toch geen verbinding met internet gekregen. In Terminal heb ik de volgende (genummerde) commando's gegeven. Het antwoord staat erna:

1. sudo lshw -C network

antwoord:

 *-network              
       description: Ethernet interface
       product: 82557/8/9/0/1 Ethernet Pro 100
       vendor: Intel Corporation
       physical id: 9
       bus info: pci@0000:00:09.0
       logical name: eth0
       version: 09
       serial: 00:d0:59:14:37:41
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k4-NAPI duplex=half firmware=N/A latency=66 link=no maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=10MB/s
  *-network DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: pan0
       serial: 92:7a:bc:4f:73:33
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

2. ifconfig

antwoord:

eth0      Link encap:Ethernet  HWaddr 00:d0:59:14:37:41  
          inet6 addr: fe80::2d0:59ff:fe14:3741/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1494 (1.4 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2672 (2.6 KB)  TX bytes:2672 (2.6 KB)

3. ping 82.211.81.158

antwoord:

connect: Network is unreachable

4. sudo ifdown eth0

antwoord:

interface eth0 not configured


Wat moet ik doen om wel een verbinding te krijgen. Graag commando's voor ingave in Terminal want de Network Manager is niet meer aanwezig in het Applications menu

Bij voorbaat dank, vriendelijke groeten, Daan (die eerder met Ubuntu werkte maar Xubuntu toch verkiest gezien de hardware).

P.S. Er is tamelijk veel RAM op dit notebook aanwezig. Kan Xubuntu dat benutten? Zo ja, gebeurt dat automatisch of moet ik een bepaald commando geven?

Offline tabasco

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #1 Gepost op: 2008/10/31, 23:25:33 »
wat krijg je bij het volgende commando in de terminal?:
ifup eth0

Offline daanhoog

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #2 Gepost op: 2008/11/01, 08:48:01 »
Hallo tabasco,

Als ik ifup eth0 tik krijg ik als antwoord:

ifup: failed to open statefile /var/run/network/ifstate: Permission denied

Ik hoop dat dit je (en mij) verder helpt, groeten Daan

Offline tabasco

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #3 Gepost op: 2008/11/01, 09:53:11 »
Permission denied staat er om dat ik ben vergeten te zeggen dat je sudo  voor de opdracht moet zetten dus: sudo ifup eth0

Offline Spider

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #4 Gepost op: 2008/11/01, 10:21:23 »
Laat maar. ;)
"We Must Become the Change We Want to See."- Mahatma Gandhi

Offline martemp

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #5 Gepost op: 2008/11/03, 16:21:49 »
Ik heb hetzelfde probleem als daanhoog. Alle instructies met overeenkomstig resultaat.
Neem het stokje dus maar even over en krijg na
sudo ifup eth0
het antwoord :
Ignoring unknown interface eth0=eth0.
Ik kan de tip van Spider dus niet overnemen.

Offline tabasco

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #6 Gepost op: 2008/11/03, 16:44:10 »
Hallo martemp,
-het stokje-

Daanhoog heeft niet meer gereageerd, welllicht opgelost?!?
Wat betreft de tip van Spider: "Laat maar."  - daar doe je ook niet veel mee...

Misschien is het handiger als je iets meer info geeft m.b.t. je configuratie:
- type verbinding?
- wanneer ging het mis?
- hoe was het voorheen?
- heb je bovenstaande 4 opdrachten van daanhoog zelf ook in de terminal uitgevoerd?
(zo ja, plaats hier ook de uitkomst...)

Offline daanhoog

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #7 Gepost op: 2008/11/03, 19:49:32 »
Hallo martemp en tabasco,

Sorry dat ik even weg was. Ik had de vraag ook gesteld op de engelstalige ubuntu-site en kreeg daar de oplossing:

De mail heb ik hieronder gezet:
-----------------------------------------------------------------------------------------
Daan Hoogland wrote:
> > Then I entered 'nm-applet &'. The answer was not a simple OK but a
> > message I did not write down. I got the idea that something was not OK.
> >
> > When I looked at the Desktop I noticed the network icon I missed
> > before has returned to the screen (2 monitors connected to each other
> > with a cross).

The error message seems to be not important because the icon reappeared
and you can use it.

> > As you mentioned I tried to configure the wired connection manually.
> > The window 'Network Connections' has 5 tabs: wired/wireless/mobile
> > broadband/vpn/dsl.

Well, you mentioned Xubuntu 8.04 in your first mail and 8.10 in another.
But obviously I didn't realize that you were now using 8.10 and my
description was for 8.04. Anyway, now I have the 8.10 LiveCD running and
try to find out where your problem is. So the procedure is to right click
the network manager icon in the top panel and select "Edit
connections...". That's where your 5 tabs are.

> > 'wired' shows the existing situation: Auto eth0 - never (the word
> > 'never' seems to pose the problem to me).

Don't worry, the "never" only means the connection has never been
established. During my trials I have also seen "now" and "2 minutes ago".

> > Also 3 buttons can be seen: add/edit/delete.
> >
> > Editing the wired 'auto eth0' connection gives a submenu with 3 tabs:
> > wired/802.1 x security/IPv4 settings.
> >
> > Under 'wired' one can choose to enable 2 items: connect automatically
> > and system setting. Both choices are unabled by default. I kept it
> > this way (I enabled both choices but that did not seem to make a
> > difference).

Well, the default from the LiveCD is both enabled. I would suggest to
enable both because here the connection was established automatically at
login. And if I uncheck both boxes the connection doesn't work
automatically any longer.

> > The subscreen also shows some values: MAC address: 00:D0:59:14:37:41
> > and MTU - automatic. I didn't change these values either.

Good. How about the "802.1x Security" tab? Please make sure you have
unchecked the box for "use 802.1x security for this connection".

> > Under 'IPv4 settings' one can choose among 5 methods: automatic
> > (DHCP)/automatic (DHCP) addresses only/manual/link-local only/shared
> > to other computers.

I suppose your router works as a DHCP server as well. Therefore
try "Automatic (DHCP)" and click OK. Then the connection should be
established. If that really doesn't work, try "Manual" instead
of "Automatic (DHCP).

> > Only when I choose 'manual' the button 'OK' at the end becomes grey,
> > meaning that the changes I make into this menu (entered IP addresses
> > for pc/netmask/gateway and DNS servers) cannot be saved.

The button only becomes active after you have entered all of the necessary
information. After you have selected "Manual", click the button "+ Add".
Then you can type the IP address "192.168.2.100" and press enter. Then
click below the "netmask" and type "255.255.255.0" and press enter. In
the same way enter the gateway address "192.168.2.1". Then enter your DNS
server address (192.168.2.1 or your ISPs DNS server) in the appropriate
field and the OK button should be active.

> > At the end I entered your last given command:
> > sudo /etc/init.d/networking restart. The answer was: reconfiguring
> > network interfaces [OK}.

I did not need this command for 8.10 but it doesn't hurt.

> > Connection to the internet is still not possible. To me the problem
> > seems that I cannot give this laptop-pc an IP-address.

If you still don't get a connection, maybe your cable is faulty? If you
have another ethernet cable available you could try that one.


Nils
------------------------------------------------------------------------------------

Vrij vertaald komt het hierop neer:

Als je kiest voor de handmatige keuze van een IP-adres voor je pc kun je dit adres pas ingeven nadat je vlak onder het woord 'adres'  geklikt hebt. Dit gaat precies zo voor de ingave van de adressen voor 'netmask' en 'gateway'.
Daarna nog het adres van de DNS-server intikken en op 'OK' drukken.

Dit is de procedure bij Xubuntu 8.10

Ik hoop dat het je nu lukt, groeten, Daan

Offline martemp

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #8 Gepost op: 2008/11/04, 12:32:59 »
Hallo Daan en Tabasco
ik heb de laatste aanbevellingen van Daan uitgevoerd en kwam wat verder, maar niet zover als ik wilde. Ik kreeg verbinding met de router, maar geen toegang tot internet. Vele dingen geprobeerd. Te veel om te kunnen beschrijven. Eerst de situatie maar even uitleggen.
Ik heb Ubuntu op een eerste partitie staan van een oude schijf die via de bootmanager doorschakelt naar een andere schijf die WinXP draait. Tot de upgrade naar 8.10 draaide 8.04 prima. Configureren van internet ging automatisch bij installatie (upgrade vanuit Gutsy G) met gewoon een door DHCP gegeven adres. Nu krijg ik ook de melding 'verbinding verbroken', maar de xp verbinding is nog normaal; het is dus geen hardware fout.

De oplossing hierboven leidt volgens mij tot een statisch adres, dat zou nog tot daar aan toe zijn, als het maar werkte. Het werkt echter niet en bij een volgende opstart zijn de ingevoerde instellingen weer vergeten. Ik kan mij niet voorstellen dat de verbinding als automatische DHCP client niet werkend gemaakt kan worden. Misschien een snel werkend vraagje: wat vul ik in dat venster in bij DHCP Client ID?

Martemp

Offline daanhoog

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #9 Gepost op: 2008/11/04, 13:44:49 »
Hallo martemp,

Je schreef o.a.

 - Misschien een snel werkend vraagje: wat vul ik in dat venster in bij DHCP Client ID? - .

Ik heb hier niets ingegeven. Ik kan er ook niets ingeven want de regel is grijs.

succes verder, Daan

Offline tabasco

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #10 Gepost op: 2008/11/04, 14:50:20 »
Wellicht is hetvolgende probleem aan de hand: Ik heb de tekst even gekopieerd van de site van pjotr123

Problemen met bedraad internet oplossen in Ubuntu Linux 8.04
Soms is er alleen internetverbinding onder Windows en niet onder Linux (op een tweevoudig opstartbare computer): dwing Windows het IP-adres vrij te geven.
Indien u een tweevoudig opstartbare PC heeft met Windows, kan het zijn dat u geen IP-adres krijgt na een herstart in Linux. En dus geen internetverbinding. Dit heeft de volgende oorzaak: elke netwerkkaart heeft een uniek MAC-adres. Dit adres is in uw netwerkkaart ingebakken. De DHCP-server houdt dit MAC-adres bij.
Indien u nu eerst via Windows op het internet gaat en daarna herstart in Linux, dan krijgt u in vele gevallen geen IP-adres van de DHCP-server. Deze server herinnert zich namelijk dat hij reeds eerder een IP-adres voor dat MAC-adres had gegeven, en geeft daarom geen nieuw.
U kunt dit handmatig oplossen door het IP-adres onder Windows vrij te geven, alvorens u de PC herstart. Overigens: Linux geeft standaard wel het IP-adres vrij. Dus herstarten vanuit Linux naar Windows geeft geen problemen.
 

Handmatige methode
Open hiervoor in Windows XP een DOS-venstertje:
Start - Programma's - Bureau-accessoires - Opdrachtprompt
tik in:
ipconfig /release(let op de spatie tussen ipconfig en /release !)
En druk op Enter.

Offline barth

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #11 Gepost op: 2008/11/05, 14:10:03 »
Wil hier even bij inhaken...heb sinds de installatie van 8.10 het zelfde probleem.Dacht ook dat het aan de kabel lag, maar het lijkt me eigenlijk sterk....Onder windows heb ik geen netwerk (geen driver geïnstalleerd) dus die hoef ik niet vrij te geven...onder 7.04 heb ik ook geen verbinding meer, het lijkt wel of 8.10 de netwerk kaart over heeft genomen...

Offline Petervdw

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #12 Gepost op: 2008/11/06, 09:22:56 »
Aan allemaal
8.10 kan denk ik niet zo goed overweg met het automatisch kiezen van het sterkste kanaal. Probeer eens de kanaal keuze vast te zetten op 1, 6, of 11 in de router. Reboot router of modem door even stroomloos te maken. Reboot computer. Misschien helpt het.
Vr.groet, peter

Offline leoneut

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #13 Gepost op: 2008/11/06, 13:28:09 »
Hallo,

Ik ben overgegaan van 8.04 naar 8.10 via een upgrade. Tijdens de upgrade werd alles keurig opgehaald van Internet, maar het ging mis na de reboot. Het systeem startte keurig op in 8.10, maar kon geen vaste netwerkverbinding meer maken. Ik draai met een dual-boot systeem (Ubuntu - XP) en onder Windows is de verbinding nog steeds prima. Volgens mij heb ik alle tips uit dit forum al geprobeerd, naar ik kom niets verder. De netwerkkaart wordt keurig herkend, dus het zal ergens in de configuratie mis gaan. Ik heb het gevoel dat de router niet meer 'gezien' wordt.

Nogmaals: het ging mis na de reboot in 8.10.
De laatste tip van Peter heb ik nog niet geprobeerd (over het vast zetten van het kanaal in de router), want ik zou niet weten hoe ik dit in de router moet regelen.

Wie helpt mij uit de nood? Na veel problemen gehad te hebben met de draadloze verbinding op de laptop met Ubuntu 7.x  (die uiteindelijk zijn opgelost) heb ik nu ook problemen met de vaste verbinding op de desktop.
Ik wil graag op termijn helemaal over naar Ubuntu, maar dit soort akkefietjes weerhoudt me nog een beetje.........

Groeten, Leo

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #14 Gepost op: 2008/11/06, 14:08:19 »
Als je computer het goed deed onder 8.04, dan raad ik je aan om bij 8.04 te blijven:
http://sites.google.com/site/computertip/versiekeuze
(punt 3)

Offline leoneut

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #15 Gepost op: 2008/11/06, 22:03:31 »
Ik begrijp je verhaal, maar het valt me tegen. Ik had verwacht dat elke nieuwe versie méér zou bieden, ipv minder (althans vwb dit probleem). Ook had ik begrepen dat 1 van de grootste verbeteringen van 8.10 de NetworkManager is...............

Ik denk nog steeds dat dit probleem oplosbaar moet zijn, maar mocht niemand mij kunnen helpen met de oplossing van dit probleem, hoe kan ik dan downgraden van 8.10 naar 8.04?

Offline barth

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #16 Gepost op: 2008/11/07, 03:03:53 »
Hmmmz...heb/had ook een aparte home voor 7.04 op mijn p3, deze lijkt precies door 8.10 overgenomen te zijn...Hopelijk heb je een back-up gemaakt ;)

Offline leoneut

  • Lid
  • Steunpunt: Nee
kan geen internetverbinding krijgen
« Reactie #17 Gepost op: 2008/11/07, 14:46:42 »
Ik heb m'n bekabelde verbinding voor mekaar en zonder te downgraden naar 8.04 (dat was toch mijn eer te na). Na een hoop gepuzzel is het gelukt. Mogelijk dat anderen iets hebben aan mijn bevindingen, daarom heb ik ze hieronder neergezet. Blijft het feit, dat dit soort grappen de uitrol van Ubuntu niet ten goede komt.

Na de update van 8.04 naar 8.10 (november 2008) werkte de bekabelde verbinding niet meer. De PC kon geen verbinding maken met de DHCP-server op de router en kreeg dus ook geen IP-adres toebedeeld. Nadat ik in de NetworkManager alles handmatig heb ingesteld, was het probleem opgelost.

In de PC zit de netwerkkaart: Intel 82547EI Gigabit Ethernet Controller met driver: Bridge Driverversion 2.3

Commando's die ik gebruikt heb om het probleem te onderzoeken:
lshw - gaf aan dat er een netwerkkaart was gevonden en dat er een netwerkdriver was geladen
ifconfig - gaf aan dat de PC geen ip-adres had

In de NetworkManager applet de volgende instellingen gedaan:
Verbinding bewerken - Kabel - Auto eth0 - Bewerken - Ipv4 instellingen
- Methode verandert van Automatisch (DHCP) naar Handmatig
- Adress: 10.0.0.10 (is het vaste ip adress dat ik aan de PC heb gegeven)
- Netmask: 255.0.0.0
- Gateway: 10.0.0.2 ( is het ip adress van de router)
- DNS servers: 62.58.50.5, 62.58.50.6 (dit zijn 2 adressen die uit de router komen)

Denk eraan om na de wijziging alles (router en PC) uit te zetten, 10 seconden te wachten en weer op te starten.

Groeten, Leo