Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ati drivers in 8.10  (gelezen 1561 keer)

gerbenr

  • Gast
ati drivers in 8.10
« Gepost op: 2008/10/31, 11:30:40 »
Als ik de ati drivers installeer (of eigenlijk "activeer") in System-Administration-Hardware Drivers, krijg ik bij de ati en glx commando's het volgende:

~# aticonfig
aticonfig: ../../src/xcb_io.c:352: _XReply: Assertion `!dpy->xcb->reply_data' failed.
Aborted

en bijv

# glxgears
glxgears: ../../src/xcb_io.c:352: _XReply: Assertion `!dpy->xcb->reply_data' failed.
Aborted

Als ik daarentegen die drivers weer deactiveer (de fglrx module is dan nog wel geladen) doet glxgears het wel! Het programma aticonfig is er dan niet meer, want die .deb is gewoon weg, dus logisch. Maar wat is er aan de hand met die foutmelding? Ik kan zo m'n scherm niet in low-power zetten (laptop).

alvast bedankt

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
ati drivers in 8.10
« Reactie #1 Gepost op: 2008/10/31, 19:13:31 »
Citaat van: gerbenr
Als ik de ati drivers installeer (of eigenlijk "activeer") in System-Administration-Hardware Drivers, krijg ik bij de ati en glx commando's het volgende:

~# aticonfig
aticonfig: ../../src/xcb_io.c:352: _XReply: Assertion `!dpy->xcb->reply_data' failed.
Aborted

en bijv

# glxgears
glxgears: ../../src/xcb_io.c:352: _XReply: Assertion `!dpy->xcb->reply_data' failed.
Aborted

Als ik daarentegen die drivers weer deactiveer (de fglrx module is dan nog wel geladen) doet glxgears het wel! Het programma aticonfig is er dan niet meer, want die .deb is gewoon weg, dus logisch. Maar wat is er aan de hand met die foutmelding? Ik kan zo m'n scherm niet in low-power zetten (laptop).

alvast bedankt
Heb je een upgrade uitgevoerd of een nieuwe installatie van 8.10?

gerbenr

  • Gast
ati drivers in 8.10
« Reactie #2 Gepost op: 2008/10/31, 19:55:25 »
Citaat van: shinger
Heb je een upgrade uitgevoerd of een nieuwe installatie van 8.10?
Een upgrade, goed dat je daar naar vraagt. Waarschijnlijk ligt het daar aan? En moet ik eerst nog wat opruimen?

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
ati drivers in 8.10
« Reactie #3 Gepost op: 2008/10/31, 20:24:17 »
Citaat van: gerbenr
Citaat van: shinger
Heb je een upgrade uitgevoerd of een nieuwe installatie van 8.10?
Een upgrade, goed dat je daar naar vraagt. Waarschijnlijk ligt het daar aan? En moet ik eerst nog wat opruimen?
Bij mij na upgraden had ik ook nog heel wat gedoe, pas later schone installatie uitgevoerd waardoor ik even opnieuw kon beginnen met de ati drivers toen lukte ze wel.. niet beter als Nvidia, maar ik kon wel weer compiz fusion aan de gang krijgen.

Offline heir4c

  • Lid
  • Steunpunt: Nee
ati drivers in 8.10
« Reactie #4 Gepost op: 2008/11/01, 01:31:02 »
Ik heb geen drivers in 'Hardware Drivers' staan en compiz werkt! cube en 'ball'. Mijn visuele effekten mag ik zelfs NIET aanklikken of compiz stopt ermee! En gij nu! :) Ongelooflijk. Ik begrijp er helemaal niets meer van. :)

Offline jthijsen

  • Lid
  • Steunpunt: Nee
ati drivers in 8.10
« Reactie #5 Gepost op: 2008/11/01, 19:11:17 »
Ik zie de driver wel staan in "systeem-beheer-hardware drivers", maar kan hem niet activeren. Als ik op de knop druk zegt hij dat ie het doet, maar hij blijft de status inactief houden. Ik heb ondertussen wel de ati catalyst control center weer geactiveerd. De achtergrond effecten kan ik ook niet meer aanzetten. En de compiz fusion icon? Die heeft bij mij nog nooit iets gedaan, er start gewoon helemaal niets op. Dus geen kubussen of balletjes, het blijft gewoon saai plat. Ik heb trouwens een X1650 en dat is wel herkend, want dat staat in het ati catalyst control center netjes vermeld.

Offline heir4c

  • Lid
  • Steunpunt: Nee
ati drivers in 8.10
« Reactie #6 Gepost op: 2008/11/01, 19:23:45 »
met de ati catalyst control heb ik niets, werkt niet samen met mijn driver.
Wat de effekten betreft: druk met rechtermuistoets op de Compiz Fusion Icon en dan op Settings Manager. Daar kan je verschillende opties aan vinken. (op het witte vierkantje klikken) Om de instellingen te veranderen per item klik op dat item voor individueel menu met instellingen.

Offline jthijsen

  • Lid
  • Steunpunt: Nee
ati drivers in 8.10
« Reactie #7 Gepost op: 2008/11/01, 19:40:13 »
Rechtsklikken op de Compiz Fusion Icon in het menu Toepassingen-systeemgereedschappen gaf me alleen de mogelijkheid om dat icon op het bureaublad en in het paneel te zetten. Het icon op het bureaublad reageert nog steeds niet op dubbelklikken en rechtsklikken geeft geen Settings Manager om op te klikken. Ook geen nederlandstalige optie die daar op lijkt, trouwens. Ik heb daar wel het bestand uitvoerbaar kunnen maken, dat stond uit, maar ook dat heeft niet geholpen.