Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: swap partitie wisselgeheugen aan/uit  (gelezen 3784 keer)

Offline acousticghille

  • Lid
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Gepost op: 2008/10/28, 17:15:00 »
Hoi,

Heb de laatste dagen heel wat zitten knutselen met ubuntu vermits deze helemaal in de puree was gedraaid. Ik heb mijn schijf opnieuw gepartionneerd. Ik maakte een swap-partitie van 1gig en de rest gewoon ext3.
Nu merk ik dat de swap-partitie niet automatisch 'aan' staat, wanneer ik opstart. Als ik dan gewoon gparted in terminal venster gebruik dan kan ik dat wisselgeheugen wel aanzetten, maar het kan toch niet de bedoeling zijn dat elke keer handmatig te doen? Wat heb ik verkeerd gedaan? Ik merk trouwens bij de opstart van de pc dat hij onderweg (wanneer al die tekst verschijnt) ergens in het rood 'fail' aangeeft bij swap...

Ik wou hier twee schermafdrukjes bijplaatsen, maar weet niet hoe het moet. (copy-paste doet hij niet noch ctrl+c en ctrl+v). Scherafdrukken zijn in png.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #1 Gepost op: 2008/10/28, 17:27:25 »
Open eens een terminal en voer de volgende commando's in. Plaats het resultaat hier op het forum, in [code ] tags.(Zie het BBCode linkje onder het reactieveld).

De commando's:
sudo fdisk -l
sudo blkid
cat /etc/fstab

Offline acousticghille

  • Lid
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #2 Gepost op: 2008/10/28, 17:27:26 »
Geen schermafdruk, maar wel dit, misschien kan het helpen om de oplossing te vinden...

ghislain@thuis-laptop:~$ sudo fdisk -l

Schijf /dev/sda: 60.0 GB, 60011642880 bytes
255 koppen, 63 sectoren/spoor, 7296 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0xe911e911

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1               1         127     1020096   82  Linux wisselgeheugen
/dev/sda4   *         128        7296    57584992+  83  Linux
ghislain@thuis-laptop:~$

Offline acousticghille

  • Lid
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #3 Gepost op: 2008/10/28, 17:29:16 »
ghislain@thuis-laptop:~$ sudo blkid
/dev/sda1: TYPE="swap" UUID="1a590cdc-01a6-4aca-adf3-fa7c7f7e9b0b"
/dev/sda4: UUID="7fcc33b4-a251-4353-8a2e-07ac860da1bc" SEC_TYPE="ext2" TYPE="ext3"
ghislain@thuis-laptop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda4
UUID=7fcc33b4-a251-4353-8a2e-07ac860da1bc /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda6
UUID=8ddd35c7-36d3-4143-bf18-9d69d332bb51 none            swap    sw              0       0
/dev/cdrom       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sda5    /media/DataGezin vfat  iocharset=utf8,umask=000  0    0ghislain@thuis-laptop:~$

Ik merk hiermee dat de vorige partities nog ergens verwijzingen krijgen, zonder dat ze nog bestaan?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #4 Gepost op: 2008/10/28, 17:32:27 »
Verander deze regel:
UUID=8ddd35c7-36d3-4143-bf18-9d69d332bb51 none            swap    sw              0       0In dit:
UUID=1a590cdc-01a6-4aca-adf3-fa7c7f7e9b0b none            swap    sw              0       0Hierna kan je met het commando sudo swapon -a je swap aanzetten.
Als je opnieuw opstart moet het automatisch gaan.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #5 Gepost op: 2008/10/28, 17:34:48 »
Het aanpassen doe je trouwens  met dit commando:
gksudo gedit /etc/fstab

Offline acousticghille

  • Lid
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #6 Gepost op: 2008/10/28, 19:42:49 »
Hoi Johan,

Bedankt, je hebt me geweldig geholpen. Ik merkte wel tijdens de opstart nog een 'fail' bij activating swap partition, maar eenmaal opgestart zag ik toch dat die 'aan' stond.
Kwestie van bij te leren. Wat heb ik nu net gedaan toen ik die regel veranderde?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
swap partitie wisselgeheugen aan/uit
« Reactie #7 Gepost op: 2008/10/29, 23:34:53 »
Door het veranderen van je partities hebben die een nieuw "identificatienummer" gekregen. Dat is die UUID.
De oude stond nog in /etc/fstab en kon dus niet gevonden worden. Nu staat de goede er wel in.

Offline stillekracht

  • Lid
  • Steunpunt: Nee
Re: swap partitie wisselgeheugen aan/uit
« Reactie #8 Gepost op: 2011/11/20, 11:00:32 »
Hoi,

Ik reageer hier in dit oude topic, omdat ik hetzelfde probleem heb, maar er net niet uitkom met deze instructies.

Heb hetzelfde probleem: wisselgeheugen (linux-swap) staat standaard uit. Moet het dus steeds met gparted aan zetten. Dit wil ik graag standaard aan hebben staan.

monique@HP-ProBook-4710s:~$ sudo fdisk -l
 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *        2048   209717247   104857600   83  Linux
/dev/sda2       218105856   625141759   203517952    5  uitgebreid
/dev/sda3       209717248   218105855     4194304   82  Linux wisselgeheugen
/dev/sda5       218107904   625141759   203516928   83  Linux

Partitietabel-items liggen niet in schijfvolgorde.
monique@HP-ProBook-4710s:~$ sudo blkid
/dev/sda1: UUID="a4f73ecb-818f-4983-85b2-4de06e1feedc" TYPE="ext4"
/dev/sda3: UUID="e6190fe1-82a1-47a7-b8db-e571b2ebc617" TYPE="swap"

-----------------------
monique@HP-ProBook-4710s:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=a4f73ecb-818f-4983-85b2-4de06e1feedc /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=7bb1d6a9-cab4-44fc-a5a6-9fd7bb620794 none            swap    sw              0       0
/dev/sda5 /data ext4 rw,auto,user 0 0
monique@HP-ProBook-4710s:~$

Wat moet ik corrigeren?
Uhhhhhh ik ben geen ervaren Ubuntu/Linux gebruiker, dus spaar mij en hou het een beetje begrijpelijk voor mij  =D

Offline thomasave

  • Lid
    • Mijn Website
  • Steunpunt: Nee
Re: swap partitie wisselgeheugen aan/uit
« Reactie #9 Gepost op: 2011/11/20, 11:08:06 »
je moet deze regel:
UUID=7bb1d6a9-cab4-44fc-a5a6-9fd7bb620794 none            swap    sw              0       0
wijzigen in deze:
UUID=e6190fe1-82a1-47a7-b8db-e571b2ebc617 none            swap    sw              0       0
If nothing goes right, try left.
Steunpunt Berchem (Antwerpen, Belgiƫ)

Offline stillekracht

  • Lid
  • Steunpunt: Nee
Re: swap partitie wisselgeheugen aan/uit
« Reactie #10 Gepost op: 2011/11/20, 11:15:56 »
Dat noemen ze nu eens een snel antwoord :D Thx!

Ik ga het zo proberen.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: swap partitie wisselgeheugen aan/uit
« Reactie #11 Gepost op: 2011/11/20, 11:18:11 »
Ter info:

Commando's voor het aan en uitzetten van de swap:
Uitzetten:
sudo swapoff /dev/sdXYAanzetten:
sudo swapon /dev/sdXY
Waarbij XY de partitie van de swap is.
Stillekracht, in jouw geval is dat dan /dev/sda3. Dus je hoeft daarvoor dus geen gParted te gebruiken.
Maar om die dus automatisch te laten opstarten doe je dus wat thomasave schrijft.

Offline stillekracht

  • Lid
  • Steunpunt: Nee
Re: swap partitie wisselgeheugen aan/uit
« Reactie #12 Gepost op: 2011/11/20, 11:31:18 »
Het is gelukt!

Heb het (definitief) aangezet met het commando: gksudo gedit /etc/fstab

Bedankt voor jullie hulp. Helemaal top!!