Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: usb2 is traag  (gelezen 7378 keer)

macmaximus

  • Gast
usb2 is traag
« Gepost op: 2008/10/25, 23:12:10 »
Hallo,

Heb een externe harde schijf via usb aangesloten op mijn computer. Als ik files copieer naar deze harde schijf dan is de transfer rate laag te noemen ongeveer 6 MB/sec. Ubuntu (hardy heron) ziet het wel als USB2, echter als ik USBView opstart dan krijg ik de melding:"can not open the file /proc/bus/usb/devices. Verify that you have USB compiled into your kernel, have the USB core modules loaded, and have the usbdevfs filesystem mounted."
OK, ik wil deze raad graag opvolgen, maar eh ...... hoe doe ik dat?

groet Mac Max
PS Ben nu bezig om files naar een usb-stick te copieren, 2.4 MB/sec das veel te traag.

Offline siegi

  • Lid
  • Steunpunt: Nee
usb2 is traag
« Reactie #1 Gepost op: 2008/10/26, 00:56:10 »
Soms kan je in de bios de snelheid van usb op usb1.1 zetten. Is dit toevallig gebeurt?

macmaximus

  • Gast
usb2 is traag
« Reactie #2 Gepost op: 2008/10/26, 12:45:53 »
Heb in de BIOS gekeken, maar iets over USB is daar niet te vinden. Kan zijn dat ik er over heen kijk, een hint waar ik moet kijken?

macmaximus

  • Gast
usb2 is traag
« Reactie #3 Gepost op: 2008/10/26, 14:02:20 »
Maar voor we de BIOS bekijken, zaak blijft:
Verify that you have USB compiled into your kernel, have the USB core modules loaded, and have the usbdevfs filesystem mounted."
Hoe doe ik dat?

macmaximus

  • Gast
usb2 is traag
« Reactie #4 Gepost op: 2008/10/30, 20:58:35 »
Ok: Hoe "verify" ik dat ik USB heb "compiled" in mijn kernel?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
usb2 is traag
« Reactie #5 Gepost op: 2008/10/30, 21:13:28 »
USB zit al in je kernel. Anders had Ubuntu je usb stick of schijf helemaal niet gezien.

Heb je het commando wel uitgevoerd met sudo ervoor?

macmaximus

  • Gast
usb2 is traag
« Reactie #6 Gepost op: 2008/10/31, 20:35:41 »
Heb je het commando wel uitgevoerd met sudo ervoor?

welk commando?

Offline vanadium

  • Lid
  • Steunpunt: Nee
usb2 is traag
« Reactie #7 Gepost op: 2008/11/01, 16:46:28 »
Op het engelstalige forum heb ik een thread gezien rond dit USB 2 probleem. Er schijnt wel degelijk een probleem (=bug) te zijn. Zelf heb ik het ondertussen ook ervaren, maar het is niet altijd reproduceerbaar.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #8 Gepost op: 2009/05/19, 16:33:16 »
Een ouwe topic omhoog schoppen om de vooruitgang te illustreren. Onder Hardy had ik trage USB overdrachtsnelheden tijdens kopiëren, en dat is met der tijd zowat goed gekomen: in het begin was dit zowat 2 MB/s, later werd dat een 12 MB/s. Na mijn upgrade naar Jaunty stel ik vast dat we terug naar af zijn: overdrachtsnelheden van 1.9 MB/s voor het ogenblik.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #9 Gepost op: 2009/05/19, 16:39:06 »
En als je gewoon kopieert met cp dus zonder gvfs?
Want op kde gaat het hier zelfs nog een stuk sneller dan 12 MB/s

Offline Mario

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #10 Gepost op: 2009/05/19, 18:23:48 »
Er is inderdaad een bug in de kernel ivm met usb2 mbt tot de volgorde dat de modules geladen worden.
Controleer in systeemlogboek bij kernlog indien volgende waarschuwing gegeven wordt.

Warning! ehci_hcd should always be loaded before uhci_hcd and ohci_hcd, not after" ...

Oplossing: open als root het bestand /etc/initramfs-tools/modules en voeg op het einde volgende toe " ehci_hcd ".
               Sla het bestand op.
               daarna in de terminal "sudo update-initramfs -u".
               heropstarten en het probleem zou opgelost moeten zijn.
PC:Intel dual core 6600 2.4Ghz-Abit AB9-nvidia GeForce 9600 GT-
dual-boot : Debian Lenny - Windows 7
Alle beschrijvingen van de werkelijkheid zijn tijdelijke veronderstellingen

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #11 Gepost op: 2009/06/07, 18:37:02 »
Een oud draadje terug omhooggeschopt.

Na mijn succesverhaal in Hardy (probleem had zichzelf opgelost), ervaarde ik nu in Jaunty transfersnelheden van 3 MB per seconde!

Ik had echter de post van Mario nooit gezien. Ik heb het eens geprobeerd. En ja! Na herstarten klokt mijn eerste test op zowat 19 MByte. Welbedankt, Mario!

Gezien de relatieve stilte rond dit probleem hebben er blijkbaar weinig mensen last van de USB 1 performatie van hun USB 2 schijven. Je merkt het dan ook maar echt als je wat zwaarder kopieerwerk doet.

Wel verontrustend dat dergelijk probleem toch al verschillende versies van de distro blijft verder bestaan ...

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #12 Gepost op: 2009/06/08, 16:06:13 »
Ik gebruik hardy, en heb verschillende snelheden, ene keer snel, andere keer langzaam, denk dat het aan nautilus ligt. Nautilus afgesloten en opnieuw met nautilus kopieren opeens hoge snelheid.(misschien de cache in ubuntu).
Met andere verkenners(in ubuntu) ook hoge snelheden.
Vermoedelijk een combinatie van grote hoeveelheid files copieren(dan is het meestal ook langzamer), opnieuw opstarten nautilus, andere copier programma gebruiken.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #13 Gepost op: 2009/06/08, 19:44:58 »
Ik zal eerst beginnen met afkloppen, maar ik heb dit probleem nog niet gehad. Zowel met hardy als met Jaunty niet. Ik kopieer regelmatig behoorlijke bestanden (USB stick van 16GB en een van 4GB) maar haal zo gemiddeld een overdracht van ±18 MB sec.

Maar toch goed om te weten dat dit draadje bestaat ;)
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #14 Gepost op: 2009/06/28, 21:48:04 »
Een oud draadje weer eens omhooggeschopt.

Wat blijkt? Opeens zit ik weer met de trage overdrachtsnelheden. O ja, enkele dagen geleden een kernelupdate. Het mag echter niet baten: de ingreep van mario werkte niet meer, en ook bij het terug opstarten van de oude kernel kon ik de situatie niet herstellen.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #15 Gepost op: 2009/07/17, 19:26:46 »
Merakel, Merakel, Merakel!

Ik besluit op deze hete bewolkte vrijdagavond nog eens mijn USB probleem te bekijken, en ik kopieer naar de USB schijf om mijn referentie te bepalen. +20 MB/seconde!

Het probleem is dus weer weg zoals het gekomen is: vanzelf. Hopelijk komt het nu niet meer vanzelf terug.

Offline Kogacarlo

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #16 Gepost op: 2009/07/19, 22:22:46 »
Ik heb net mijn stick in het gat geduwd  XD
En wat blijkt; van de stick naar de pc gaat met 20 mB/s en andersom gaat het met 3 mB/s.
Diverse malen herhaald en het blijft zo.
Ubuntu op een stickie

Offline JPtja

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #17 Gepost op: 2009/08/21, 00:23:10 »
30 minuten om 1,5 gb te kopieren naar usbstickje @800kbps... :S
ga dalijk ook even proberen of de raad van Mario helpt ;)
Bij mij is het trouwens ook zo dat van usb naar pc wel gewoon snel gaat :P

Offline JPtja

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #18 Gepost op: 2009/08/21, 13:01:47 »
Na de raad van Mario gaat het bij mij op 2mbps....
Nog niet echt indrukwekkend dus.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #19 Gepost op: 2009/08/22, 03:38:31 »
Heb die tip van Mario ook eens gedaan maar dan kom ik dit uit:
http://forum.ubuntu-nl.org/test-forum/ubuntu-9-10-karmic-koala-40545/msg463641/#msg463641
Lees in de link ook de twee volgende berichten.

Blijkbaar word de usb-snelheid trager gezet in plaats van hoger en veranderd daardoor de desktop-manager naar een lager niveau. (lijkt wel oude xfce). Is zoals in windows als je de kleurdiepte verzet naar 16 of 8 bit, dan krijg je de omgeving van windows95.

Offline JPtja

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #20 Gepost op: 2009/09/02, 21:03:12 »
Uit dit linkje is het bij mij gelukt weer terug op 25mbps te komen:
http://ubuntuforums.org/showthread.php?t=793688


sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
Now edit the boot options

gksudo gedit /boot/grub/menu.lst
Search for "kopt=" (without quotes). It should look something like this

Code:

# kopt=root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro
Now, put a space at the end and add "pci=routeirq" at the end, so it looks like this

# kopt=root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro pci=routeirq
That sets the default options, so that when you upgrade your kernel the fix gets copied, otherwise it will revert.

Next, change the options on your current kernel, search for

End Default Options
Following this will be the boot options for the currently installed kernels. I added the option to the end of each of my current kernels, but I left alone the recovery ones, just in case.

Before

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro quiet splash
initrd /boot/initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, kernel 2.6.24-16-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-16-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro single
initrd /boot/initrd.img-2.6.24-16-generic

After adding "pci=routeirq" to the non recovery options (first and third entries)

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro quiet splash pci=routeirq
initrd /boot/initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, kernel 2.6.24-16-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro quiet splash pci=routeirq
initrd /boot/initrd.img-2.6.24-16-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-16-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=efd264eb-0f54-4d58-953a-d89a85a696e4 ro single
initrd /boot/initrd.img-2.6.24-16-generic

Reboot, and hopefully you'll have USB working again. If it causes problems, then you can restore the old menu.lst with

sudo cp /boot/grub/menu.lst.bak /boot/grub/menu.lst

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #21 Gepost op: 2009/09/03, 09:01:35 »
Het probleem is zeer willekeurig bij mij. Gisteren zat ik plots weer tegen snelheden van 2.5 MB/s aan te kijken. JPtja, ik zal je suggestie eens proberen.

Offline ubuntu4life

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #22 Gepost op: 2009/09/04, 00:00:24 »
Als je file transfer op een ander OS wel snel is dan ligt het niet aan je BIOS.

Good Luck.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb2 is traag
« Reactie #23 Gepost op: 2009/09/04, 12:43:59 »
Dit schijnt een specifiek Ubuntu/debian probleem te zijn.