Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: problemen met beeld (ATI Readon X800Pro)  (gelezen 978 keer)

Offline Hij

  • Lid
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Gepost op: 2006/09/07, 15:59:00 »
Ik heb een vraag. Ik heb een ATI Readon X800Pro video kaart.
Eerst kreeg ik nooit beeld na de installatie van linux. Het opstartscherm kreeg ik wel, maar daarna werd het zwart. Ik heb toen dit gedaan:

RECOVERY MODE:
$sudo nano /etc/X11/xorg.conf

Section "Device" gezocht en de Driver  "bla" vervangen met Driver "vesa"

Toen had ik gewoon beeld, maar hij vond de videokaart niet. Video's afspelen enzo ging dus erg traag. Ik heb toen de fglrx driver geinstalleerd op deze manier:

Code:
sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Toen ik opnieuw opstartte kreeg ik geen beeld meer (ook geen inlogscherm zoals eerst) Ik ben toen gaan kijken in de recovery mode maar bij driver stond nog steeds "vesa" dus dat is niet het probleem.
Iemand enig idee hoe ik dit kan oplossen?

blubber

  • Gast
problemen met beeld (ATI Readon X800Pro)
« Reactie #1 Gepost op: 2006/09/07, 16:48:20 »
Volgens mij moet je vesa in fglrx veranderen. Kun je je xorg.conf posten?

Offline Hij

  • Lid
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Reactie #2 Gepost op: 2006/09/07, 17:46:30 »
heb het gedaan, maar helpt niks helaas.
ik weet niet precies hoe ik mn xorg.conf kan posten omdat ik nu op de pc ernaast zit. De pc waar linux opstaat krijg ik geen beeld dus daar kan ik ook niet mee op internet

ik krijg bij het opstarten wel deze melding:

*not starting GNOME display manager (this is not the default display ... )

klopt niet precies maar zoeits staat er ongeveer.
Mischien dat dat het probleem is?

Offline Hij

  • Lid
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Reactie #3 Gepost op: 2006/09/07, 18:49:22 »
als ik deze commend invoer:
sudo dpkg-reconfigure

krijg ik deze melding:
dpkg-reconfigure: cannot connect to X server
debconf: unable to initialize fronted: Kde
debconf: (DISPLAY problem?)
debconf: falling back to fronted: Dialog

alle dirvers terugzetten naar "vesa" of "fglrx" helpt niks.
hoe moet ik dit oplossen zonder ubuntu opnieuw te hoeven installeren?

blubber

  • Gast
problemen met beeld (ATI Readon X800Pro)
« Reactie #4 Gepost op: 2006/09/08, 01:59:33 »
Hmm, beetje lastig zonder debug info. Ik neem aan dat je sudo dpkg-reconfigure xserver-xorg bedoelt? Wat je zou kunnen doen is
cat /etc/X11/xorg.conf > qwertyen dan van de live cd booten, je /home mounten en jezelf qwerty web-mailen om het vervolgens vanaf je andere computer te posten. Ofzo. Dat kan vast handiger maar het is laat.

En dit kun je nog proberen:
Citaat
If the screen is coming up blank on startup, start in recovery mode then try editing your /etc/X11/xorg.conf file to remove this line
Load "extmod"and optionally replace it with this
SubSection "extmod"
     Option "omit XVideo"
     Option "omit XVideo-MotionCompensation"
     Option "omit XFree86-VidModeExtension"
EndSubSection

Offline Hij

  • Lid
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Reactie #5 Gepost op: 2006/09/08, 18:03:41 »
die regel veranderen werkt helaas ook niet, probleem blijft hetzelfde :(
Geen andere oplossing?

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Reactie #6 Gepost op: 2006/09/08, 19:02:07 »
zo ik heb even een eigen acount aangemaakt ("Hij" was van mijn broer).
Ik kreeg het probleem niet opgelost dus ik heb een herinstallatie gedaan. Ik heb nu weer gewoon beeld, maar het gaat nog steeds erg langzaam. Als ik de test met de tandwielen doe, lopen die ook niet soepel.
Ik kan nu mn xorg.conf posten:
/etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                            # /dev/input/event
                                           # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                        # /dev/input/event
                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                      # /dev/input/event
                                       # for USB
Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. R420 JI [Radeon X800PRO]"
        Driver          "vesa"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "vesa"
        HorizSync       28-49
        VertRefresh     43-72
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. R420 JI [Radeon X800PRO]"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
SubSection "Display"
                Depth           15
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "stylus" "SendCoreEvents"
        InputDevice     "cursor" "SendCoreEvents"
        InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
        Mode    0666
EndSection
ik hoop dat dit helpt!
Open Source = Freedom = Power !!

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Reactie #7 Gepost op: 2006/09/08, 19:06:55 »
Citaat
Section "Device"
        Identifier      "ATI Technologies, Inc. R420 JI [Radeon X800PRO]"
        Driver          "vesa"
Je maakt gebruik van de vesa standaard ubuntu driver terwijl je de ATI driver moet hebben.

Lees ff deze topic:
http://forum.ubuntu-nl.org/topic/2411
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
problemen met beeld (ATI Readon X800Pro)
« Reactie #8 Gepost op: 2006/09/08, 21:10:27 »
bedankt! daar stond het antwoord in!
alles loopt nu lekker :) heb deze keer ook alle codecs en plugins handmatig geinstalleerd ipv easyubuntu. Werkt echt goed!
zo nu ga ik weer verder genieten van dit prachtige besturingssysteem :)
Open Source = Freedom = Power !!