Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: samba / umask / chmod - standaard rechten geven voor nieuwe mappen  (gelezen 2297 keer)

wlevels

  • Gast
Beste mede-forum'ers,

Ik zit met het volgende:

Ik heb (even ter verduidelijking) een data share aangemaakt op een samba server, deze samba server wil ik bij een bedrijf inzetten en doormiddel van ACL's rechten geven.

Nou heb ik een group "users" aangemaakt, waar alle users in komen te staan.

Ik wil dat zodra een gebruiker een map aanmaakt, deze map standaard niet in te zien is door gebruikers in dezelfde primary group en niet in te zien is door de rest, eigenlijk dus chmod 700 rechten. Ik wil de rechten namelijk via ACL's automatisch laten "inheriten".

Wat ik gelezen had, moest ik in /etc/profile de umask setting aanpassen naar wat ik wou, deze zou ervoor zorgen dat iedere user die inlogt automatisch deze rechten meegeeft bij het creeren van een nieuwe map. Ik heb opgegeven:

umask 077

(dit zou dus alleen de creator rechten geven en de rest geen rechten op een nieuwe map)

Helaas werkt dit niet, ik krijg gewoon bij een nieuw aangemaakte map met een willekeurige gebruiker de rechten:

# file: lala
# owner: test
# group: users
user::rwx
group::r-x
other::r-x


Als ik met root een mapje aanmaak gaat alles perfect:

# file: lili
# owner: root
# group: root
user::rwx
group::---
other::---

Zodra ik op de door de user "test" aangemaakte map het volgend commando geef:

chmod 700 lala

Krijg ik dit:

# file: lala
# owner: test
# group: users
user::rwx
group::r-x                      #effective:---
other::---

helaas krijg ik dit dus ook vervolgens bij met acl aangemaakte rechten:

[EDIT] het is mij opgevallen dat dit een beetje dubbel is, ik geef hieronder rechten die ik eerst probeer weg te halen met CHMOD 700 op "group", en vervolgens geef ik de group "users" weer r-x rechten via ACL's, echter dit is niet de oorzaak van mijn probleem dus negeer dit maar even :))

# file: lala
# owner: test
# group: users
user::rwx
user:wesley:rwx                 #effective:---
group::r-x                      #effective:---
group:users:r-x                 #effective:---        
mask::---
other::---

Dit terwijl aangemaakte mapjes met root (die dus 700 hebben) wel gewoon ACL's pakt zonder problemen, en netjes alleen root als user rwx rechten geeft en de rest van de gebruikers uitsluit deze map te benaderen:

# file: lili
# owner: root
# group: root
user::rwx
user:wesley:rwx
group::---
group:users:r-x
mask::rwx
other::---

Hopelijk komen jullie er nog een beetje uit.

Ik hoop dat iemand mij kan helpen. Ik zou het erg op prijs stellen, dit is namelijk het enige wat mij nog verhinderd om deze samba server in het bedrijf in te zetten.

greets en bedankt alvast voor het meedenken!

Offline rja

  • Lid
  • Steunpunt: Nee
samba / umask / chmod - standaard rechten geven voor nieuwe mappen
« Reactie #1 Gepost op: 2008/10/19, 08:00:46 »
Maak je die file aan onder Unix of onder Samba ?

In samba zit ook een create mask en directory mask.

 create mask =0744
 directory mask = 0755

Er zijn meer instellingen die betrekking hebben op acl.

Dan vindt ik Swat wel handig, heb je alle instellingen bij elkaar, als je de Geadvanceerde display kiest bij een share.

sudo apt-get install swat
sudo apt-get install samba-doc

wlevels

  • Gast
samba / umask / chmod - standaard rechten geven voor nieuwe mappen
« Reactie #2 Gepost op: 2008/10/19, 09:30:41 »
Citaat van: rja
Maak je die file aan onder Unix of onder Samba ?

In samba zit ook een create mask en directory mask.

 create mask =0744
 directory mask = 0755
Das een goeie wat je daar zegt, ik neem aan dat hier ook de fout zit.

Ik maak met root gewoon via de console (commando mkdir *), en als ik een user test doe ik dit vanaf een windows werkstation, connect ik naar de share en dan doe ik gewoon rechtermuisknop "nieuwe map"

Thanks! Ik ga eens zoeken op samba default masks.

greets





-------------------[EDIT]opgelost![EDIT]------------------------

Zoals RJA reeds gemeld had, dit was voor mij de oplossing.

Even ter verduidelijking voor mensen die op dit topic stuiten.

Eerst had ik deze share aangemaakt in smb.conf:

[Data]
    comment = Algemene DATA schijf
    read only = no
    path = /data/data

En dacht ik dat de umask setting mijn standaardrechten bepaalde.

Dit was dus niet het geval, dit omdat het dus inderdaad alleen mijn UNIX rechten bepaalde, samba heeft weer losse rechten.

Dit was de oplossing:

[Data]
    comment = Algemene DATA schijf
    read only = no
    path = /data/data
    create mask = 0700
    directory mask = 0700

Nogmaals bedankt RJA!