Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: verbinding maken met een draadloze router  (gelezen 2814 keer)

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Gepost op: 2008/10/16, 20:17:41 »
Ik ben nieuw met Ubuntu - ik heb een oudere desktop die op windows niet meer vooruit te branden was met allerlei virussoftware die nodig was.

Heb in een grijs verleden jaren op een xterminal gewerkt, dus het was leuk om weer eens met vi te werken (was wel een beetje roestig geworden).

De reden dat ik een vraag post is dat ik geen verbinding kan leggen met mijn KPN Experiabox.

Ik draai 8.04 Hardy Heron (GNOME) en heb een Speedtouch 120g USB wireless adapter. Na wat prutsen met NDISWRAPPER ben ik onder meer via dit forum achter gekomen hoe ik de driver kon installeren.

Als ik nu een 'sudo iwlist scan' doe, dan krijg ik onder wlan0 keurig mijn draadloze thuisnetwerkje te zien, met de juiste SSID en het kanaal waarop uitgezonden wordt. Als ik een 'iwconfig' doe, dan zie ik dat er geen contact gelegd wordt met mijn thuisnetwerkje - interface wlan0 heeft geen verbinding gemaakt.

Hoe kan ik nou verbinding maken met mijn netwerk?

Wat ik tot nu toe geprobeerd heb: In het netwerkicoontje rechtsbovenin kan ik met 'manual configuration' mijn thuisnetwerkje zien. Ik heb daar de WPA key ingevuld en vervolgens geen contact kunnen leggen. In /etc/network/interfaces zie ik vervolgens de ESSID van mijn netwerk, maar met een heel andere WPA key. Ten einde raad heb ik maar in deze file de WPA key ingevoerd die ik van de KPN opgekregen heb, maar dat helpt ook niet. Tenslotte heb ik nog geprobeerd om een DNS server op te geven (afgekeken van een andere PC thuis) maar ik ga er eigenlijk van uit dat dat niet nodig zou moeten zijn....

Ik had het idee dat ik heel dichtbij de oplossing was, maar dat laatste stukje lukt me nog niet.... kan iemand me helpen? Ik heb een tijd gezocht, ook op dit forum, maar ben niet verder gekomen - de meeste posts gaan over NDISWRAPPER. Mocht ik met mijn neus gekeken hebben dan hoor ik het graag!

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #1 Gepost op: 2008/10/16, 20:27:53 »
Oh ja, ik heb geen dual boot PC, ik draai alleen UBUNTU.

Maak wel met andere PC's gebruik van hetzelfde draadloze netwerk.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #2 Gepost op: 2008/10/16, 21:09:14 »
Aan roodgolfje
De Netwerk Manager kan niet zo goed met die WPA codes overweg. Probeer het eens zonder code of met WEP. Niet te lange passwoorden helpt ook soms. En een paar keer opnieuw opstarten met de internetverbinding met kabel erbij.
Vr.groet, peter

Ja, WPA lukt wel als de verbinding eenmaal geslaagd is.

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #3 Gepost op: 2008/10/16, 21:38:39 »
heb ook even geprobeerd om in networkmanager geen WPA key in te vullen, en heb 'm daarna weer opnieuw ingevuld. Dat hielp niet. Maar volgens mij bedoel je dat ook niet. Bedoel je wat anders, PetervdW?

Oh ja, ik heb geen kabel, alleen de draadloze USB adapter.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #4 Gepost op: 2008/10/17, 00:15:39 »
Aan roodgolfje
Ik bedoelde eigenlijk dat je ook in het modem even de code moet weglaten. Maar bij nog eens lezen ontdekte ik dat je zo'n KPN modem hebt met een vast ingestelde code. Dus daar kun je niet in. Overheen gelezen. Sorry. Stom van me.
Heb je de drivers bij speedtouch opgehaald voor de 120? Bij de 121 heb ik het werkend gekregen door op een andere computer onder XP met het schijfje van KPN de 121 te installeren. Bij die geinstalleerde files vind je de XXXX.sys en de XXXX.inf files. Die moet je ook gebruiken voor Ubuntu (van die 120 dan, hè)
Die zet je onder Ubuntu in een mapje. Met Ndiswrapper verwijs je naar die XXXX.inf file (kan ook XXXX.INF zijn.) Heb je dat ook zo gedaan? Als je geen kabel verbinding voor Ubuntu hebt, kun je de files overbrengen met een geheugenstick van af een Windowscomputer.
Ik hoop dat het helpt.
Vr.groet, peter

http://www.speedtouch.nl/software.html#110g

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #5 Gepost op: 2008/10/17, 08:14:02 »
Hoi Peter, dat is precies wat ik gedaan heb. Ik heb ook het idee dat het adaptertje zelf nu wel werkt: ik kan mijn thuisnetwerk zien (met iwlist scan), ik kan alleen geen verbinding maken.

martinx76

  • Gast
verbinding maken met een draadloze router
« Reactie #6 Gepost op: 2008/10/17, 10:53:48 »
Hoi Roodgolfje,

Ik herken het probleem. Het rare is dat ik het met exact dezelfde hardware (experiabox en speedtouch 120g usb adapter wel werkend heb gekregen.
Soms moet hij het een aantal keer (3 a 4) en dan doet hij het wel. Soms moet ik ook opeens opnieuw de WPA key ingeven.

Ik probeer nu met een nieuwe installatie op mijn externe schijf het weer werkend te krijgen en dat lukt me nu ook niet meer. Dus ik weet niet precies waar het nou aan ligt. (zie ander topic in dit forum)

Maar goed: je hebt dus een oude desktop waar eerder windows opstond? Dan kan het zijn dat de laatste keer dat je draadloos verbinding maakt met deze PC onder windows het ip adres niet vrijgegeven werd. Normaal kun je dat oplossen door onder windows op die PC ipconfig /release onder uitvoeren in te tikken en dan op te starten in ubuntu. Dat zal bij jou lastig worden.
Wat je kunt doen:
Handmatig invoeren van de gegevens (SSID en WPA key) verbinding laten maken, en daarna (zonder af te sluiten) direct roaming service aanzetten. Dan vraagt hij weer om de WPA key, maar soms blijkt dit te werken.

Wat je ook kan doen is dat bestand in /etc/network/interfaces verwijderen en dan opnieuw de codes invullen.

Succes. Ik blijf het met mijn PC ook proberen, als ik het werkend krijg post ik het hier wel.


Edit: eind oktober komt de nieuwe versie (8.10) van Ubuntu uit, de netwerkmanager die daarin zit schijnt wel met WPA keys overweg te kunnen. Dus als je nog ff geduld hebt dan wordt het wrsch wel opgelost.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #7 Gepost op: 2008/10/17, 11:03:29 »
Aan roodgolfje
OK, het enige wat ik je kan aanraden is het blijven proberen. Hier op het forum lees je heel vaak dat het na verloop van tijd en een beetje aan de NetwerkManager wringen ineens toch lukt. Daarbij zou ik gewoon de door kpn opgegeven WPA code gebruiken. Niemand kan verklaren waarom het dan ineens wel gaat. Zelf probeer ik dat soort dingen werkend te krijgen, als ik de spullen heb, op diverse computers, en ik moet zeggen, soms lukt het pas na dagen wroeten. Maar ik heb uiteraard niet alle spullen waar op het forum sprake van is.
Controleer via de Synaptic of de WPA-Supplicant is geinstalleerd, installeer libstdC++5, en hou de updates bij. Ubuntu is grotendeels in C++6 gemaakt, maar sommige routines maken nog gebruik van de oude versie. Kan geen kwaad om het erbij te zetten.
Misschien zijn er anderen die nog andere oplossingen kunnen voorstellen?
Vr.groet, peter

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #8 Gepost op: 2008/10/17, 14:10:01 »
Martin, Peter,

bedankt voor jullie antwoorden! Helaas lukt het nog niet...

Heb /etc/network/interfaces verwijderd en in de network manager de gegevens opnieuw ingevuld. In de network manager wordt mijn netwerk ook gevonden, ook de signaalsterkte krijg ik te zien. Na invullen is de file /etc/network/interfaces opnieuw aanwezig, met het juiste ssid. Dus dat werkt allemaal wel.

De wpasupplicant is met de installatie meegekomen, libstdc++5 moet ik even opsnorren.

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #9 Gepost op: 2008/10/17, 14:39:07 »
Ik heb precies dezelfde ervaring zoals Petervdw beschrijft. NM in Hardy is en blijft lastig te sturen.
Een relatief simpele oplossing kan ook zijn om direct achter de experiabox met een kabeltje een andere draadloze router(als accesspoint) te zetten. Daarmee lukte het mij zowel met WPA en met een vast IP adres te werken. Met de experiabox (ik gebruik de Siemens) lukt dat niet altijd met Ubuntu. Daarbij ook rekening houden dat het kanaal waarop door de router zendt niet altijd ontvangen wordt door Ubuntu. Kortom: meestal niet eenvoudig, voor beginnende Ubuntero's.
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline Petervdw

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #10 Gepost op: 2008/10/17, 14:40:08 »
Aan roodgolfje
Ja, dat is de manier, gewoon volhouden. Opnieuw opstarten en overnieuw een netwerk aanmaken,
echt waar, zo werkt het bij mij vaak ook, rommelen. Eén maal gemaakt, dan werkt het verder meestal automatorieschjjj goed.
peter

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #11 Gepost op: 2008/10/17, 15:07:03 »
Helaas... een extra router heb ik zo niet liggen. Heb de libstc++5 geinstalleerd, en nog een ander pakket (was nodig ivm dependencies) en nu krijg ik een mysterieuze mededeling bij het opstarten, nadat het scherm eerst een hele tijd blanco blijft met een grijs vak linksboven:  
There was an error starting the GNOME settings daemon
Some things, such as themes, sounds or background settings may not work correctly.

The last error message was:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GNOME will still try to restart the Settings Daemon next time you log in.

Deze fout kreeg ik eerder niet....! Zou ik nou toch heel even contact met het netwerk hebben? Firefox werkt nog steeds niet.....

In ieder geval alvast bedankt voor alle advies. Misschien moet ik inderdaad maar even wachten op de volgende versie.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #12 Gepost op: 2008/10/17, 16:42:22 »
Aan roodgolfje
Je schreef: libstc++5, maar ik neem aan dat je libstdC++5 hebt geïnstalleerd (via Synaptic?) en dat het een typefoutje is. De foutmeldingen die je beschreef, zijn die nu na nog eens opstarten over? Als ze blijven moeten we er toch even serieus naar zoeken.
Vr.groet, peter

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #13 Gepost op: 2008/10/17, 17:17:29 »
Klopt Peter, ik schreef het verkeerd. Ik bedoelde libstdC++5. En ik moest ook cdd-3.3-base_3.3.6-15_i386.deb installeren, want die dependency zat erin.

Na een paar keer opnieuw opstarten verandert de situatie niet. Wat nu? Toch die pakketjes maar weer deinstalleren?

Offline Petervdw

  • Lid
  • Steunpunt: Nee
verbinding maken met een draadloze router
« Reactie #14 Gepost op: 2008/10/17, 20:59:29 »
Sorry, ik kan er bij mij niets over terugvinden. Je kan via de Synaptic proberen om het pakket te deïnstalleren. Als dan die melding weg is, zou ik het maar zo laten.
Voor het eerst dat dit voor de dag komt.
Vr.groet, peter

Het is me ook niet duidelijk wat er mee bedoeld wordt en waar het voor dient.
Vreemd.

roodgolfje

  • Gast
verbinding maken met een draadloze router
« Reactie #15 Gepost op: 2008/10/18, 10:33:07 »
ik heb de pakketten gedeinstalleerd en nu blijft het vreemde effect aanwezig. Ik denk dat ik Ubuntu maar opnieuw moet installeren of wachten op de volgende versie.

Hoop dat iemand anders nog een goed idee heeft? Iemand thuis in het gebruik van terminal commando's (iwconfig)? Ik heb hier een tijd mee zitten spelen maar kreeg het niet voor elkaar.