Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Firefox en flash 32bits installeren op 64bits systeem  (gelezen 3810 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Gepost op: 2008/10/15, 15:04:54 »
Heeft of weet iemand een duidelijke stap-voor-stap tutorial om de 64 bits versies van Firefox 3.0.3 en Flash 9 te verwijderen en daar de 32bits versies Firefox 3.0.3 en Flash 10 voor in de plaats te zetten?
De tutorials die ik tot op heden gezien heb, zijn namelijk om hoofdpijn van de krijgen. Om niks ook nog, want het werkte allemaal niet...
Ik houd me van harte aanbevolen, want het is het is een waar surfdrama miet die moderne Flashbeklede sites tegenwoordig!
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #1 Gepost op: 2008/10/17, 00:01:54 »
Aparte versies van Firefox en flash? Ik kan ze niet vinden http://packages.ubuntu.com/

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #2 Gepost op: 2008/10/17, 00:04:19 »
Intrepid, dat is de volgende versie van ubuntu zal flash 10 bevatten. Deze zal binnen een kleine 2 weken uitkomen, namelijk 30 oktober.

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #3 Gepost op: 2008/10/17, 00:10:29 »
Citaat van: siegi
Intrepid, dat is de volgende versie van ubuntu zal flash 10 bevatten. Deze zal binnen een kleine 2 weken uitkomen, namelijk 30 oktober.
Ook 64bits?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #4 Gepost op: 2008/10/17, 00:13:40 »
De 64 bit versie van ubuntu gebruikt nspluginwrapper.
Met dit klein tooltje kan een 64 bit firefox, een 32 bit plugin van flash gebruiken.

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #5 Gepost op: 2008/10/17, 00:41:40 »
Citaat van: siegi
De 64 bit versie van ubuntu gebruikt nspluginwrapper.
Met dit klein tooltje kan een 64 bit firefox, een 32 bit plugin van flash gebruiken.
Juist, die is ook geïnstalleerd. Toch kan ik de deb-file van Flash 10 niet installeren (Error: Wrong architexture 'i386') onder 8.04.1 64bits...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #6 Gepost op: 2008/10/17, 14:25:02 »
Dan zal je het verkeerde pakket gedownload hebben...
Je moet de amd64 hebben. Want i386 is 32 bit.
http://packages.ubuntu.com/intrepid/flashplugin-nonfree

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #7 Gepost op: 2008/10/17, 14:46:09 »
Citaat van: siegi
Intrepid, dat is de volgende versie van ubuntu zal flash 10 bevatten. Deze zal binnen een kleine 2 weken uitkomen, namelijk 30 oktober.
Hoe kom je daar op? Flash zal nooit meegeleverd worden met Ubuntu, omdat het geen vrije software is. Flash 10 draait daarbij prima in Hardy.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #8 Gepost op: 2008/10/17, 14:53:03 »
Citaat van: cumulus007
Citaat van: siegi
Intrepid, dat is de volgende versie van ubuntu zal flash 10 bevatten. Deze zal binnen een kleine 2 weken uitkomen, namelijk 30 oktober.
Hoe kom je daar op? Flash zal nooit meegeleverd worden met Ubuntu, omdat het geen vrije software is. Flash 10 draait daarbij prima in Hardy.
Ik denk, dat Siegi bedoelt dat Flash 10 bij Intrepid in het pakket ubuntu-restricted-extras zal zitten.

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #9 Gepost op: 2008/10/17, 14:53:22 »
Citaat van: siegi
Dan zal je het verkeerde pakket gedownload hebben...
Je moet de amd64 hebben. Want i386 is 32 bit.
http://packages.ubuntu.com/intrepid/flashplugin-nonfree
Bedankt voor de link. Via de Adobe site werd alleen 32bits aangeboden. 's Kijken of het werkt in Hardy 64bits...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #10 Gepost op: 2008/10/17, 14:53:26 »
Citaat van: cumulus007
Citaat van: siegi
Intrepid, dat is de volgende versie van ubuntu zal flash 10 bevatten. Deze zal binnen een kleine 2 weken uitkomen, namelijk 30 oktober.
Hoe kom je daar op? Flash zal nooit meegeleverd worden met Ubuntu, omdat het geen vrije software is. Flash 10 draait daarbij prima in Hardy.
Okey na het installeren van ubuntu-restricted extras gaat het out of the box werken...
Het leek me overigens gewoon het gemakkelijkste voor hem om te wachten op intrepid, inplaats van de kans te lopen dat flash helemaal niet meer werkt :)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #11 Gepost op: 2008/10/17, 14:59:50 »
Je loopt niet echt veel gevaar. Vanaf de site van Adobe kun je een .deb downloaden. Werkt flash 10 onverhoopt niet, dat installeer je de oude flashplugin-nonfree weer gewoon terug.

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #12 Gepost op: 2008/10/17, 15:05:53 »
Citaat van: cumulus007
Je loopt niet echt veel gevaar. Vanaf de site van Adobe kun je een .deb downloaden. Werkt flash 10 onverhoopt niet, dat installeer je de oude flashplugin-nonfree weer gewoon terug.
Als je even had terug gelezen had je gezien dat de persoon in kwestie 64 bit gebruikt, een 32 bit pakket kan dan niet geinstalleerd worden zonder het te forceren.

Als je nog niet veel ervaring hebt met linux kan zoiets er wel voor zorgen dat flash niet meer wil werken. Gewoon is niet gewoon bij beginners.

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #13 Gepost op: 2008/10/17, 15:13:58 »
Citaat van: 10o
Citaat van: siegi
Dan zal je het verkeerde pakket gedownload hebben...
Je moet de amd64 hebben. Want i386 is 32 bit.
http://packages.ubuntu.com/intrepid/flashplugin-nonfree
Bedankt voor de link. Via de Adobe site werd alleen 32bits aangeboden. 's Kijken of het werkt in Hardy 64bits...
Installeren gaat ook met de 64bits file niet goed:
Flash Plugin installed.
*** NSPlugin Viewer *** ERROR: libnss3.so: cannot open shared object file: No such file or directory
nspluginwrapper: no appropiate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so
Frapante is dat-ie in Software toevoegen/verwijderen wel weer aangevinkt staat, maar in Firefox pagina about:plugins niet te zien is en niet werkt.
Door ´m in synaptic te verwijderen en weer opnieuw aan te vinken, heb ik versie 9 weer terug.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #14 Gepost op: 2008/10/17, 15:33:03 »
Waarschijnlijk ga je de nieuwe versie van nspluginwrapper nodig hebben, maar die is van redelijk wat afhankelijk.
Ik zou gewoon mijn eerder advies nemen om te wachten op intrepid.

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #15 Gepost op: 2008/10/18, 10:28:50 »
Flash 10 is als volgt via terminal te installeren in Ubuntu 64bits:

1. Script downloaden:
wget http://queleimporta.com/downloads/flash10_en.sh

2. Script uitvoerbaar maken:
sudo chmod +x flash10_en.sh

3. Script uitvoeren
sudo sh ./flash10_en.sh

4. Bestanden verwijderen (eventueel)
rm flash10_en.sh getlibs-all.deb
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #16 Gepost op: 2008/10/18, 12:31:05 »
Dat lijkt me niet het gezondste manier om flash 10 te installeren. Je kan het beste een kleine twee weekjes wachten tot intrepid.

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #17 Gepost op: 2008/10/18, 14:07:26 »
Citaat van: Kiwinote
Dat lijkt me niet het gezondste manier om flash 10 te installeren. Je kan het beste een kleine twee weekjes wachten tot intrepid.
Why not? Wat zijn de bezwaren van het script?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #18 Gepost op: 2008/10/18, 14:12:43 »
flash wordt op een handmatige manier geïnstalleerd. Ik zal een paar mogelijkheden opnoemen die kunnen mislopen.
Er kan bijv een beveiligingslek zijn in flash. Die belangrijke update zal je mislopen.
Je gebruikt nog nspluginwrapper uit de ubuntu repo's, stel dat ubuntu hiervan een update uitbrengt dan kan het gebeuren dat flash niet meer werkt, of niet meer stabiel werkt.
Bij een latere upgrade naar intrepid, loop je de kans dat flash niet meer werkt, er blijft zowiezo rotzooi achter.

En als het misloopt is het weer allemaal ubuntu zijn schuld ... (zeggen de meeste mensen die je tip zouden volgen)

Offline 10o

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #19 Gepost op: 2008/10/18, 14:17:12 »
Wat is het alternatief dan, als je bij de LTS versie 8.04.1 wil blijven en veel problemen ondervindt met de 'oude' flash onder 64bits?
Is het script terug te draaien?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #20 Gepost op: 2008/10/18, 14:22:28 »
Citaat van: Kiwinote
Dat lijkt me niet het gezondste manier om flash 10 te installeren. Je kan het beste een kleine twee weekjes wachten tot intrepid.
Helemaal mee eens.
Gewoon even wachten op Intrepid of totdat Flash 10 in de repo's van Hardy komt. Dat zal misschien nog een week of 2 duren. Als je al jaren met Flash 9 gewerkt hebt, kunnen die 2 weekjes er ook nog wel bij.

Offline merijn

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #21 Gepost op: 2008/10/23, 16:22:38 »
Ik ga er ook van uit dat flash 10 uit zal komen voor Hardy,want het is immers een LTS versie.
Alleen hij is nog niet stabiel voor Hardy dus vandaar dat hij nog niet in de repo zit.
Intrepid is gewoon het nieuwste van het nieuwste,vandaar dat flash 10 er daar wel standaard bij zit, althans als je de medibuntu repo installeerd.
Ik hou mijn systeem bij Hardy,want deze is verder ontwikkeld nu dan Intrepid,en heeft dus wat minder kinderziektes wat Intrepid wel nog zou kunnen hebben.
De half jaarlijkse versie´s van Ubuntu zie ik gewoon als tussenstappen naar een betere stabiele volgende LTS versie.
Mede daarom dat ik mijn systeem nog lekker met Hardy laat werken.

Offline Drummies

  • Lid
  • Steunpunt: Nee
Gestopt als aktief Forumlid 17/10/2011

Offline siegi

  • Lid
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #23 Gepost op: 2008/10/23, 17:12:19 »
Die voor 64 bit gebruikt nog steeds dat script en dus redelijk ugly.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Firefox en flash 32bits installeren op 64bits systeem
« Reactie #24 Gepost op: 2008/10/23, 17:55:03 »
Citaat van: 10o
Citaat van: Kiwinote
Dat lijkt me niet het gezondste manier om flash 10 te installeren. Je kan het beste een kleine twee weekjes wachten tot intrepid.
Why not? Wat zijn de bezwaren van het script?
Hier is de code van dat script:
#!/bin/bash
# Script  created by
# Romeo-Adrian Cioaba romeo.cioaba@spotonearth.com
# Super minor updates by jason.melton[at]gmail[dot]com
# Updates by Alejandro Cuervo 3[at]cuervo[dot]net
# Released under GPL

echo "Closing Firefox"
sudo killall -9 firefox

echo "Downloading and instaling Getlibs for required libraries"
wget http://www.boundlesssupremacy.com/Cappy/getlibs/getlibs-all.deb
sudo dpkg -i getlibs-all.deb

echo "Removing previous installs of flash:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper

echo "Installing ia32-libs and nspluginwrapper"
sudo apt-get install ia32-libs nspluginwrapper

echo "Getting libs"
sudo getlibs -p libcurl3
sudo getlibs -p libnss3-1d
sudo getlibs -p libnspr4-0d

echo "Installing Flash Player 10"
cd ~
wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
tar zxvf install_flash_player_10_linux.tar.gz
sudo cp install_flash_player_10_linux/libflashplayer.so /usr/lib/mozilla/plugins/
rm -rf ~/install_flash_player_10_linux/
sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

echo "Linking the libraries so that firefox can see them."
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/firefox-addons/plugins/

echo "Done :-)"
echo "You may re-start Firefox now"
De uitleg waarom het niet echt gezond is:

echo "Closing Firefox"
sudo killall -9 firefox
Zonder waarschuwing of vraag wordt Firefox op de meest abrupte manier afgesloten. Hierdoor kan je niet opgeslagen werk kwijtraken, kunnen "lock" bestanden achterblijven of andere verstoringen plaatsvinden.

echo "Downloading and instaling Getlibs for required libraries"
wget http://www.boundlesssupremacy.com/Cappy/getlibs/getlibs-all.deb
sudo dpkg -i getlibs-all.deb
echo "Getting libs"
sudo getlibs -p libcurl3
sudo getlibs -p libnss3-1d
sudo getlibs -p libnspr4-0d
Geen idee wat dat "Getlibs" precies is, maar zomaar ergens wat pakketten vandaan halen is onveilig, en als je niet weet wat het doet ook onverstandig. Kijk ik naar de namen van de libs die blijkbaar opgehaald worden, dan zitten die ook gewoon in Synaptic... Waarom zou je dan zo moeilijk doen?

echo "Removing previous installs of flash:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper
Zomaar dingen verwijderen binnen mappen die door de package manager beheerd worden is niet bevorderlijk voor de gezondheid van je systeem.

echo "Installing Flash Player 10"
cd ~
wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
tar zxvf install_flash_player_10_linux.tar.gz
sudo cp install_flash_player_10_linux/libflashplayer.so /usr/lib/mozilla/plugins/
rm -rf ~/install_flash_player_10_linux/
sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

echo "Linking the libraries so that firefox can see them."
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/firefox-addons/plugins/
Er vindt geen controle plaats op het downloaden van bestanden. Als dat mislukt, dan gaat het script gewoon door, met mogelijk vreemde gevolgen. Ook de integriteit van het gedownloade bestand wordt niet gecontroleerd.


Verder installeer je dingen buiten de package manager om (getlibs(?), en flash zelf). Je moet nu dus zelf bij gaan houden of er updates zijn voor flash, en die daarna handmatig bijwerken. Erg omslachtig en waarschijnlijk vergeet je dat. Mogelijk conflicteren de bestanden die je op je computer zet in een later stadium met de bestanden die je via Synaptic installeert, bijvoorbeeld met het officiële flash-pakket dat Ubuntu binnenkort vast aan gaat bieden.
Je gebruikt ook een niet-standaard manier om dingen te installeren, en installeert pakketten die niet van Ubuntu afkomstig zijn. Fouten oplossen gaat dus niet op dezelfde manier als bij de rest van de Ubuntu gebruikers en bugs melden bij Canonical gaat niet.
Ik zal vast wel wat dingen over het hoofd gezien hebben, of te zwaar rekenen, maar dit zijn wat bezwaren die ik zo snel zie.