Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: php parser werkt niet in Ubuntu 8.10  (gelezen 4203 keer)

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Gepost op: 2008/10/14, 16:30:56 »
Tijdens het testen van 8.10 heb ik apache2 en php5 geinstalleerd als ik nu een php file met firefox open in localhost wordt gevraagd of ik de file wil openen of downloaden.

Met andere woorden de PHP parser werkt niet, ik heb diverse van deze configuraties draaien met Hardy 8.04 zonder problemen, het lijkt dus een 8.10 probleem.

Zijn er nog meer mensen tegen dit probleem opgelopen?

Offline lordnoid

  • Lid
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #1 Gepost op: 2008/10/14, 17:30:45 »
Heb je ook libapache2-mod-php5 geinstalleerd?

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #2 Gepost op: 2008/10/14, 18:55:11 »
Citaat van: lordnoid
Heb je ook libapache2-mod-php5 geinstalleerd?
Ja ook die is geinstalleerd maar het wil nog steeds niet, lijkt toch een bug in 8.10

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
php parser werkt niet in Ubuntu 8.10
« Reactie #3 Gepost op: 2008/10/14, 18:59:43 »
Met de handleiding op de wiki ging het hier in één keer goed.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #4 Gepost op: 2008/10/17, 10:04:28 »
Ik begrijp er niets van, zojuist een nog maar eens een nieuwe install van Ubuntu 8.10 gedaan.

Apache2 geinstalleerd
php5 geinstalleerd

http://localhost/  werkt prima

Maar roep ik in localhost een php file aan dan vraagt firefox om de file te downloaden of te openen.

Op mijn andere machine met 8.04 werkt het 100% met dezelfde instellingen of ik zie consequent iets over het hoofd.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
php parser werkt niet in Ubuntu 8.10
« Reactie #5 Gepost op: 2008/10/17, 11:35:39 »
Citaat van: velthuizen
Ik begrijp er niets van, zojuist een nog maar eens een nieuwe install van Ubuntu 8.10 gedaan.

Apache2 geinstalleerd
php5 geinstalleerd

http://localhost/  werkt prima

Maar roep ik in localhost een php file aan dan vraagt firefox om de file te downloaden of te openen.

Op mijn andere machine met 8.04 werkt het 100% met dezelfde instellingen of ik zie consequent iets over het hoofd.
Heb je op de rechten van je files gelet?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
php parser werkt niet in Ubuntu 8.10
« Reactie #6 Gepost op: 2008/10/17, 11:46:38 »
Heb je alles gedaan wat hier staat:
https://help.ubuntu.com/8.04/serverguide/C/php5.html

Dan moet het werken !
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #7 Gepost op: 2008/10/17, 16:43:28 »
Al het bovenstaande heb ik uitgevoerd maar het wil echt niet gaan werken.

Weet je zeker dat je het werkend hebt in Ubuntu 8.10 want in 8.04 werkt het perfect.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
php parser werkt niet in Ubuntu 8.10
« Reactie #8 Gepost op: 2008/10/17, 16:59:47 »
Vanaf versie 7.04 heb ik het in alle versies gebruikt, eigenlijk nooit problemen gehad, alleen de rechten moesten nog met de hand ingesteld worden.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #9 Gepost op: 2008/10/17, 17:16:27 »
Nee dat vraag ik niet, ik vraag heb je het ook werkend onder 8.10 want onder alle voorgaande versies werkt het bij mij ook.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
php parser werkt niet in Ubuntu 8.10
« Reactie #10 Gepost op: 2008/10/17, 18:20:39 »
Ik heb het werkend onder 8.10. Gewoon geinstalleerd vanuit synaptic door te kiezen voor installeren naar taken en dan lamp server selecteren.

Verder had ik het probleem ook eerst, maar na de rechten allemaal goed te zetten (uitvoerbaar maken) en apache opnieuw te hebben opgestart:

sudo /etc/init.d/apache2 restart

deed alles het prima.

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #11 Gepost op: 2008/10/17, 18:44:25 »
Vreemd want in synaptic van 8.10 is bij mij lamp niet te vinden en alleen via de terminal te installeren.

Offline Koen Bokern

  • Lid
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #12 Gepost op: 2008/10/17, 20:16:02 »
Probeer eens a2enmod php5 in de terminal. Ik weet even niet of deze root rechten nodig heet.

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #13 Gepost op: 2008/10/17, 20:24:50 »
Citaat van: vlerknozem
Probeer eens a2enmod php5 in de terminal. Ik weet even niet of deze root rechten nodig heet.
a2enmod php5 geeft: php5 already enabled

Zover ik kan zien is alles goed geinstalleerd zowel apache als php alleen de parser werkt niet als ik een php file opent met Firefox in Localhost.


Ik heb zojuist nog even getest door het IP adres te gebruiken in plaats van Localhost
en dan werkt het perfect.
Het is niet de gebruikelijke manier maar goed hier kan ik mee leven, ga later wel eens zoeken waarom localhost niet werkt.

7horses

  • Gast
php parser werkt niet in Ubuntu 8.10
« Reactie #14 Gepost op: 2008/10/22, 15:50:28 »
Ik heb een gelijkaardig probleem.  Lokaal via http://127.0.0.1/drupal5 werkt alles prima. browse ik vanop een andere pc naar de site vb http://192.168.2.2/drupal5 ga werkt php blijkbaar ook niet.

Dirk

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
php parser werkt niet in Ubuntu 8.10
« Reactie #15 Gepost op: 2008/10/22, 15:59:14 »
Met localhost werkt nu ook maar alleen als ik er geen .php achter zet

Offline jeroenl

  • Lid
  • Steunpunt: Nee
Re: php parser werkt niet in Ubuntu 8.10
« Reactie #16 Gepost op: 2008/12/31, 03:01:18 »
Nog een oplossing gevonden voor dit probleem? Ik heb het zelfde na een her install van alle lamp onderdelen :(


Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: php parser werkt niet in Ubuntu 8.10
« Reactie #17 Gepost op: 2009/01/02, 09:38:47 »
Verwijder alle lamp-onderdelen eens grondig. Daarna:
sudo tasksel
met Tab de Lamp-installatie selecteren.