Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met X-server  (gelezen 4689 keer)

lucdec

  • Gast
Probleem met X-server
« Gepost op: 2005/12/05, 19:26:52 »
Dag iedereen,

Ik had graag Ubuntu op mijn pc geplaatst.

Eerst probeer ik met de live cd.  Dit lukt niet.
Kan iemand mij helpen ?

Alles loopt goed, op een bepaald moment (juist
achter "checking battery state" doet hij niet
verder.
Hij geeft een foutmelding over de X-server en
vraagt of ik de logging wil zien.

Hieruit geraak ik niet wijzer.
Na nogmaals klikken zegt de installatie :
X-server is now disabled, restart GDM when it is
configured correctly"

Ik weet niet wat ik moet configureren, bij de live
cd kan dat trouwens niet , denk ik.

Juist het zelfde probleem bij de 64 bit versie.

Mijn pc :

amd sempron 64 bit 3Ghz
lan, video, sound onboard
moederbord asrock k8nf4g-sata2
video nvidia geforce 6100

Kan het niet werken bij mij ?
Ik heb geen ervaring met ubuntu of linux
in het algemeen.

Alvast mijn dank

Luc

lucdec

  • Gast
Probleem met X-server
« Reactie #1 Gepost op: 2005/12/05, 21:08:38 »
Dag nogmaals,

Ik zie toevallig op de site van nvidia

http://www.nvidia.com/object/linux_display_amd64_1.0-8174.html

dat ze vandaag een  linux videodriver uitgebracht
hebben die de geforce6100 ondersteund.
Hoe kan ik deze laten werken met de live cd ?

Groetjes

Luc

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Probleem met X-server
« Reactie #2 Gepost op: 2005/12/05, 22:17:51 »
Moeilijk en dat moet elke keer weer opnieuw, dus dat is niet aan te raden :) Kun je eens de tekst uit het log meesturen.

lucdec

  • Gast
Probleem met X-server
« Reactie #3 Gepost op: 2005/12/06, 20:55:20 »
Sorry Dennis, Ik heb het vandaag opnieuw
geprobeerd, mar nu krijg ik geen log file te zien.
De pc doet op die plaats niet meer verder en hij
zegt dat er een probleem is met de
grafische interface.

Ik heb dan nogmaals geprobeerd nu met
het commando live-expert, en het loopt
ook verkeerd bij het kiezen van de
grafische interface.
Waarschijnlijk staat het linux stuurprogramma
voor de nvidia geforce6100 chipset nog
niet op de cd.  Ik zie dat  er wel 1 beschikbaar is
op de nvidia site sedert 5/12.
Mijn pc is vrij recent.
Is er een mogelijkheid om die te gebruieken ?
Ik heb die driver afgehaald van de nvidia site.
Hij is +- 10 mbyte groot, maar hij opent
als een tekstbestand, Het is zeker
geen exe file ?  Wie weet raad?

groetjes
Luc

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Probleem met X-server
« Reactie #4 Gepost op: 2005/12/06, 21:10:30 »
De driver is inderdaad een script. Maar als je het ganse bestand bekijkt zie je wel een aantal "binaire" zaken staan. De driver kan je installeren door in een console:
- chmod +x
- ./
Dit zal de driver installeren en compileren voor uw kernel. Ik heb ook een NVidia kaart en mijn PC is ook recent. Werkt perfect. Ik gebruik wel de volledige installatie, dus niet de live CD.

lucdec

  • Gast
Probleem met X-server
« Reactie #5 Gepost op: 2005/12/06, 21:37:42 »
Dag kenny,

Ik gebruik de live cd als kennismaking met linux.
Als ik het goed begrijp, kan ik niet verder meer
met de live cd ?

Hoe kom ik in zo een console ?

Hoe weet u zo die commando's ?
Is dit het goede commando :
chmod +x driver6100./driver6100

groetjes
Luc

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Probleem met X-server
« Reactie #6 Gepost op: 2005/12/06, 21:45:13 »
Wel, aangezien X niet start veronderstel ik dat je gewoon op de commandolijn terecht bent gekomen. Je kan dan inderdaad:
- chmod +x
- ./

Hoe ik al die commando's weet, tja, lees eens http://kennywest.blogspot.com (25/11/2005) als je een beetje tijd hebt ;)

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Probleem met X-server
« Reactie #7 Gepost op: 2005/12/07, 16:13:41 »
Wat ik je aan kan raden: wacht 5 maanden. Je PC heeft delen die zo nieuw zijn dat ze nog niet door linux ondersteund worden. Over 5 maanden komt de volgende versie van Ubuntu uit die deze drivers zeker zal hebben.

lucdec

  • Gast
Probleem met X-server
« Reactie #8 Gepost op: 2005/12/07, 21:17:21 »
ok Dennis,

Dat zal het beste zijn.

Mocht je nog nieuws hebben, omtrent
Nvidia6100 en Ubuntu, mail mij
gerust.  

Dank u
Luc

Offline bwog

  • Lid
  • Steunpunt: Nee
Probleem met X-server
« Reactie #9 Gepost op: 2005/12/08, 12:54:32 »
Met de install CD zou lucdec wellicht eerst de vesa drivers kunnen installeren. Die werken toch altijd? Later, als lucdec aan linux gewend is, kan deze howto gebruikt worden: http://ubuntuforums.org/showthread.php?t=75074

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Probleem met X-server
« Reactie #10 Gepost op: 2005/12/08, 13:55:14 »
Mja, maar vesa is bok-en-bok traag. Als je iets aan spelletjes wilt kun je het wel vergeten :)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Probleem met X-server
« Reactie #11 Gepost op: 2005/12/08, 14:27:07 »
Waarom prullen met een live CD. Als de live CD niet werkt wil dit niet noodzakelijk zeggen dat Linux (of Ubuntu) niet zal werken voor u. Durf de stap te nemen, Windows eraf, Ubuntu erop ... you'll enjoy the ride.

Offline bwog

  • Lid
  • Steunpunt: Nee
Probleem met X-server
« Reactie #12 Gepost op: 2005/12/08, 15:32:36 »
Ik heb het ook over installeren. VESA is geen pretje, maar ik zou toch even willen wennen aan linux voor dat ik bovengenoemde howto ga proberen voor de 6100 driver.

Voordeel is dat lucdec niet 5 maanden hoeft te wachten. Nadeel is de lastige installatie van de driver.

Wat zou Johan's inbreng in deze zijn? :)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Probleem met X-server
« Reactie #13 Gepost op: 2005/12/08, 15:39:37 »
Ok, maar ik heb ook een Nvidia kaart, zelfs een recentere versie dan lucgen. De installatie van (toen nog Hoary) ubuntu verliep vlot. Grafisch werkte ook alles onmiddellijk. Pas later heb ik de nvidia driver gebruikt van de website ... en dat was niet echt moeilijk :D

lucdec

  • Gast
Probleem met X-server
« Reactie #14 Gepost op: 2005/12/08, 21:33:49 »
Hallo,
Vriendelijk bedankt voor de reacties iedereen.
Nog een vraagje misschien : Kan ik WindowsXP
laten staan en linux op een andere vrije
partitie installeren ?  Wordt dit gevraagd
bij installatie, of wordt Ubuntu direct op de
C partitie geinstalleerd ?
Er zijn momenteel 5 partities op mijn pc waarvan
de laatste 8 Gb groot is en nog niet
geformateerd.  Hoe kan ik dit het best
aanpakken ?

Groetjes
Luc

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Probleem met X-server
« Reactie #15 Gepost op: 2005/12/08, 23:38:50 »
Simpel, stop de CD erin, bij het partitioneren zeg je dat-ie nergens aan mag komen behalve die vrije partitie.

lucdec

  • Gast
Probleem met X-server
« Reactie #16 Gepost op: 2005/12/10, 18:24:08 »
Hallo,
Ik heb opnieuw geprobeerd met de live cd.
Op het moment dat de xserver stopt heb ik via het
commando
sudo nano /etc/X11/Xorg.conf
het device verandert van NV in Vesa
en nu start ubuntu wel op.

Ik heb wel geen toegang tot internet via
firefox, en ook het geluid
werkt niet.

Waarom werkt dit allemaal niet ?
Dit is mijn pc :


gebruikte chipset op moederbord :(Asrock K8NF4G-SATA2)

Chipset - Northbridge: nVidia GeForce 6100
- Southbridge: nVidia nForce 410 MCP


Audio - Realtek ALC850 7.1channel AC'97 audio codec

LAN - Realtek PHY RTL8201CL
- Speed: 10/100 Ethernet
- Supports Wake-On-LAN

OS - Microsoft Windows 2000/XP/XP 64-bit compliant

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Probleem met X-server
« Reactie #17 Gepost op: 2005/12/11, 14:27:25 »
Allemaal realtek prut :/
Die hebben niet de meest fijne linux drivers zoals je gemerkt hebt en daar is weinig aan te doen (behalve klagen bij realtek)

Offline bwog

  • Lid
  • Steunpunt: Nee
Probleem met X-server
« Reactie #18 Gepost op: 2005/12/11, 15:18:07 »
Dat kan best wezen, maar bij mij werden de Realtek ac97 en Realtek LAN wel automagisch herkend en geinstalleerd. Mischien zijn dit nieuwere versies, of is de chipset erg nieuw.

Het zou goed kunnen dat er al oplossingen voor bestaan.

Paulus

  • Gast
Probleem met X-server
« Reactie #19 Gepost op: 2005/12/11, 16:18:23 »
Citaat van: kennywest
Waarom prullen met een live CD. Als de live CD niet werkt wil dit niet noodzakelijk zeggen dat Linux (of Ubuntu) niet zal werken voor u. Durf de stap te nemen, Windows eraf, Ubuntu erop ... you'll enjoy the ride.
Dat zeg je nu wel, maar dat gaat niet op voor new-bees, er valt weinig te genieten als je het boeltje niet aan de praat kunt krijgen. En allerhande commando's gaan intypen, dat is toch niet meer helemaal van deze tijd, of zie ik dat verkeerd?
Groetjes,

Offline bwog

  • Lid
  • Steunpunt: Nee
Probleem met X-server
« Reactie #20 Gepost op: 2005/12/11, 20:03:50 »
Kennywest bedoeld het goed: werken met de live CD is gewoon moeilijker (bijvoorbeeld omdat je veranderingen niet kan vastleggen). Wanneer niet de verkeerde partitie wordt uitgekozen kan er niets mis gaan met installatie. Bovendien kan ubuntu makkelijk verwijderd worden als het niet bevalt.

Ik kan me voorstellen dat iemand die een lastige installatie moet doen niet verder wil met linux. De problemen komen dan op het verkeerde moment, nl als je er nog niets van af weet. Dennis raadde al aan om tot de volgende distributie te wachten. Wellicht is Mephis beter voor je, ik hoorde dat die veel meer met GUIs doet. Wellicht heeft iemand nog betere suggesties?

bagt

  • Gast
Probleem met X-server
« Reactie #21 Gepost op: 2005/12/13, 12:14:48 »
In je /etc/X11/xorg.conf kun je het volgende veranderen

section "Device"
Driver "nv" # standaard nvidia driver geen 3D

Section "Screen"
DefaultDepth "16"

nv driver probeert nu alle resoluties uit in de 16bit mode en zal de hoogst mogelijke toepassen wat je monitor nog goed vindt het hoeft niet aan de pc te liggen het kan ook aan je monitor liggen...

als je gegevens hebt van je monitor kijk ook even in de sectie

Section "Monitor"
HorizSync "xx-xx"
VertRefresh "yy-yy"

waarbij de waardes moeten overeen komen met de gegevens van je kijkijzer
LET OP Overdrijf de waardes niet, bel dan alvast de brandweer geheid een afgebrande monitor is het resultaat...