Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Vreemde karakters in bestandsnamen / locale settings  (gelezen 920 keer)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Vreemde karakters in bestandsnamen / locale settings
« Gepost op: 2008/10/04, 16:01:50 »
Ik heb een mp3 speler die te benaderen is als een externe harde schijf. Op de mp3 speler staat een map Café Del Mar.

Als ik de mp3 speler benader vanuit ubuntu staat daar Café Del Mar (Dus é wordt vervangen door rare karakters). Als ik de mp3 speler benader vanuit Windows staat daar ook Café Del Mar.

Als ik de mp3 speler handmatig mount met het commando: sudo mount -o iocharset=iso8859-1 /dev/sdh /mnt
dan krijg ik wel de juiste karakters te zien.

Ook de inhoud van bestanden met franse karakters werd niet correct weergegeven. Jérome werd J?rome. Ik heb wat zitten googlen en heb de locale van mijn systeem aangepast naar nl_BE@euro. Nu wordt de inhoud van de bestanden al correct weergegeven, maar de folder namen en bestandsnamen blijven rare tekens bevatten. Iemand een idee?

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Vreemde karakters in bestandsnamen / locale settings
« Reactie #1 Gepost op: 2008/10/04, 16:36:06 »
Sorry dat ik jullie lastiggevallen heb. Heb ondertussen zelf de oplossing gevonden:
https://bugs.launchpad.net/kdebase/+bug/199165
't Is een bug in KDE 4. Met pmount wordt alles wel correct gemount, KDE 4 geeft de iocharset optie verkeerd door aan HAL :/

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Vreemde karakters in bestandsnamen / locale settings
« Reactie #2 Gepost op: 2008/10/05, 09:51:21 »
Kan iemand anders met KDE 4 dit gedrag bevestigen?

Als ik de schijf mount met pmount, dan levert pmount deze output:
/dev/sdd on /media/sdd type vfat (rw,nosuid,nodev,noexec,uid=1002,gid=513,fmask=0177,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,quiet)Als ik de schijf mount via Dolphin, dan levert pmount deze output:
/dev/sdd on /media/music type vfat (rw,nosuid,nodev,relatime,uid=1002,fmask=0022,dmask=0022,codepage=cp437,iocharset=utf8)De iocharset optie is IMHO dus verkeerd.

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Vreemde karakters in bestandsnamen / locale settings
« Reactie #3 Gepost op: 2008/10/14, 09:59:19 »
Collega's van mij op kantoor gebruiken ook 8.04 met kde4 en daar doet blijkbaar het probleem zich ook voor. In Intrepid is het blijkbaar opgelost. Ik heb dit virtueel geprobeerd met een nieuwe VMWare image. Heeft er iemand een idee waarom dit in 8.04 wel een probleem is en in 8.10 niet. Beide zijn, dacht ik toch, gebaseerd op KDE 4.1.2, dus daaraan kan het niet liggen.