Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: joomla installatie  (gelezen 7994 keer)

senszi

  • Gast
joomla installatie
« Gepost op: 2008/10/01, 21:49:46 »
hallo,

Ik ben een nieuwe gebruiker van ubuntu. Nu probeer ik joomla te installeren maar daar gaat het fout.
Tot nu heb ik alle benodigde programma's in me var/www map gezet. Nu kan ik wel op de instalatie site van joomla komen maar als ik bij stap 7 (voltooien) ben krijg ik deze tekst:

Uw configuratiebestand of map is niet schrijfbaar, of er is een probleem bij het aanmaken ervan. U dient volgende code manueel te uploaden.
(dit is een lange code, dus niet toegevoed)

nu is mijn vraag hoe moet ik die code uploaden?
ik weet namelijk niet hoe dat werkt.(ik heb wel geprobeerd deze code in een .conf bestand te zetten maar daar reageert het niet op).

b.v.d

Offline eXtreem

  • Lid
  • Steunpunt: Nee
joomla installatie
« Reactie #1 Gepost op: 2008/10/02, 07:37:16 »
Start je de installatie wel met "root"-rechten? Dat wil zeggen, zet je "sudo" voor het installatie-script?

Als het met sudo niet lukt, laat dan even de code achter, misschien dat iemand aan de hand van de opmaak van de code kan zien waar deze voor dient.

Gr. Richard
http://ubuntu.zurf.nl    (password ubuntu)
:wq

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
joomla installatie
« Reactie #2 Gepost op: 2008/10/02, 08:08:03 »
Tip: Wanneer de code te lang is, dan zet je deze tussen [ code ] en [/ code] (zonder spaties) dan komt de leesbaarheid te goede.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
joomla installatie
« Reactie #3 Gepost op: 2008/10/02, 18:33:36 »
Als ik het goed heb, zul je de code die je krijgt bij de laatste stap moeten copiëren en vervolgens een apart configuration.php bestand aanmaken en die code daarin plakken. Opslaan, je install map wegpleuren en voila...

Ik ga er natuurlijk wel even vanuit dat je een LAMP server hebt lopen?

edit: Typo
edit2: Als je nog geen LAMP server hebt lopen, kun je HIER een duidelijke beschrijving vinden
Ubuntu user#: 24352

senszi

  • Gast
joomla installatie
« Reactie #4 Gepost op: 2008/10/02, 22:19:29 »
bedankt voor de reacties.

ik heb wel een lamp surver lopen. maar ik weet niet hoe ik een aparte configuration.php bestand moet aanmaken.
b.v.d

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
joomla installatie
« Reactie #5 Gepost op: 2008/10/02, 22:59:10 »
Citaat van: senszi
bedankt voor de reacties.

ik heb wel een lamp surver lopen. maar ik weet niet hoe ik een aparte configuration.php bestand moet aanmaken.
b.v.d
Heel makkelijk, je maakt een nieuw document aan dat noem je configuration.php ;).
Dat zet je dus gewoon in de /var/www map waar ook de andere mappen en bestanden van de joomla installatie staan.
Ubuntu user#: 24352

senszi

  • Gast
joomla installatie
« Reactie #6 Gepost op: 2008/10/03, 16:14:17 »
ik heb nu een nieuw document aangemaakt en dat configuration.php genoemd. en in de map var/www gezet. dan verwijder ik me istallatie map van joomla maar dan krijg ik dit.

The requested URL /joomla/installation/index.php was not found on this server.

en het bestand index.php staat wel gewoon in me joomla map.

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
joomla installatie
« Reactie #7 Gepost op: 2008/10/03, 21:22:33 »
Heb je wel bij de laatste stap, als je gevraagd wordt de installatie map te verwijderen, de code die er stond gekopieerd en in configuration.php geplakt?
Ubuntu user#: 24352

Offline Xirtam

  • Lid
    • Ubuntu 4 You
  • Steunpunt: Nee
joomla installatie
« Reactie #8 Gepost op: 2008/10/03, 22:41:45 »
Het lijkt er op dat je het pad, dat je moest aangeven tijdens de installatie, niet juist hebt ingevuld.

Trouwens, Joolma! vragen worden snel en goed beantwoord op http://forum.joomla.org/viewforum.php?f=13
Bookmark deze onmisbare link als je met Joomla! verder wilt.

Als je de configuration.php hier plaatst kan men je sneller helpen.
_/_/_/ I took an IQ test and the result was negative... :cool:
_/_/_/ Ubuntu user #24348
_/_/_/ HP 6820 - Ubuntu 9.04 - Compiz - Virtualbox XP

senszi

  • Gast
joomla installatie
« Reactie #9 Gepost op: 2008/10/06, 12:50:16 »
ja ik heb de installatie map verwijderd. maar ik heb de code gewoon in me var/www map gezet en niet in me var/www/joomla.

senszi

  • Gast
joomla installatie
« Reactie #10 Gepost op: 2008/10/06, 14:14:39 »
dit bestant configuration.php komt ook terug bij de controle van mijn minimale systeem vereising.
dan staat er dat ik dit bestand in de hoofdmap van de server moet plaatsen nu vraag ik me af of dat in me joomla map moet en waar?
of dat het in me LAMPP map moet en waar?

b.v.d.

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
joomla installatie
« Reactie #11 Gepost op: 2008/10/06, 18:02:55 »
Daar waar alle mappen van je joomla installatie staan. In de folder waar je ook de installation map wegpleurd. Daar staat ook oa index.php, index.html, robots.txt, changelog.php, copyright.php instaan. Daar komt je configuration.php ook in te staan, je ziet daar ook configuration.php-dist staan. Dat is het soort template voor je configuration.php.
Ubuntu user#: 24352

Offline ubuking

  • Lid
  • Steunpunt: Nee
joomla installatie
« Reactie #12 Gepost op: 2008/10/09, 20:16:32 »
Ook ik heb als beginner in ubuntu en joomla deze foutmelding gehad tijdens de installatie van joomla. Het probleem was bij mij direct opgelost nadat ik via  configuration.php op "lezen en schrijven" heb gezet. Alternatief kun je ook het bestand configuration.php-dis hernoemen in configuration.php
Ubuntu user# 24394   :cool:

Intel Core i5 750 2.66GHz / Kingston 2x2GB DDR3 PC10666 CL9.0 / MSI P55-GD65 / Nvidia GTS-450 / OCZ ModXStream Pro 600W / Ubuntu 10.10 Maverick Meerkat / Windows 7 Ultimate

Offline BMF

  • Lid
    • The Rock Temple
  • Steunpunt: Nee
joomla installatie
« Reactie #13 Gepost op: 2008/10/09, 20:53:22 »
Citaat van: ubuking
Ook ik heb als beginner in ubuntu en joomla deze foutmelding gehad tijdens de installatie van joomla. Het probleem was bij mij direct opgelost nadat ik via  configuration.php op "lezen en schrijven" heb gezet. Alternatief kun je ook het bestand configuration.php-dis hernoemen in configuration.php
Hij heeft als het goed is deze melding gekregen:

VERWIJDER NU DE VOLLEDIGE MAP "INSTALLATION" VAN DE SERVER
U kunt niet verdergaan als deze installatiemap niet is verwijderd. Dit is een veiligheids instelling van Joomla!.
Inloggegevens administratie
Gebruikersnaam: admin
 

Joomla! in uw eigen taal?
Bezoek de Joomla! helppagina voor meer informatie en downloads.

 
Uw configuratiebestand of map is niet schrijfbaar of er is een probleem bij het aanmaken hiervan.
U dient volgende code handmatig te uploaden. Klik in het tekstvak om alle code te kopieëren,
en plak de code in een nieuw bestand. Noem dit bestand 'configuration.php' en upload deze naar de rootmap van uw website.

class JConfig {
/* Site Settings */
var $offline = '0';
var $offline_message = 'Deze website is tijdelijk niet beschikbaar i.v.m. werkzaamheden.
 Probeert u het later nog eens.';
var $sitename = 'test';
var $editor = 'tinymce';
var $list_limit = '20';
var $legacy = '0';
/* Debug Settings */
var $debug = '0';
var $debug_lang = '0';
/* Database Settings */
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = 'root';
var $password = 'xxxxxxx';
var $db = 'test';
var $dbprefix = 'jos_';
/* Server Settings */
var $live_site = '';
var $secret = 'xxxxxxxxxxxxx';
var $gzip = '0';
var $error_reporting = '-1';
var $helpurl = 'http://help.joomla.org';
var $xmlrpc_server = '0';
var $ftp_host = '127.0.0.1';
var $ftp_port = '21';
var $ftp_user = '';
var $ftp_pass = '';
var $ftp_root = '';
var $ftp_enable = '0';
/* Locale Settings */
var $offset = '0';
var $offset_user = '0';
/* Mail Settings */
var $mailer = 'mail';
var $mailfrom = 'xxxxxx@gmail.com';
var $fromname = 'test';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';
var $smtpuser = '';
var $smtppass = '';
var $smtphost = 'localhost';
/* Cache Settings */
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
/* Meta Settings */
var $MetaDesc = 'Joomla! - Het dynamische portaal- en Content Management Systeem';
var $MetaKeys = 'joomla, Joomla, DutchJoomla';
var $MetaTitle = '1';
var $MetaAuthor = '1';
/* SEO Settings */
var $sef           = '0';
var $sef_rewrite   = '0';
var $sef_suffix    = '0';
/* Feed Settings */
var $feed_limit   = 10;
var $log_path = '/var/www/joomla/logs';
var $tmp_path = '/var/www/joomla/tmp';
/* Session Setting */
var $lifetime = '15';
var $session_handler = 'database';
}
?>
En als je die melding krijgt, is er idd geen configuration.php. Dat wordt normaliter idd door configuration.php-dis gemaakt, maar bij deze melding is ze helemaal niet aanwezig. (zojuist ff gauw uitgeprobeerd) (xxxxx = fake)

Edit: Trouwens ben ik dit zelf nog niet online tegen gekomen, enkel als ik het via LAMP of vroeger WAMP onder windows geinstalleerd heb. Bij al mijn domeinen en die van mijn klanten nog nooit. Dus denk dat het te maken heeft met het feit dat je local draait. Ik heb me eigenlijk nooit afgevraagd waardoor eigenlijk. Die het weet mag het zeggen...

Moet je even een beetje bijsturen als het mag? Soms heb je gewoon instellingen, die geen automatische configuration.php wegschrijven. Vaak moet je daarom ook gewoon bij de laatste stap de inhoud copieëren in een nieuw te maken configuration.php. Dit is namelijk configuration.php-dis. Als je die hernoemt werkt het niet, tsjek de verschillen.


/**

* @version $Id: configuration.php-dist 9991 2008-02-05 22:13:22Z ircmaxell $

* @package Joomla

* @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.

* @license GNU/GPL, see LICENSE.php

* Joomla! is free software and parts of it may contain or be derived from the

* GNU General Public License or other free or open source software licenses.

* See COPYRIGHT.php for copyright notices and details.

*

* -------------------------------------------------------------------------

* THIS SHOULD ONLY BE USED AS A LAST RESORT WHEN THE WEB INSTALLER FAILS

*

* If you are installing Joomla! manually i.e. not using the web browser installer

* then rename this file to configuration.php e.g.

*

* UNIX -> mv configuration.php-dist configuration.php

* Windows -> rename configuration.php-dist configuration.php

*

* Now edit this file and configure the parameters for your site and

* database.

*/

class JConfig {

/**

* -------------------------------------------------------------------------

* Site configuration section

* -------------------------------------------------------------------------

*/

/* Site Settings */

var $offline = '0';

var $offline_message = 'This site is down for maintenance.
 Please check back again soon.';

var $sitename = 'Joomla!'; // Name of Joomla site

var $editor = 'tinymce';

var $list_limit = '20';

var $legacy = '0';



/**

* -------------------------------------------------------------------------

* Database configuration section

* -------------------------------------------------------------------------

*/

/* Database Settings */

var $dbtype = 'mysql'; // Normally mysql

var $host = 'localhost'; // This is normally set to localhost

var $user = ''; // MySQL username

var $password = ''; // MySQL password

var $db = ''; // MySQL database name

var $dbprefix = 'jos_'; // Do not change unless you need to!



/* Server Settings */

var $secret = 'FBVtggIk5lAzEU9H'; //Change this to something more secure

var $gzip = '0';

var $error_reporting = '-1';

var $helpurl = 'http://help.joomla.org';

var $xmlrpc_server = '1';

var $ftp_host = '';

var $ftp_port = '';

var $ftp_user = '';

var $ftp_pass = '';

var $ftp_root = '';

var $ftp_enable = '';

var $tmp_path = '/tmp';

var $log_path = '/var/logs';

var $offset = '0';

var $live_site = ''; // Optional, Full url to Joomla install.



/* Session settings */

var $lifetime = '15'; // Session time

var $session_handler = 'database';



/* Mail Settings */

var $mailer = 'mail';

var $mailfrom = '';

var $fromname = '';

var $sendmail = '/usr/sbin/sendmail';

var $smtpauth = '0';

var $smtpuser = '';

var $smtppass = '';

var $smtphost = 'localhost';



/* Cache Settings */

var $caching = '0';

var $cachetime = '15';

var $cache_handler = 'file';



/* Debug Settings */

var $debug      = '0';

var $debug_db = '0';

var $debug_lang = '0';



/* Meta Settings */

var $MetaDesc = 'Joomla! - the dynamic portal engine and content management system';

var $MetaKeys = 'joomla, Joomla';

var $MetaTitle = '1';

var $MetaAuthor = '1';



/* SEO Settings */

var $sef = '0';

var $sef_rewrite = '0';

var $sef_suffix = '';



/* Feed Settings */

var $feed_limit   = 10;

}

?>
Ubuntu user#: 24352

Knim

  • Gast
Re: joomla installatie
« Reactie #14 Gepost op: 2009/02/09, 12:25:47 »
Hallo allemaal,
Ik heb al deze stappen doorlopen maar krijg deze melding  " JError Unable to load Database Driver:"
Wie kan me verder helpen ??
Groet

Knim

  • Gast
Re: joomla installatie
« Reactie #15 Gepost op: 2009/02/09, 20:01:28 »
Het is na een nieuwe installatie van Joomla 1.5.9 gelukt.
Alles werkt !
Groeten