Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: rechtermuisknop  (gelezen 1029 keer)

peterjan

  • Gast
rechtermuisknop
« Gepost op: 2006/09/04, 14:47:26 »
Hallo ik ben net nieuw als gerbruiker van Ubuntu. Na een lange tijd spelen met eea loop ik tegen een klein probleem aan. Ik heb voor de PC's waarop Ubuntu moet gaan draaien de wens om de rechtermuisknop uit te schakelen.
Hoe moet ik dat doen in Ubuntu versie 6.?? met Gnome desktop?

Ik heb al even gezocht op het forum maar kon niets vinden, Mocht ik een topic over het hoofd hebben gezien dan mijn excuus...

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
rechtermuisknop
« Reactie #1 Gepost op: 2006/09/04, 14:59:23 »
Moet zeker gaan, maar wat een bizarre vraag ;)
Een eerste idee lijkt mij om uw muisconfig in /etc/X11/xorg.conf om zeep te helpen :D
Anders sleutelen aan GNOME/Nautilus.

Xano

  • Gast
rechtermuisknop
« Reactie #2 Gepost op: 2006/09/04, 20:18:05 »
Gewoon nieuwsgierig, maar waarom wil je dit?

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
rechtermuisknop
« Reactie #3 Gepost op: 2006/09/04, 20:22:24 »
Volgens mij om anderen te verbieden van dingen op te slaan of te verwijderen.
Is 't voor de kids of voor in een zaak?

Als 't voor in een zaak is zou ik gewoon de rechtermuisknop onklaar maken. Een scriptje maken kan ook maar daar weet ik niets van
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
rechtermuisknop
« Reactie #4 Gepost op: 2006/09/04, 20:28:18 »
Ik heb iets gevonden maar weet niet precies hoe 't verder kan.
gconf-editor (gewoon dit invoeren in uw terminal) openen en dan browsen naar dit path:
/apps/gok/actions/mousebutton3

Nu 1 van deze sleutels aanpassen en uw rechtermuisknop werkt niet meer maar ik zie niet direct welke. Iemand?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

peterjan

  • Gast
rechtermuisknop
« Reactie #5 Gepost op: 2006/09/05, 07:58:19 »
Citaat van: bartek
Is 't voor de kids of voor in een zaak?

Als 't voor in een zaak is zou ik gewoon de rechtermuisknop onklaar maken. Een scriptje maken kan ook maar daar weet ik niets van
voor de zaak, dat betkent dus voor leerlingen. Een muisknop onklaar maken is wel een oplossing, maar om dat een stuk of 100 keer te moeten doen. En dan nog, als ik als root inlog moet ik natuurlijk wel even alle muisknoppen gebruiken kunnen. Ik zal zo dadelijk wel eens naar de aangedragen oplossing kijken. Ondertussen blijf ik natuurlijk ook zoeken....

peterjan

  • Gast
rechtermuisknop
« Reactie #6 Gepost op: 2006/09/05, 08:37:42 »
Citaat van: zappa
Moet zeker gaan, maar wat een bizarre vraag ;)
Een eerste idee lijkt mij om uw muisconfig in /etc/X11/xorg.conf om zeep te helpen :D
Anders sleutelen aan GNOME/Nautilus.
bestand heb ik aangepast, maar het resultaat is niet wat ik zou verwachten. Komt ongetwijfeld ook doordat ik een absolute beginner ben met Ubuntu.
ik heb toegevoegd

Option       "Buttons"       "1"

 Ook alleen maar omdat ik dat ergens heb gelezen :D

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
rechtermuisknop
« Reactie #7 Gepost op: 2006/09/05, 09:53:54 »
Is er misschien een X utiility net als xkeybd maar dan voor de muis waarmee je de rechter-muisknop kunt uitzetten?
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

peterjan

  • Gast
rechtermuisknop
« Reactie #8 Gepost op: 2006/09/08, 12:52:09 »
Citaat
Ik ken wel een hack die dat kan veroorzaken:

xmodmap -e "pointer = 1 11 10 9 8 7 6 5 4 3 2"

Hierdoor krijgt de linker muisknop zijn eigen functie, en de middelste en rechter muisknop een niet-bestaande functie.
De overige getallen zijn toegevoegd om er voor te zorgen dat de knoppenlijst compleet blijft.

Dit commando is actief totdat je de X-server afsluit (dus uitlogt)
Om hem definitief te maken kun je dit commando in ~/.xinitrc of ~/.bashrc zetten.
Deze kreeg op een ander forum binnen, dat volstond. Alleen had Ubuntu maximaal 9 getallen voor de pointer dus ben ik gestopt bij 4 :D.