Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wacom Bamboo  (gelezen 1443 keer)

WillemM

  • Gast
Wacom Bamboo
« Gepost op: 2008/09/27, 15:05:43 »
Ik heb een Wacom Bamboo Funwelke ik vooralsnog niet aan de praat krijg heb de zoekfunctie in dit forum al gebruikt en dit draadje http://forum.ubuntu-nl.org/topic/29635 geprobeerd maar zonder resultaat, iemand enig idee?

Bij voorbaat dank

Willem

Offline eendje

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #1 Gepost op: 2008/09/27, 15:12:59 »
Wat doet de tablet niet en wat wel?

Als ik hier mijn tablet (Graphire Classic 4) inplug doet deze het direct, maar staat op de relatieve mode en daarvoor pas ik wat aan in de xorg.conf.

In onderstaand draadje hebben ze het één en ander gecompileerd, maar ik mag toch aannemen dat het met Hardy niet meer nodig is: http://forum.ubuntu-nl.org/topic/19802
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

WillemM

  • Gast
Wacom Bamboo
« Reactie #2 Gepost op: 2008/09/27, 15:19:38 »
Citaat van: eendje
Wat doet de tablet niet en wat wel?

Het enig dat hij doet is het blauwe lampje in de zoomknop laten branden, voor de rest helemaal noppes.

Als ik hier mijn tablet (Graphire Classic 4) inplug doet deze het direct, maar staat op de relatieve mode en daarvoor pas ik wat aan in de xorg.conf.

In onderstaand draadje hebben ze het één en ander gecompileerd, maar ik mag toch aannemen dat het met Hardy niet meer nodig is: http://forum.ubuntu-nl.org/topic/19802
Ik heb geprobeerd de items in dar draadje te volgen en heb aan aan xorg.conf toegevoegd wat daar beschreven staat ben nadat het niet werkte opnieuw opgestart maar nog steeds nix.
Mijn xorg.conf ziet er nu alsvolgt uit

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "intl"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection
Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "stylus"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "eraser"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "cursor"
    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "pad"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "pad"
    Option        "USB"        "on"
EndSection



Section "Device"
   Identifier   "Configured Video Device"
   Boardname   "nvidia"
   Busid      "PCI:4:0:0"
   Driver      "nvidia"
   Screen   0
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Vendorname   "Dell"
   Modelname   "Dell 1901FP (Analog)"
   Horizsync   30.0-80.0
   Vertrefresh   56.0-76.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   1600   1200
      Modes      "1280x1024@75"   "1280x960@60"   "1152x864@75"   "1280x1024@60"   "1024x768@60"   "1280x960@75"   "1024x768@70"   "1400x1050@60"   "1024x768@75"   "1600x1200@60"   "832x624@75"   "800x600@60"   "800x600@75"   "800x600@72"   "800x600@56"   "640x480@75"   "640x480@72"   "640x480@60"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
EndSection
Section "ServerLayout"
    Identifier    "Default Layout"
    InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
    InputDevice    "pad"        "SendCoreEvents"
EndSection
Section "Module"
   Load      "glx"
   Load      "v4l"
EndSection
Section "device" #
   Identifier   "device1"
   Boardname   "nvidia"
   Busid      "PCI:4:0:0"
   Driver      "nvidia"
   Screen   1
EndSection
Section "screen" #
   Identifier   "screen1"
   Device      "device1"
   Defaultdepth   24
   Monitor      "monitor1"
EndSection
Section "monitor" #
   Identifier   "monitor1"
   Gamma   1.0
EndSection
Section "ServerFlags"
EndSection

Zal wel iets fout gedaan hebben al doet mijn pc het nog steeds :-)

Mvrgr

Willem

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #3 Gepost op: 2008/09/27, 19:02:44 »
Gaat niet werken. Je tablet zit niet onder /dev/input/wacom als het goed is. Bovendien moet je de regels waar achter staat # Tablet PC ONLY weghalen. Staat er niet voor niets ;)
Je moet even kijken onder /dev/input/by-id/ Daar staat de tablet waarschijnlijk onder. Dat volledige pad moet je invullen ipv /dev/input/wacom
Daarnaast moet je ServerLayout sectie boven de InputDevice secties staan voor zo ver ik weet.

Oh, en volgens mij krijg je de Bamboo niet helemaal aan de gang, vooral die ronde touchstrip niet.

Offline eendje

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #4 Gepost op: 2008/09/27, 19:57:28 »
Je hebt twee keer een sectie serverlayout.  Haal het hieronder vetgedrukte gedeelte eens weg.

Citaat
Section "ServerLayout"
    Identifier    "Default Layout"
  screen 0 "Default Screen" 0 0
EndSection
Section "ServerLayout"

    Identifier    "Default Layout"
    InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
    InputDevice    "pad"        "SendCoreEvents"
EndSection
Hmm, wat Static zegt over plaats van ServerLayout klopt niet volgens mij. Bij mij staat deze juist onder Inputdevice (zelfs nog onder de Screen en Monitor sectie. Ook de verwijzing naar /dev/input/wacom is volgens mij prima tenzij het bij een Bamboo anders is dan bij een Graphire 4 Classic. Op Dapper moest ik inderdaad wel direct verwijzen naar /dev/input/event#, maar in Hardy hoeft dat niet meer.
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Duckie

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #5 Gepost op: 2008/09/27, 20:23:59 »
Citaat van: AutoStatic
Gaat niet werken. Je tablet zit niet onder /dev/input/wacom als het goed is. Bovendien moet je de regels waar achter staat # Tablet PC ONLY weghalen. Staat er niet voor niets ;)
Je moet even kijken onder /dev/input/by-id/ Daar staat de tablet waarschijnlijk onder. Dat volledige pad moet je invullen ipv /dev/input/wacom
Daarnaast moet je ServerLayout sectie boven de InputDevice secties staan voor zo ver ik weet.

Oh, en volgens mij krijg je de Bamboo niet helemaal aan de gang, vooral die ronde touchstrip niet.
Wat jij hier zegt klop dus inderdaad niet.
De Bamboo is gewoon aan het werk te krijgen onder Ubuntu, en normaal gesproken (als je dus niet zelf iets veranderd) is het /dev/input/wacom.
Ook "die ronde touchstrip" moet gewoon kunnen werken.
Waar de ServerLayout staat is ook niet belangrijk, als ie er maar staat.

Waarom ie bij de ts (nog) niet werkt is voor mij ook nog even de vraag. Misschien door die dubbele ServerLayout, zoals eendje al opmerkte.

edit:
Die regel met Tablet PC ONLY kun je inderdaad weghalen bij een Bamboo, maar met die regel moet ie het ook gewoon doen.
____________________________________________

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #6 Gepost op: 2008/09/27, 20:36:49 »
Zat er dus naast, heb ook niet zelf zo'n ding, wel een Intuos3. En die hangt aan mijn Fedora PC. Blijkt maar weer, de ene distro is de andere niet ;) En zat ook te veel in m'n hoofd met een ander draadje.

WillemM

  • Gast
Wacom Bamboo
« Reactie #7 Gepost op: 2008/09/27, 23:22:48 »
Ik heb al de manieren geprobeerd maar hij doet ut nog steeds niet mocht iemand nog raad hebben dan hou ik me aanbevolen.
Mijn xorg.conf ziet er nu zo uit

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "intl"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection
Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "stylus"
    Option        "ForceDevice"    "ISDV4"        
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "eraser"
    Option        "ForceDevice"    "ISDV4"        
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "cursor"
    Option        "ForceDevice"    "ISDV4"      
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "pad"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"        "pad"
    Option        "USB"        "on"
EndSection



Section "Device"
   Identifier   "Configured Video Device"
   Boardname   "nvidia"
   Busid      "PCI:4:0:0"
   Driver      "nvidia"
   Screen   0
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Vendorname   "Dell"
   Modelname   "Dell 1901FP (Analog)"
   Horizsync   30.0-80.0
   Vertrefresh   56.0-76.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   1600   1200
      Modes      "1280x1024@75"   "1280x960@60"   "1152x864@75"   "1280x1024@60"   "1024x768@60"   "1280x960@75"   "1024x768@70"   "1400x1050@60"   "1024x768@75"   "1600x1200@60"   "832x624@75"   "800x600@60"   "800x600@75"   "800x600@72"   "800x600@56"   "640x480@75"   "640x480@72"   "640x480@60"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
InputDevice     "stylus"    "SendCoreEvents"
    InputDevice     "cursor"    "SendCoreEvents"
    InputDevice     "eraser"    "SendCoreEvents"
    InputDevice    "pad"        "SendCoreEvents"
EndSection

Section "Module"
   Load      "glx"
   Load      "v4l"
EndSection
Section "device" #
   Identifier   "device1"
   Boardname   "nvidia"
   Busid      "PCI:4:0:0"
   Driver      "nvidia"
   Screen   1
EndSection
Section "screen" #
   Identifier   "screen1"
   Device      "device1"
   Defaultdepth   24
   Monitor      "monitor1"
EndSection
Section "monitor" #
   Identifier   "monitor1"
   Gamma   1.0
EndSection
Section "ServerFlags"
EndSection

Mvrgr

Willem

Offline Duckie

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #8 Gepost op: 2008/09/28, 00:01:38 »
Kijk eens of de wacom module is geladen met het commando "lsmod" (zonder "").
In de lijst die je dan krijgt moet als het goed is wacom staan.
Als dat het geval is kun je nog kijken of ie werkt met "sudo cat /dev/input/wacom".
Als je dat ingevoerd hebt en je schrijft wat me de pen dan krijg je als het goed is allemaal rare tekens te zien.
Wanneer dat het geval is weet je in ieder geval (zo goed als zeker) dat ie de module goed heeft geladen.

Ik ga er wel van uit dat je niet zelf de driver hebt gecompileerd?

Verder zou je nog kunnen kijken in "/var/log/Xorg.0.log" met het commando "gedit /var/log/Xorg.0.log"
Kijk daar dan vooral naar de regels waar een Error voor staat. Uit mijn hoofd staat er dan "EE" voor.

edit:
b.t.w. Je weet wel dat je X opnieuw moet opstarten na iets gewijzigd te hebben in de Xorg?
Dit kun je doen door jezelf af te melden en weer aan, of wat abrupter door op [Ctrl] [Alt] [BackSpace] te drukken.
Bij die laatste moet je er wel rekening mee houden dat al je ge-opende vensters zullen sluiten. (Bij die eerste ook trouwens :))
____________________________________________

Offline vis

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #9 Gepost op: 2008/10/31, 16:21:47 »
Offtopic: Ik zit te denken om ook een tablet aan te schaffen, maar vraag me af of wat ik wil ook wel zinvol is. Ik zit namelijk thuis veel met kleine papiertjes met aantekeningen en tekeningen van bijvoorbeeld database modellen. Is het een goede gedachte dat een tablet mijn papier verminderd en dat ik makkelijk aantekingen en database modellen kan teken met zo'n tablet en deze kan oplsaan en evt. uitprinten, mocht ik dit nodig hebben op een andere werkplek? Of is het zinvoller om gewoon bij papier te blijven?

Alvast bedankt voor jullie mening.

Vis.

Offline eendje

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #10 Gepost op: 2008/10/31, 20:22:53 »
Als het doel is om je hoeveelheid papier te verminderen met de dingen die jij doet weet ik niet of het werkt. Want als je een database model hebt geschets en je hebt het uitgewerkt dan wil je toch af en toe op je schetsjes kijken en dan is een schetjes op papier makkelijk denk ik. Schetsen kan met een tablet prima, maar als je net zoals ik potlood en papier prettig vind werken, omdat je bijvoorbeeld het papier heel makkelijk kunt draaien dan week ik niet of je het schetsen met een tablet heel fijn vindt. Wat wel een voordeel is dat je een schets in de computer hebt staan die je makkelijk weer in  een ander document kunt invoegen en ook makkelijker kunt "opleuken" voor het geval je het wilt tonen aan iemand. Wat ikzelf een heel groot voordeel van een tablet vind t.o.v. papier is dat als je een fout maakt je makkelijker deze kunt herstellen op de computer dan op papier. Zelf gebruik ik de tablet ook i.p.v. van een gewone muis, omdat ik het veel prettiger vind werken. Het is jammer dat je niet vlak in de buurt woont anders zou ik zeggen kom eens een avond aanwaaien dan kun je even proberen met mijn tablet hier dan merk je vrij snel of je het prettig vindt al vond ik zelf het wel even wennen dat een tablet absoluut werkt en een muis relatief (bij een tablet is hetzelfde punt op de tablet altijd hetzelfde punt op het scherm)
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline vis

  • Lid
  • Steunpunt: Nee
Wacom Bamboo
« Reactie #11 Gepost op: 2008/11/01, 03:50:30 »
Beste eendje,

Bedankt voor je duidelijke en uitgebreide antwoord. Ik denk dat ik na jouw verhaal deze maar moet aanschaffen. Zit alleen nog te denken welk formaat (a6, a5 of a4), maar hier zal ik de komende week even rustig over nadenken.

groeten,

Vis.