Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Emu soundcard  (gelezen 596 keer)

Khem

  • Gast
Emu soundcard
« Gepost op: 2008/09/27, 12:45:26 »
Hallo.

Ik ben nogal een noob en ben mń emu soundcard aan het installeren. Het is me tot zover gelukt todat ik op gegeven moment de volgende modules in de kernel moet plaatsen  

modprobe snd-emu10k1 ; modprobe snd-pcm-oss ; modprobe snd-mixer-oss ; modprobe snd-seq-oss


Ik zou niet weten hoe ik dat moet doen. de handleiding is te vinden op

http://www.alsa-project.org/main/index.php/Matrix:Module-emu10k1-fpga

Helpt iemand mij alstublieft. Ik wil heel graag dat mijn geluid werkt :D

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Emu soundcard
« Reactie #1 Gepost op: 2008/09/27, 12:49:05 »
Open een terminal ( Toepassingen > Hulpmiddelen > Terminalvenster) en voer deze commando's in, beginnend met sudo:

sudo modprobe snd-emu10k1 ; sudo modprobe snd-pcm-oss ; sudo modprobe snd-mixer-oss ; sudo modprobe snd-seq-ossEr zal naar je wachtwoord gevraagd worden. Typ dit in en druk op Enter. Je zult geen sterretjes zien; dat hoort zo.


Oh ja, op een gegeven moment zeggen ze dat je dit moet doen:

vi ~/.asoundrcmaak daar maar van:

gedit ~/.asoundrcer wordt ook ergens gezegd:

Citaat
Note:     

Debian GNU/Linux users need to save this information into a file in the /etc/​modutils/ directory (eg. /etc/​modutils/​alsa) and run update-modules
Ubuntu is gebaseerd op Debain, dus dit geldt voor Ubuntu ook.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Emu soundcard
« Reactie #2 Gepost op: 2008/09/27, 12:53:24 »
Wat voor geluidskaart heb je precies? (Merk en type).
Geef ook eens de uitkomst van het commando lspci in de terminal.

Als het goed is zit die emu10k1 chip ook in bijvoorbeeld een Audigy geluidskaart, en die doet het automatisch in Ubuntu. Daar hoef je niks voor te doen. Ook andere geluidskaarten met die chip zouden het direct moeten doen lijkt me.

Khem

  • Gast
Emu soundcard
« Reactie #3 Gepost op: 2008/09/27, 14:08:59 »
Bedankt voor het snelle antwoord!!!

als ik die file aanmaak in modutils en update-modules intoets krijg ik dit:

The update-modules command is deprecated and should not be used!



Als ik dat lspci commando invoer krijg ik:

khem@khem-desktop:/$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev f3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:01.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)
01:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
05:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)


En audigy is mijn onboard souncard en ik heb een e-mu 0404 erin zitten.