Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04  (gelezen 2163 keer)

Kobain

  • Gast
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Gepost op: 2008/09/23, 20:58:46 »
Als ik Ubuntu start op mijn HP dv7 1080ed notebook doet alles het perfect, behalve het geluid. Meer dan een aantal, zich steeds weer herhalende en zeer vervelende pieptoontjes, komt er niet uit. Ik denk dat ik de nieuwste alsa-driver moet installeren maar weet niet hoe dat moet. Als ik Vista gebruik op hetzelfde notebook werkt de sound prima.

Weet iemand de oplossing voor dit probleem?

Offline Jakke5

  • Lid
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #1 Gepost op: 2008/09/23, 21:33:08 »
Systeem->Beheer->synaptic pakketbeheer->wachtwoord->even geduld->alsa o.i.d. in zoekfunctie stoppen, aanvinken voor installatie, installeren, klaar.
Blij dat ik ook eens iets weet.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #2 Gepost op: 2008/09/23, 22:41:47 »
Ja, maar dat gaat niet werken omdat de geluidskaart waarschijnlijk zo nieuw is dat de huidge Alsa drivers (1.0.16 geloof ik) van 8.04 het niet trekken. Kobain, je hebt zeker last van rare echo's en geluid dat blijft hangen? Kun je een terminal openen (Applications - Accessoires - Terminal) en ingeven lspci | grep Audio en de uitkomst hier plakken? Je kunt knippen in de terminal met ctrl+shift+c en dan plakken met ctrl+v. Waarschijnlijk moet je inderdaad de laatste stabiele Alsa drivers (1.0.17) hebben.

Kobain

  • Gast
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #3 Gepost op: 2008/09/24, 00:38:03 »
Jij beschrijft precies het probleem wat ik met mijn geluid heb Autostatic, rare echo's en het geluid blijft hangen, en als gevolg daarvan soms ook Ubuntu.
lspci | grep audio geeft geen resultaat in het terminal venster. lspci | grep -i audio geeft de volgende regel:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Weet niet of je hier wat aan hebt.

Wat jij schrijft Jakke5 heb ik al een paar keer geprobeerd maar dit hielp niet, toch bedankt voor de tip.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #4 Gepost op: 2008/09/24, 10:31:27 »
Kobain, je hebt hetzelfde onboard geluidsgeval als ik. Had je pci=noacpi al toegevoegd als kernel optie? Die kun je in het bestand /boot/grub/menu.lst toevoegen:
title           Ubuntu 8.04.1, kernel 2.6.24-19-generic
root            (hd0,5)
kernel          /boot/vmlinuz-2.6.24-19-generic root=UUID=06001a61-8a85-4788-9447-f10fa7b3e4ea ro quiet splash pci=noacpi
initrd          /boot/initrd.img-2.6.24-19-generic
Als dat niet werkt moet je de laatste stabiele Alsa drivers downloaden: ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.17.tar.bz2
Vervolgens uitpakken, kan met de Archive Manager of in een terminal met tar jxv alsa-driver-1.0.17.tar.bz2. Dan cd je in het mapje wat is aangemaakt (alsa-driver-1.0.17) en draai je het configuratiescript dmv ./configure. Als dat klaar is, hopelijk zonder fouten, maak je de drivers aan met het commando make. Vervolgens installeer je de boel op de goede plek met het commando sudo make install. Nog even /etc/modprobe.d/alsa-base aanpassen door de regel options snd-hda-intel single_cmd=1 toe te voegen, kan met sudo nano -w /etc/modprobe.d/alsa-base, opnieuw opstarten en het zou moeten werken.

Kobain

  • Gast
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #5 Gepost op: 2008/09/24, 11:25:10 »
Hoi Autostatic, probleem opgelost dankzij jouw heldere uitleg. Heb pci=noacpi toegevoegd zoals je beschreef, en tot mijn grote verbazing doet het geluid het nu. Het installeren van een nieuwe alsa driver was niet eens nodig, maar toch bedankt dat je het opschreef, nu weet ik tenminste ook hoe dat werkt en misschien hebben anderen hier wat aan.

Nog even wat extra info voor beginners waar ik ook toe behoor en voor wie het allemaal niet zo makkelijk is om te begrijpen en uit te zoeken.

Om het probleem op te lossen ging ik naar Applications/Hulpmiddelen/Terminalvenster
dan intikken: gksudo gedit /boot/grub/menu.lst (druk vervolgens op enter/return toets)
Er wordt nu naar je password gevraagd, tik die in en druk op enter.
Je ziet nu een soort tekstbestand met programmacode.
voeg nu pci=noacpi toe aan de regel:
kernel          /boot/vmlinuz-2.6.24-19-generic root=UUID=06001a61-8a85-4788-9447-f10fa7b3e4ea ro quiet splash
De regel ziet er nu dus zo uit:
kernel          /boot/vmlinuz-2.6.24-19-generic root=UUID=06001a61-8a85-4788-9447-f10fa7b3e4ea ro quiet splash pci=noacpi
Druk vervolgens boven op "save".

Start de computer opnieuw op, het geluid zou het nu moeten doen.

Pas op!!!!!: het is "noacpi" en NIET "noapci"

Autostatic nogmaals hartstikke bedankt!

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #6 Gepost op: 2008/09/24, 11:50:01 »
Goed dat je het volledig hebt beschreven!
Mooie tip voor in het geluidkaart-deel van m'n docu. Ik neem aan, dat je daar geen bezwaar tegen hebt?   :-)

Overigens: je zult deze handeling wel moeten herhalen, telkens wanneer je een kernel update hebt gehad.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #7 Gepost op: 2008/09/24, 12:21:54 »
Tenzij een volgende kernel update dit probleem oplost ;)
En Kobain, graag gedaan, mooi dat het nu werkt.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #8 Gepost op: 2008/09/24, 13:32:16 »
Citaat van: AutoStatic
Tenzij een volgende kernel update dit probleem oplost ;)
Is er ook een manier om deze parameter blijvend te maken, dus onafhankelijk van de kernel-regel? Bijvoorbeeld via de Default Options in de menulijst, of denk ik nu in de verkeerde richting?

Offline Jakke5

  • Lid
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #9 Gepost op: 2008/09/25, 23:30:12 »
Leuk voor Kobain dat zijn micro-probleem opgelost is.
Ondertussen blijf ik helaas met mijn probleem(pje) zitten: geluidskaart werkt 100% in XP, geluid opnemen via LINE-ingang werkt niet in Ubuntu. (zie bv. mijn post van 20-09) Weet er echt niemand raad?
P.S. regelmatig lees ik: "multimedia-instellingen aanpassen". Ik heb me al wezenloos gezocht maar vind nergens waar dat dan kan; Kan iemand een dummy als ik helpen?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #10 Gepost op: 2008/09/25, 23:52:37 »
Citaat van: Jakke5
Leuk voor Kobain dat zijn micro-probleem opgelost is.
Ondertussen blijf ik helaas met mijn probleem(pje) zitten: geluidskaart werkt 100% in XP, geluid opnemen via LINE-ingang werkt niet in Ubuntu. (zie bv. mijn post van 20-09) Weet er echt niemand raad?
P.S. regelmatig lees ik: "multimedia-instellingen aanpassen". Ik heb me al wezenloos gezocht maar vind nergens waar dat dan kan; Kan iemand een dummy als ik helpen?
Waarom noem je jezelf een dummy? Onnodig en niet toepasselijk. Je weet gewoon iets niet, en daar is niks doms aan.

Opnemen zou je eventueel kunnen proberen voor elkaar te krijgen met behulp van alsamixergui:
http://computertip.googlepages.com/geluidskaartinubuntu
(nummer 2)

Multimedia-instellingen aanpassen: ik heb geen flauw idee wat dat betekent.  :-)
Misschien multimedia-ondersteuning compleet maken:
http://computertip.googlepages.com/multimediainubuntulinux

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #11 Gepost op: 2008/09/26, 09:28:10 »
Citaat van: pjotr123
Citaat van: AutoStatic
Tenzij een volgende kernel update dit probleem oplost ;)
Is er ook een manier om deze parameter blijvend te maken, dus onafhankelijk van de kernel-regel? Bijvoorbeeld via de Default Options in de menulijst, of denk ik nu in de verkeerde richting?
Voor zover ik weet kan dat niet. Je zou het wel kunnen scripten ;) Maar hoe vaak is er een kernel update? En in het gunstigste geval is de hele parameter na een update niet meer nodig. De bug is gemeld bij Launchpad dus de techneutiekers hebben er weet van.

Offline Jakke5

  • Lid
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #12 Gepost op: 2008/09/26, 22:03:04 »
Dank je wel, Pjotr. Maar echt, als ik de posts van specialisten zoals jij of Autostatic lees, dan voel ik me echt een domme dummy. Met dit probleem loop ik Kobain wat voor de voeten. Hindert dat niet?

Ik denk dat ik al zowat 100 pag. heb gelezen i.v.m. geluid(skaart), w.o. natuurlijk http://computertip.googlepages.com/geluidskaartinubuntu.
Alsamixergui, alsamixer via terminal, voorkeuren in systeem, wat nog meer heb ik 1000den keer ingesteld en weer een andere combinatie geprobeerd enz. Bij bijna alle combinaties  kom het geluid via de LINE binnen en langs de speaker-uitgang terug naar buiten, maar opnemen, oh maar.
P.S. hoe krijg ik de ingangsniveau-indicatie op het scherm?

Kobain

  • Gast
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #13 Gepost op: 2008/09/27, 20:06:52 »
Je hindert mij niet jakke5, ga gewoon verder met vragen stellen hier. Ik hoop dat je probleem snel wordt opgelost, helaas kan ik je daar niet bij helpen want ik ben ook pas met Ubuntu begonnen. Ik ben dus zelf ook een dummy. Gelukkig zijn er hier mensen die er meer verstand van hebben dan wij. Ik las dat er eind volgende maand een nieuwe versie van Ubuntu uit gaat komen, Ubuntu 8.10, misschien dat na de installatie hiervan jou probleem opgelost is, even afwachten dus.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
soundprobleem op HP dv7 1080ed notebook onder ubuntu8.04
« Reactie #14 Gepost op: 2008/11/11, 22:55:26 »
Probleem is nu definitief opgelost: https://bugs.launchpad.net/ubuntu/+bug/269586
Door de optie options snd-hda-intel enable_msi=1 toe te voegen aan /etc/modprobe.d/alsa-base is het gestotter weg. De kernel optie pci=noacpi kun je dus uit je menu.lst halen.
Dit geldt voor zowel 8.04 als 8.10 en op meerdere modellen in de DV7 serie.