Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wireless netwerk na opstart geen verbinding.  (gelezen 1685 keer)

Offline Xirtam

  • Lid
    • Ubuntu 4 You
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Gepost op: 2008/09/22, 09:33:20 »
Nadat ik de laptop heb opgestart moet ik steeds in ' Manual Network Configuration'  in de Network settings voor het draadloze netwerk het wachtwoord wissen en opnieuw invoeren Hierna zoekt hij en pakt zo de verbinding weer op.
Dit is natuurlijk niet handig en begrijp ook niet dat dit zo moet.
Iemand een suggestie?

Ik werk met de nieuwe Ubuntu 8.04 "Hardy Heron".

more /etc/network$ more interfaces
auto lo
iface lo inet loopback


iface wlan0 inet dhcp
wpa-psk 740bf9445cda904ba274d4c92146d081ff71e683e15e3e24dc22a25935e7df69
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid Ummagumma

auto wlan0
_/_/_/ I took an IQ test and the result was negative... :cool:
_/_/_/ Ubuntu user #24348
_/_/_/ HP 6820 - Ubuntu 9.04 - Compiz - Virtualbox XP

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Wireless netwerk na opstart geen verbinding.
« Reactie #1 Gepost op: 2008/09/23, 23:25:09 »
Deze al gevolgd http://computertip.googlepages.com/geendraadloosinternet ?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline woteb

  • Lid
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Reactie #2 Gepost op: 2008/09/23, 23:36:59 »
Gijsbert, zijn spulletje doet het wel, maar niet automatisch. Er is dus iets anders aan de hand..??
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Xirtam

  • Lid
    • Ubuntu 4 You
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Reactie #3 Gepost op: 2008/09/24, 15:30:57 »
Citaat van: woteb
Gijsbert, zijn spulletje doet het wel, maar niet automatisch. Er is dus iets anders aan de hand..??
Klopt helemaal en het frusteert me meer en meer. Zeker voor een laptop gewoon lastig en dat ik er maar niet achter kan komen ergert me natuurlijk ook ;-)
_/_/_/ I took an IQ test and the result was negative... :cool:
_/_/_/ Ubuntu user #24348
_/_/_/ HP 6820 - Ubuntu 9.04 - Compiz - Virtualbox XP

Offline woteb

  • Lid
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Reactie #4 Gepost op: 2008/09/24, 16:10:31 »
Probeer eens het volgende:

Start in een terminal Gedit op met het commando:
sudo gedit /etc/rc.local

Geef een aantal returns voor de laatste regel met de inhoud: exit

Zet daarboven:
ifdown wlan0 && ifup wlan0

Dus: de inhoud van dat bestandje moet er zo uit zien:

Citaat
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
ifdown wlan0 && ifup wlan0

exit
Sla het bestandje op en herstart de laptop.

Werkt het nu?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Xirtam

  • Lid
    • Ubuntu 4 You
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Reactie #5 Gepost op: 2008/09/24, 21:21:56 »
ifdown Xirtam && ifhappy Xirtam

Het werkt dus!
Geweldig! Me happy.
_/_/_/ I took an IQ test and the result was negative... :cool:
_/_/_/ Ubuntu user #24348
_/_/_/ HP 6820 - Ubuntu 9.04 - Compiz - Virtualbox XP

Offline woteb

  • Lid
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Reactie #6 Gepost op: 2008/09/24, 21:28:58 »
Mooi zo, nu de uitleg zodat je er ook van leert.

Het bestandje /etc/rc.local is een uitvoerend scriptje waarmee je commando's uit voert netna het opstarten en net voor het inloggen.

Dat regeltje wat hebt toegevoegd zorgt ervoor dat je netwerkkaart even uit wordt gezet, en daarna weer wordt aangezet met de instellingen van /etc/network/interfaces. En daarin staan o.a. de aanmeldgegevens en instellingen van jouw draadloze kaart.

En omdat die instellingen via rc.local (opnieuw) worden uitgevoerd, hoef jij dat niet meer handmatig te doen.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Wireless netwerk na opstart geen verbinding.
« Reactie #7 Gepost op: 2008/09/24, 21:29:33 »
Citaat van: woteb
Gijsbert, zijn spulletje doet het wel, maar niet automatisch. Er is dus iets anders aan de hand..??
Ik had in gedachte de exercitie opnieuw te laten doen, soms wilt dit al genoeg zijn om iets werkend te krijgen, je kan altijd iets over het hoofd zien. Werkt het dan nog niet naar behoren, dan kan je altijd verder zoeken/vragen.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Xirtam

  • Lid
    • Ubuntu 4 You
  • Steunpunt: Nee
Wireless netwerk na opstart geen verbinding.
« Reactie #8 Gepost op: 2008/09/24, 21:48:06 »
Citaat van: woteb
Mooi zo, nu de uitleg zodat je er ook van leert.

Het bestandje /etc/rc.local is een uitvoerend scriptje waarmee je commando's uit voert netna het opstarten en net voor het inloggen.

Dat regeltje wat hebt toegevoegd zorgt ervoor dat je netwerkkaart even uit wordt gezet, en daarna weer wordt aangezet met de instellingen van /etc/network/interfaces. En daarin staan o.a. de aanmeldgegevens en instellingen van jouw draadloze kaart.

En omdat die instellingen via rc.local (opnieuw) worden uitgevoerd, hoef jij dat niet meer handmatig te doen.
Kijk, dat waardeer ik enorm.
Ben nieuw op dit forum maar het 'voelt'  goed.
_/_/_/ I took an IQ test and the result was negative... :cool:
_/_/_/ Ubuntu user #24348
_/_/_/ HP 6820 - Ubuntu 9.04 - Compiz - Virtualbox XP