Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geluid weg..  (gelezen 4618 keer)

Offline Korah

  • Lid
  • Steunpunt: Nee
geluid weg..
« Gepost op: 2008/09/13, 11:56:07 »
na de dualboot installatie had ik, na afwerken van een lijst - geluid.
vandaag start ik de computer op en heb geen geluid meer.
hoe dit op te lossen?!
hoofdcomputer thuis; Asus Eee box met windows 8.1                  
laptop thuis; MSI, AMD Athlon(tm) X2 Dual-Core QL-62 × 2
Ubuntu 14.04

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geluid weg..
« Reactie #1 Gepost op: 2008/09/13, 12:20:17 »

Offline Bramos

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #2 Gepost op: 2008/09/13, 12:30:20 »
Ik had dat ook en ik moest gewoon de PCM opzetten...
te vinden bij de mixer van uw geluid.

Offline Korah

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #3 Gepost op: 2008/09/13, 13:30:27 »
heb een aantal opties van jullie gebruikt, maar nog zonder resultaat.
het lijkt wel of hij ergens gedempt staat omdat hij het eerst wel deed (zelfs die sound bij opstarten computer). Maar ik kan nergens een demping vinden.
hoofdcomputer thuis; Asus Eee box met windows 8.1                  
laptop thuis; MSI, AMD Athlon(tm) X2 Dual-Core QL-62 × 2
Ubuntu 14.04

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #4 Gepost op: 2008/09/13, 16:05:37 »
Aan Korah
Testen via systeem>voorkeuren>geluid. Klikken geeft een lage fluittoon als 't goed is.
Vaak helpt nog eens opnieuw opstarten. Computer afzetten, en de stekker er een paar minuten uit.
Nog meer info geeft de alsa-base file.
In terminal: gedit  /etc/modprobe.d/alsa-base
De uitvoer even naar hier slepen.
Kunnen we zien of je geluidkaart wordt aangesproken.
Vr.groet, peter

bartsturm

  • Gast
geluid weg..
« Reactie #5 Gepost op: 2008/09/13, 17:38:23 »
@ petervdw
Ik heb hetzelfde probleem. Kun je mijn uitvoer ook even bekijken?

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #6 Gepost op: 2008/09/13, 20:43:25 »
Aan bartsturm
Geen bijzonderheden te zien, precies eender als bij mij.
Kun je de uitkomst van:
cat  /proc/asound/modules
ook even laten zien?
Vr.groet, peter

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #7 Gepost op: 2008/09/14, 11:26:03 »
Aan bartsturm
Eigenlijk kun je het beste de googlepage van Pjotr123 volgen:
http://computertip.googlepages.com/geluidskaartinubuntu
Ergens staat een punt waarbij je aan die alsa-base file onderaan toe moet voegen:
options snd_hda_intel model=auto    Vergeet niet de file te saven.
Enige tijd terug was er ook zo'n geval waarbij een soortgelijke regel voor een bepaald merk computer ook hielp. Voor Acer, IBM, lenovo zijn weer andere toevoegingen die werken.
Afgezien hiervan helpt ook het installeren van libstdC++5 via de synaptic. HH8.04 is grotendeels met C++6 gemaakt, maar sommige routines van toeleveranciers grijpen nog terug op C++5. Kan in ieder geval geen kwaad.
Wel steeds opnieuw na elke aktie opnieuw opstarten.

Aan Korah
Eén en ander kun jij ook proberen, als het geluid bij jou ook nog niet werkt.
Als 't werkt, stuur bericht, werkt het niet, vraag verder.

Vr.groet, peter

bartsturm

  • Gast
geluid weg..
« Reactie #8 Gepost op: 2008/09/14, 14:53:22 »
@ Peter
Dank voor je aanwijzing. Ik heb de regel toegevoegd in ALsa-base, maar geen resultaat. Ik heb gisteren gegoogeld op SI7012, maar deze audio geeft blijkbaar veel problemen. Veel dingen geprobeerd, maar geen resultaat. Overigens, op de googlepage van Pjotr123 stond dat ik het volgende in de terminal moest zetten: sudo rmmod snd_hda_intel. Ik krijg dan de melding: "ERROR: Module snd_hda_intel does not exist in /proc/modules". De volgende stappen kon ik dan ook niet uitvoeren. Weet jij hier iets op? Wil je een bepaalde uitvoer hebben?

Vr.Groet,
Bart

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #9 Gepost op: 2008/09/14, 15:01:00 »
Aan Bart
Welk merk en type computer is het?
peter

bartsturm

  • Gast
geluid weg..
« Reactie #10 Gepost op: 2008/09/14, 15:04:02 »
Hoi,

Asus A9t Laptop

Gr, Bart

bartsturm

  • Gast
geluid weg..
« Reactie #11 Gepost op: 2008/09/14, 15:19:27 »
keek net even in de PulseAudio Applet en de Volumemeter laat gewoon geluid zien. Alleen komt er nix door de speakers. De geluidskaart wordt dus gewoon herkend en werkt uiterlijk gezien zoals het moet.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #12 Gepost op: 2008/09/14, 15:20:52 »
Aan Bart
Kijk hier eens:
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/204794
Misschien werkt het ook voor 8.04
Vr.groet, peter

Ene Hants beschrijft het. Mocht Engels een probleem zijn, dan kijk ik er naar.

bartsturm

  • Gast
geluid weg..
« Reactie #13 Gepost op: 2008/09/14, 15:34:02 »
Bij Alsamixer krijg ik dit:
bartsturm@bartsturm:~$ sudo alsamixer
[sudo] password for bartsturm:
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so

alsamixer: function snd_ctl_open failed for default: No such file or directory

Is dit een fout van het systeem? Onoverkomelijk?

Met Gnome ALSA Mixer heb ik gedaan wat de instructies voorschreven, maar geen resultaat

Vr.groet, Peter

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
geluid weg..
« Reactie #14 Gepost op: 2008/09/14, 15:59:19 »
Je kan hier kijken of er iets van toepassing is:
http://wordpress.dvdmeer.nl/?p=70

bartsturm

  • Gast
geluid weg..
« Reactie #15 Gepost op: 2008/09/14, 16:00:27 »
Overigens was ik deze uitvoer vergeten te posten:

bartsturm@bartsturm:~$ cat  /proc/asound/modules
 0 snd_intel8x0

bartsturm

  • Gast
geluid weg..
« Reactie #16 Gepost op: 2008/09/14, 16:02:54 »
@dvdmeer
Thanks, ik ga het direct uitproberen. Wie weet, helpt het bij mij ook.
Groet,
Bart

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #17 Gepost op: 2008/09/14, 16:12:23 »
Aan bartsturm
Kijk in de alsa-base file.
Onderaan staat ergens: options snd-intel8x0m index=-2  
Verander dat in: options snd-intel8x0m index=0
Save de file en grondig opnieuw opstarten. Dus spanningsloos maken.
Vr.groet, peter

Eventueel  aan de laatste regel toevoegen: index=-2   of index=1

Of zet die intel regel er onderaan gewoon nog een keer bij. Let op de juiste streepjes.
SAVE, en reboot. Bij jou uitvoer staat er geen "m" bij. misschien moet je die wel weglaten en gewoon onderaan typen: options snd-intel8x0 index=0
Sorry voor de verschillende raadgevingen, maar ik denk dat je op die manier vlakbij een oplossing zit.
Het blijft proberen.

bartsturm

  • Gast
geluid weg..
« Reactie #18 Gepost op: 2008/09/14, 19:56:42 »
Hallo,

Ik heb bovenstaande uitgevoerd, maar nog geen geluid. In de Alsa-base staat nu het volgende:

options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=0
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
options snd-intel8x0 index=0
options snd_hda_intel model=auto
Is hier iets mee mis of moet het dan ergens anders aan liggen?

Vr. gr,
Bart

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #19 Gepost op: 2008/09/14, 20:47:18 »
Bart
De laatste regel even weghalen. (options snd_hda_intel model=auto)
Nu achter de voorlaatste regel, eindigend op ----port=0x388 index=-2  (of index=1) proberen.
Mocht dat niet werken, dan gaan we nog eens naar die link in post 13 kijken.
Vr.groet, peter

bartsturm

  • Gast
geluid weg..
« Reactie #20 Gepost op: 2008/09/14, 21:15:19 »
Excuus, nee hij doet het niet... Ik heb hem overigen op index=-2 gezet

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #21 Gepost op: 2008/09/14, 21:29:22 »
Bart
Ik zit even te puzzelen op die link. Snap eigenlijk niet zo goed wat hants bedoelt.
Kost even tijd. Nachtje over slapen. Kan het morgenavond misschien aan iemand vragen.
Vr.groet, peter

Voor een Tecra laptop hebben we eens gevonden:
options snd-hda-intel probe_mask=8 model=3stack index=0
en het werkte. Dvdmeer schreef ook iets in die richting, maar ik snap er echt niks van.

bartsturm

  • Gast
geluid weg..
« Reactie #22 Gepost op: 2008/09/14, 21:51:59 »
Hoi Peter,
Wat Hants daar zegt had ik al drie keer gedaan, maar geen resultaat. En als je Googeld op SI7012 wordt je ook niet erg vrolijk, want behalve deze simpele oplossingen (bijv. van Hants) die bij sommigen dus schijnen te werken, zie je verder alleen wanhopige mensen die zich kwaad maken op de SiS apparatuur. Meestal schaffen ze een externe (Usb-)geluidskaart aan en verhelpen zo het probleem.
Als ik niets kan vinden, ga ik er binnenkort even een XP-cd overheen draaien denk ik. Maar als je nog iets kunt doen, graag! Bedankt voor de moeite tot nu toe.

Groet,
Bart

Offline Korah

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #23 Gepost op: 2008/09/15, 22:52:29 »
Citaat van: Petervdw
Aan Korah
Testen via systeem>voorkeuren>geluid. Klikken geeft een lage fluittoon als 't goed is.
Vaak helpt nog eens opnieuw opstarten. Computer afzetten, en de stekker er een paar minuten uit.
Nog meer info geeft de alsa-base file.
In terminal: gedit  /etc/modprobe.d/alsa-base
De uitvoer even naar hier slepen.
Kunnen we zien of je geluidkaart wordt aangesproken.
Vr.groet, peter
Ik hoor geen lage fluittoon.

Hieronder de gevraagde info

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
hoofdcomputer thuis; Asus Eee box met windows 8.1                  
laptop thuis; MSI, AMD Athlon(tm) X2 Dual-Core QL-62 × 2
Ubuntu 14.04

Offline Petervdw

  • Lid
  • Steunpunt: Nee
geluid weg..
« Reactie #24 Gepost op: 2008/09/15, 23:26:35 »
Aan Korah
De alsa-base file ziet er normaal uit. Voor we daar aan gaan veranderen, kun je dan nog de uitvoer van aplay  -l (kleine letter L) en lshw hier naar toe slepen. Als het zo'n Asus is als van bartsturm dan zal het niet gaan lukken, maar dat zien we dan wel. Sorry dat ik even tussendoor met Bart verder ben gegaan, maar dat is m.i. mislukt. Vanavond niet mijn raadgever kunnen bereiken, wordt later.
Vr.groet, peter