Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geklooi met multiboot  (gelezen 2631 keer)

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Gepost op: 2008/09/06, 18:53:48 »
Dag allemaal,

Ik heb hier al wat ervaring met dualboot WinXP en Ubuntu 8.04 met Grub als bootloader. Mijn Ubuntudistroke draaide goed.
Mijn vriend heeft echter een laptop met weinig ruimte en ik wilde hier wat experimenteren met wat lichtere distro's.
Ik installeerde gisteren Zenwalk op een lege partitie die ik geformatteerd had met ext3.
Nu gebruikt Zenwalk lilo als bootloader en ik kende dat nog van de tijd dat ik SuSe draaide, dus installeerde ik die maar, omdat er geen andere keuze was.

Nu wil mijn Ubuntu niet meer opstarten (Windows en Zenwalk wel). Ik heb al meermaals geprobeerd Grub te herstellen maar krijg foutmeldingen zoals error 15 en 23 waar ik weinig mee kan.
Nu heb ik ook ergens in de computertips gelezen dat je best niet meer dan / en swap aanmaakt voor Linux. Wel ik zit met /home en /boot. Waarschijnlijk is mij hier de fout ingeslopen. Zenwalk heeft in de /bootpartitie een en ander geschreven, ook een map met d enaam grub staat er nog in.

Ik weet niet of dit uberhaupt nog te herstellen is, anders overweeg ik om Ubuntu opnieuw te installeeren.
Is het dan beter om de /boot en /home partities te verwijderen?
Ik wil graag nog wat meer testen met andere distro's, dus wil ik problemen vermijden.
Ik wil uiteraard wel bestanden delen met de verschillende distro's onderling. Daar zijn nog andere datapartities in Fat32 voor aangemaakt.

Hier nog even mijn lijst: Zenwalk staat op sda4 en Ubuntu (root) op sda6
De bootpartitie is sda8 en home is sda9

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbff1bff1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3824    30716248+   7  HPFS/NTFS
/dev/sda2            3825       27137   187261672+   f  W95 Ext'd (LBA)
/dev/sda4           27138       30401    26218080   83  Linux
/dev/sda5            3825        5081    10096821    7  HPFS/NTFS
/dev/sda6            5082        7334    18097191   83  Linux
/dev/sda7            7335        7530     1574338+  82  Linux swap / Solaris
/dev/sda8            7531        7550      160618+  83  Linux
/dev/sda9            7551        9989    19591236   83  Linux
/dev/sda10           9990       11534    12410181    7  HPFS/NTFS
/dev/sda11          11535       16663    41198661    b  W95 FAT32
/dev/sda12          16664       21783    41126368+   b  W95 FAT32
/dev/sda13          21784       27137    43005973+   b  W95 FAT32

Disk /dev/sdb: 8019 MB, 8019509248 bytes
255 heads, 63 sectors/track, 974 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0002f860

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         975     7831520+   c  W95 FAT32 (LBA)
Partition 1 has different physical/logical endings:
     phys=(973, 254, 63) logical=(974, 250, 44)

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #1 Gepost op: 2008/09/06, 22:28:04 »
Hallo Starterke.

Jij bent goed bezig, hoor. Lekker klooien met een uitprobeer-syteem, en dan in de problemen komen is de beste leerschool die je kan bedenken ;).
Citaat
Nu heb ik ook ergens in de computertips gelezen dat je best niet meer dan / en swap aanmaakt voor Linux.
Ik weet niet waar je dit gelezen hebt, maar volgens mij is het onzin. Maar bij multi-booten moet je inderdaad wel even goed opletten wat je aan het doen bent.
Ik ben geen expert op dit gebied, maar als ik het met m'n boerenverstand analyseer, dan lijkt mij dat er niet echt principiele bezwaren zijn tegen een gemeenschappelijk gebruik van een /boot partitie, zolang de kernel-bestanden van de verschillende systemen maar verschillende namen hebben (of het verstandig is, is een andere vraag). Als grub dan verder goed geconfigureerd is, dwz met de juisten pad/filenamen van de kernels in menu.lst, zou het goed moeten gaan, lijkt mij. Een gemeenschappelijk gebruik van /home lijkt me niet slim, maar dat kan niet de oorzaak zijn van het niet booten.
Aldus:
- De grubmap die je hebt, is die nog van de Ubuntu-installatie? Zo ja, dan moet je die nog gewoon kunnen gebruiken.
- Zijn de kernelbestanden van Ubuntu nog in /boot, of zijn die misschien overschreven? (weet zo ook even niet hoe je dat zou kunnen oplossen)
- Staan alle paden/namen in /boot/grub/menu.lst goed?
Succes.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Geklooi met multiboot
« Reactie #2 Gepost op: 2008/09/06, 22:31:26 »
Error 15: Fout bij het ontleden (parsen) van een getal
Grub had een getal verwacht, maar kreeg de verkeerde gegevens terug. Als deze fout vóórkomt voordat u het menu ziet, is Grub herinstalleren een optie. Als deze fout voorkomt na het menu, controleer dan  /boot/grub/menu.lst op tikfouten.
Error 23: Linuxkernel moet voor initrd geladen worden
Eerst moet de kernel worden aangeroepen, daarna pas initrd.
Voorbeeld: eerst kernel /boot/vmlinuz-2.6.22 , daarna initrd /boot/initrd-2.6.22 typen in de grub-prompt. Van http://computertip.googlepages.com/grubfoutmeldingen
Ik heb ook al de diverse foutmeldingen gehad, weet je zeker dat je de juiste drive/partitie hebt? Dat was bij mij steeds het geval. Kan je niet via Zenwalk op de Ubuntu partitie komen en in de map boot/grub kijken bij menu.lst wat daar staat als schijf/partitie?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #3 Gepost op: 2008/09/07, 01:22:39 »
Bedankt voor de reacties.

Ik heb nog niks ingrijpends gedaan tot nu toe,
De errors kwamen tijdens de pogingen om in een terminalvenster grub terug te plaatsen.
Grub start niet omdat die is overschreven door Lilo in de MBR.

De lijst staat in de bootpartitie, hier een stukje eruit:

## ## End Default Options ##

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,7)
kernel /vmlinuz-2.6.24-19-generic root=UUID=0765d080-d01e-4a5b-96da-a4c7bfb98f8e ro quiet splash
initrd /initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root (hd0,7)
kernel /vmlinuz-2.6.24-19-generic root=UUID=0765d080-d01e-4a5b-96da-a4c7bfb98f8e ro single
initrd /initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, kernel 2.6.24-16-generic
root (hd0,7)
kernel /vmlinuz-2.6.24-16-generic root=UUID=0765d080-d01e-4a5b-96da-a4c7bfb98f8e ro quiet splash
initrd /initrd.img-2.6.24-16-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-16-generic (recovery mode)
root (hd0,7)
kernel /vmlinuz-2.6.24-16-generic root=UUID=0765d080-d01e-4a5b-96da-a4c7bfb98f8e ro single
initrd /initrd.img-2.6.24-16-generic

title Ubuntu 8.04.1, memtest86+
root (hd0,7)
kernel /memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1
Ik vermoed dat ik gewoon in Lilo een verkeerde partitie heb opgegeven.
Het is ook verwarrend met die verschillende naamgevingen.
De lilo config vind ik nergens.

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #4 Gepost op: 2008/09/07, 01:40:02 »
Ik heb de lilo config toch gevonden. Ingelogd als root.
Hier de lilo.conf in /etc :
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="resume=/dev/sda7 splash=silent "
boot = /dev/sda
bitmap=/boot/splash.bmp
bmp-table=234p,348p,1,4
bmp-colors=220,0,,255,220,
bmp-timer=539p,396p,220,0,
#compact        # faster, but won't work on all systems.
prompt
timeout = 300
# VESA framebuffer console @ 1024x768x64k
vga = 791
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda4
  label = ZenWalk
  initrd = /boot/initrd.splash
  read-only
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda6
  label = Ubuntu
  initrd = /boot/initrd.splash
  read-only
# Windows bootable partition config begins
other = /dev/sda1
  label = WinXP
  table = /dev/sda
# Windows bootable partition config ends
/dev/sda6 is de rootpartitie van Ubuntu, als ik dat nu verander naar /dev/sda8 de bootpartitie. Zou die dan wel booten?
Ik durf niet goed...

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #5 Gepost op: 2008/09/07, 02:38:41 »
Heb lilo terug proberen installeren (http://linux.sitetree.nl/doc/html/node114.html):
root[~]# /sbin/lilo    
Warning: LBA32 addressing assumed
Added ZenWalk *
Added Ubuntu
Added WinXP
One warning was issued.
Die regel staat er dus niet in. Waar mag ik die nu plaatsen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Geklooi met multiboot
« Reactie #6 Gepost op: 2008/09/07, 12:42:13 »
Helaas heb ik niet zo'n ervaring met LILO, wel met Grub daar kan ik wel wat over vertellen. Ubuntu Live cd opstarten. Terminal venster openen en dan:
sudo grub   <------ dit commando uitvoeren
[ Minimal BASH-like line editing is supported.   For           <--- hulptekst
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]

grub> root (hd1,3) <---- dit commando uitvoeren, bij jou invullen  root (hd0,6) i.v.m. telling van Grub, bij mij staat de root op sdb partitie 4.
Let op er staat een spatie tussen root en (hd1,3) geldt ook voor het volgende commando.
grub> setup (hd0)   <------ dit commando uitvoeren
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 d (hd0) (hd0)1+16 p (hd1,3)/boot/grub/stage
2 /boot/grub/menu.lst"... succeeded
Done.

grub>quit  <------ dit commando uitvoeren kom je weer terug in de terminal

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #7 Gepost op: 2008/09/07, 21:24:56 »
Helaas... steeds foutmeldingen. hd0,6 moet trouwens hd0,5 zijn, omdat Grub toch één cijfer achteruit plaatst (zie fdisk -l). Maar dan vindt grub blijkbaar niet wat hij in die partitie moet vinden. Heb dan voor hd0,7 gekozen omdat grub in de sda8 zit...
grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... yes
 Checking if "/grub/stage2" exists... yes
 Checking if "/grub/e2fs_stage1_5" exists... yes
 Running "embed /grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
succeeded
 Running "install /grub/stage1 (hd0) (hd0)1+16 p (hd0,7)/grub/stage2 /grub/menu
.lst"... succeeded
Done.
Even herstarten... :)

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #8 Gepost op: 2008/09/07, 21:39:43 »
Voila, ik zit weer te tokkelen in Ubuntu, maaaarrrr...

Die kan enkel in 'veilige' modus starten (ik zie op het eerste gezciht geen verschil). Is gewoon mijn desktop.
ZenWalk start nu niet meer op natuurlijk, die moet nog toegevoegd worden. Heb dat nog nooit gedaan, dus dat wordt weer zoeken en vragen.
Zenwalk had een mooi progje om systeembestanden te editten, heeft Ubuntu ook zoiets?
Maar dat is een zorg voor later, want morgen moet ik weer gaan werken, het mag vandaag geen kot in de nacht weer worden...

Bedankt in ieder geval voor jullie tips, ik heb er zeker veel van geleerd!

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #9 Gepost op: 2008/09/08, 07:35:20 »
De foutmelding die ik bij de opstart krijg is:

"Geen essec-regel in het sessiebestand xfce. Zal daarom Gnome in veilige modus proberen."

Heb wat zitten googelen op essec-regel en xfce, niks gevonden.
Heeft iemand een idee wat ik hiermee moet doen?

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #10 Gepost op: 2008/09/08, 14:17:44 »
Probleem (voorlopig toch) opgelost. Heb in het loginscherm ingesteld dat die in Gnome moet opstarten. Geen foutmeldingen meer.
Ik heb die xfce hier nog nooit gebruikt, wel in ZenWalk. Waarschijnlijk is dat iets wat gebeurd is in de /boot partitie die nu door Ubuntu en Zenwalk samen gebruikt wordt?

Heeft iemand nog een tip hoe ik ZenWalk moet toevoegen in Grub?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Geklooi met multiboot
« Reactie #11 Gepost op: 2008/09/08, 16:08:40 »
Normaal staat er in Ubuntu /boot/grub/ menu.lst wat er op moet starten, zover ik het nog weet moet er ook een map met lilo of een lilo.config in de /boot directory staan hier uit kan je de regels kopiëren voor zenwalk en in de  /boot/grub/ menu.list onderaan plakken wel de bestanden openen met root rechten anders kan je de gewijzigde bestanden niet opslaan. --> sudo gedit /boot/grub/menu.lst  en zoiets voor lilo --->
sudo gedit /boot/lilo/lilo.conf of hoe het bestand heet. Ik kan het helaas  niet nakijken omdat ik Suse er niet meer op heb staan. Bedoel je /home ipv /boot?
Volgens mij gaat dat niet zo goed, ik had al problemen met twee Ubuntu 8.04 installaties met een gezamenlijke home, geeft af en toe problemen, althans dat is mijn ervaring. Een gedeelde SWAP is geen probleem. Ik zou voor Zenwalk een aparte home partitie gebruiken. Wat XFCE betreft heb je de desktop hiervoor geïnstalleerd? Als je er niet uitkomt, schrijf je maar weer, ik kan soms erg kort door de bocht gaan.
Desnoods installeer ik Suse weer.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #12 Gepost op: 2008/09/08, 19:43:56 »
Gedeelde partities zijn /boot en /home.

Lilo.conf staat in /etc in Zenwalk, zie posting 5 hierboven.
En dit staat er voor Zenwalk:

image = /boot/vmlinuz
  root = /dev/sda4
  label = ZenWalk
  initrd = /boot/initrd.splash
  read-only
Hoe moet ik dat vertalen naar Grub?

Ik had daarstraks wat updates gedaan in Ubuntu en wat kreeg ik na de reboot?
Kernel panic!
"not syncing: VFS: unable to mount rootfs"
Dit in  Ubuntu 8.04.1 kernel default en in 8.04.1 kernel 2.6.25.4
Dit waren twee regels (met nog wat recovery ertussen).
Ik heb de vorige weer gebruikt en kon gewoon weer opstarten.
Ubuntu werkte goed, dus misschien beter die regels weer uit de Grub verwijderen, lijst wordt ook weer lang.
De vrije tijd is zo'n beetje op aan't geraken...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Geklooi met multiboot
« Reactie #13 Gepost op: 2008/09/08, 20:31:21 »
Probeer in eerste instantie de regels uit Zenwalk te plakken onderaan  in de menu.lst. Wat ik me kan herrineren van Suse. Als deze niet wil opstarten, probeer het dan zoals in het voorbeeld staat in menu.lst alvast aangepast aan zenwalk
title Zenwalk
root (hd3,?) <-- Ik weet niet welke partitie of staat het op een aparte schijf?
kernel vmlinuz-2.6.18.6 root=/dev/sda4 <-- hier het juiste kernel nummer invullen wat ik neer gezet heb is een voorbeeld.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #14 Gepost op: 2008/09/08, 22:10:04 »
Ik heb het nu al op drie verschillende manieren geprobeerd, krijg altijd een error 15 (file not found) nadat ik in Grub op Zenwalk enter.

Nu weet ik ook waarom ik nooit nog een een /boot partitie ga delen met andere linux os' :o
www.steenbeeldhouwer.be/fotogalerij/boot.jpg

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Geklooi met multiboot
« Reactie #15 Gepost op: 2008/09/09, 19:18:43 »
Je kan niet de Zenwalk installatie vanuit Ubuntu benaderen en kijken welke kernel versie is geïnstalleerd? vmlinuz-2.6.18.6 of een ander getal bijv. vmlinuz-2.6.18.9.In Ubuntu kan je het hier bijv. vinden /lib/linux-restricted-modules/2.6.24-19-generic als het er nier staat dan moet je helaas even zoeken.
Grub Error 15: Fout bij het ontleden (parsen) van een getal
Grub had een getal verwacht, maar kreeg de verkeerde gegevens terug. Als deze fout vóórkomt voordat u het menu ziet, is Grub herinstalleren een optie. Als deze fout voorkomt na het menu, controleer dan  /boot/grub/menu.lst op tikfouten.
Als je er niet helemaal uitkomt is het dan een optie om Ubuntu opnieuw te installeren? Dan herkent Ubuntu vanzelf de Zenwalk installatie en  Windows . Kan je gelijk het zo installeren zoals het zou moeten een root partitie  /   en een  /home is niet verplicht maar wel erg makkelijk bij installatie van een nieuwe versie. Het enigste wat ik vreemd blijf vinden is een gedeelde /boot map een aparte partitie voor /boot, /etc enz kan natuurlijk wel alleen een beetje omslachtig.
Dus schrijf maar wat je volgende stap/stappen is/zijn.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Starterke

  • Lid
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #16 Gepost op: 2008/09/10, 19:18:07 »
Die bootpartitie is nog iets uit een vorig leven van  mij: SuSE. Daar heb ik via eeen linux forum die tip gekregen om een aparte bootpartitie te maken, voor het geval de distro niet meer zou opstarten je dan alsnog met een bootdiskette kon booten om in die bootmap te gaan sleutelen. Maar ik draaide toen enkel Windows en SuSE samen, geen derde (tweede linux) erbij.

Dit is nog iets wat ik niet goed begrijp: vroeger draaide ik hier SuSE en Yast werd gebruikt voor de installatie en later als SuSE draaide kon je nog allerlei zaken in Yast gaan juist zetten, zoals o.a. de lilo. Je kreeg dan gewoon weer een grafische tool. Voor die tekstmode heb ik te weinig tijd, te weinig ervaring. Ofwel ken ik Ubuntu nog niet goed genoeg.
Zenwalk installeer ik later eens opnieuw, want ik vond dat toch een fijn distroke. Dan gewoon opletten dat ik Ubuntu juist zet in Lilo.

Ubuntu herinstalleren doe ik niet graag, tenzij dat kan met behoud van de huidige instellingen. Ik had alles nu zo mooi staan. Veel werk aan gehad.

Offline Max van Dongen

  • Lid
    • Plink Stairway site (band)
  • Steunpunt: Nee
Geklooi met multiboot
« Reactie #17 Gepost op: 2008/11/04, 16:32:37 »
Citaat van: Gijsbert
Helaas heb ik niet zo'n ervaring met LILO, wel met Grub daar kan ik wel wat over vertellen. Ubuntu Live cd opstarten. Terminal venster openen en dan:
sudo grub   <------ dit commando uitvoeren
[ Minimal BASH-like line editing is supported.   For           <--- hulptekst
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]

grub> root (hd1,3) <---- dit commando uitvoeren, bij jou invullen  root (hd0,6) i.v.m. telling van Grub, bij mij staat de root op sdb partitie 4.
Let op er staat een spatie tussen root en (hd1,3) geldt ook voor het volgende commando.
grub> setup (hd0)   <------ dit commando uitvoeren
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 d (hd0) (hd0)1+16 p (hd1,3)/boot/grub/stage
2 /boot/grub/menu.lst"... succeeded
Done.

grub>quit  <------ dit commando uitvoeren kom je weer terug in de terminal

Met vriendelijke groet,

Gijs
dankjewel, ik zit er ook altijd mee te KL**en
Ik begrijp er weer eens geen zak van. Maar da maak ni uit.. trek in een koekje:P:P

Acer aspire 3620: ubuntu hardy- Windows xp home

paradigit enforcer:
core2quad processor
nvidea geforce gtx 260
4 gig ddr2 ram
750 gb hd
22" beeldscherm