Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba server vraagje  (gelezen 6038 keer)

Coolbone

  • Gast
Samba server vraagje
« Gepost op: 2008/09/05, 17:17:26 »
Hallo iedereen,

Ik ben vrij nieuw in de wereld van linux maar toch is het me gelukt een linux-servertje te laten werken op een oude pc hier. Het is me ook gelukt om samba te laten werken .
Maar nu heb ik toch een klein vraagje: Om aan de shares van samba te komen moeten de users zich inloggen en krijgen ze zo de desbetreffende home-dir.
Dus bvb bij windows vista naar netwerk gaan naam vd server selecteren en dan inloggen. Het probleem is nu dat de gebruikers zich niet kunnen uitloggen zonder de pc opnieuw op te starten. Weet iemand of die wel gaat? Er zijn zowel xp als vista clients.


Groetjes Gert-Jan

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #1 Gepost op: 2008/09/05, 17:43:15 »
Als je inlogt krijg je een schermpje waar je kunt aanvinken of het wachtwoord onthouden worden moet. Dat kun je dan uitlaten. Als de gebruiker zijn map sluit in Windows logt ie automatisch uit, voor zover ik weet.
De share blijft wel in netwerk omgeving staan op de Windows clients.
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Coolbone

  • Gast
Samba server vraagje
« Reactie #2 Gepost op: 2008/09/05, 17:48:34 »
Mmh ik heb het net geprobeerd maar het lukt niet. Als ik nu terug naar men server ga met windows zit ik nogaltijd bij de mappen vd user waarmee ik inlogde.

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #3 Gepost op: 2008/09/05, 18:13:48 »
Dan zal het aan Samba liggen denk ik. Uit het vastgezet onderwerp uit dit forum gehaald: https://help.ubuntu.com/community/SettingUpSamba
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Coolbone

  • Gast
Samba server vraagje
« Reactie #4 Gepost op: 2008/09/05, 20:23:18 »
Ik heb het document al eens doorgenomen maar kan mijn probleem nergens vinden? Lees ik dan zo slecht? :p

Offline joop905

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #5 Gepost op: 2008/09/05, 20:47:53 »

Coolbone

  • Gast
Samba server vraagje
« Reactie #6 Gepost op: 2008/09/06, 20:35:05 »
Ik denk niet dat het daar tussen staan.

Het probleem:
----------------
Ik ga met de verkenner naar mij server. De server vraagt om wachtwoord en gebruikersnaam, ik geef ik "piet" en wachtwoord "piet".

Daardoor kom ik bij de home-dir van "piet" en de public shares voor alle users uit. Nu zou ik graag de home-dir van "klaas" zien. Daarvoor zal ik me moeten uitloggen op de server.
Hoe doe ik dit in windows, want als ik alle vensters sluit en terug naar men server ga zie ik terug te home-dir van "piet".
Hiermee hoop ik dat men probleem een beetje duidelijker uitgelegd is.

Groetjes Coolbone

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #7 Gepost op: 2008/09/06, 20:54:02 »
Als je in Windows in de map piet zit, dan moet je om in de map klaas te komen even bij netwerkomgeving de server opnieuw aanklikken, desnoods ook even bij beeld, herladen. je zou dan alle shares op je server moeten kunnen zien en in elke map waarvoor je de juiste rechten hebt inloggen.
Je kunt in de verkenner ook in de adres balk de naam achter server/home kunnen veranderen in klaas.
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Coolbone

  • Gast
Samba server vraagje
« Reactie #8 Gepost op: 2008/09/07, 11:02:01 »
Ah bedankt voor het antwoord.
Dit werkt dus: als ik met "piet" ben ingelogd, dan bij de adresbalk vd verkenner server/klaas ingeven dan kom ik zonder het invoeren van het wachtwoord (van "klaas" ) bij zijn home-dir uit.
Dit kan normaal toch niet?

Coolbone

  • Gast
Samba server vraagje
« Reactie #9 Gepost op: 2008/09/07, 14:33:51 »
Ik heb precies iets gevonden voor men origineel probleem nl http://help.lockergnome.com/linux/samba-connection-XP-ftopict420098.html

Maar /etc/samba/smbusers staat er bij mij niet bij

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #10 Gepost op: 2008/09/07, 15:23:23 »
Je moet de (Windows) users op de server wel eerst lid maken van de groep smbusers, anders wordt die lijst niet getoond in de user groepen.
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Coolbone

  • Gast
Samba server vraagje
« Reactie #11 Gepost op: 2008/09/07, 15:52:06 »
De windows users zijn al lid van een groep nl. thuis en volgens mij kan je toch niet lid zijn van 2 groepen?

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #12 Gepost op: 2008/09/07, 16:10:45 »
Ja hoor, zoveel als je wilt. Echter om rechten in te stellen in samba moet je een groep smbusers hebben.
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Coolbone

  • Gast
Samba server vraagje
« Reactie #13 Gepost op: 2008/09/07, 17:11:17 »
Is het de bedoeling dat ik dan eerst de groep smbusers maak? want als ik een user probeer toe te voegen zegt ie dat die groep niet bestaat

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #14 Gepost op: 2008/09/07, 17:33:22 »

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.  Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S


Uit mijn smb.conf. Je hoeft dan niet de groep smbusers aan te maken schijnbaar, maar inplaats van valid userers=%S de users specificeren. Als iemand hier meer varstand van heeft, graag. :)
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Coolbone

  • Gast
Samba server vraagje
« Reactie #15 Gepost op: 2008/09/07, 20:50:47 »
Bij mij staat

valid users = @thuis

waarbij volgens mij @thuis staat voor alle leden vd groep thuis.
Wat ik ook al geprobeerd heb is zelf smbusers te maken maar dit help ook niet
Alvast bedankt voor de input btw :p

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Samba server vraagje
« Reactie #16 Gepost op: 2008/09/07, 21:50:25 »
Coolbone, die '%S' die prikkebeen aanhaalt is een variabele. Je kan bijvoorbeeld de variabele '%U' eens proberen. Die variabele staat namelijk voor de username, wat zou inhouden dat de valid user, de users zijn die gekend zijn op het systeem.
Ik zou echter die %S laten staan, want blijkbaar is dat de default setting die bedoeld is om elke Samba-user toegang te geven tot zijn eigen Home-map, en niet meer dan dat. Hier heb ik een heel klein beetje info gevonden: KLIK.
De optie @thuis die je gebruikt is correct, maar volgens mij veroorzaakt die net je probleem nl. dat iedereen toegang heeft tot de Share map waar je Home-directory's in staan, maar die optie legt geen beperking op zoals %S dat (blijkbaar) doet.
Hopelijk versta je een beetje wat ik probeer duidelijk te maken :)

° Bezoek mijn blog Digital (in)Sanity °

Offline ruujan

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #17 Gepost op: 2008/09/08, 14:19:20 »
Een Windows machine houdt de connectie gewoon vast. Je kunt deze vanaf de command prompt zien met het commando "net use".

Je kunt de verbinding verbreken door in te kloppen "net use \\server\share /delete". Dat moet je doen voor alle verbindingen naar die server. Een Windows machine kan namelijk niet twee netwerkverbindingen aan naar dezelfde host met twee verschillende accounts.
Pas als je dit hebt gedaan kun je opnieuw inloggen op de server. Denk erom dat Windows altijd eerst probeert in te loggen met gebruikersnaam en wachtwoord van de gebruiker die op dat moment is ingelogd. Daarna proberen de professional versies ook nog in te loggen met het account dat vorige keer werd gebruikt en pas als dat niet lukt wordt er aan de gebruiker gevraagd om een gebruikersnaam en wachtwoord.

Daarom kun je dit soort dingen beter regelen vanuit een batchfile met daarin een regel als:
"net use q: \\server\share /user:gebruikersnaam" eventueel met de optie /persistent:no er nog achteraan.

Maar goed, dit probleem is iets van Windows en heeft als zodanig niet zoveel met Samba te maken. Als je een Windows-server hebt, dan gebeurt er precies hetzelfde.

Coolbone

  • Gast
Samba server vraagje
« Reactie #18 Gepost op: 2008/09/08, 16:13:41 »
Goed na even proberen werkt valid users = %s en is de beveiligings-leak opgelost. Maar ik kan nog steeds niet uitloggen om van user te switchen. Weet hier niemand het antwoord voor?

Wat bedoel je eigenlijk met :

Daarom kun je dit soort dingen beter regelen vanuit een batchfile met daarin een regel als:
"net use q: \\server\share /user:gebruikersnaam" eventueel met de optie /persistent:no er nog achteraan.

Want hier kan ik toch even niet echt volgen.

Alvast bedankt voor de antwoorden

Offline ruujan

  • Lid
  • Steunpunt: Nee
Samba server vraagje
« Reactie #19 Gepost op: 2008/09/08, 21:10:41 »
Dat is de manier om op een Windows-machine een netwerkshare te koppelen aan een drive-letter. Je zou het kunnen vergelijken met smbmount onder linux. Het unmounten doe je onder Windows ook met "net use" en dan /delete als optie meegeven. Dat is de enige manier waarop Windows dat kan. Er is geen GUI-dingetje voor. Je zult het echt vanaf de commandline moeten doen. Daarom stel ik voor dat je het in een batchfile kwakt en die op je bureaublad neerzet. Volgens mij is dit het antwoord op je vraag.

Coolbone

  • Gast
Samba server vraagje
« Reactie #20 Gepost op: 2008/09/09, 19:46:03 »
Goed dus al ik jullie goed begrijp moet een batchfileje maken en dit telkens uitvoeren om van de server te disconnecten en dan met een nieuwe user inloggen?

Nu concreet: goed hier zit ik een beetje vast :p

edit: ik heb een beetje zitten rommelen met het net use command in windows maar hier geraak  ik niet echt wijs uit. Het enige wat ongeveer werkt is net use * /d /y. Maar nog steeds niet helemaal. Want als ik de server verken zie nog nog eerst de home-dir vd vorige user.

Coolbone

  • Gast
Samba server vraagje
« Reactie #21 Gepost op: 2008/09/09, 20:43:46 »
Goed Het werkt =p

Ik heb een batch script gemaak met net use * /d /y in. Ik heb een snelkoppeling vd server op de bureaublad en ernaast het batch script. Als iemand van user wil wisselen  moet hij alles sluiten en daarna het batchscript runnen. Daarna op de snelkoppeling drukken en terug de juiste user gegevens ingeven.

Hiermee wil ik ook iedereen bedanken voor de hulp
Vriendelijke groeten
Coolbone

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Samba server vraagje
« Reactie #22 Gepost op: 2008/09/10, 08:45:36 »
Als je de authenticatie van de user laat gebeuren op de server (zoals in een klassiek domeinmodel) dan heb je dit probleem niet. Maar dan moet je natuurlijk wel je samba-server instellen als domeincontroller, en je systemen ook toevoegen aan het domein. Misschien gaat dat wat te ver voor hetgeen je wil bereiken, maar het lost in ieder geval wel je probleem op.
Het handige is dat je een script kan laten uitvoeren elke keer als een user aan- of aflogt.
Hier is een goede how-to: http://doc.ubuntu.com/ubuntu/serverguide/C/samba-dc.html. Je hebt het eerste deel nodig, dat voor 'Primary Domain Controller'

° Bezoek mijn blog Digital (in)Sanity °

Coolbone

  • Gast
Samba server vraagje
« Reactie #23 Gepost op: 2008/09/10, 22:05:04 »
Goed dankjewel dit ga ik ook dan eens proberen

Coolbone

  • Gast
Samba server vraagje
« Reactie #24 Gepost op: 2008/09/11, 21:29:27 »
Wel dit werkt echt niet. Ik heb geen flauw idee wat ik eigenlijk doe als ik je guide volg. Zou je mss een beetje uitleg kunnen geven? O ja mij batch file werkt soms wel en soms niet =p