Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apt-get foutmelding  (gelezen 1259 keer)

Offline schorem

  • Lid
  • Steunpunt: Nee
Apt-get foutmelding
« Gepost op: 2006/09/01, 16:28:08 »
Als ik een pakket probeer te installeren (in dit apt-get -f upgrade) dan krijg ik de volgende foutmelding:

...
 `Depends'-veld, ongeldige pakketnaam `libgnomecanvas2-0$': teken `$' niet toegestaan - slechts letters, cijfers en -+._ toegestaan
E: Sub-process /usr/bin/dpkg returned an error code (2)
Iemand een oplossing?

Het 'leuke' is dus dat ik nu alleen maar die foutmelding krijg, wat ik ook wil installeren. Ook met dpkg -i /var/cache/apt/archives/libpanel-applet2-0_2.14.3-0ubuntu1_i386.deb.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #1 Gepost op: 2006/09/01, 17:37:01 »
Volgens de foutmelding heb je ergens een fout teken gebruikt.
Zou 't kunnen dat je ergens copy->paste gedaan hebt en per ongeluk $ hebt mee gekopieert?

Doe nog eens 't zelfde en zorg ervoor dat dit: libgnomecanvas2-0$
Er zo uitziet: libgnomecanvas2-0

:D
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #2 Gepost op: 2006/09/01, 17:41:47 »
een foutje is zo snel gemaakt he....puntje/hoofdletter/kleineletter
:D
ik vind het tof dat je het toch zo wilt proberen!

Offline schorem

  • Lid
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #3 Gepost op: 2006/09/01, 19:58:06 »
Ik kreeg deze foutmelding toen ik XGL en Compiz wilde installeren. Ik heb de xgl repo toegevoegd aan mijn sources.list. Direct na Apt-get update en apt-get dist-upgrade kreeg ik de foutmelding. Niets gekopieerd....

Er stond ook bij dat de fout op een bepaalde regel stond in de package, maar weet zo even niet meer welke... :(

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #4 Gepost op: 2006/09/01, 19:59:42 »
En is 't reeds opgelost?

Doe de installatie anders nog eens over en zorg ervoor dat je alles precies volgt.  ;)
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline schorem

  • Lid
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #5 Gepost op: 2006/09/01, 20:01:53 »
Nee, nog steeds niet. Volgens een post op ubuntuforums.org zou het betekenen dat er nog een proces draait op de achtergrond, alleen blijft de foutmelding bestaan ook na een update. Inmiddels gekeken op Launchpad, maar niets gevonden. Lijkt erop dat ik een bug gevonden heb. Een foutje in het pakket. Dus moet er een nieuwe komen, denk ik. Lastig.

EDIT: Nieuwe installatie? Wask net van plan. Toch maar even posten nog op Launchpad, wie weet? ;)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #6 Gepost op: 2006/09/02, 01:49:14 »
kan sudo apt-get -f install ook niet meer helpen?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Apt-get foutmelding
« Reactie #7 Gepost op: 2006/09/02, 09:48:02 »
sudo gedit /var/lib/dpkg/status

Ga op zoek naar Package: libgnomecanvas2-0$
Daaronder, in die blok bij depends $ weg doen en misschien vervangen ook door iets die zinneger is, wijst zichzelf wel uit I guess ;)

Edit, o ja en dan sudo apt-get clean
sudo apt-get update
sudo apt-get install alwatjawil