Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Datum wijzigt bij kopieren van bestanden  (gelezen 5381 keer)

Offline roeland

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Gepost op: 2008/09/02, 15:35:09 »
Als ik foto's van mijn SD kaart kopieer naar een map, wijzigt de datum van de foto in de datum van de dag van kopieren.  Hoe kan ik dit voorkomen?  Ik gebruik onder andere Thunar hiervoor.
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #1 Gepost op: 2008/09/02, 15:57:16 »
Roelant, of dit met Thunar kan weet ik niet. Vanaf de commando-regel gaat het met de optie -p van het commande cp (van preserve, dit laat dus ook de andere attributen, zoals eigenaar e.d. in stand).

Offline roeland

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #2 Gepost op: 2008/09/02, 16:09:51 »
Met de terminal werken probeer ik te voorkomen.  Is ook veel complexer bij veel bestanden overzetten.  Iemand nog een oplossing?
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #3 Gepost op: 2008/09/02, 16:47:42 »
Koudwatervrees voor de commando-regel is een weidverbreid verschijnsel. Maar er zijn nu eenmaal dingen die alleen via de commando-regel kunnen (dit zou er een kunnen zijn, brrrrrrrrrrrrrrrrr)  ;)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #4 Gepost op: 2008/09/02, 16:54:09 »
Grafisch kan het bijvoorbeeld met grsync.
Daarmee kan je alleen niet losse bestanden kopiëren, maar wel hele mappen.

Offline siegi

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #5 Gepost op: 2008/09/02, 17:05:39 »
Voor bv foto's word in de tag van de foto de datum en uur opgeslagen wanneer de foto genomen is.
Deze datum kan verschillend zijn van deze van het bestand.

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #6 Gepost op: 2008/09/02, 17:21:08 »
Ja, de datum in b.v. Nautilus toont de datum laatst gewijzigd. De extra info, zoals datum genomen enz. staat in de exif informatie. Is wel lastig, je kunt de kolom gemaakt op niet aan Nautilus toevoegen. Exif kun je wel oproepen in Fspot, maar daar zal het je wel niet om te doen zijn.
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #7 Gepost op: 2008/09/02, 19:53:13 »
Ik heb nog even naar je probleem zitten kijken, maar ben nu toch enigzins in verwarring.
Bij een kopieer-actie in bijv. thunar verandert bij mij niet de datum 'Gewijzigd', maar alleen de datum 'Geopend'. En het is de datum 'Gewijzigd' die normaal gesproken te zien is, en die verandert dus niet.
De vraag is dus, wat bedoel je precies met "de datum van de foto"?

Hoe dan ook, er is een truc denkbaar, niet helemaal zonder die enge terminal, maar misschien acceptabel voor jou:
alias cp='cp -p' && thunar && exitJe start dan een thunar sessie waarbij ELKE kopieer-actie met behoud van de attributen gaat. Voor het gemak sluit de terminal direct na het afsluiten van tunar (hoewel de werkelijke reden is dat de alias dan direct vernietigd wordt).
Als dit werkt voor je, kunnen we daar ook een klein scriptje van maken, die je met een Launcher kan starten.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #8 Gepost op: 2008/09/02, 22:26:58 »
Mijn ervaring is dat bij een kopieeractie wel degelijk een nieuwe "inode" gecreëerd wordt die in eerste instantie als "Date Modified" en "Date Accessed" het ogenblik van het kopiëren heeft. Anderszijds sta ik wel te kijken van dat trukje van jou: achter de schermen maken de grafische file managers dus blijkbaar gebruik van het cp commando als dusdanig (ja, het werkt wel degelijk, ook met nautilus!).

Dat gezegd zijnde heb ik een elegantere manier om het gedrag van cp meer permanent te veranderen: neem de alias op in ~/.bashrc en zowel cp als thunar zullen bij een kopie de datum van het origineel gebruiken.

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #9 Gepost op: 2008/09/02, 23:03:07 »
Citaat
Mijn ervaring is dat bij een kopieeractie wel degelijk een nieuwe "inode" gecreëerd wordt
Ik moet zeggen dat ik ook het idee had dat het zo werkte. In ieder geval is dat zo bij een cp vanaf de cli. Maar toen ik het uitprobeerde in thunar zag ik "date modified" niet veranderen.

Over de alias in .bashrc. Dat kan natuurlijk op die manier. Zelf zou ik er niet voor willen kiezen om het gedrag van cp permanent te veranderen. In die zin zou, in mijn optiek, "alias cp='cp -p' && thunar && unalias cp" nog iets netter zijn.

Offline roeland

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #10 Gepost op: 2008/09/03, 13:44:21 »
Wat een "simpele" vraag al niet voor reacties oproept.  Ik kan er zeker wat mee en ik denk dat mijn probleem is opgelost.
Ik heb "alias cp='cp -p' && thunar && exit" in de terminal ingetikt en het werkt.  Een scriptje zou welkom zijn.  Een combinatie van de oplossing van leepesjee en vanadium lost alles gelijk op.  Wat mij betreft mag het script er toe leiden dat zowel bij gebruik van Thunar en/of Nautilus permanent de datum van de kolom "laatst gewijzigd" alleen maar verandert als de inhoud van het bestand wijzigt.

Een paar opmerkingen:
Wat het gebruik van de terminal betreft: ik ben in 1982 gestart met een terminal dus daar heb ik alle kanten wel van gezien.  Zonder terminal werken vind ik gewoon praktischer met minder kans op fouten of onvoorziene acties.

Ik bedoel binnen Thunar de kolom "laatst gewijzigd".  Ik lees mijn SD kaarten via een kaartlezer in en plaats die in een archiefmap.  Daarna maak ik vaak eerst een backup op CD/DVD (van die map).  Vervolgens groepeer ik de foto's op basis van de datum van de opname (= datum "laatst gewijzigd") in afzonderlijke mappen.  Daarna ga ik pas met fotobewerkingprogramma's aan het werk en zie de exif gegevens.
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline vanadium

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #11 Gepost op: 2008/09/03, 13:50:46 »
Citaat
Daarna ga ik pas met fotobewerkingprogramma's aan het werk
In die context is het zowieso zeer spijtig dat Thunar/Nautilus ook niet de exif gegevens kunnen weergeven in een kolom. Onze oude kennis "explorer" kon dat wel.

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #12 Gepost op: 2008/09/03, 19:33:59 »
Het is jammer dat de exif velden niet in Thunar te zien zijn, maar alleen per bestand. Je zou als vooropige opplossing 'custom action' kunnen maken in Thunar die verwijst naar een script dat van alle bestanden met exif datumtag leest  in een geselecteerde map en vervolgens de bestandsdatum of naam wijzigt in die exif datum.

Ik vond de volgende tools in de repository

exiv2
renrot
pyrenamer

en blijkbaar is er nog  http://mundogeek.net/rename-to-exif-date/  

Verder zou je forumlid Stani ook eens kunnen vragen of hij zo'n mogelijkheid in zijn Phatch tool kan inbouwen. Deze tool kan allerlei beeldbewerkingen op grote hoeveelheden bestanden uitvoeren en maakt er automatisch een Thunar action van. Het is schat ik een kleine moeite om de datum aan te passen ahv een exif veld.

Ik denk dat je het beheren van fotos beter met een speciaal beeld-archief programma kan doen. Daar is een algemene  filemanager misschien ook niet voor.

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #13 Gepost op: 2008/09/03, 21:37:07 »
Citaat
Wat mij betreft mag het script er toe leiden dat zowel bij gebruik van Thunar en/of Nautilus permanent de datum van de kolom "laatst gewijzigd" alleen maar verandert als de inhoud van het bestand wijzigt.
In dat geval is de aanpak van Vanadium het eenvoudigst. Open in gedit het bestand ~/.bashrc en voeg onderaan de volgende regels toe:
# User aanpassing:
# Copy standaard met behoud van attributen
alias cp='cp -p'
Opslaan en daarna uit- en weer inloggen.
Dat zou het moeten doen. Als je in een terminal nu "alias" intikt, moet je cp-alias erbij staan.

Citaat
... dat van alle bestanden met exif datumtag leest  in een geselecteerde map en vervolgens de bestandsdatum ... wijzigt in die exif datum
Hm, even de man-page van exiv2 bekeken. Zoiets zou het moeten kunnen doen:
exiv2 mv -T *.jpg -v

Offline vanadium

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #14 Gepost op: 2008/09/04, 20:42:21 »
Bedankt voor de exiv2 tip!

Offline roeland

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #15 Gepost op: 2008/09/08, 22:26:32 »
Aanvulling op de wijziging van het bestand ~/.bashrc door leepesjee (zodat de datum in o.a. Thunar alleen maar gewijzigd wordt bij een wijzging van het bestand en niet bij een verplaatsing of kopieeractie van het bestand):

de toe te voegen code aanvullen met fi.  Zonder die aanvulling werkte het niet en ik zag dat elke code wordt afgesloten met meeestal fi (zal wel iets als uitvoeren betekenen).

Code wordt dan als volgt:

# User aanpassing:
# Copy standaard met behoud van attributen
alias cp='cp -p'
fi
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #16 Gepost op: 2008/09/08, 22:57:34 »
Ha roelant,
Dat is een beetje raar. "fi" is de afsluiting van een stukje je code die begint met "if". Het is statement die in bijna alle programmeertalen voorkomt (en dus ook bash scripts) van de vorm: als A doe dan B.
De regel met de alias bevat geen if en hoeft dus ook niet met een fi afgesloten te worden. Als het bij jou zo is dat het alleen werkt met een if aan het eind, dan betekent dat eigenlijk, dat er ergens een if is geopend, die niet is afgesloten. Heb je niet per ongeluk een fi gedelete?

Offline roeland

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #17 Gepost op: 2008/09/12, 21:03:22 »
Vandaag met Grsync een backup gedraaid waarbij de datums niet zijn gewijzigd.  Het werkt dus!
ik heb hieronder de laatste twee alinea's gekopieerd uit het bashcr bestand.  De door mij geplaatste fi aan het eind heb ik weer weggehaald.  Waar staat "fi" (finalize?) in de voorlaatste alinea?


# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
fi
# User aanpassing:
# Copy standaard met behoud van attributen
alias cp='cp -p'
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline leepesjee

  • Lid
  • Steunpunt: Nee
Datum wijzigt bij kopieren van bestanden
« Reactie #18 Gepost op: 2008/09/12, 21:51:57 »
Ha Roelant.
Mooi dat het werkt. Ik weet niet of ik je vraag helemaal begrijp. Het stukje code boven de alias regels is zoals die hoort te zijn. De regels daarboven:
# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ] && [ -x /usr/bin/dircolors ]; then
    eval "`dircolors -b`"
    alias ls='ls --color=auto'
    #alias dir='ls --color=auto --format=vertical'
    #alias vdir='ls --color=auto --format=long'

    #alias grep='grep --color=auto'
    #alias fgrep='fgrep --color=auto'
    #alias egrep='egrep --color=auto'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'