Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Sitecom Wl - 141  (gelezen 7152 keer)

dragon9114

  • Gast
Sitecom Wl - 141
« Gepost op: 2006/09/01, 14:32:27 »
Hoi,

ik heb geprobeert om de drivers voor mijn draadloze netwerk kaart een sitecom wl - 141 te installeren via ndiswrapper maar dan krijg ik deze error.

dragon@dragon-desktop:~$ sudo -i ndiswrapper wlanCIG.inf
/usr/sbin/ndiswrapper: line 21: use: command not found
/usr/sbin/ndiswrapper: line 22: use: command not found
/usr/sbin/ndiswrapper: line 23: use: command not found
/usr/sbin/ndiswrapper: line 24: use: command not found
/usr/sbin/ndiswrapper: line 26: my: command not found
/usr/sbin/ndiswrapper: line 27: my: command not found
/usr/sbin/ndiswrapper: line 28: my: command not found
/usr/sbin/ndiswrapper: line 30: my: command not found
/usr/sbin/ndiswrapper: line 31: my: command not found
/usr/sbin/ndiswrapper: line 32: my: command not found
/usr/sbin/ndiswrapper: line 33: my: command not found
/usr/sbin/ndiswrapper: line 34: my: command not found
/usr/sbin/ndiswrapper: line 35: my: command not found
/usr/sbin/ndiswrapper: line 36: my: command not found
/usr/sbin/ndiswrapper: line 39: my: command not found
/usr/sbin/ndiswrapper: line 40: my: command not found
/usr/sbin/ndiswrapper: line 43: my: command not found
/usr/sbin/ndiswrapper: ndiswrapper: line 46: syntax error near unexpected token `('
/usr/sbin/ndiswrapper: ndiswrapper: line 46: `my %param_fixlist = ("EnableRadio| 0" => "EnableRadio|1",'


weet iemand een manier om deze kaart werkend te krijgen onder linux ?

Groeten Dragon

Phaldmmor

  • Gast
Sitecom Wl - 141
« Reactie #1 Gepost op: 2006/09/01, 14:59:39 »
Hoi, je hebt geluk, want ik heb dezelfde kaart en Azalin ook.
Volgende oplossing werkt (met dank aan Azalin (heb de tekst van hem overgenomen, had geen zin om het zelf allemaal op te schrijven, hoop datie het niet erg vind :) ) :

Doe het volgende in een terminal:
lspci | grep Intersil

Als je dan het volgende ziet staan dan kun je dus de rest wat hier volgt opvolgen:
Network controller: Intersil Corporation ISL3886 [Prism Javelin/Prism Xbow] (rev 01)

Als je het type van je kaart weet ben je denk ik sneller klaar.
Als het een WL-141 is dan heb je dezelfde als ik en dan kun je verder.

Staat dit er? Mooi, dan moet je eerst ndiswrapper installeren. (sudo apt-get install ndiswrapper)
Dan moet je de standaard intersil drivers buiten spel zetten. Maak een bestand aan waar in die drivers buiten spel gezet worden:

sudo gedit /etc/modprobe.d/islsm_blacklist

in dat bestand zet je het volgende:

als je dapper drake gebruikt zet je dit er in:
blacklist islsm_pci
blacklist islsm_device
blacklist islsm

als je breezy badger gebruikt:
blacklist prism54

Verder is het wel handig om een driver te hebben, die kan je hier downloaden: http://download.fujitsu-siemens.com/Download/ShowDescription.asp?SoftwareGUID=3B928095-EEEE-4194-91A7-E0CBE2D28B56

Deze is eigenlijk niet voor de WL-141 maar de drivers die bij de WL-141 geleverd zijn werken niet met ndiswrapper.

De driver uitpakken. Zorg er voor dat je zowel de inf als het sys bestand in dezelfde map hebt staan.
Doe dan
sudo rmmod islsm
sudo rmmod islsm_device
sudo rmmod islsm_pci
sudo ndiswrapper -i
sudo ndiswrapper -m
sudo modprobe ndiswrapper

De eerste regel met sudo verwijdert islsm uit het geheugen. De tweede regel verwijdert islsm_device, de derde de islsm_pci. De vierde regel vertelt ndiswrapper welk inf file als driver gebruikt moet worden. De vijfde regel vertelt het systeem dat het ndiswrapper moet toevoegen aan de lijst met modules die tijdens het opstarten gestart moeten worden (manual drivers). En de laatste doet iets wat tijdens opstarten eigenlijk gebeurd: het jump starten van de ndiswrapper zodat de kaart geactiveerd wordt met de nieuwe driver. Je zou nu even kunnen herstarten.

Nu kun je met iwconfig de essid instellen (doe maar even een iwconfig --help voor alle commandos)
en ook je eventuele WEP key.
Als je met iwconfig je essid en je wep key goed hebt kunnen instellen dan is het tijd om dit in je interfaces bestand te zetten.
sudo gedit /etc/network/interfaces

als het goed is heet je wlan kaartje wlan0 (doe maar eens een ifconfig -a). zet dan in het bestand dat je zojuist geopend hebt:

iface wlan0 inet dhcp
wireless-keymode open
wireless-key
wireless-mode managed
wireless-essid
auto wlan0

Ik hoop dat dit allemaal helpt en werkt.

Phaldmmor

  • Gast
Sitecom Wl - 141
« Reactie #2 Gepost op: 2006/09/01, 15:01:29 »
PS wat voor processor heb je? Ik heb namelijk een AMD64 Athlon X2, dan dien je eerst nog de K7 kernel te installeren, anders werkt ndiswrapper niet goed. (duurde ook even voor ik daar achter was namelijk).

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #3 Gepost op: 2006/09/01, 15:27:02 »
ik heb een amd athlon xp 64 3000 + venice

Phaldmmor

  • Gast
Sitecom Wl - 141
« Reactie #4 Gepost op: 2006/09/01, 15:43:34 »
Citaat van: dragon9114
ik heb een amd athlon xp 64 3000 + venice
Dan dien je eerst via synchap het pakket linux K7 pakket te installeren, daarna kan je dan via bovenstaande procedure je WLAN kaart via ndiswrapper installeren. Indien je de AMD64 bits versie van ubunutu hebt geinstalleerd heb je een probleem, er zijn namelijk nog geen 64 bits drivers voor de sitecom beschikbaar. 32 Bits drivers werken niet op een 64 bits omgeving dus je dient de 32-bits versie van ubuntu te installeren.

Mocht je wel 64-bits drivers hebben, laat even weten waar je ze gevonden hebt ;)

(zelfde probleem heb je trouwens ook bij windows xp 64-bits, ook hier heb je 64-bits drivers nodig...)

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #5 Gepost op: 2006/09/01, 17:32:31 »
hij vind de netwerk kaart nog steeds niet :S
hij gaf dit aan bij de installatie.

Installing wlancig
no dev WLAN_DCB4.XP NTx86.5.1
no dev WLAN_DCB6.XP NTx86.5.1

Azalin

  • Gast
Sitecom Wl - 141
« Reactie #6 Gepost op: 2006/09/01, 22:59:30 »
Mja, je moet niet vergeten om het bij behorende .sys bestand in dezelfde map te zetten als het .inf bestand. Verder gaat de bijgeleverde driver NIET werken. Je moet echt deze driver hebben: http://download.fujitsu-siemens.com/Download/ShowDescription.asp?SoftwareGUID=3B928095-EEEE-4194-91A7-E0CBE2D28B56

Sitecom heeft iets uitgespookt met die driver van hun en dus werkt hij niet... Als je de driver van bovengenoemde locatie download, uitpakt en met ndiswrapper installeert (via de optie -i) dan moet het werken.

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #7 Gepost op: 2006/09/10, 22:02:41 »
om een of andere reden heeft het niet gewerkt :(

Azalin

  • Gast
Sitecom Wl - 141
« Reactie #8 Gepost op: 2006/09/10, 23:28:39 »
Je moet toch iets precieser zijn willen we je kunnen helpen. Krijg je een error? Welke error krijg je dan? Wat heb je precies gedaan? Heb je wel islsm geblacklist (als je een PCI kaart hebt, heb je ook islsm_pci en islsm_device geblacklist, met usb is het niet islsm_pci maar islsm_usb die je moet blacklisten)? Dit laatste is erg belangrijk en wordt heel vaak vergeten.

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #9 Gepost op: 2006/09/11, 16:08:14 »
moet ik die black list zelf maken of moet ik er 1 aanpassen ?

toen in het inf bestand probeerde te installeren met ndiswrapper kreeg ik een error van iets met line 135.
heb het daarna nog een keer geprobeert ,maar toen gaf ie aan dat het al geinstalleert is.

Azalin

  • Gast
Sitecom Wl - 141
« Reactie #10 Gepost op: 2006/09/11, 20:30:36 »
Citaat van: dragon9114
moet ik die black list zelf maken of moet ik er 1 aanpassen ?

toen in het inf bestand probeerde te installeren met ndiswrapper kreeg ik een error van iets met line 135.
heb het daarna nog een keer geprobeert ,maar toen gaf ie aan dat het al geinstalleert is.
Ok, die blacklist moet je inderdaad zelf aanmaken. Kijk even een paar berichtjes terug in deze post. Om je in elk geval op gang te helpen:

sudo gedit /etc/modprobe.d/islsm_blacklist

>in dat bestand zet je het volgende:

>als je dapper drake gebruikt zet je dit er in:
blacklist islsm_pci
blacklist islsm_device
blacklist islsm

>als je breezy badger gebruikt:
blacklist prism54

Verder moet je even ndiswrapper -l doen om te zien of en wat er geinstalleerd staat. Of de juiste driver geinstalleerd staat. Maar heb je wel de driver van de site gedownload zoals hier eerder in deze thread vermeld werd? Ndiswrapper -l moet overigens hardware present, driver present geven... dan kun je verder.

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #11 Gepost op: 2006/09/12, 07:06:19 »
hoe kan ik een driver deinstalleren ?

root@dragon-desktop:/home/dragon# ndiswrapper -l
Installed ndis drivers:
driver  invalid driver!
prisma00        invalid driver!
wlancig invalid driver!

dat is dus niet de goeie driver die ik nodig heb.

Azalin

  • Gast
Sitecom Wl - 141
« Reactie #12 Gepost op: 2006/09/12, 07:34:39 »
Een driver deinstalleren:

sudo ndiswrapper -e [naam van driver]

Usage: ndiswrapper OPTION

Manage ndis drivers for ndiswrapper.
-i inffile        Install driver described by 'inffile'
-d devid driver   Use installed 'driver' for 'devid'
-e driver         Remove 'driver'
-l                List installed drivers
-m                Write configuration for modprobe


where 'devid' is either PCIID or USBID of the form XXXX:XXXX

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #13 Gepost op: 2006/09/13, 06:58:29 »
dit is de error die ik krijg als ik de driver installeer die hier in het topic staat.

Installing prisma00
couldn't copy PRISMA00.inf at /usr/sbin/ndiswrapper line 135.

Azalin

  • Gast
Sitecom Wl - 141
« Reactie #14 Gepost op: 2006/09/13, 08:24:39 »
Je moet natuurlijk wel sudo ndiswrapper -i PRISMA00.inf doen en zorgen dat je beide (dus .inf en .sys) bestanden in de map hebt staan waar je ze uit wil lezen... dus staat de PRISMA00.inf en .sys in /home/user/driver/ dan doe kun je beter cd /home/user/driver doen en dan sudo ndiswrapper -i PRISMA00.inf

dragon9114

  • Gast
Sitecom Wl - 141
« Reactie #15 Gepost op: 2006/09/13, 16:18:42 »
ik heb alles gedaan zoals beschreven staat maar ik krijg steeds couldn't copy PRISMA00.inf at /usr/sbin/ndiswrapper line 135.

Azalin

  • Gast
Sitecom Wl - 141
« Reactie #16 Gepost op: 2006/09/13, 23:48:12 »
Mja, als je alles hebt gedaan zoals beschreven en je krijgt een error dan weet ik het ook niet meer. Het ziet er naar uit dat de inf file niet gekopieerd kon worden omdat hij of niet gevonden kon worden of omdat hij niet naar het doelbestand kon schrijven. Maar ik zit er even doorheen wat idee