Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: FAQ Problemen met Java  (gelezen 2487 keer)

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
FAQ Problemen met Java
« Gepost op: 2008/09/01, 13:16:18 »
Omdat ik de laatste tijd zie dat er nogal wat vragen zijn m.b.t. Java, heb ik hier een (zeer korte) FAQ over Java geschreven.
Q. Java-programma XYZ werkt niet meer!
Q. Java-programma XYZ doet raar!
Q. Ik kan m'n code niet meer compileren!

A. Dit komt omdat Ubuntu 8.04 standaard met OpenJDK komt. Alhoewel OpenJDK een mooie vooruitgang is, is het nog lang niet compatibel met alle programma's (ik zou zelfs beweren: het is nog in alpha-fase en alleen voor testers bedoeld). Je moet dus Sun Java installeren. Open Synaptic, VERWIJDER alles wat lijkt op 'Gnu classpath', 'OpenJDK', en 'GCJ', en INSTALLEER sun-java-jdk6. Indien je Java-programmeren echt serieus neemt, raad ik je aan om de JDK te downloaden van de website van Sun

Q. NetBeans/Eclipse werkt niet/doet vreemd!
A. NetBeans of Eclipse die via Synaptic worden geïnstalleerd, worden opgesplits in verschillende kleine pakketjes, en vaak heb je dan niet het juiste pakketje. Uiteraard kan je gaan 'jagen' achter de pakketjes die je nodig hebt, maar het is eenvoudiger om gewoonweg NetBeans of Eclipse te downloaden van de website van NetBeans of Eclipse.

@Moderatoren: zouden jullie dit kunnen sticky'en? Bedankt.
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
FAQ Problemen met Java
« Reactie #1 Gepost op: 2008/09/01, 13:49:38 »
Het installeren van programma's buiten de pakketbronnen van Ubuntu om gaan we niet zomaar promoten.
Je zal je FAQ aan moeten passen zodat de bronnen van Ubuntu wel gebruikt worden, of een betere onderbouwing moeten geven waarom de standaardpakketten niet goed zijn.

Bovendien: Als de standaardpakketten niet goed zijn, dan lijkt me dat wel een reden om een bugrapport in te dienen zodat dit verholpen kan worden.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
FAQ Problemen met Java
« Reactie #2 Gepost op: 2008/09/01, 15:05:37 »
Probleem 1 is al opgelost eigenlijk: sinds enige tijd krijg je bij installatie van ubuntu-restricted-extras niet langer OpenJDK en de IcedTea plugin mee geïnstalleerd, maar weer (net zoals vroeger bij 7.10) sun-java6-jre en sun-java6-plugin.

Er was een bugrapport van, en daar hebben ze dus wat mee gedaan.  :-)

http://forum.ubuntu-nl.org/topic/29428

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
FAQ Problemen met Java
« Reactie #3 Gepost op: 2008/09/01, 15:15:12 »
Citaat van: Johanvd
Het installeren van programma's buiten de pakketbronnen van Ubuntu om gaan we niet zomaar promoten.
Je zal je FAQ aan moeten passen zodat de bronnen van Ubuntu wel gebruikt worden, of een betere onderbouwing moeten geven waarom de standaardpakketten niet goed zijn.

Bovendien: Als de standaardpakketten niet goed zijn, dan lijkt me dat wel een reden om een bugrapport in te dienen zodat dit verholpen kan worden.
Ik zou het normaal ook afraden, maar bij Java-programma's raad ik het toch echt aan. In tegenstelling tot programma's die specifiek gemaakt zijn voor Linux, zijn deze programma's nooit bedoeld om in een pakket gedraaid te worden. Zo heeft NetBeans bijvoorbeeld z'n eigen module-installatiemethode. Bovendien installeert de pakketbeheerder de programma's in niet-standaard locaties (java wordt normaal gezien in /usr/java geïnstalleerd, netbeans in /opt/netbeans). Plus, de versie van netbeans in de repo's is outdated (6.0 zit in de repo's, 6.1 is uit). In tegenstelling tot programma's van source compileren is dit geheel onschadelijk voor het systeem, omdat de programma's in hun eigen map worden geïnstalleerd. En nog erger: wat één download is bij de website van sun/netbeans, wordt opgesplits in verscheidene kleine pakketjes, wat dus betekent dat (omdat de dependancies niet altijd kloppen :/ ) je vaak de helft van de functionaliteit mist. Ik heb onlangs gezien bijvoorbeeld dat JavaDoc niet geïnstalleerd wordt met sun-java6-jdk (het zit in het pakket sun-java6-doc, wat niet als dependancy opstaat voor sun-java6-jdk), en netbeans is practisch onbruikbaar omdat de java-plugin niet geïnstalleerd wordt (en deze is moeilijk achteraf te installeren), terwijl deze op de website gewoon meegeleverd wordt....

- SeySayux
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline Georingo

  • Lid
    • Bellen voor het goede doel
  • Steunpunt: Nee
FAQ Problemen met Java
« Reactie #4 Gepost op: 2008/10/31, 18:30:08 »
Met de upgrade van 8.04 naar 8.10 werkt bij mij een specifieke "java transport agent" niet meer. Ik herinner me dat ik hetzelfde probleem had bij de overstap van 7.10 naar 8.04. Toen hielp het inderdaad om Icedtea en dergelijke te verwijderen, zodat de sun-java-6 gebruikt werd. Nu lukt dit echter niet. Ik heb alles met "OpenJDK" verwijdert, en de java loopt nog steeds vast. Heeft iemand een idee waar het nog aan zou kunnen liggen?

(ondertussen opgelost, het lag aan interferentie met Firefox add-ons Addblock en NoScript, dus niet aan de java)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
FAQ Problemen met Java
« Reactie #5 Gepost op: 2008/11/01, 19:49:37 »
Voor Eclipse raad ik momenteel toch ook aan om het van de Sun website te downloaden..
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)