Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: converteren van .rpm naar .deb voor bv. Kerio Mailserver, "ALIEN"?  (gelezen 817 keer)

wlevels

  • Gast
Beste linuxgoeroe's,

Ik weet niet precies of dit nou in het server en netwerk gedeelte moest, of in het softwaregedeelte, excuses als het toch fout geplaatst is.

Ik ben nogal ERG nieuw met linux, mis nogal dat er op mijn IT opleiding bijna niets behandeld word mbt. linux, ik ben maar zelf mijn weg aant zoeken binnen linux, en ben begonnen bij ubuntu serveromgevingen. Ik wou eens beginnen met een kerio mailserver te installeren op de laatste serverversie van ubuntu.
Helaas zijn er nogal wat probleempjes met de installatie van ALIEN, het converteerprogramma die (onder andere) mooie .deb files van .rpm files maakt.

Kerio mailserver wordt namelijk alleen als .rpm geleverd.

Nu heb ik met de nederlandse djieno gesproken die een tutorial heeft geschreven op het kerio forum en op http://sudan.ubuntuforums.com/showthread.php?t=460955, en hij heeft me bevestigd dat het probleem niet aan mij ligt, maar de installatie van ALIEN op ubuntu Hardy Heron foutgaat.
Ik kan niet echt wat over ALIEN vinden, kan iemand mij meer vertellen of nog aan ALIEN ontwikkeld wordt of deze nog uitkomt voor de laatste versie van Ubuntu?

Indien er niks meer met ALIEN gedaan wordt, wat voor opties heb ik dan om dit .rpm package om te toveren om op ubuntu te kunnen installeren?

Alvast bedankt voor jullie moeite!

Donderbokje

  • Gast
converteren van .rpm naar .deb voor bv. Kerio Mailserver, "ALIEN"?
« Reactie #1 Gepost op: 2008/09/01, 00:56:41 »
Wat zijn dan precies de problemen die je hebt met de installatie?
Ik heb het programma net even geinstalleerd en dat ging zonder problemen.

martin@ubuntu-pc:/etc/init.d$ sudo apt-get install alien
[sudo] password for martin:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libbeecrypt6 librpm4.4 rpm
Suggested packages:
  lsb-rpm
The following NEW packages will be installed:
  alien libbeecrypt6 librpm4.4 rpm
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1791kB of archives.
After this operation, 6586kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://nl.archive.ubuntu.com hardy/main libbeecrypt6 4.1.2-6build1 [108kB]
Get:2 http://nl.archive.ubuntu.com hardy/main librpm4.4 4.4.2.1-1ubuntu6 [953kB]
Get:3 http://nl.archive.ubuntu.com hardy/main rpm 4.4.2.1-1ubuntu6 [625kB]
Get:4 http://nl.archive.ubuntu.com hardy/main alien 8.69 [104kB]
Fetched 1791kB in 2s (787kB/s)
Selecting previously deselected package libbeecrypt6.
(Reading database ... 88174 files and directories currently installed.)
Unpacking libbeecrypt6 (from .../libbeecrypt6_4.1.2-6build1_i386.deb) ...
Selecting previously deselected package librpm4.4.
Unpacking librpm4.4 (from .../librpm4.4_4.4.2.1-1ubuntu6_i386.deb) ...
Selecting previously deselected package rpm.
Unpacking rpm (from .../rpm_4.4.2.1-1ubuntu6_i386.deb) ...
Selecting previously deselected package alien.
Unpacking alien (from .../archives/alien_8.69_all.deb) ...
Setting up libbeecrypt6 (4.1.2-6build1) ...

Setting up librpm4.4 (4.4.2.1-1ubuntu6) ...

Setting up rpm (4.4.2.1-1ubuntu6) ...

Setting up alien (8.69) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
martin@ubuntu-pc:/etc/init.d$