Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: XGL + Compiz  (gelezen 6419 keer)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Gepost op: 2006/08/31, 16:51:52 »
hey :)

weet iemand een duidelijke (en liefst in het Nederlands) handleiding voor het installeren van XGL + Compiz op het internet staan ?

en het is voor ATI (!!) niet voor Nvidea ;)

Doritos

Offline Arvid Van Essche

  • Lid
  • Steunpunt: Nee
XGL + Compiz
« Reactie #1 Gepost op: 2006/08/31, 16:57:10 »

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #2 Gepost op: 2006/08/31, 17:02:22 »
Citaat van: Doritos
het is voor ATI (!!) niet voor Nvidea ;)
Citaat van: NlXglCompiz
Deze pagina is gemarkeerd om uitgebreider te worden. Het is niet aangeraden om deze pagina te volgen met een ATI grafische kaart. Voor een Nvidia kaart is deze pagina up-to-date.
Die tutorial dus niet volgen :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #3 Gepost op: 2006/08/31, 17:26:54 »
Eerst en vooral: welke grafische kaart heb je en is deze door XGL ondersteund?
lspci|grep VGA
ondersteunde hardware: http://gentoo-wiki.com/HARDWARE_Video_Card_Support_Under_XGL
--------
heb je 3D acceleratie? en welke driver gebruik je?
Kijk even na voordat je verdergaat!

fglrx moet tussen de output van dit commando staan:
cat /etc/X11/xorg.conf|grep Driverdirect rendering moet werken (moet yes zijn):
glxinfo|grep directalles in orde? ga verder
--------
Eerst sources.list aanpassen:
sudo gedit /etc/apt/sources.listVoeg vanonder aan dat bestand de volgende lijn toe:
# xgl en compiz repository
deb http://xgl.compiz.info/ dapper main
Update je apt-get en doe dist-upgrade om er zeker van te zijn dat we nieuwste packages hebben die we nodig hebben als dependancies:
sudo apt-get update
sudo apt-get dist-upgrade
Installeer XGL, compiz en extra compiz tooltjes:
sudo apt-get install xserver-xgl compiz compiz-core compiz-plugins compiz-gnome xwinwrap cgwd cgwd-themes cgwd-themes-extraAls alles is gelukt:

Ik heb daarna gdm.conf-custom gebackupped omdat ik die ga aanpassen:
sudo cp /etc/gdm/gdm.conf-custom /etc/gdm/gdm.conf-c-xorg
sudo cp /etc/gdm/gdm.conf /etc/gdm/gdm.conf-xorg
Pas nu /etc/gdm/gdm.conf aan
sudo gedit /etc/gdm/gdm.confZoek dit gedeelte:
0=Standard
#1=Standard
en verander het in:
#0=Standard
1=Standard
Pas nu /etc/gdm/gdm.conf-custom aan
sudo gedit /etc/gdm/gdm.conf-customvanonder staat waarschijnlijk al [servers], vervang dit woord dan gewoon met onderstaande tekstblok:
[servers]
# Override display 1 to use Xgl (DISPLAY 1 IMPORTANT FOR ATI FGLRX).
1=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer
flexible=true
Als je dit bestand nu backupped, dan kan je  scripts schrijven waarmee je kan switchen tussen XGL en de normale X:
sudo cp /etc/gdm/gdm.conf-custom /etc/gdm/gdm.conf-c-xgl
sudo cp /etc/gdm/gdm.conf /etc/gdm/gdm.conf-xgl
Schrijf nu een script om xorg terug te zetten (als er iets misgaat, of gewoon om xgl uit te schakelen en terug te keren naar gewone xorg na een X restart [restart van je grafische omgeving]):
sudo gedit /usr/bin/setxorgPlak in het lege bestand:
#!/bin/bash
cp /etc/gdm/gdm.conf-c-xorg /etc/gdm/gdm.conf-custom
cp /etc/gdm/gdm.conf-xorg /etc/gdm/gdm.conf
Maak ook een script om XGL terug in te schakelen (na een X restart):
sudo gedit /usr/bin/setxglPlak in het lege bestand:
#!/bin/bash
cp /etc/gdm/gdm.conf-c-xgl /etc/gdm/gdm.conf-custom
cp /etc/gdm/gdm.conf-xgl /etc/gdm/gdm.conf
Maak de scripts uitvoerbaar:
sudo chmod +x /usr/bin/setxorg
sudo chmod +x /usr/bin/setxgl
Probeer X te herstarten!
(LEES EVEN NAAR BENEDEN DE NOTA VOORDAT JE DIT UITVOERT)
sudo /etc/init.d/gdm stopJe bent nu in de terminal, log in en typ:
sudo /etc/init.d/gdm startEr zullen nog geen effecten zijn!
Het belangrijkste op dit punt is dat alles gewoon 'werkt'
Daarna gaan we een compiz script maken.

* * * * NOTA:
Om terug te keren naar de normale X en X te herstarten typ je:
[of: als er na de X restart iets misgaat en je krijgt geen scherm meer ofzo,
probeer dan CTRL+ALT+F1 (zwarte terminal), log jezelf in en typ:]
sudo setxorg
sudo /etc/init.d/gdm stop
sudo /etc/init.d/gdm start
Om terug te keren naar XGL en X te herstarten typ je:
sudo setxgl
sudo /etc/init.d/gdm stop
sudo /etc/init.d/gdm start
* * * *

--> Ga vanaf hier verder als alles is gelukt <--

NOTA: zijn de toetsenbordinstellingen fout, ga dan naar Systeem -> Voorkeuren -> Toetsenbord -> Indelingen en stel je Indeling en Indelingsopties juist in en gebruik de GNOME instellingen i.p.v. de X instellingen als er je wat gevraagd wordt.

Nu gaan we het compiz script maken om alles af te maken.
Met dit script kan je switchen tussen compiz en het standaard metacity:

sudo gedit /usr/bin/togglecompizPlaats in het lege bestand:
#!/bin/bash
if ps -A | grep -e "compiz.real$" > /dev/null; then
        killall cgwd
        metacity --replace &
else
        cgwd &
        compiz --replace gconf &
        xmodmap -e "keycode 22 = BackSpace BackSpace"
fi
Maak het script uitvoerbaar:
sudo chmod +x /usr/bin/togglecompizZet het script eventueel op je desktop of taakbalk
of voer het gewoon uit via de terminal om te switchen tussen compiz en metacity.

Nu maken we nog een script waarmee we compiz kunnen starten en/of herstarten:

sudo gedit /usr/bin/startcompizPlaats in het lege bestand:
#!/bin/bash
cgwd --replace & compiz --replace gconf &
xmodmap -e "keycode 22 = BackSpace BackSpace"
Maak het script uitvoerbaar:
sudo chmod +x /usr/bin/startcompizDit script kan je nu toevoegen bij "Systeem -> Voorkeuren -> Sessies" en dan het tabblad "Programma's Starten" en op de knop "Toevoegen" klikken.

Dan vul je in:
/usr/bin/startcompiz

en je slaat de instellingen op.

Probeer dan nu compiz in te schakelen:
startcompiz* * * *
OVERVIEW:

Normale X herstellen:
sudo setxorgXGL terug inschakelen:
sudo setxglCompiz aan/uitzetten:
togglecompizCompiz thema wijzigen:
gcompizthemer* * * *

Ik denk/hoop dat dit alles was :) Succes
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #4 Gepost op: 2006/08/31, 17:42:41 »
:o bedankt :):):):)

ik ga em nu uitvoeren  :)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #5 Gepost op: 2006/08/31, 17:44:28 »
hoe kan je dit zien ?

heb je 3D acceleratie? en welke driver gebruik je?
                                 ik heb de drivers die ubuntu me "gaf"


en ik krijg geen Yes maar een No bij het 2de commando

"direct rendering: No
OpenGL renderer string: Mesa GLX Indirect"

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #6 Gepost op: 2006/08/31, 18:18:23 »
Eerst fglrx installeren dan.
Welke grafische kaart heb je.

lspci|grep VGA
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #7 Gepost op: 2006/08/31, 18:20:18 »
ik heb een Ati Radeon X1600 pro AGP

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #8 Gepost op: 2006/08/31, 18:24:11 »
Restricted moet ingeschakeld zijn in repositories
----

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv
sudo /etc/init.d/gdm restart


om te testen of het werkt, typ in een terminalvenster fglrxinfo
je zou zoiets moeten zien:
Citaat
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X1600 Generic
OpenGL version string: 2.0.5814 (8.25.18)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #9 Gepost op: 2006/08/31, 19:09:08 »
ik heb alles gedaan,maar als ik tijp

startcompiz

dan krijg ik dit,

/usr/bin/startcompiz: line 2: cgwd: command not found
/usr/bin/startcompiz: line 2: compiz: command not found

wat heb ik verkeerd gedaan ?
wat moet ik opnieuw doen ?

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #10 Gepost op: 2006/08/31, 19:16:18 »
ook als ik opnieuw heb opgestart krijg ik die melding :(

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
XGL + Compiz
« Reactie #11 Gepost op: 2006/08/31, 19:24:04 »
Heb je dit correct gedaan?
Citaat
Plaats in het lege bestand:
Code:

#!/bin/bash
cgwd --replace & compiz --replace gconf &
xmodmap -e "keycode 22 = BackSpace BackSpace"

Maak het script uitvoerbaar:
Code:

sudo chmod +x /usr/bin/startcompiz
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #12 Gepost op: 2006/08/31, 19:24:40 »
Dan heb je de handleiding niet goeg gevolgd.
Heb je ergens een foutmelding gekregen?
Het beste wat je kan doen als je een foutmelding krijgt is stoppen met wat je aan het doen bent en de fout naar hier kopi
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #13 Gepost op: 2006/08/31, 19:25:09 »
ja,maar ik zal het voor de zekerheid nog eens doen :)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #14 Gepost op: 2006/08/31, 19:26:59 »
nee,werkt nog altijd niet :(

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #15 Gepost op: 2006/08/31, 19:31:26 »
Citaat van: profoX
Dan heb je de handleiding niet goeg gevolgd.
Heb je ergens een foutmelding gekregen?
Het beste wat je kan doen als je een foutmelding krijgt is stoppen met wat je aan het doen bent en de fout naar hier kopi
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #16 Gepost op: 2006/08/31, 19:34:24 »
dit bedoel je toch e ?

Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
De volgende extra pakketten zullen ge

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #17 Gepost op: 2006/08/31, 19:35:47 »
als ik nu startcompiz tijp krijg ik dit,

filip@filip-desktop:~$ startcompiz
filip@filip-desktop:~$ compiz.real: No composite extension
Couldn't load settings.  Reverting to defaults.
Couldn't load theme.  Reverting to defaults.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #18 Gepost op: 2006/08/31, 19:54:06 »
Staat Xgl aan?
pgrep Xgl zou een getal als uitvoer moeten geven
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #19 Gepost op: 2006/08/31, 19:57:29 »
ik krijg geen getal :(

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #20 Gepost op: 2006/08/31, 20:00:32 »
Wat is de output van deze commando's ?

cat /etc/gdm/gdm.conf|grep "1=Standard"

cat /etc/gdm/gdm.conf|grep "0=Standard"

tail /etc/gdm/gdm.conf-custom
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #21 Gepost op: 2006/08/31, 20:02:01 »
#1=Standard

0=Standard

BackgroundType=1
BackgroundImage=/usr/share/pixmaps/backgrounds/cosmos/earth-horizon.jpg
GraphicalTheme=BlueSwirl
GraphicalThemes=Tux-Mania

[chooser]

[debug]

[servers]
filip@filip-desktop:~$

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #22 Gepost op: 2006/08/31, 20:06:33 »
Ok
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline filenox

  • Lid
    • filenox@tweakblogs.net
  • Steunpunt: Nee
XGL + Compiz
« Reactie #23 Gepost op: 2006/08/31, 20:10:01 »
als ik cat /etc/gdm/gdm.conf|grep "1=Standard uitvoer komt er een >
en daar blijft het bij

bij het 2de commando, krijg ik dit #0=Standard

bij het 3de komt dit ,

[debug]

[servers]
# Override display 1 to use Xgl (DISPLAY 1 IMPORTANT FOR ATI FGLRX).
1=Xgl

[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl :1 -fullscreen -ac -accel glx:pbuffer -accel xv:pbuffer
flexible=true

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
XGL + Compiz
« Reactie #24 Gepost op: 2006/08/31, 20:14:40 »
Bij het eerste commando was je de laatste " vergeten (aanhalingsteken)

Nogmaals: lees goed commando's na voordat je deze uitvoert, en als je kopieert/plakt moet je er zeker van zijn dat je per ongeluk geen lettertje of tekentje vergeet :)

Xgl wou waarschijnlijk niet starten omdat je per ongeluk sudo setxorg had getypt terwijl dit niet moest -- dit moet pas wanneer je terug wilt naar de standaard Xorg (zonder Xgl)

Alles lijkt nu wel terug in orde te zijn.

Probeer X nu eens te herstarten:

sudo /etc/init.d/gdm restart

Succes.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)