Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: netwerk problemen  (gelezen 2231 keer)

Offline wimduk

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Gepost op: 2008/08/24, 18:54:06 »
Beste lezer,

Ik probeer om, met behulp van een wireless connection, een Ubuntu 8.04 server te installeren en wordt met de volgende problemen geconfronteerd;

1. Wireless instellingen gaan verloren
2. Ik kan mijn andere computers in het netwerk niet "pingen"

Achtergrond info
a. Ik gebruik een linksys  wusb54cg kaart
b. deze kaart is zichtbaar als wlan0
c. in het bestand /etc/network/interfaces heb ik deze interface benoemd (gegevens als eth0)
d. het IP adres is fixed (192.168.1.201); DHCP ingesteld  op max. 200
e. Verbinding met wireless modem = OK (adres server is zichbaar in modem)
f. vanaf de server kan ik de google website pingen en ik krijg replies
g. Ik kan mijn eigen PCś NIET pingen (destination host not accessable)
h. Mijn lokale desktop onder Ubuntu 8.04 krijgt standaard netwerkgroup MSHOME

Wireless instellingen
Als ik met iwconfig de kaart van de benodigde gegevens voorzie dan wordt de verbinding tot stand gebracht. wel moet ik eerst het commando ifconfig wlan0 up uitvoeren. Het AP adres van het wireless modem wordt zichjtbaar en de verbinding met het internet is daar. Echter als ik de server opnieuw opstart zijn de instellingen weer vertrokken. Ook de commit optie van Iwconfig biedt geen soelaas. Ik heb de benodigde coding nu in een scriptje vastgelegd.

Mijn vraag: waar moet ik wat aanpassen om de wireless instellingen vast te houden?

Kan andere computers in het netwerk niet pingen
Ik wil graag de server onderdeel van het MSHOME netwerk laten zijn om bestanden te kunnen delen. In etc/samba/smb.conf heb ik in de global instellingen WORKGROUP al vervangen door MSHOME maar dat werkt niet.

Ik heb alle documentie die ik over dit onderwerp kon vinden bestudeerd maar tot nu toe geen succes. wie kan mij op dit punt uit de droom helpen?

Bij voorbaat dank voor alle reacties.

met vriendelijk groet; wimduk

Offline tabasco

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #1 Gepost op: 2008/08/24, 19:07:34 »
Citaat van: wimduk
Ik heb alle documentie die ik over dit onderwerp kon vinden bestudeerd maar tot nu toe geen succes. wie kan mij op dit punt uit de droom helpen?
Haha, dat betwijfel ik ;)
https://help.ubuntu.com/8.04/serverguide/C/index.html

Offline elgl

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #2 Gepost op: 2008/08/24, 22:30:22 »
Wat er nu in ieder geval mis gaat waarom u niet kunt pingen is het volgende,
eth0 is de vaste (bekabelde) aansluiting, de aanduiding van de netwerk kaart in de server. U zult de interface wlan0 in uw geval moeten voorzien van een vast ip adres en ook de gegevens van het draadloze netwerk moeten opnemen in /etc/network/interfaces.

Offline wimduk

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #3 Gepost op: 2008/08/25, 10:24:11 »
Citaat van: elgl
Wat er nu in ieder geval mis gaat waarom u niet kunt pingen is het volgende,
eth0 is de vaste (bekabelde) aansluiting, de aanduiding van de netwerk kaart in de server. U zult de interface wlan0 in uw geval moeten voorzien van een vast ip adres en ook de gegevens van het draadloze netwerk moeten opnemen in /etc/network/interfaces.
Beste elgl bedankt voor uw reactie :)
Het opnemen van wlan0 in interfaces had ik al tijdens de installatie gedaan.
Mijn wlan0 ziet er als volgt uit (het verliezen van de instellingen na reboot is met deze configuratie opgelost)

auto wlan0 up
iface wlan0 inet static
        ifconfig wlan0 up
        wireless-essid DV201AM  (mijn AP)
        wireless-channel 11        (AP kanaal in modem)
        wireles-key s:
        adress 192.168.1.201     (IP adres van mijn server)
        netmask 255.255.255.0
       network 192.168.1.0
       broadcast 192.168.1.255
       gateway 192.168.1.1

Wat mij opvalt is dat ik vanuit mijn MS omgeving de gateway 192.168.1.1 kan pingen maar vanaf de server NIET. Er zit dus ergens nog een instelling fout, alleen weet ik (nog) niet welke :(

Groet wimduk

Offline wimduk

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #4 Gepost op: 2008/08/25, 10:54:04 »
Citaat van: tabasco
Citaat van: wimduk
Ik heb alle documentie die ik over dit onderwerp kon vinden bestudeerd maar tot nu toe geen succes. wie kan mij op dit punt uit de droom helpen?
Haha, dat betwijfel ik ;)
https://help.ubuntu.com/8.04/serverguide/C/index.html
Beste Tabasco,

Die heb ik gezien maar werk liever met een "tastbaar" document ipv lezen vanf mijn terminal en het maken van aantekeningen. Daarom deze guide gevonden en gedownload

https://help.ubuntu.com/6.10/pdf/ubuntu/C/serverguide.pdf

Is (bijna) hetzelfde als op de website

Groet, wimduk

Offline elgl

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #5 Gepost op: 2008/08/25, 11:57:00 »
Wat je nog eens kunt bekijken is de route tabel van de server.

dan typed u in,
route -nBij mij staat dan staat onderaan,
destination    gateway          genmask       flags  metric ref    use iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eth0

bij u zou eth0 dan wlan0 moeten zijn, eventueel met een andere metric omdat een draadloze verbinding minder bandbreedte bied.

Offline wimduk

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #6 Gepost op: 2008/08/27, 07:34:21 »
Citaat van: elgl
Wat je nog eens kunt bekijken is de route tabel van de server.

dan typed u in,
route -nBij mij staat dan staat onderaan,
destination    gateway          genmask       flags  metric ref    use iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eth0

bij u zou eth0 dan wlan0 moeten zijn, eventueel met een andere metric omdat een draadloze verbinding minder bandbreedte bied.
Beste Elgl,
Mijn machine heeft 2 netwerkkaarten (eth0 en wlan0)
eth0 is NIET met een kabel op het AP aangesloten.

route -n geeft de volgende waarden:
destination      gateway        genmask           flags  metric   ref    use iface
192.168.1.0     0.0.0.0         255.255.255.0      U         0       0      eth0
192.168.1.0     0.0.0.0         255.255.255.0      U         0       0      wlan0
0.0.0.0           192.168.1.1   0.0.0.0                UG    100       0      wlan0
0.0.0.0           192.168.1.1   0.0.0.0                UG    100       0      eth0

route zonder parameter geeft de volgende waarden:
destination      gateway        genmask           flags  metric   ref    use iface
localnet               *             255.255.255.0      U         0       0      eth0
localnet               *             255.255.255.0      U         0       0      wlan0
default            192.168.1.1   0.0.0.0               UG    100       0      wlan0
default            192.168.1.1   0.0.0.0               UG    100       0      eth0

Ik denk dat ik het principe van de route table begrijp, maar wat ik hier aan waarden zie is voor mij echt chocolade (begrijp er niets van).

Ik hoor graag van je en al vast bedankt voor de moeite en het meedenken. Ik stel dat zeer op prijs.
wimduk

Offline elgl

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #7 Gepost op: 2008/08/27, 15:07:11 »
Wat mij verbaasd, is dat eth0 nog erin staat, terwijl hier geen kabel in zit.

het zou kunnen dat hij nog via eth0 naar buiten wil, aangezien deze op hetzelfde netwerk zit.
u zou het volgende eens kunnen proberen,


sudo ifdown eth0
Hierdoor wordt interface eth0 op niet actief gezet, waardoor het verkeer wel via wlan0 zal moeten.

josspyker

  • Gast
netwerk problemen
« Reactie #8 Gepost op: 2008/08/27, 18:37:32 »
heb je de dns servers in /etc/resolv.conf ook ingesteld?

Offline wimduk

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #9 Gepost op: 2008/08/27, 18:51:05 »
Citaat van: elgl
Wat mij verbaasd, is dat eth0 nog erin staat, terwijl hier geen kabel in zit.

het zou kunnen dat hij nog via eth0 naar buiten wil, aangezien deze op hetzelfde netwerk zit.
u zou het volgende eens kunnen proberen,


sudo ifdown eth0
Hierdoor wordt interface eth0 op niet actief gezet, waardoor het verkeer wel via wlan0 zal moeten.
Beste Elgl,

Je hebt de spijker op de kop geslagen; ik kan mijn AP nu pingen. Nu nog even kijken of de rest ook goed gaat.

Kan ik dit commando in de het interface bestand zetten om het tijdens de bootfase uit te laten voeren?

Nogmaals ontzettend bedankt namens deze linux newbie
Groet, wimduk

Beste Jos,

Dank voor je reactie en ja, ik heb de nameservers in resolv.conf geplaatst.

Groet, wimduk

Offline elgl

  • Lid
  • Steunpunt: Nee
netwerk problemen
« Reactie #10 Gepost op: 2008/08/27, 20:18:58 »
Ik denk dat dat niet nodig is, als er geen kabel in zit. U kunt de instellingen voor eth0 gewoon op dhcp laten staan. Wanneer de server start zal deze op eth0 dan een adres proberen te verkrijgen, dit zal niet lukken omdat er geen kabel in zit. Vervolgens zal deze een adres toegewezen krijgen dat begint met 169.x.x.x. Dit zal ook zo in de route tabel komen staan en dus zal hier geen verkeer heen gaan voor het 192.x.x.x netwerk of internet.