Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: pwmconfig probleem  (gelezen 3041 keer)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Gepost op: 2008/08/19, 17:37:00 »
Ik probeer dus middels de volgende guide http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_detect_CPU_temperature.2C_fan_speeds_and_voltages_.28lm-sensors.29, de titel in de guide zegt het al. Dan staat er dat ik in de terminal pwmconfigmoet typen. Helaas krijg ik dan de volgende melding:

heimen-at-ubuntu@heimen-at-compaq:~$ pwmconfig
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed
Zelfs als ik het met sudo doe krijg ik dezelfde foutmelding. Wat moet ik doen?

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #1 Gepost op: 2008/08/19, 18:54:04 »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #2 Gepost op: 2008/08/19, 19:40:38 »
Dat had ik al gelezen. Maar 1: Het is al een oudere bug. 2: Ik heb geen Asus (niet dat dat veel uitmaakt, maar het kan per computer verschillen). 3: Het is met een oudere kernel getest. Ik heb de recenste: numero 19.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
pwmconfig probleem
« Reactie #3 Gepost op: 2008/08/19, 20:09:04 »
http://wiki.ubuntu-nl.org/HardwareSensors eerst deze uitvoeren en herstarten hierna kan je sudo pwmconfig doen in de terminal.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #4 Gepost op: 2008/08/20, 15:34:15 »
Dank, maar helaas, de foutmelding van pwmconfig is er nog steeds :(

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
pwmconfig probleem
« Reactie #5 Gepost op: 2008/08/20, 20:12:29 »
Vistaus, lmsensors werkt wel? of ook niet?pwmconfig is nl. een onderdeel van lmsensors.
Dit zou het moeten zijn:
gijs@gijs-desktop:~$ sudo pwmconfig
[sudo] password for gijs:
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following devices:
   hwmon0/device is it8718
   hwmon1/device is coretemp
   hwmon2/device is coretemp

Found the following PWM controls:
   hwmon0/device/pwm1
   hwmon0/device/pwm2
   hwmon0/device/pwm3

Giving the fans some time to reach full speed...
Found the following fan sensors:
   hwmon0/device/fan1_input     current speed: 2136 RPM
   hwmon0/device/fan2_input     current speed: 0 ... skipping!

Warning!!! This program will stop your fans, one at a time,
for approximately 5 seconds each!!!
This may cause your processor temperature to rise!!!
If you do not want to do this hit control-C now!!!
Hit return to continue:

Testing pwm control hwmon0/device/pwm1 ...
  hwmon0/device/fan1_input ... speed was 2136 now 2142
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon0/device/pwm1,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)?

Testing pwm control hwmon0/device/pwm2 ...
  hwmon0/device/fan1_input ... speed was 2136 now 2149
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon0/device/pwm2,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)?

Testing pwm control hwmon0/device/pwm3 ...
  hwmon0/device/fan1_input ... speed was 2136 now 2149
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon0/device/pwm3,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)?

Testing is complete.
Please verify that all fans have returned to their normal speed.

The fancontrol script can automatically respond to temperature changes
of your system by changing fanspeeds.
Do you want to set up its configuration file now (y)?
What should be the path to your fancontrol config file (/etc/fancontrol)?
/etc/fancontrol does not exist, shall I create it now (y)?
Loading configuration from /etc/fancontrol ...

Select fan output to configure, or other action:
1) Change INTERVAL     3) Save and quit
2) Just quit       4) Show configuration
select (1-n): 4

Common Settings:
INTERVAL=10


Select fan output to configure, or other action:
1) Change INTERVAL     3) Save and quit
2) Just quit       4) Show configuration
select (1-n):
Heb je misschien Ubuntu de 64 bit uitvoering? Ik weet niet of het iets uitmaakt, is zomaar een idee.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #6 Gepost op: 2008/08/20, 20:36:05 »
Nee ik heb de 32-bit uitvoering, al heb ik wel een 64-bit processor :-)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
pwmconfig probleem
« Reactie #7 Gepost op: 2008/08/20, 20:44:32 »
Ik draai zelf ook 32 bit met mijn 64 bit processor, sommige programma's lukt het niet zo onder 64 bit vandaar. lmsensors werkt wel bij je?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #8 Gepost op: 2008/08/20, 21:34:59 »
Ja lm-sensors doet het wel goed.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #9 Gepost op: 2008/09/02, 18:36:39 »
Niemand? :(

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #10 Gepost op: 2008/09/05, 22:13:46 »
Is er echt niemand die me nog even kan helpen? :( Want ik maak me best zorgen om mijn videokaart, dus ik wil graag de temperatuur omlaag brengen..

Offline prikkebeen2

  • Lid
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #11 Gepost op: 2008/09/05, 22:22:22 »
Als het je alleen om je videokaart te doen is, die kun je ook aflezen in systeem, beheer, Nvidia Xserver settings. Kijk maar bij Thermal Monitor.
Wie de gemakkelijkste weg niet zoekt is een luiaard. :)
Linux User #228066

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #12 Gepost op: 2008/09/05, 22:25:18 »
Het gaat me niet om het aflezen. Dat kan ik wel met de temperatuurmetertjes. Het gaat me om het terugdringen van de hitte. Hij wordt iets te heet af en toe..

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #13 Gepost op: 2008/09/09, 21:12:11 »
Niemand? :( Of kan iemand me misschien vertellen of 62-78 graden celsius niet te heet is voor een videokaart? Bij Vista is het logisch, maar bij Ubuntu verbaas ik me erover...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #14 Gepost op: 2008/09/10, 03:23:17 »
Lijkt me een prima temperatuur. Je moet je pas zorgen gaan maken als het boven de 100 graden komt.

Bovendien kan je met pwmconfig de ventilatoren alleen vertragen, niet versnellen. Je videokaart zou er dus alleen maar warmer van kunnen worden.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
pwmconfig probleem
« Reactie #15 Gepost op: 2008/09/10, 14:55:16 »
Ok, bedankt Johanvd :) Ik had gelezen dat boven de 70 graden niet goed was, en inderdaad wordt ie wel wat warm, maar goed, daar is dus niks van waar.

Deze vraag is opgelost :D