Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Twee verschillende beeldschermen naast elkaar  (gelezen 3996 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Gepost op: 2008/08/16, 22:38:19 »
Ik gebruik twee beeldschermen:

1. 1680x1050 (Links; hoofdscherm)
2. 1280x1024 (Rechts; extra scherm)

De grafische kaart is geïntegreerd op het moederbord en is een ATI Radeon X1250

Om gebruik te maken van de big desktop modus heb ik de volgende commando's uitgevoerd.

aticonfig --initial=dual-head  --screen-layout=right
aticonfig --dtop=horizontal

Werkt prima, maar ondanks veel geknutsel en gezoek in de aticonfig mogelijkheden, lukt het me niet om het tweede beeldscherm op de juiste hoogte in te stellen. Ubuntu gaat er vanuit dat deze ook 1050 hoog is i.p.v. de aanwezige 1024. Volgens mij maakt-ie 'm ook nog eens iets te breed.

Weet iemand hoe dit juist is in te stellen?

Ik dacht de oplossing te hebben gevonden met de onderstaande regels, maar dat bleek ook niet te baten.

aticonfig --add-pairmode=1680x1050+1280x1024

Weet iemand meer over dit probleem, want na flink gegoogled te hebben, lijkt er overal verwarring te zijn... In XP was de setup hiervan overigens altijd erg eenvoudig...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Reactie #1 Gepost op: 2008/08/16, 22:50:37 »
Probeer eens gksudo displayconfig-gtk

Offline 10o

  • Lid
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Reactie #2 Gepost op: 2008/08/16, 23:04:14 »
Dan krijg ik te zien:

Scherm 1
Resolutie 3360x1050
Standaarscherm is geselecteerd. Geen andere opties mogelijk.

Een kleine verbetering kan ik hier wel maken door te kiezen voor 2960x1050, maar dan is mijn tweede beeldscherm nog steeds niet juist ingesteld qua hoogte...

Na dit gedaan te hebben en opnieuw opstarten blijkt het effect hiervan desastreus en zit ik met een resolutie van 1280x480 opgescheept :-(. Hoger instellen in onmogelijk! Ik hoop dat het terugzetten van de oude xconf.org soelaas biedt...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Reactie #3 Gepost op: 2008/08/16, 23:06:42 »
Je kunt je grafische omgeving altijd als volgt repareren:
http://computertip.googlepages.com/herstelgrafischeomgeving

Maar dan begin je wel meteen helemaal met een schone lei. Maar goed, misschien wel handig in dit geval.

Offline 10o

  • Lid
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Reactie #4 Gepost op: 2008/08/16, 23:37:32 »
Ok! Dank voor de supersnelle reacties.
Dat heb ik gedaan en ben dan weer bij de initiële scherminstellingen.

Na heractivering van de ATI hardware stuurprogramma's lijk ik weer bij mijn eerdere dual settings uit te komen.
Na uitvoering van het commando uit de eerste tip lijkt het veelbelovend. Ik kan twee schermen afzonderlijk instellen. Echter als ik dat doe conform mijn hardware overkomt mij hetzelfde als een stap geleden...

aticonfig --mode2=1280x1024
lijkt ook niets te doen...

Dit is mijn xconf.org:

Section "ServerLayout"
   Identifier     "Default Layout"
   Screen         "Default Screen" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Generic Keyboard"
   Driver      "kbd"
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "us"
   Option       "XkbVariant" "intl"
   Option       "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier  "Configured Mouse"
   Driver      "mouse"
   Option       "CorePointer"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Device"
   Identifier  "Configured Video Device"
   Driver      "fglrx"
   Option       "Mode2" "1280x1024"
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device     "Configured Video Device"
   Monitor    "Configured Monitor"
   DefaultDepth     24
EndSection
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Reactie #5 Gepost op: 2008/08/16, 23:49:20 »
p.s. ik heb alles als su (na sudo su) gedaan, omdat aticonfig anders niets deed... Ik ben een linux noob dus ben (nog) niet bekend met eerder genoemde gksudo. Maakt dat wat uit?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Twee verschillende beeldschermen naast elkaar
« Reactie #6 Gepost op: 2008/08/19, 15:45:43 »
De volgende instellingen zorgen toch voor een goed werkend systeem. Vensters worden ook op het rechterscherm netjes gemaximaliseerd. Alleen lijkt de muis daar iets verder naar beneden en naar rechts te kunnen dan de rand van het scherm.

sudo aticonfig --initial=dual-head  --screen-layout=right
sudo aticonfig --dtop=horizontal --mode2=1280x1024

Alles uiteraard na inschakeling van de door het systeem gevonden ATI drivers.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)