Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ik heb helemaal geen " /etc/fstab" !?  (gelezen 1587 keer)

Offline Milly

  • Lid
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Gepost op: 2008/08/16, 01:05:12 »
Ik zit me helemaal suf te zoeken/bladeren/lezen naar de mogelijkheden en oplossingen voor het koppelen van m'n netwerk schijven, externe schijven en andere computers. Materiaal genoeg. Maar telkens loop ik aan tegen "/etc/fstab" en dat heb ik echt niet in mijn bestands-systeem zitten. Waar komt dat vandaan; moet ik dat zelf maken? Zo ja, hoe dan?
Ben nog maar net bezig met Ubuntu, dus excuus als dit een domme vraag is.
Zal het op prijs stellen een beetje op weg geholpen te worden! Alvast dank!
Milly
Wie half luistert, hoort alleen zichzelf.
Hardy Heron/AMD64 (sinds aug 2008, na 22 jaar Windows)

Offline Thomas Berends

  • Lid
    • Mijn blog
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #1 Gepost op: 2008/08/16, 01:14:34 »
ik ehb het ook niet...
maar volgens http://www.tuxfiles.org/linuxhelp/fstab.html zouden we het toch moeten hebben... :\

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #2 Gepost op: 2008/08/16, 01:35:01 »
Als je dat bestand niet hebt, start Ubuntu niet op. Of hij start wel op, maar met heel veel foutmeldingen :)
Je hebt het bestand waarschijnlijk dus wel, maar misschien kijk je op de verkeerde plek?

Ga eens naar Locaties>Computer.
Druk nu op het podloodje onder de terug en vooruit knoppen, naast de knop "computer"
Nu verandert die knop in een adresbalk waar je wat in kan tikken.
Als je daar /etc/ intikt, kom je in de goede map uit. Daar zal je het fstab bestand terugvinden.

Het kan ook in een terminalvenster:
cd /etc
gksudo gedit fstab
Nu kan je het bestand bewerken.
Misschien is het handig als je eerst een backup van dat bestand maakt, voor als je per ongeluk een fout maakt:

sudo cp /etc/fstab /etc/fstab.origineel

Offline Milly

  • Lid
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #3 Gepost op: 2008/08/16, 02:06:46 »
Nee, hoor, Ubuntu start flitsend op, zonder foutmeldingen. (in dual boot, ook nog).
En ik heb echt op de goede plek gekeken, en ook van de zoekfunctie gebruik gemaakt, en ook van de adresbalk.
Maar..................., als ik het via het terminalvenster doe, krijg ik "bash: /etc/fstab: Toegang geweigerd
" .
Hoe nu?
Milly

aanvulling: ik heb in Bestandsbeheer mijn rechten gecheckt, en van alle mappen ben ik kennelijk niet de eigenaar. Er zijn geen andere gebruikers; ik heb gewoon geïnstalleerd (als mezelf) en ben er van uit gegaan dat ik dan de "root" ben en overal bij kan. Niet dus....

aanvulling 2: ik heb geprobeerd via Beheer -> Gebruikers, mezelf aan allerlei groepen onder de gebruikersgroep "root" te koppelen, maar dat helpt ook niet.
Wie half luistert, hoort alleen zichzelf.
Hardy Heron/AMD64 (sinds aug 2008, na 22 jaar Windows)

Offline Floyo

  • Lid
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #4 Gepost op: 2008/08/16, 07:58:17 »
Zoals Johanvd al in zijn post beschrijft moet je er sudo voor zetten (Dan wordt je tijdelijk de eigenaar Root) anders krijg je inderdaad geen toegang. Dit komt omdat de strikte rechten op mappen ervoor zorgen dat een gewone gebruiker niet zomaar het systeem kan slopen zonder het wachtwoord.

Met het sleutelen aan rechten moet je oppassen, als je een bepaalde map teveel rechten geeft dan gaat Ubuntu zeuren omdat je dan een potentieel veiligheidslek gecreëerd wordt.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #5 Gepost op: 2008/08/16, 08:36:44 »
Citaat van: millybreak
1 aanvulling: ik heb in Bestandsbeheer mijn rechten gecheckt, en van alle mappen ben ik kennelijk niet de eigenaar. Er zijn geen andere gebruikers; ik heb gewoon geïnstalleerd (als mezelf) en ben er van uit gegaan dat ik dan de "root" ben en overal bij kan. Niet dus....



2
aanvulling 2: ik heb geprobeerd via Beheer -> Gebruikers, mezelf aan allerlei groepen onder de gebruikersgroep "root" te koppelen, maar dat helpt ook niet.
1
Dit wil zeggen dat je het verschil niet weet tussen windows en linux, omdat dit zo moet zijn, daarom is linux veilig. En ga eens wat lezen over linux.

2
Indien je iets over linux had gelezen, dan had je wist je dat je dit niet moet doen.


Een snelkoppeling maken:
sudo gedit
Dan opend een tekstverwerker, dan kun je in admin mode alles wijzigen, dus menu.lst fstab xorg.

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #6 Gepost op: 2008/08/16, 19:17:41 »
jan 11000, vriendelijker antwoorden mag altijd

1) Je bent geen beheerder van je systeem bij Linux. Bij Windows heb je oftewel een Administrator-account of je hebt die niet. Als je deze hebt, dan ben je 100% van de tijd administrator en alles kan zich op zo'n account installeren en het systeem zal zich geen vragen stellen. Dus met andere woorden, op een administrator account kan onder Windows een virus zichzelf installeren. Het systeem zal zich geen vraag stellen van "mag dit wel?" Tuurlijk mag het, het is toch een administrator zijn account die de opdracht geeft uiteindelijk.
Onder Linux ben je nooit Administrator, dus het systeem stelt zich overal de vraag bij of dit wel zo maar even kan. Je wordt pas Administrator als er om je wachtwoord gevraagd wordt. Daarom zijn alle mappen die niet in je persoonlijke map zijn ook van root. Als je kan bewijzen dat je administrator van deze computer bent (en dus het juiste wachtwoord kan ingeven), dan mag je iets in die mappen verwijderen. Dat is veiligheid van het systeem want een virus kan jouw wachtwoord niet te weten komen.

2
Gewoon niet doen. Reden hiervoor is de bovenstaande.

3.
Om jan11000 zijn uitleg wat vollediger te maken. Als je een bestand dat zich in een beveiligde zone bevindt wil aanpassen moet je dit openen als administrator. Dit kan op twee manieren.
1) je opent een terminal en je typt in: "sudo gedit "
2) je installeert eerst het pakket nautilus-gksu, je navigeert naar het bestand via de bestandsbladeraar Nautilus (de "Verkenner" zoals onder Windows) en je klikt dan rechts op het bestand en kiest voor "openen als beheerder". Dan wordt je wachtwoord eveneens gevraagd.

De twee werkwijzen leveren allebei hetzelfde resultaat op.
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

Offline Milly

  • Lid
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #7 Gepost op: 2008/08/17, 00:00:55 »
@Bail,

Vriendelijk dank voor deze uitgebreide uitleg. Na 22 jaar (intensief) Windows en 2 maanden Ubuntu, zit ik inderdaad nog veel te veel met Bill Gates in m'n hoofd. Ik probeer ernstig te doorgronden hoe het allemaal in elkaar zit, en ben dus iets te voortvarend te werk gegaan, begrijp ik nu. (Niet dat dat hielp, overigens).
Er is ook zoveel informatie beschikbaar, dat ik wat ondergesneeuwd raak.

Inmiddels heb ik de opdrachten gevolgd en het werkt! Had wel sudo gebruikt, maar verzuimd de directory te wisselen (cd /etc). dom, dom, dom. Ben er nu dus ook achter dat fstab een bestand is, geen map.

Nu zit ik nog met 1 probleempje, want jullie hebben me de stuipen op het lijf gejaagd met de opmerkingen over beveiliging, n.a.v. punt 2. Is er een manier om de "default settings" van de Gebruikersinstellingen terug te zetten, of kan ik ergens vinden hoe het hoort te staan?

@Jan11000: lezen is een kunst; ik begon mijn bericht al met de mededeling dat ik me suf had gelezen. Hoop en verwacht dat deze fora vooral bestemd zijn voor nieuwe en onervaren gebruikers, en hen die het gewoon niet zelf kunnen vinden.

Dank voor jullie tijd en aandacht. Denk dat Tumie ook zijn/haar antwoord heeft.

Milly
Wie half luistert, hoort alleen zichzelf.
Hardy Heron/AMD64 (sinds aug 2008, na 22 jaar Windows)

Offline Dave

  • Lid
  • Steunpunt: Nee
Ik heb helemaal geen " /etc/fstab" !?
« Reactie #8 Gepost op: 2008/08/17, 12:05:41 »
das lang zeg. 3.11 was m'n eerste windows maar deed er maar weinig mee buiten wat spelletjes.
Deed de rest liever met Dos.