Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: het andere probleem, mysql remote  (gelezen 567 keer)

Jean_

  • Gast
het andere probleem, mysql remote
« Gepost op: 2008/08/15, 15:22:09 »
Ik heb ubuntu hardy server op een pc gezet waar eerst xp op stond.

Ik kan niet via het netwerkje op mysql inloggen. Dat ging met xp als server wel altijd goed.
Locaal op de server zijn er geen problemen, maar zo gauw ik via de desktop wil inloggen krijg ik

Could not connect to host '192.168.1.10'.
MySQL Error Nr. 2013
Lost connection to MySQL server at 'reading initial communication packet', system error: 0
Click the 'Ping' button to see if there is a networking problem.
De ping werkt gewoon, de server draait ook wel, alleen ik kom er niet in over het netwerk.

Nu heb ik dus een paar uur gegoogled, ook op het forum van mysql (waar je alleen kunt posten als je betaald lid bent). De 'oplossingen' die ik heb gevonden zijn:

in /etc/mysql/my.conf de regel bind-adress=120.0.01 uit commenteren
in /etc/mysql/my.conf connection_timeout op 200 zetten.
En natuurlijk daarna /etc/init.d/mysql restart

(phpinfo() laat echter nog steeds als connection_timeout value 60 zien, maar ook dat zou genoeg moeten zijn.)

Wat 'vreemd' is aan de error is dat hij onmiddelijk opkomt, ik klik connect (in mysql query browser) en hup die error staat er.

Ik geef nog wat links, oplossing kreeg ik er echter niet uit.
http://dev.mysql.com/doc/refman/5.0/en/error-lost-connection.html
http://bugs.mysql.com/bug.php?id=28359

Ik ben nu echt aant eind van mn latijn. Wie helpt me verder? :) Aan hardware kan het niet liggen want in xp ging het wel. Grr, balen.

Jean_

  • Gast
het andere probleem, mysql remote
« Reactie #1 Gepost op: 2008/08/15, 18:17:45 »
Het bleek aan /etc/hosts.allow en /etc/hosts.deny te liggen.

Voor nfs share had ik deze howto gevolgd:
http://littlergirl.googlepages.com/NFSHowToKubuntu.html

Dat is dus blijkbaar achterhaald en zelfs schadelijk. Ik heb sharing daarna helemaal opgezet via krusader.

Het enige wat ik heb laten staan is All All All in /etc/hosts/allow.


Ik kwam erachter toen mn ssh ook al niet wilde werken, die werkt nu ook.

Moraal van het verhaal, pas op met oudere howto's.