Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Netwerk niet zichtbaar  (gelezen 10622 keer)

michielv

  • Gast
Netwerk niet zichtbaar
« Gepost op: 2008/08/11, 17:26:01 »
Beste mensen,

Ik heb 8.0.4. geïnstalleerd, maar ik loop tegen een netwerkprobleem op. Laat ik eerst zeggen dat ik een volledige newbie ben, dus excuses voor eventuele "domme vragen".

Het lukt me niet verbinding te krijgen met mijn draadloze netwerk (ik gebruik een KPN-Experiabox).

Merkwaardig genoeg ziet de netwerkmanager wel een paar andere netwerken in de buurt, maar dat van mij niet.

Wat ik ook merkwaardig vind is dat als ik geen wpa-sleutel opgeef iwconfig netjes d juiste SSID weergeeft (niet dat ik dan verbinding heb, maar toch) en als de de sleutel invoer zegt hij ineens dat de SSID "" is.

Wat kan hier de oorzaak van zijn? Ik heb al eens geprobeerd voor het afsluiten van Windows XP (ik zit op een dual-boot machine) ipconfig /release te doen, maar dat had geen nuttig effect.

Michiel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #1 Gepost op: 2008/08/11, 17:28:07 »
Heb je de SSID op "verborgen" gezet in de configuratie van je router? Zo ja, ongedaan maken. Voor de beveiliging heeft dat sowieso geen nut.

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #2 Gepost op: 2008/08/11, 17:33:04 »
Citaat van: pjotr123
Heb je de SSID op "verborgen" gezet in de configuratie van je router? Zo ja, ongedaan maken. Voor de beveiliging heeft dat sowieso geen nut.
Broadcast staat op On, dus volgens mij is hij dan niet verborgen.

Michiel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #3 Gepost op: 2008/08/11, 17:50:37 »
Zitten er bijzondere tekens in de SSID? Zoja, verander die en gebruik alleen letters en cijfers, geen bijzondere tekens, geen spaties, geen hoofdletters. Helpt dat?

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #4 Gepost op: 2008/08/11, 17:58:13 »
Citaat van: pjotr123
Zitten er bijzondere tekens in de SSID? Zoja, verander die en gebruik alleen letters en cijfers, geen bijzondere tekens, geen spaties, geen hoofdletters. Helpt dat?
Nee, puur standaard letters en cijfers. Wel alles hoodfdletters, maar zo geef ik het in de networkmanager ook op.
Veranderingen doe ik liever niet, ik denk dat de andere gebruikers van mijn netwerkje dat niet kunnen waarderen...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #5 Gepost op: 2008/08/11, 19:00:29 »
Hoe is de verbindingskwaliteit? Soms is die in Linux wat lager dan in Windows (verschillende drivers), waardoor het signaal te zwak is. De oplossing is dan natuurlijk om wat dichter bij de router te gaan zitten.

Of het signaal te verbeteren: zitten er meer routers op hetzelfde kanaal? Zo ja, wissel eens van kanaal. Alleen de kanalen 1, 6 of 11 gebruiken, want dan is er geen overlap.

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #6 Gepost op: 2008/08/11, 20:41:41 »
Citaat van: pjotr123
Hoe is de verbindingskwaliteit? Soms is die in Linux wat lager dan in Windows (verschillende drivers), waardoor het signaal te zwak is. De oplossing is dan natuurlijk om wat dichter bij de router te gaan zitten.

Of het signaal te verbeteren: zitten er meer routers op hetzelfde kanaal? Zo ja, wissel eens van kanaal. Alleen de kanalen 1, 6 of 11 gebruiken, want dan is er geen overlap.
Ik kan me niet voorstellen dat het aan de verbindingskwaliteit ligt; netwerken van drie huizen verder worden wel gezien....

Zal straks kanaal 1 eens proberen.

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #7 Gepost op: 2008/08/11, 21:40:13 »
Bij mij werd de KPN experiabox ook pas in ubuntu gezien nadat ik van kanaal veranderd was.
KPN adviseerde mij kanaal 8; dat zou de breedste ontvangst opleveren; over ubuntu kon men mij niks vertellen(daar heb ik meteen maar eens een hartig woordje over gesproken, zoals je begrijpt).
XP vangt kanaal 8 hier wel goed op, maar mijn PC met ubuntu ontving dat signaal niet. Een nieuwe laptop met de live CD Ubuntu weer wel....mogelijk ligt de oorzaak van de ontvangstproblemen dus toch bij een bepaalde pc configuratie (en hardware  vrees ik).
¨ik respecteer u zoals ik ben¨
Herman Brood

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #8 Gepost op: 2008/08/11, 21:45:54 »
Ok, we zijn alweer een stapje verder:
het overschakelen naar kanaal 1 heeft er voor gezorgd dat het netwerk herkend wordt. Bedankt zover!

Maar... veel kan ik er nog niet mee. iwconfig geeft wel netjes de gegevens van device wlan0 (SSid) maar als ik met network tools het device wil configureren krijg ik de melding dat hij niet bestaat. Pingen naar de Experiabox lukt ook niet.

Wat nu?

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #9 Gepost op: 2008/08/11, 22:11:48 »
Je vertelt hierboven niets over de hardware van de PC die je gebruikt.
Heb je soms een usb ontvanger aangesloten? Heb dat hier ook (wegens ontbrekende draadloos kaartje). En dan kun je niet fysiek aanpassen.
Wat geeft de terminal met: sudo lshw -class network

Met rechtermuisknop op het NM applet kun je ook verbindingsinfo vinden.
Zie je daar naast: ip adress, broadcast addres, DNS, etc reele cijfers of allemaal nullen?
¨ik respecteer u zoals ik ben¨
Herman Brood

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #10 Gepost op: 2008/08/13, 16:39:35 »
Citaat van: Peterbeter
Je vertelt hierboven niets over de hardware van de PC die je gebruikt.
Heb je soms een usb ontvanger aangesloten? Heb dat hier ook (wegens ontbrekende draadloos kaartje). En dan kun je niet fysiek aanpassen.
Wat geeft de terminal met: sudo lshw -class network

Met rechtermuisknop op het NM applet kun je ook verbindingsinfo vinden.
Zie je daar naast: ip adress, broadcast addres, DNS, etc reele cijfers of allemaal nullen?
Ik heb geen usdb-ontvangen maar een inbouwkaart.
Ik krijg de volgende gegevens:
  *-network:0              
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: RaLink
       physical id: a
       bus info: pci@0000:00:0a.0
       logical name: wmaster0
       version: 00
       serial: 00:0c:f6:1d:9b:60
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci latency=32 module=rt61pci multicast=yes wireless=IEEE 802.11g
  *-network:1
       description: Ethernet interface
       product: VT6102 [Rhine-II]
       vendor: VIA Technologies, Inc.
       physical id: 12
       bus info: pci@0000:00:12.0
       logical name: eth0
       version: 74
       serial: 00:0c:6e:e4:25:a7
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=via-rhine driverversion=1.4.3 duplex=half latency=32 link=no maxlatency=8 mingnt=3 module=via_rhine multicast=yes port=MII speed=10MB/s

Inmiddels ziet hij nu geen enkel netwerk meer.... :-(

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #11 Gepost op: 2008/08/13, 16:44:31 »
Ralink kaartje. Doe dit eens:

- leg tijdelijk een bedrade internetverbinding: eventjes via de netwerkkabel dus.

- Dan dit:
http://computertip.googlepages.com/enkelebekendefouteninubuntu
(nummer 9)

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #12 Gepost op: 2008/08/13, 17:27:53 »
Citaat van: pjotr123
Ralink kaartje. Doe dit eens:

- leg tijdelijk een bedrade internetverbinding: eventjes via de netwerkkabel dus.

- Dan dit:
http://computertip.googlepages.com/enkelebekendefouteninubuntu
(nummer 9)
Helaas, hij vindt libstdc++5 niet.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #13 Gepost op: 2008/08/13, 18:03:35 »
Citaat van: michielv
Citaat van: pjotr123
Ralink kaartje. Doe dit eens:

- leg tijdelijk een bedrade internetverbinding: eventjes via de netwerkkabel dus.

- Dan dit:
http://computertip.googlepages.com/enkelebekendefouteninubuntu
(nummer 9)
Helaas, hij vindt libstdc++5 niet.
Dan is de desbetreffende pakketbron nog niet ingeschakeld. Schakel hem eens in door dit af te werken:
http://computertip.googlepages.com/multimediainubuntulinux

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #14 Gepost op: 2008/08/14, 22:55:01 »
Nou, het is gelukt hoor!

Heel hartelijk bedankt voor de hulp. Het is heel fijn dat er mensen zijn die gewoon newbies willen helpen zonder direct "RTFM!" te roepen.

Helemaal geweldig werkt het nog niet; ik moet nu wel elke keer opnieuw mijn WPA-key invullen.

Maar ik ben al blij dat ik het net op kan!

Groeten,

Michiel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #15 Gepost op: 2008/08/14, 23:04:46 »
Citaat van: michielv
Nou, het is gelukt hoor!

Heel hartelijk bedankt voor de hulp. Het is heel fijn dat er mensen zijn die gewoon newbies willen helpen zonder direct "RTFM!" te roepen.

Helemaal geweldig werkt het nog niet; ik moet nu wel elke keer opnieuw mijn WPA-key invullen.

Maar ik ben al blij dat ik het net op kan!

Groeten,

Michiel
Mooi zo!  :-)

Die WPA-sleutel zit toch gewoon in je sleutelbos? Hoe komt het, dat je die steeds moet opgeven?

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #16 Gepost op: 2008/08/14, 23:46:21 »
Sorry, toch nog even hulp nodig.

Is er ergens documentatie voor die sleutelbossen? Ik kom er zo niet uit hoe dat werkt.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #17 Gepost op: 2008/08/14, 23:54:41 »
Als je een WPA-sleutel opgeeft, dan zal normaal gesproken de sleutelbos (keyring) vragen of je die WPA-sleutel erin wil opnemen. Normaliter wil je dat ook.

Zodoende zal de sleutelbos ervoor zorgen, dat je meteen na het aanmelden automatisch wordt verbonden.

Ik bedenk me ineens: hoe verbind je? Dat "moet" je doen via Network Manager, door te klikken op het netwerksymbooltje (dubbele terminal) in het systeemvak van de werkbalk: de beschikbare draadloze netwerken klappen dan uit.

De sleutelbos is daaraan gekoppeld.

michielv

  • Gast
Netwerk niet zichtbaar
« Reactie #18 Gepost op: 2008/08/15, 00:05:32 »
Citaat van: pjotr123
Als je een WPA-sleutel opgeeft, dan zal normaal gesproken de sleutelbos (keyring) vragen of je die WPA-sleutel erin wil opnemen. Normaliter wil je dat ook.
Ik kan me niet herinneren dat ooit gezien te hebben, maar misschien heb ik het in het begin per ongeluk geweigerd of weggeklikt?

Citaat van: pjotr123
Ik bedenk me ineens: hoe verbind je? Dat "moet" je doen via Network Manager, door te klikken op het netwerksymbooltje (dubbele terminal) in het systeemvak van de werkbalk: de beschikbare draadloze netwerken klappen dan uit.

De sleutelbos is daaraan gekoppeld.
Dat doe ik ook.

Offline Jessr

  • Lid
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #19 Gepost op: 2008/08/22, 11:16:04 »
pjotr123,

Ook ik moet iedere keer mijn WPA-sleutel opnieuw invullen, anders krijg ik geen verbinding met internet. Kortom, dit gebeurt helaas niet automatisch. Ik doe dit op de systeembalk op de netwerkbalk op het netwerkicoontje (dubbele terminal) te klikken. Nu klik ik op handmatige configuratie -> Ontgrendelen. Via de eigenschappen van de Draadloze verbinding overschrijf ik het netwerkwachtwoord. Nu krijg ik wel verbinding met internet.
Kun je aangeven hoe dit automatisch kan. Ik zie niet iets vergelijkbaars op het forum.

sudo lshw -class network levert de volgende info op:

  *-network              
       description: Wireless interface
       product: PRO/Wireless 3945ABG Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wmaster0
       version: 02
       serial: 00:18:de:2d:45:bb
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 ip=10.0.0.148 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g
  *-network
       description: Ethernet interface
       product: RTL8101E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 01
       serial: 00:16:d4:2b:da:aa
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.2LK duplex=half latency=0 link=no module=r8169 multicast=yes port=twisted pair

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #20 Gepost op: 2008/08/22, 11:54:08 »
Citaat van: Jessr
pjotr123,

Ook ik moet iedere keer mijn WPA-sleutel opnieuw invullen, anders krijg ik geen verbinding met internet. Kortom, dit gebeurt helaas niet automatisch. Ik doe dit op de systeembalk op de netwerkbalk op het netwerkicoontje (dubbele terminal) te klikken. Nu klik ik op handmatige configuratie -> Ontgrendelen. Via de eigenschappen van de Draadloze verbinding overschrijf ik het netwerkwachtwoord. Nu krijg ik wel verbinding met internet.
Kun je aangeven hoe dit automatisch kan. Ik zie niet iets vergelijkbaars op het forum.

sudo lshw -class network levert de volgende info op:

  *-network              
       description: Wireless interface
       product: PRO/Wireless 3945ABG Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wmaster0
       version: 02
       serial: 00:18:de:2d:45:bb
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 ip=10.0.0.148 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g
  *-network
       description: Ethernet interface
       product: RTL8101E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 01
       serial: 00:16:d4:2b:da:aa
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.2LK duplex=half latency=0 link=no module=r8169 multicast=yes port=twisted pair
Waarom klik je op handmatige configuratie? Is je draadloze netwerk niet meteen zichtbaar, als je op het netwerksymbooltje klikt?

Zo niet: zendt je router wel z'n SSID (essid, oftewel netwerknaam) uit? Dat is noodzakelijk voor Network Manager. Er is bovendien geen reden om de netwerknaam te verbergen: dat biedt namelijk geen extra veiligheid (zoals sommigen denken).

Offline Jessr

  • Lid
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #21 Gepost op: 2008/08/22, 13:32:55 »
Mijn router zendt het SSID gewoon uit. Als ik op het netwerkicoontje klik, zie ik alleen de opties:
- bekabelde netwerk
- Handmatige configuratie

Dus mijn draadloze netwerk is niet meteen te kiezen vanuit het netwerkicoontje.
Heb je nog andere tips voor mij?

Offline Jessr

  • Lid
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #22 Gepost op: 2008/08/23, 13:42:50 »
Wat speurwerk op het engelse Ubuntu forum levert op dat er bekende problemen zijn met de PRO/Wireless 3945ABG wifi kaart met driver iwl3945.
Er wordt verwezen naar het gebruik van WCID i.p.v. de Network-Manager. Echter, ondanks toevoegen van de softwarebron in Synaptic kan het pakket WCID niet worden gevonden.

Wat voor mij een oplossing is, is om na opstarten een terminalvenster te openen en de volgende 2 commando's te geven:

sudo modprobe -r iwl3945
sudo modprobe iwl3945

Nu werkt mijn draadloze internetverbinding probleemloos
Is er een mogelijkheid om deze commando's automatisch te laten uitvoeren bij opstarten?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #23 Gepost op: 2008/08/23, 15:10:57 »
Je zult dit inderdaad telkens moeten herhalen wanneer je je computer opnieuw opstart. Natuurlijk kun je daarvoor gebruikmaken van het terminalgeheugen: een druk op de bovenste pijltjestoets maakt het vorige commando zichtbaar. Maar handiger is het, om deze terminalcommando's automatisch te laten uitvoeren wanneer je je computer opstart.
Als volgt:

Toepassingen - Hulpmiddelen - Terminalvenster

Tik in (of beter nog: kopieer en plak, zonder het woordje "code"):

gksudo gedit /etc/rc.localNu opent zich het tekstbestand rc.local. Voeg daaraan deze regels toe, vlak boven de regel exit 0:

modprobe -r iwl3945
modprobe iwl3945
(Let op: nu staat er dus geen sudo voor!)

Het bestand komt er daardoor als volgt uit te zien:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
modprobe -r iwl3945
modprobe iwl3945
exit 0
Opslaan, sluiten en de computer volledig herstarten.

Offline Jessr

  • Lid
  • Steunpunt: Nee
Netwerk niet zichtbaar
« Reactie #24 Gepost op: 2008/08/23, 16:33:42 »
Pjotr123, hartelijk dank voor de tips. Het werkt super! Eindelijk van die handmatige acties af.