Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Raid 0, fakeraid... iemand ervaring of kennis hiervan?  (gelezen 1636 keer)

Phaldmmor

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Gepost op: 2006/08/29, 13:14:38 »
Ik heb dit weekend een nieuw moederbord geplaatst in mijn pc en twee nieuwe indentieke SATA schijven.
Het moederbord ondersteund raid, maar dit is volgens mij een software matige raid config. Chipset wat word gebruikt is ULI M1567. Ik ben er helaas nog niet ingeslaagd om linux op de raid configuratie werkend te krijgen, de installatie ziet mijn schijven niet. Ik heb gekeken of ik DMRAID kon gebruiken, maar die ondersteund dit chipset volgens mij niet. Nu ben ik wat verder aan het zoeken geweest en ben ik op het internet het volgende tegen gekomen :

Linux often cannot read existing fakeraid volumes on such host adapters, unless you're willing to use proprietary fakeraid drivers (where available). But unless you're dual-booting MS-Windows, you shouldn't care, because Linux's software RAID (kernel "md" driver) is much faster and more reliable. You're advised to blow away fakeraid volumes, use SATA drives as straight block devices, and enable Linux software RAID instead, during Linux installation.

Wat ik hier uit begrijp is dat linux zelf raid drivers beschikbaar heeft? Dus ik zou mijn twee SATA schijven in raid config kunnen plaatsen vanuit linux, zonder gebruik te maken van de ULI M1567 chipset? Het is niet nodig dat windows op deze twee schijven staat, die kan ik op een aparte ide schijf installeren.

Heeft iemand hier ervaring mee? Weet iemand een goede handleiding waarin staat omschreven hoe ik Ubuntu kan installeren met softwarematige raid?

wr19026

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #1 Gepost op: 2006/08/29, 15:25:43 »
Probeer het hier eens (http://users.piuha.net/martti/comp/ubuntu/raid.html); het is weliswaar voor RAID1 maar volgens mij zal het qua configuratie niet al te veel verschillen.

En zoek anders eens in LVM, volgens mij kan je daarmee ook van meerdere schijven

Phaldmmor

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #2 Gepost op: 2006/08/30, 21:47:12 »
Het is me uiteindelijk gelukt! Yoepie! Heb het alleen helemaal zelf moeten uitdokteren, want op internet kon ik helaas niet echt een duidelijke handleiding vinden. Na mijn systeem ongeveer een keer of 10 te hebben geherinstalleerd is het mij uiteindelijk gelukt :D :D :D.

Als ik alles weer up and runnning heb zal ik proberen een how to te schrijven. Het is niet echt moeilijk, maar je moet net even weten wat je precies moet instellen. Voor die gene die het ook willen proberen alvast een tip, zet je \boot directory niet op je raid config, bij mij crashte zowel lilo als grub tijdens de installatie :(. Meerdere keren van alles geprobeerd, uiteindelijk is het gelukt door de \boot dir buiten de raid te configureren. Verder staat alles wel in raid (swap / en /home).

Offline eendje

  • Lid
  • Steunpunt: Nee
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #3 Gepost op: 2006/08/30, 23:05:40 »
Ik zie uit naar de How To. Ik wil zelf ook nog met m'n fakeRAID aan de gang (wel ingebouwd, maar niet in gebruik voor Ubuntu).
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

wr19026

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #4 Gepost op: 2006/09/16, 22:52:18 »
Citaat van: Phaldmmor
Voor die gene die het ook willen proberen alvast een tip, zet je \boot directory niet op je raid config, bij mij crashte zowel lilo als grub tijdens de installatie :(. Meerdere keren van alles geprobeerd, uiteindelijk is het gelukt door de \boot dir buiten de raid te configureren. Verder staat alles wel in raid (swap / en /home).
Dus je hebt /boot maar op

Phaldmmor

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #5 Gepost op: 2006/09/17, 00:49:52 »
Citaat van: wr19026
Citaat van: Phaldmmor
Voor die gene die het ook willen proberen alvast een tip, zet je \boot directory niet op je raid config, bij mij crashte zowel lilo als grub tijdens de installatie :(. Meerdere keren van alles geprobeerd, uiteindelijk is het gelukt door de \boot dir buiten de raid te configureren. Verder staat alles wel in raid (swap / en /home).
Dus je hebt /boot maar op

wr19026

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #6 Gepost op: 2006/09/17, 09:51:06 »
Citaat van: Phaldmmor
Yep, ik heb de /boot directory op een kleine aparte partitie op 1 schijf gedefinieerd, niet op de raid configuratie.
Inderdaad, zo heb ik het ook aan de praat gekregen maar ik blijf het vreemd vinden want nou kan ik dus niet echte hotswap gaan doen met m'n schijven. Wat ik dacht was dat er nu een schijf het loodje zou kunnen leggen maar dat de machine door zou blijven draaien. Dat lijkt me met deze setup niet echt mogelijk.

Of je moet een derde harde schijf gaan gebruiken (dus een extra IDE controller inbouwen) waarop je enkel /boot hebt staan.

Of zie ik iets over het hoofd?

Phaldmmor

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #7 Gepost op: 2006/09/17, 11:18:45 »
Je hebt niets over het hoofd gezien :)
Het is idd zo dat de /boot partitie niet redundant is, als dus de schijf crasht waarop je /boot partitie staat ben je het haasje.
Je zou idd eventueel een derde ide schijf er bij kunnen plaatsen met daarop een aparte /boot partitie, maar het probleem blijft dan toch bestaan.
Een oplossing voor dit probleem ben ik zelf ook nog niet tegen gekomen

Ik gebruik raid 0, dus ik heb zo wie zo geen redundant systeem.

wr19026

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #8 Gepost op: 2006/09/26, 11:04:45 »
Het was even klooien maar ik heb m'n 2 WD 80GB IDE schijven volledig redundant in RAID-1 werkend.

Maar wat schetst m'n verbazing; om het werkend te krijgen moet je vanaf de alternate cd installeren. En ook al kies je dan voor de server install, je krijgt toch de "gewone" kernel.

Domme vraag misschien, maar kan het aan de server kernel liggen dat het niet mogelijk is om /boot in RAID-1 mee te nemen? bij de 386 versie van de kernel die ik nu ge

Offline Jan Meijer

  • Lid
  • Steunpunt: Nee
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #9 Gepost op: 2006/10/29, 11:44:23 »
Interessant om te weten, lijkt me, is dat veel discussies over de implementatie van softRAID in Ubuntu (en andere Linux varianten) vermelden dat je met dmraid dit kunt realiseren.
Dapper Drake (Ubuntu 6.06) gebruikt m.i. echter mdadm (zie /etc/mddm/mdadm.conf) voor het aanmaken van software raid devices. verwijzingen naar de devmapper zullen zo bij voorbeeld geen informatie opleveren. Uitvoeren van het mdadm command daarentegen zal  je informatie verschaffen over je RAID configuratie:
voorbeeld: mdadm --detail /dev/md0

Wellicht nuttig voor lezers van deze thread, die ook nog niet weten waar ze nu aan toe zijn ;)
Hoe ouder hoe wijzer? Nou zeker weten van niet!

Offline Jan Meijer

  • Lid
  • Steunpunt: Nee
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #10 Gepost op: 2006/10/29, 11:51:18 »
Tweede tip voor hen die stoeien met hun /boot partitie:

Gebruik virtualisatie van je systeem. Drie belangrijkste spelers momenteel (okt 2006) zijn in mijn favorite volgorde:
- VMware (Server of workstation versie, ondersteunen beide zowel Windows als Linux. Gebruik VMware Infrastructure alleen als je professioneel in een datacenter omgeving werkt.
- MS Virtual PC of Virtual Server (niet gezond voor Linux gebruikers)
- Xen (slecht support voor MS WIndows gebruikers)

Dan ben je van je boot problematiek af en kan je twee (of meer) machines tegelijk actief hebben!
Hoe ouder hoe wijzer? Nou zeker weten van niet!

ruitenag

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #11 Gepost op: 2006/12/13, 16:39:50 »
Ik heb een ASUS moederbord met RAID 0 en 1.
Op deze heb ik mijn schijf op RAID1 gezet in het moederbord (!) en vervolgens middels de alternate CD netjes Ubuntu geinstalleerd. Hierbij wordt het gehele systeem (system/data/etc.) op RAID1 geinstalleerd dus alles wel dubbel !

Als leidraad heb ik het document van http://users.piuha.net/marti/comp/ubuntu/raid.html gebruikt.

Werkt goed !

Inmiddels heb ik de twee 80Gb RAID schijven vervangen met 2 van 400Gb. Nu krijg ik de systeempartitie niet meer in RAID. Er is iets fout met de /dev/md0 . Hierdoor is de systeempartitie nu niet dubbel (helaas). Dus de RAID configuratie werkt op zich goed.

AvR

ruitenag

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #12 Gepost op: 2006/12/13, 16:42:01 »
Sorry,

De web pagina is:
http://users.piuha.net/martti/comp/ubuntu/raid.html !

martti is met dubbel 't'

AvR

ruitenag

  • Gast
Raid 0, fakeraid... iemand ervaring of kennis hiervan?
« Reactie #13 Gepost op: 2006/12/15, 10:01:46 »
Inmiddels heb ik de systeempartitie ook in RAID.
Tijdens de installatie en testen van de nieuwe schijven had ik een RAID partitie te veel gemaakt ! Deze verwijderd en middels mdadm kun je perfekt je RAID partities controleren en aanmaken etc.

AvR :)