Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: DHCP server, clients komen het internet niet op  (gelezen 3914 keer)

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Gepost op: 2008/08/05, 17:39:31 »
Ik heb wat problemen met mijn Wireless router. Deze gebruik ik tot nu toe als DHCP servertje (en als accesspoint natuurlijk). Het vervelende van dit ding is echter dat ik geen gereserveerde IP nummers aan MAC adressen toe kan wijzen. Omdat ik mijn  systemen ook regelmatig op afstand met PuTTY wil benaderen een vervelend iets, omdat de IP adressen kunnen wijzigen.

Nu heb ik mijn server als DHCP server ingericht. Dat gaat -intern- prima, maar de clients komen geen van allen het internet op.

Eerst even de situatie:

Linksys wireless router:
IP-adres intern: 192.168.0.254
IP-adres extern (van de modem): 10.0.0.3
Adres Modem: 10.0.0.2
DNS adressen provider: 212.45.33.3 en 212.45.32.3

Server: Intern IP adres: 192.168.0.1 en draait op Ubuntu Server 6.06.2 (ook wel Dapper Drake genaamd)

Hier mijn bestandje dhcpd.conf:
Citaat
default-lease-time 600;
max-lease-time 7200;
INTERFACES="eth0";
# Spinakker
subnet 192.168.0.0 netmask 255.255.255.0 {
   option domain-name "spinakker.net";
   option broadcast-address 192.168.0.255;
   option subnet-mask 255.255.255.0;
   option routers 192.168.0.254 , 10.0.0.2 , 10.0.0.3;
   option domain-name-servers 10.0.0.2 , 10.0.0.3 , 212.45.33.3 , 212.45.32.3;
#   ddns-updates on;
   ddns-domainname "spinakker.net";
   range 192.168.0.2 192.168.0.50;
   }
Ik heb hiervoor Webmin gebruikt. Ook kun je zien dat ik alle IP-adressen heb gebruikt, dus van de router en de modem plus van de provider.

Ik heb de router aan het modem hangen, en daarachter de switch waarachter mijn LAN draait.

Schetsje:

Privider/Internet===========[Modem]===========[router]==============[switch]=======LAN + server
212.45.33.3 / 212.45.32.3       10.0.0.2           10.0.0.3 / 192.168.0.254                            192.168.0.1 t/m 192.168.0.253

Wie kan mij hiermee helpen?

PS. Statische IP-adressen zijn helaas geen optie. Dat heb ik al uitgeprobeerd.... :(
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Kev

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #1 Gepost op: 2008/08/05, 18:01:57 »
Je zou kunnen gebruikmaken van een DHCP-relay agent.
Ik weet niet exact hoe je dit zou moeten regelen in Linux, met Windows Server 2003 weet ik het wel, maar misschien zal de documentatie voor de dhcp server die je gebruikt hiervoor uitsluitsel kunnen bieden.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #2 Gepost op: 2008/08/05, 21:59:44 »
Ik kwam op dit forum een config bestand van Gandyman tegen. Dat heb ik overgenomen een aangepast aan mijn situatie...

Het resultaat:  :) :)  :)  :)

Hier het aangepaste config bestandje van mij:
Citaat
ddns-update-style none;
option domain-name "spinakker.net";
option domain-name-servers 212.45.33.3, 212.45.32.3;

default-lease-time 600;
max-lease-time 7200;

authoritative;

log-facility local7;

# No service will be given on this subnet, but declaring it helps the
# DHCP server to understand the network topology.

# Upstream subnet is 213.211.128.0/16 (Telebyte / Free Online)
#subnet 213.211.128.0 netmask 255.255.192.0 {
#}


# A slightly different configuration for an internal subnet.
subnet 192.168.0.0 netmask 255.255.255.0 {
   range 192.168.0.10 192.168.0.200;
   # option domain-name-servers ns1.internal.example.org;
   option domain-name "spinakker.net";
   option routers 192.168.0.254;
   option broadcast-address 192.168.0.255;
   default-lease-time 600;
   max-lease-time 7200;
   }
# Vaders laptop
host enigma {
   hardware ethernet 00:4f:62:01:a9:ac;
   fixed-address 192.168.0.10;
   }
# Werkstation-1
host werkstation-1 {
   hardware ethernet 00:10:dc:e0:71:e9;
   fixed-address 192.168.0.11;
   }
# Werkstation-2
host werkstation-2 {
   hardware ethernet 00:10:dc:e0:71:73;
   fixed-address 192.168.0.12;
   }
# Werkstation-3
host werkstation-3 {
   hardware ethernet 00:40:f4:ca:bd:0e;
   fixed-address 192.168.0.13;
   }
Alleen vraag ik mij af of er niet iets dubbel in staat. Deze regels aan het begin:
Citaat
option domain-name "spinakker.net";
en
default-lease-time 600;
max-lease-time 7200;
kom ik namelijk hier ook tegen:
Citaat
subnet 192.168.0.0 netmask 255.255.255.0 {
   range 192.168.0.10 192.168.0.200;
   # option domain-name-servers ns1.internal.example.org;
   option domain-name "spinakker.net"; <<== Dubbel
   option routers 192.168.0.254;
   option broadcast-address 192.168.0.255;
   default-lease-time 600;  <<== Dubbel
   max-lease-time 7200;    <<== Dubbel
   }
Iemand die weet of dit persé moet, of dat die regels aan het begin (of aan het einde) weg kan?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Kev

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #3 Gepost op: 2008/08/05, 22:19:05 »
Ik denk dat je die moet laten staan, omdat die bovenste rij algemene instellingen zijn en dat de regels vanonder specifiek voor je subnet gemaakt zijn.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #4 Gepost op: 2008/08/05, 22:28:17 »
Dat zou dan, concreet, inhouden dat als de lease-time wordt verhoogd (of verlaagd) dat dubbel moet worden aangepast?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Gandyman

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #5 Gepost op: 2008/08/05, 23:24:45 »
Ja je mag ze laten staan, en denk dat weghalen ook mag van de bovenste regels omdat het toch gedefinieerd word.

ff over je probleem.

Citaat
Nu heb ik mijn server als DHCP server ingericht. Dat gaat -intern- prima, maar de clients komen geen van allen het internet op.
Dit kan komen omdat ze geen DNS server (van het internet) doorkrijgen van je router.

Weet niet zeker of dit het oplost, maar invullen kan nooit kwaad ...
Kijk in Webmin -> Netwerk -> Netwerk Configuratie
Dan klikken op DNS Client.
Vul hier de hostnaam in van jouw server Resolutie volgorde Hosts - DNS
DNS servers - hier 2 DNS server die op het internet staan invullen.
 
Tot slot kan je bij iedere client handmatig de DNS invullen zodat ze niet hoeven te resolven via het internet, dit werkt ook een stuk sneller.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #6 Gepost op: 2008/08/05, 23:41:48 »
Voordat ik hierop ga antwoorden (dat wordt morgen...) eerst een 'probleem'. Wanneer ik bij Webmin naar het config bestand kijk, dan zie ik daar de regel
Citaat
option domain-name-servers 212.45.33.3, 212.45.32.3;
staan, maar bij de rest van de DHCP modules verder nergens (ik heb vanavond de server herstart om te kijken of alles blijft werken).
Enig idee hoe dat kan?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Gandyman

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #7 Gepost op: 2008/08/05, 23:56:10 »
Hmz dit lijkt erop dat hij die gekregen heeft van je router ??

ff wat anders , waar vind je dat precies ???
Zal het uitleggen.
Ik gebruik nu Virtualmin Pro de betaalde versie.
En Webmin en Virtualmin-Usermin zitten door en naast elkaar.
Dus bij mij staan de dingen waarschijnlijk ook ergens anders.

Dus waar heb je dit gevonden ??

((Eventueel kan ik kijken of mijn oude server nog boot daar staat alleen Webmin op.))
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #8 Gepost op: 2008/08/06, 00:12:37 »
Dat config bestandje is /etc/dhcp3/dhcpd.conf. Dat kan ik vinden bij de optie Config File. Als het goed is (en dat klopt ook wel) worden wijzigingen van Webmin daarin weggeschreven en wordt vervolgens bij een herstart van dhcp3-server dat bestandje uitgelezen.
Merkwaardig dus dat die regel er wel in staat (ik heb jouw bestandje overgenomen en aangepast naar mijn situatie) en vervolgens in Webmin niet wordt weergegeven. Ik heb gekeken bij Edit Subnet, bij Edit Host, bij Client Options (waar het dus zeker zou moeten staan, omdat je daar de DNS adressen kunt invullen).
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #9 Gepost op: 2008/08/06, 10:50:31 »
Intussen heb ik die DNS opties kunnen vinden. Zij staan onder de DHCP module

Client Options    
For all networks, hosts and groups

En daar hebben die dubbele opties ook gestaan. Die heb ik rechtstreeks (via PuTTY op de server) met een # uigeschakeld en de dhcp server opnieuw opgestart. Die dubbele regels kunnen dus weg. Voor hen die daarmee worstelen dus een hele opluchting... :)

Goed, nu de mogelijkheden t.a.v. het host / DNS verhaal voor iedere client afzonderlijk. Staan die hier?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Gandyman

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #10 Gepost op: 2008/08/06, 11:21:49 »
Hmz heb net me oude server aangeslingert maar werd er niet veel wijzer van omdat ik het deels gesloopt had....

ff alles bekijkent heb je dit gedeelte afgeblokt:
# Upstream subnet is 213.211.128.0/16 (Telebyte / Free Online)
#subnet 213.211.128.0 netmask 255.255.192.0 {
#}
Die had ik erin staan omdat hij de upstream moet weten van je provider.
Nu je dit hebt afgeblokt kan hij niet upstream kijken.
Zet hier dus eens de ipadressen in van je modem of je provider ???

Met upstream bedoel ik het www.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #11 Gepost op: 2008/08/06, 12:10:02 »
Okay, nu nog achterhalen wat het subnetmasker voor 212,45,33,3 en 212.45.32.3 is. Vroeger heb ik mij daarin wel eens verdiept, maar zo te zien is het een Class-B netwerk, en daamee ben ik niet zo vertrouwd omdat ik zelf altijd met Class-C netwerken draai (192.168.x.x).
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #12 Gepost op: 2008/08/06, 15:21:58 »
212 is ook een classe C, maar uiteraard wel een publiek adres.
Handig progje is "ipcalc". Geef in een terminal maar eens in "ipcalc 212.45.33.3".

Maar bij DNS servers hoef je toch geen netmask mee geven?

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline ruujan

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #13 Gepost op: 2008/08/06, 22:50:01 »
Even heel simpel. Start een werkstaion op met dhcp.

Lijk of het ip-adres juist is (met ifconfig).
Kijk of je route goed staat (met route -n)
Ping je adslmodem (ping 10.0.0.2).
Als dit goed gaat dat heb je een verbinding tot aan het internet. Nu zijn er twee situaties mogelijk.

1. Je router doet NAT.
OK, als je vanaf je server het internet op kunt, dan moet het ook vanaf de werkstations lukken. Het enige dat nog fout kan zijn is de DNS-instelling. Deze zul je in de dhcp-server best kunnen aanpassen in webmin (ik heb geen ervaring met webmin).

2. Je router doet geen NAT.
Tja dan kom je in een moeilijk gebied. Huis- tuin en keuken ADSL-modems kennen niet allemaal de mogelijkheid om een statische route naar een intern netwerk te gebruiken. Sommige kunnen het wel, maar dan weer niet vanuit de webinterface, alleen van de commandline. In deze situatie kun je ook niet vanaf je werkstation bij je ADSL-router komen met ping. Pakketjes komen wel aan op de modem, maar deze heeft geen juiste route om ze terug te sturen naar het netwerk (192.huppeldepup) waar je op zit.



Stel dat je vanaf je werkstation wel kunt pingen naar je ADSL-modem, dan kan eigenlijk alleen je DNS-server nog verkeerd zijn. Deze kun je achterhalen met cat /etc/resolv.conf.

Het volgende stukje is voor jouw dhcp-server niet van belang. Je wilt tenslotte geen dhcp staan doen op het netwerk van je provider.

# Upstream subnet is 213.211.128.0/16 (Telebyte / Free Online)
#subnet 213.211.128.0 netmask 255.255.192.0 {
#}

Verder kun  je trouwens ook eens op je werkstation kijken naar /var/lib/dhcp3/dhclient..leases. Hierin staat alle info die je van de DHCP server krijgt.

Offline woteb

  • Lid
  • Steunpunt: Nee
DHCP server, clients komen het internet niet op
« Reactie #14 Gepost op: 2008/08/06, 23:15:20 »
Even heel simpel. Start een werkstaion op met dhcp.

Zoals je misschien hebt gemerkt werkt alles nu uit de kunst.
Toch een antwoord. Deze zijn voorzien met A. voor de regels.

Lijk of het ip-adres juist is (met ifconfig).

A. Klopt

Kijk of je route goed staat (met route -n)

A. Klopt

Ping je adslmodem (ping 10.0.0.2).

A. lukt nu ook

(....knipperdeknip...)

Stel dat je vanaf je werkstation wel kunt pingen naar je ADSL-modem, dan kan eigenlijk alleen je DNS-server nog verkeerd zijn. Deze kun je achterhalen met cat /etc/resolv.conf.

A. Hier mijn output:

vader@enigma:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 212.45.33.3
nameserver 212.45.32.3
search spinakker.net
Klopt dus ook.


Het volgende stukje is voor jouw dhcp-server niet van belang. Je wilt tenslotte geen dhcp staan doen op het netwerk van je provider.

# Upstream subnet is 213.211.128.0/16 (Telebyte / Free Online)
#subnet 213.211.128.0 netmask 255.255.192.0 {
#}

A. Heb ik dus uitgevinkt staan, dat haal ik t.z.t. wel weg.

Verder kun  je trouwens ook eens op je werkstation kijken naar /var/lib/dhcp3/dhclient..leases. Hierin staat alle info die je van de DHCP server krijgt.

A. Dit is nu ook in orde:

lease {
  interface "wlan0";
  fixed-address 192.168.0.10;
  option subnet-mask 255.255.255.0;
  option routers 192.168.0.254;
  option dhcp-lease-time 600;
  option dhcp-message-type 5;
  option domain-name-servers 212.45.33.3,212.45.32.3;
  option dhcp-server-identifier 192.168.0.1;
  option broadcast-address 192.168.0.255;
  option domain-name "spinakker.net";
  renew 3 2008/8/6 21:15:24;
  rebind 3 2008/8/6 21:19:48;
  expire 3 2008/8/6 21:21:03;
}

Maar de volgorde van checken of een en ander in orde is, is heel makkelijk. Bedankt voor de tips!!
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)