Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: UDMA-probleem  (gelezen 4225 keer)

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Gepost op: 2008/08/04, 12:54:30 »
gegevens:
Kernel LINUX 2.6.24-20-generic / mobo=ASUS M2NPV-VM (Nvidia)

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
fstab:
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda6
UUID=f75e046b-47a9-4d87-a435-d025f710ebc8 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda9
UUID=8adea9b3-cc81-47fa-94da-9a5de643d515 /Algemeen       ext3    relatime        0       2
# /dev/sda8
UUID=4e444c78-9330-4287-a7e3-1c8aff59b462 /Backup         ext3    relatime        0       2
# /dev/sdb2
UUID=067896ae-623d-4e0c-b6f1-2d9365a6ae84 /Muziek         ext3    relatime        0       2
# /dev/sda7
UUID=996c83b8-6c9d-4767-a58b-8d3e7033dff8 /home           ext3    relatime        0       2
# /dev/sda5
UUID=bf124374-bd38-487a-9d07-f027d2ec0fc9 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
root@ubuntuHH32:/home/marco# hdparm -i /dev/sda6

/dev/sda6:

 Model=WDC WD2500KS-00MJB0                     , FwRev=02.01C03, SerialNo=     WD-WCANKL346031
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=50
 BuffType=unknown, BuffSize=16384kB, MaxMultSect=16, MultSect=?1?
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=488397168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: Unspecified:  ATA/ATAPI-1,2,3,4,5,6,7

 * signifies the current active mode

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
root@ubuntuHH32:/home/marco# dmesg | grep ata
[    0.000000]  BIOS-e820: 00000000afef3000 - 00000000aff00000 (ACPI data)
[   27.467880] Memory: 2846336k/2882496k available (2177k kernel code, 34844k reserved, 1006k data, 368k init, 1964992k highmem)
[   27.467956]       .data : 0xc0320504 - 0xc041bdc4   (1006 kB)
[   30.107811] libata version 3.00 loaded.
[   30.879612] sata_nv 0000:00:0e.0: version 3.5
[   30.880264] scsi0 : sata_nv
[   30.879920] scsi1 : sata_nv
[   30.880137] ata1: SATA max UDMA/133 cmd 0x9f0 ctl 0xbf0 bmdma 0xe000 irq 19
[   30.880192] ata2: SATA max UDMA/133 cmd 0x970 ctl 0xb70 bmdma 0xe008 irq 19
[   31.343765] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[   31.352015] ata1.00: ATA-7: WDC WD2500KS-00MJB0, 02.01C03, max UDMA/133
[   31.352068] ata1.00: 488397168 sectors, multi 1: LBA48
[   31.359996] ata1.00: configured for UDMA/133
[   31.828695] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   31.880240] ata2.00: ATA-7: MAXTOR STM3160211AS, 3.AAE, max UDMA/133
[   31.880293] ata2.00: 312581808 sectors, multi 1: LBA48 NCQ (depth 0/32)
[   31.946878] ata2.00: configured for UDMA/133
[   31.947900] scsi2 : sata_nv
[   31.947983] scsi3 : sata_nv
[   31.950757] ata3: SATA max UDMA/133 cmd 0x9e0 ctl 0xbe0 bmdma 0xcc00 irq 16
[   31.950809] ata4: SATA max UDMA/133 cmd 0x960 ctl 0xb60 bmdma 0xcc08 irq 16
[   32.259638] ata3: SATA link down (SStatus 0 SControl 300)
[   32.580582] ata4: SATA link down (SStatus 0 SControl 300)
[   32.591582] pata_amd 0000:00:0d.0: version 0.3.10
[   32.594508] scsi5 : pata_amd
[   32.595429] scsi6 : pata_amd
[   32.595957] ata5: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf400 irq 14
[   32.596010] ata6: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf408 irq 15
[   32.911853] ata5.00: ATAPI: Optiarc DVD RW AD-7173A, 1-01, max UDMA/66
[   33.083776] ata5.00: configured for UDMA/66
[   33.904576] EXT3-fs: mounted filesystem with ordered data mode.
[   98.811039] EXT3-fs: mounted filesystem with ordered data mode.
[   98.828164] EXT3-fs: mounted filesystem with ordered data mode.
[   98.838939] EXT3-fs: mounted filesystem with ordered data mode.
[   98.881305] EXT3-fs: mounted filesystem with ordered data mode.


*note: dus zie regel    [31.946878] ata2.00: configured for UDMA/133
                            [31.946878] ata2.00: configured for UDMA/133
                  [33.083776] ata5.00: configured for UDMA/66

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
( SDA6 = / )
root@ubuntuHH32:/home/marco# hdparm /dev/sda6

/dev/sda6:
 IO_support    =  0 (default)
16-bit)
 HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
 readonly      =  0 (off)
 readahead     = 256 (on)
 geometry      = 30401/255/63, sectors = 61448562, start = 109675818

root@ubuntuHH32:/home/marco# hdparm -d1 /dev/sda6

/dev/sda6:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device


root@ubuntuHH32:/home/marco# hdparm /dev/scd0

/dev/scd0:
 IO_support    =  0 (default)
16-bit)
 HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
 readonly      =  0 (off)
 readahead     = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

        google: WD2500KS+UDMA Blacklist: een actuele niet gevonden
   http://forum.ubuntu-nl.org/message/255005#p255005 + http://forum.ubuntu-nl.org/topic/26934 geprobeerd.

Vraag is het nu driverfout zoja hoe op te lossen of toch een kernelbug
mvg Marco
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #1 Gepost op: 2008/08/04, 13:17:51 »
Citaat van: noyomipa
gegevens:
Kernel LINUX 2.6.24-20-generic / mobo=ASUS M2NPV-VM (Nvidia)

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
fstab:
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda6
UUID=f75e046b-47a9-4d87-a435-d025f710ebc8 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda9
UUID=8adea9b3-cc81-47fa-94da-9a5de643d515 /Algemeen       ext3    relatime        0       2
# /dev/sda8
UUID=4e444c78-9330-4287-a7e3-1c8aff59b462 /Backup         ext3    relatime        0       2
# /dev/sdb2
UUID=067896ae-623d-4e0c-b6f1-2d9365a6ae84 /Muziek         ext3    relatime        0       2
# /dev/sda7
UUID=996c83b8-6c9d-4767-a58b-8d3e7033dff8 /home           ext3    relatime        0       2
# /dev/sda5
UUID=bf124374-bd38-487a-9d07-f027d2ec0fc9 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
root@ubuntuHH32:/home/marco# hdparm -i /dev/sda6

/dev/sda6:

 Model=WDC WD2500KS-00MJB0                     , FwRev=02.01C03, SerialNo=     WD-WCANKL346031
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=50
 BuffType=unknown, BuffSize=16384kB, MaxMultSect=16, MultSect=?1?
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=488397168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: Unspecified:  ATA/ATAPI-1,2,3,4,5,6,7

 * signifies the current active mode

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
root@ubuntuHH32:/home/marco# dmesg | grep ata
[    0.000000]  BIOS-e820: 00000000afef3000 - 00000000aff00000 (ACPI data)
[   27.467880] Memory: 2846336k/2882496k available (2177k kernel code, 34844k reserved, 1006k data, 368k init, 1964992k highmem)
[   27.467956]       .data : 0xc0320504 - 0xc041bdc4   (1006 kB)
[   30.107811] libata version 3.00 loaded.
[   30.879612] sata_nv 0000:00:0e.0: version 3.5
[   30.880264] scsi0 : sata_nv
[   30.879920] scsi1 : sata_nv
[   30.880137] ata1: SATA max UDMA/133 cmd 0x9f0 ctl 0xbf0 bmdma 0xe000 irq 19
[   30.880192] ata2: SATA max UDMA/133 cmd 0x970 ctl 0xb70 bmdma 0xe008 irq 19
[   31.343765] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[   31.352015] ata1.00: ATA-7: WDC WD2500KS-00MJB0, 02.01C03, max UDMA/133
[   31.352068] ata1.00: 488397168 sectors, multi 1: LBA48
[   31.359996] ata1.00: configured for UDMA/133
[   31.828695] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   31.880240] ata2.00: ATA-7: MAXTOR STM3160211AS, 3.AAE, max UDMA/133
[   31.880293] ata2.00: 312581808 sectors, multi 1: LBA48 NCQ (depth 0/32)
[   31.946878] ata2.00: configured for UDMA/133
[   31.947900] scsi2 : sata_nv
[   31.947983] scsi3 : sata_nv
[   31.950757] ata3: SATA max UDMA/133 cmd 0x9e0 ctl 0xbe0 bmdma 0xcc00 irq 16
[   31.950809] ata4: SATA max UDMA/133 cmd 0x960 ctl 0xb60 bmdma 0xcc08 irq 16
[   32.259638] ata3: SATA link down (SStatus 0 SControl 300)
[   32.580582] ata4: SATA link down (SStatus 0 SControl 300)
[   32.591582] pata_amd 0000:00:0d.0: version 0.3.10
[   32.594508] scsi5 : pata_amd
[   32.595429] scsi6 : pata_amd
[   32.595957] ata5: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf400 irq 14
[   32.596010] ata6: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf408 irq 15
[   32.911853] ata5.00: ATAPI: Optiarc DVD RW AD-7173A, 1-01, max UDMA/66
[   33.083776] ata5.00: configured for UDMA/66
[   33.904576] EXT3-fs: mounted filesystem with ordered data mode.
[   98.811039] EXT3-fs: mounted filesystem with ordered data mode.
[   98.828164] EXT3-fs: mounted filesystem with ordered data mode.
[   98.838939] EXT3-fs: mounted filesystem with ordered data mode.
[   98.881305] EXT3-fs: mounted filesystem with ordered data mode.


*note: dus zie regel    [31.946878] ata2.00: configured for UDMA/133
                            [31.946878] ata2.00: configured for UDMA/133
                  [33.083776] ata5.00: configured for UDMA/66

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
( SDA6 = / )
root@ubuntuHH32:/home/marco# hdparm /dev/sda6

/dev/sda6:
 IO_support    =  0 (default)
16-bit)
 HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
 readonly      =  0 (off)
 readahead     = 256 (on)
 geometry      = 30401/255/63, sectors = 61448562, start = 109675818

root@ubuntuHH32:/home/marco# hdparm -d1 /dev/sda6

/dev/sda6:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device


root@ubuntuHH32:/home/marco# hdparm /dev/scd0

/dev/scd0:
 IO_support    =  0 (default)
16-bit)
 HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
 readonly      =  0 (off)
 readahead     = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

        google: WD2500KS+UDMA Blacklist: een actuele niet gevonden
   http://forum.ubuntu-nl.org/message/255005#p255005 + http://forum.ubuntu-nl.org/topic/26934 geprobeerd.

Vraag is het nu driverfout zoja hoe op te lossen of toch een kernelbug
mvg Marco
verder :NFORCE-Linux-x86-1[1].0-0311-pkg1 van install CD mobo -> dpkg etc.
nieuwste driver NFORCE-Linux-x86-1.23. = alleen rpm
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #2 Gepost op: 2008/08/06, 20:34:45 »
wie kan me er bij helpen?
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
UDMA-probleem
« Reactie #3 Gepost op: 2008/08/06, 22:28:51 »
Je moet hdparm uitvoeren op de hele schijf, niet alleen een bepaalde partitie.
Dus niet /dev/sda6, maar /dev/sda

Verder zou ik het ook niet weten.

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #4 Gepost op: 2008/08/06, 22:39:39 »
ook gedaan, zelfde resultaat.
Brandprogramma's als K3B, Brasero en Nero4Linux geven dus errors: doen het domweg niet ( wegschrijven van veel data= langzaam) Voor branden ben ik gedwongen om dat verd*(excuseer!) ander OS  te gebruiken waar NERO wel werkt.
Wie weet wel wat ik kan doen?
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline Gandyman

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #5 Gepost op: 2008/08/09, 10:48:51 »
Citaat
tot nu toe geen bevredigend antwoord gekregen op  http://forum.ubuntu-nl.org/topic/30291.  Uit jou topic bijdrage http://forum.ubuntu-nl.org/topic/2560 wordt ik niet veel wijs uit ( verouderde commodo's?). Kan je misschien helpen? Bij voorbaat dank!
Met commando's of opdrachten is Linux geboren en die blijven altijd geldig, dus verouderen niet.

Zoals in die andere topis al staat, allereerst je hardware nakijken, hoe dit zit aangesloten.
Zit de brander en een harddisk op 1 kabel ??
Dan dit veranderen zodat ze beide op een eigen kabel zitten.

Jumpers goed controleren, want die kunnen aardig roet in het eten gooien.

Kan je zeggen in Windo werkt het toch ook ?
Jwel maar Windo is minder slim dan Linux en zal meer zijn oortjes laten hangen naar de bios, die een compromie gaat sluiten indien iets niet helemaal 100% ged staat.
Op die manier werkt je hardware wel, maar niet 100%.

Linux werkt anders en heeft er meer last van indien hardware niet in orde is of verkeerd staat ingesteld.

Uit je postings hierboven maak ik op dat hdparm wel alle mogelijkheden aangeeft die bruikbaar zijn.....

Geef eens nog eens de opdracht in terminal:
hdparm -i /dev/scd0BTW ben de hele dag weg...
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #6 Gepost op: 2008/08/09, 19:44:25 »
root@ubuntuHH32:/home/marco# hdparm -i /dev/scd0

/dev/scd0:

 Model=Optiarc DVD RW AD-7173A                 , FwRev=1-01    , SerialNo=                    
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 *udma4
 AdvancedPM=no

 * signifies the current active mode
PS: Overigens heeft deze opstelling/indeling ook de versies 7.04 en 7.10 gehad zonder deze problemen.
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline Gandyman

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #7 Gepost op: 2008/08/09, 21:59:35 »
Mja maar er zijn natuurlijk in de nieuwe programma's nieuwe instellingen en settings gekomen, en dan heb ik het niet over Ubuntu zelf.

Zo te zien is alles netjes in orde en word alles ondersteund.

Dus misschien moet je de moeite eens nemen om de proggie's die je gebruikt eens onder de loep te nemen.

eg flink rondklikken erin, en eens kijken wat de instellingen zijn.

Als die niet jofel staan heb je kans dat het daarom allemaal langzaam gaat.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

damusic2me

  • Gast
UDMA-probleem
« Reactie #8 Gepost op: 2008/08/10, 09:26:16 »
Is waarschijnlijk een sata schijf: als je de melding zelf:  HDIO_GET_DMA failed: Inappropriate ioctl for device door google heen gooit, kom je verscheidene fora tegen: debian en Ubuntu waar al staat dat dit komt omdat sata niet 100% overeenkomt met de dma van pata
zie bijv. http://www.linuxquestions.org/questions/susenovell-60/copy-files-from-partition-to-partition-too-slow-sata-hard-disk.what-should-i-do-377370/

zijn er ook specifieke problemen die je ondervindt naast deze fout melding?

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #9 Gepost op: 2008/08/10, 11:05:51 »
op de side http://forum.soft32.com/linux/gentoo-Problem-hdparm-SATA-controller-ftopict461773.html werd geopperd dat alles zo ok is, en dat SDA disks niet hdparm maar met sdparm moet lezen. het navolgende wordt dus interessant:
root@ubuntuHH32:/home/marco# sdparm /dev/sda
    /dev/sda: ATA       WDC WD2500KS-00M  02.0
Read write error recovery mode page:
  AWRE        1
  ARRE        0
  PER         0
Caching (SBC) mode page:
  WCE         1
  RCD         0
Control mode page:
  SWP         0
root@ubuntuHH32:/home/marco# sdparm /dev/sdb
    /dev/sdb: ATA       MAXTOR STM316021  3.AA
Read write error recovery mode page:
  AWRE        1
  ARRE        0
  PER         0
Caching (SBC) mode page:
  WCE         1



  RCD         0
Control mode page:
  SWP         0
root@ubuntuHH32:/home/marco# sdparm /dev/sdc
    /dev/sdc: SEAGATE   ST3250823A        3.03
Read write error recovery mode page:
  AWRE        1  [cha: n, def:  1, sav:  1]
  ARRE        0  [cha: n, def:  0, sav:  0]
  PER         0  [cha: n, def:  0, sav:  0]
Caching (SBC) mode page:
  WCE         1  [cha: n, def:  1, sav:  1]
  RCD         0  [cha: n, def:  0, sav:  0]
root@ubuntuHH32:/home/marco# sdparm -tT /dev/sda
abbreviation does not match a transport protocol
Available transport protocols:
  fcp    0x00     Fibre channel (FCP)
  spi    0x01     SCSI parallel interface (SPI)
  ssa    0x02     Serial storage architecture (SSA)
  sbp    0x03     Serial bus (SBP)
  srp    0x04     SCSI remote DMA (SRP)
  iscsi  0x05     Internet SCSI (iSCSI)
  sas    0x06     Serial attached SCSI (SAS)
  adt    0x07     Automation/Drive interface (ADT)
  ata    0x08     AT attachment interface (ATA/ATAPI)
  none   0x0f     No specific

root@ubuntuHH32:/home/marco# sdparm  --transport=TN | -t TN
abbreviation does not match a transport protocol
bash: -t: opdracht niet gevonden
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline jolo

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #10 Gepost op: 2008/08/10, 11:35:08 »
Citaat van: "noyomipa"
Brandprogramma's als K3B, Brasero en Nero4Linux geven dus errors: doen het domweg niet ( wegschrijven van veel data= langzaam)
Maar welke info geeft K3B dan bij Settings > Configure K3b  > Devices?

En als je de snelheid wilt meten via hdparm, gaat dat zoals dat in die linuxquestion.org link van damusic2me ook al staat met de -t optie. Bij mijn interne SATA schijf onder Ubuntu Hardy Heron is die op de PC uit mijn onderschrift

jolo@hardy-8:~$ sudo hdparm  -t /dev/sda

/dev/sda:
 Timing buffered disk reads:  208 MB in  3.02 seconds =  68.93 MB/sec
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #11 Gepost op: 2008/08/10, 12:55:53 »
@jolo : thx maar alle optie's hdparm --help & sdparm --help bekeken en geprobeerd. Heeft dus met enig brandprogramma als zodanig niets van doen.
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #12 Gepost op: 2008/08/10, 12:57:57 »
Citaat van: noyomipa
@jolo : thx maar alle optie's hdparm --help & sdparm --help bekeken en geprobeerd. Heeft dus met enig brandprogramma als zodanig niets van doen.
voor duidelijkheid:
marco@ubuntuHH32:~$ sudo hdparm  -t /dev/sda

/dev/sda:
 Timing buffered disk reads:  186 MB in  3.01 seconds =  61.72 MB/sec

marco@ubuntuHH32:~$ sudo hdparm -t /dev/sdb

/dev/sdb:
 Timing buffered disk reads:  216 MB in  3.01 seconds =  71.83 MB/sec
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline Gandyman

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #13 Gepost op: 2008/08/11, 11:41:34 »
Het word nu een beetje verwarrend......
Als ik het goed begrijp geeft nu de MAXTOR STM316021  problemen. ??

Zie nu ook dat je en Maxtor en Seagate in je pc gebruikt en moet eerlijk zeggen dit zijn vrij onbetrouwbare merken die op willekeurige momenten crashen en zich vreemd gedragen.

Als je dan ook nog ATA  (harddisk en Rom brander) en SATA harddisk door elkaar gebruikt
hoop ik dat het instellingen zijn waar hdparm mee worsteld...

Zou je voor mij eens de output willen geven van deze opdracht ?
sudo lshw -C diskMisschien staat hier nog iets zinnigs bij ?
http://ubuntuforums.org/showthread.php?t=801771
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline noyomipa

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #14 Gepost op: 2008/08/11, 11:57:57 »
Citaat van: Gandyman
sudo lshw -C disk
marco@ubuntuHH32:~$ sudo lshw -C disk
[sudo] password for marco:
  *-cdrom                
       description: DVD-RAM writer
       product: DVD RW AD-7173A
       vendor: Optiarc
       physical id: 0.0.0
       bus info: scsi@4:0.0.0
       logical name: /dev/cdrom
       logical name: /dev/dvd
       logical name: /dev/scd0
       logical name: /dev/sr0
       version: 1-01
       serial: [Optiarc DVD RW AD-7173A 1-01 Jul11,2006
       capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: ansiversion=5 status=open
  *-disk:0
       description: ATA Disk
       product: WDC WD2500KS-00M
       vendor: Western Digital
       physical id: 0
       bus info: scsi@0:0.0.0
       logical name: /dev/sda
       version: 02.0
       serial: WD-WCANKL346031
       size: 232GiB (250GB)
       capabilities: partitioned partitioned:dos
       configuration: ansiversion=5 signature=e3c3ac2d
  *-disk:1
       description: ATA Disk
       product: MAXTOR STM316021
       vendor: Maxtor
       physical id: 1
       bus info: scsi@1:0.0.0
       logical name: /dev/sdb
       version: 3.AA
       serial: 6PT4YB30
       size: 149GiB (160GB)
       capabilities: partitioned partitioned:dos
       configuration: ansiversion=5 signature=012210cd
marco@ubuntuHH32:~$sudo gedit /etc/udev/rules.d/70-persistent-cd.rules

# This file maintains persistent names for CD/DVD reader and writer devices.
# See udev(7) for syntax.
#
# Entries are automatically added by the 75-persistent-cd-generator.rules
# file; however you are also free to add your own entries provided you
# add the ENV{GENERATED}=1 flag to your own rules as well.
# DVD_RW_AD-7173A (pci-0000:00:0d.0-scsi-0:0:0:0)
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0d.0-scsi-0:0:0:0", SYMLINK+="cdrom", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0d.0-scsi-0:0:0:0", SYMLINK+="cdrw", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0d.0-scsi-0:0:0:0", SYMLINK+="dvd", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0d.0-scsi-0:0:0:0", SYMLINK+="dvdrw", ENV{GENERATED}="1"
OS:  ubuntu Gnome  16.10/64
Ubuntu-user  12044

Offline petbus

  • Lid
  • Steunpunt: Nee
UDMA-probleem
« Reactie #15 Gepost op: 2008/09/14, 21:43:16 »
Ik kon ook niet branden onder Hardy. Bovenstaande komt me bekend voor. Ik kreeg ook continu een foutmelding.

Nadat ik in K3b bij het "burnvenster" tabblad CD-Tekst het kruisje bij "Write CD Tekst" heb weggehaald
kon ik branden!!!!

Probeer het ook eens zou ik zeggen. Ben benieuwd....