Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleem met toetsenbord  (gelezen 4046 keer)

eric52

  • Gast
probleem met toetsenbord
« Gepost op: 2008/07/29, 11:45:16 »
ik heb ca. 3 weken een nieuw Apple toetsenbord aan mijn PC hangen.
Onder Umbuntu 10.4 werd deze onmiddellijk herkent en werkt e.a. probleemloos
(op de speciale Apple toetsen na ).

Sinds gisteren is het echter helemaal mis,
ik krijg alleen de tekens * / = - +  bij een enkele toetsen ( geloof de m & M )
de meeste toetst aanslagen blijven geheel dood.

Als ik bij Beheer --- Toetsenbord kijk  zie ik nog steeds Apple en MAC internationaal staan een andere keuze heeft geen effect.

Wie weet wat hier aan de hand is ?

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu.
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #1 Gepost op: 2008/07/29, 12:43:35 »
Citaat van: eric52
ik heb ca. 3 weken een nieuw Apple toetsenbord aan mijn PC hangen.
Onder Umbuntu 10.4 werd deze onmiddellijk herkent en werkt e.a. probleemloos
(op de speciale Apple toetsen na ).

Sinds gisteren is het echter helemaal mis,
ik krijg alleen de tekens * / = - +  bij een enkele toetsen ( geloof de m & M )
de meeste toetst aanslagen blijven geheel dood.

Als ik bij Beheer --- Toetsenbord kijk  zie ik nog steeds Apple en MAC internationaal staan een andere keuze heeft geen effect.

Wie weet wat hier aan de hand is ?
Ubuntu 10.4 = in het jaar 2010  - de maand april. ???
Of mis ik iets.
Grtz Tom.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.3 Lts 64 bits stand alone.
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren

kurosaki_ichigo

  • Gast
probleem met toetsenbord
« Reactie #2 Gepost op: 2008/07/29, 12:46:31 »
Hij bedoelt ubuntu 8.04

eric52

  • Gast
probleem met toetsenbord
« Reactie #3 Gepost op: 2008/07/29, 16:35:34 »
ja natuurlijk,

fijn te zien dat er onmiddellijk mensen zijn die je op je fouten wijzen.

Maar het onderwerp !!  mijn fijne Linux is nu onbruikbaar

Offline Willem_D

  • Lid
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #4 Gepost op: 2008/07/29, 18:30:06 »
Heb je een ander toetsenbord ter beschikking om te testen?
Aankoppelen en opnieuw opstarten, en kijken of dat normaal werkt.
Daarna weer die apple eraan, en opnieuw opstarten.
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

eric52

  • Gast
probleem met toetsenbord
« Reactie #5 Gepost op: 2008/07/30, 10:48:43 »
Hi Willem ,

je advies gevolgd, mijn oude (Microsoft usb) toetsenbord op een andere usb ingang aangesloten en
Perfect !

Opnieuw gestart zonder de Apple , nog steeds prima ( met het oude tb dus), de Apple op een andere usb poort aangesloten en ..... nog steeds ... bij m geeft deze 0 , / geeft + , ; geeft -
maar verder cijfers en letters ho maar !

Ik heb nu de beide tb'n er aanhangen en tik dus dit in met de oude , maar de Apple is een erg fijn
tb en verder heeft het gewerkt !  WAAROM

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #6 Gepost op: 2008/07/30, 11:42:14 »
Hoogstwaarschijnlijk iets met de manier waarop de kernel je toesten detecteert. bij mij bijvoorbeeld zijn de >/< en de (kwadraat)/(derde macht) toetsen omgewisseld (ik kan nu niet zo een tweetje en drietje typen, want ik zit op Mac OS X nu). Dit is echter niet zo'n groot probleem.

Jij hebt precies een Nederlands toestenbord (ik een belgisch), en daar verschilt het wat... Het enigste wat ik kan zeggen is:
a) graaf je door de menu'tjes van de toetsenbordinstellingen. Waarschijnlijk gebruik je Gnome, ik gebruik KDE en daar is het wel in te stellen.
b) zoek even op hoe je het programma xmodmap moet gebruiken en schakel dit in
c) schrijf je eigen keyboard layout.

- SeySayux
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

eric52

  • Gast
probleem met toetsenbord
« Reactie #7 Gepost op: 2008/07/30, 13:52:18 »
Hi SeySayux,

ja ik gebruik Gnome en deze heeft onder Systeem -- Voorkeuren -- Toetsenbord

maar ik heb de indruk dat wat ik daar ook verander niet overgenomen wordt.
Voorbeeld toen ik het drie weken geleden het Apple toetsenbord er aan hing was
dat gedetecteerd als MacBook/MacBook Pro (Intl) .  Toen e.a. niet meer werkte
en ik het oude tb er aan hing bleef deze instelling op de Mac staan. Op e.a. manier
worden veranderingen niet overgenomen.

Het programma xmodmap kan ik met mijn Synatic niet vinden en lijkt mij ook iets om
enkele toetsten te veranderen. Ik zit met het probleem dat geen van mijn toetsen niet
wil werken.

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #8 Gepost op: 2008/07/30, 14:52:53 »
Waarschijnlijk heeft het iets met de driver voor het toetsenbord in de kernel te maken. Deze zit er niet in, of is niet ingeschakeld omdat er niet verwacht wordt dat je een Mac-toetsenbord op een PC gaat gebruiken. Als deze erin zit maar niet is ingeschakeld, is het een kwestie van de naam van de driver te vinden en deze in te schakelen. Anders moet je je kernel hercompileren, en tenzij je dan nog een paar dagen/weken wilt liggen prullen om je grafische kaart/geluidskaart/netwerkkaart/wifi-kaart/noem-een-ander-stuk-probleemhardware aan de gang te krijgen, raad ik het niet aan.

- SeySayux
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

kurosaki_ichigo

  • Gast
probleem met toetsenbord
« Reactie #9 Gepost op: 2008/07/30, 14:59:44 »
Mijn apple toetsenbord en muis werken wel in linux maar dat zijn er van de oude imac g3 met usb

eric52

  • Gast
probleem met toetsenbord
« Reactie #10 Gepost op: 2008/07/30, 15:59:40 »
ja ik ben zojuist herstart met alleen mijn oude MS tb  aangesloten en als ik bij
Voorkeuren -- toetsenbord kijk dan staat daar weer de MAC ....

Ik had dit verandert in MS interm.  maar blijkbaar wordt dit niet overgenomen

Wie weet waar de tb definities staat en is aanpassen / weggooien een optie.
Compileren van de kernel is ver boven mijn pet van deze beginneling

Offline Willem_D

  • Lid
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #11 Gepost op: 2008/07/30, 18:18:26 »
Citaat van: eric52
Wie weet waar de tb definities staat en is aanpassen / weggooien een optie.
Compileren van de kernel is ver boven mijn pet van deze beginneling
Eric,
Als je opstart met de live-CD, terwijl alleen het apple-keyboard is aangesloten, werkt het dan oké?

Zoja,
kijk dan eens - tijdens deze live-CD sessie - in het bestand:  /etc/X11/xorg.conf, en post de inhoud van de Section "InputDevice" hier.

Je hebt dan namelijk de juiste driver te pakken, en dan kun je de xorg.conf van je geïnstalleerde Ubuntu handmatig aanpassen.
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

eric52

  • Gast
probleem met toetsenbord
« Reactie #12 Gepost op: 2008/07/31, 10:16:35 »
Hi Willem, fijn dat je wilt helpen

ik heb de computer met de live CD (7.1  ik heb geen 8.4 op cd) opgestart met het Apple tb en ja het werkt (even terzijde e.a. werkt al in de BIOS) als ik naar xconf kijk zie ik :

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

en
Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"

Als ik mijn 8.4 opstart zie ik

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

en
Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"

Als leek kan ik alleen concluderen dat er "iets" mis is in die "kbd" driver.
Ik zie nergens iets van een MAC toetsenbord genoemd. Maar op een paar kleine missers (bv. alt 2 is niet  @ ) werkte het hele toetsenbord.

Om e.a. nog vreemder te maken het ingeven van het wachtwoord voor dat je met een sessie begint ging dit keer ook !  . Tijdens Gnome was alles weer van streek, inpluggen van het oude tb maakt dat ik dit weer kan ingeven, RA RA    

Iets anders,  tijdens de Live CD werkte
Systeem -- Voorkeuren -- Toetsenbord    ook beter had ik de indruk

Offline jan11000

  • Lid
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #13 Gepost op: 2008/07/31, 10:54:40 »
opstarten in textmode(recoverymode), dan dpkg-reconfigure xserver-xorg,
hier kun je het toetsenbord instellen, welke je moet hebben weet ik niet, maar je krijgt daar een keuze.

Offline Willem_D

  • Lid
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #14 Gepost op: 2008/07/31, 12:31:56 »
@eric52:

Het lijkt erop dat de keyboard-instellingen in de xorg.conf van je 8.04 overruled zijn. Het zou me niet verbazen dat 8.04 dat zelf doet, na automatische detectie van je keyboard-type.
(Dat "overrulen" gebeurt waarschijnlijk ook als je zelf de instellingen wijzigt via Systeem>Voorkeuren>Toetsenbord.)

Hoe dan ook: je actuele configuratie is niet correct meer.

Mogelijk kun je door het wijzigen van de xorg.conf toch een gewenste instelling forceren.

Ik ben benieuwd wat de tip van Jan oplevert. Via "dpkg-reconfigure xserver-xorg" kon je in 7.10 de xorg.conf naar je hand zetten. Ik vraag me af of dat in 8.04 nog werkt.


EDIT 16u40:
Ik heb het hier geprobeerd: het lukt in 8.04 om de keyboard-instellingen in de xorg.conf te wijzigen via "dpkg-reconfigure xserver-xorg". Er wordt automatisch een backup van de bestaande xorg.conf aangemaakt; ik zou je wèl adviseren om de naam van deze backup te noteren, zodat je terug kunt. Bij mij werden namelijk de beeldscherm-instellingen ongewenst gewijzigd door deze operatie.
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille

eric52

  • Gast
probleem met toetsenbord
« Reactie #15 Gepost op: 2008/07/31, 19:25:14 »
Hallo Willem & Jan

ik heb in de tekst mode geprobeerd het dpkg-reconfigure xserver-xorg in te geven maar
bij mij werd dat niet herkent . Ik heb bij de opties gekeken maar zag alleen dpkg-config(old/new) met een waarschuwingsteken dat e.a gevaarlijk was. Daar durfde ik niet verder te mee te gaan.

Willem ik was te laat met het lezen van je update.

MAAR WAT BIJ MIJ WEL WERKTE ,
en ik heb mijn Apple tb ook weer aan de praat was het volgende.

Bij het opstarten in Grub kiezen voor de Ubunto Recovery Mode (optie 2)
je krijgt dan een hulpscherm waar o.a. in staat :  dpkg Repair Broken Packages
Omdat jullie het ook over dpkg hadden heb ik die gebruikt met het bovengenoemde
resultaat!

Hierna was alles weer OK , alle instellingen (o.a. beeld) waren gelijk gebleven

Dank voor jullie steun

Offline Willem_D

  • Lid
  • Steunpunt: Nee
probleem met toetsenbord
« Reactie #16 Gepost op: 2008/07/31, 20:37:35 »
Mooi dat het weer werkt, Eric!
Kennelijk was er een pakket verdwenen of beschadigd.

P.S.: Ik heb "sudo dpkg-reconfigure xserver-xorg" met succes uitgevoerd in de terminal na een normale 8.04-opstart; dus niet via recovery-mode.
Acer 5930G laptop met nVidia 9600M GT


"Je verschijnt niet in je lichaam, maar je lichaam verschijnt in Jou."
Francis Lucille