Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [8.04] RT2500: wel herkenning, geen verbinding  (gelezen 1819 keer)

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Gepost op: 2008/07/17, 11:21:16 »
Ik heb op mijn pc een tijd geleden Xubuntu 8.04 geïnstalleerd, met een uit-de-doos werkende RT2500 wifi-kaart. Alles werkte naar behoren, tot een paar weken geleden.

Ik gebruik deze pc alleen in het weekeinde, als ik bij mijn ouders thuis ben. Zo ineens in een weekeinde kreeg ik geen verbinding meer. Vermoedelijk komt dat door de updates die ik het weekend ervoor had geïnstalleerd, maar het zou ook nog wel eens kunnen dat het komt omdat er een stroomstoring was geweest, en dat de router daardoor misschien ontregeld is geraakt.

Ik heb de pc nu even op een andere kamer gezet, waar wel een netwerkkabel is en alles werkt prima zolang de kabel er maar in zit. Ik typ dit dus ook vanaf die pc.

Bekabelde verbinding op andere kamer werkt dus wel.
Draadloze verbinding werkt nergens.

Zijn er wat commando's die ik kan intikken waardoor er meer informatie naar boven komt? Of is de router misschien niet goed geconfigureerd, bijvoorbeeld een poort die verkeerd staat? Met andere woorden: hebben jullie goede tips zonder met ndiswrapper aan te komen? ;)

Ndiswrapper is eigenlijk het laatste dat ik wil proberen, op een volledige herinstallatie na dan, want ik weet dat het uit-de-doos zou moeten werken, want dat heeft 't ook gedaan.

Ik hoop op spoedige tips! :D

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #1 Gepost op: 2008/07/17, 12:03:18 »
Allereerst is het verstandig om ook de topics te lezen die je op dit forum kunt vinden door in de zoekfunktie wat kernwoorden in te geven. Ook tips van Pjotr mag ik hier niet vergeten te melden: http://computertip.googlepages.com/home.
Belangrijk is ook te weten welke hardware je gebruikt en natuurlijk de bijbehorendde instellingen.

Ben zelf ook nog maar een half jaartje met ubuntu bezig maar heb met de vele helpende handen en hersenen op dit forum mijn netwerkprobleempjes overwonnen. Dat geeft de burger moed...niet?

Hier zijn er een paar commando's die je in de terminal kunt doen; zorg wel dat je daadloze verbinding aanstaat, anders kun je niks vinden mbt draadloos:
Je kunt die gegevens uit de terminal knippen en plakken naar dit forum.
Wel even zorgen dat je niet je veiligheid in gevaar brengt met bepaalde gegevens.
sudo iwconfig  
sudo iwlist scan
sudo lshw -class network
na intypen van het commando zal je password worden gevraagd en daarna komt er een reeks gegevens over jouw configuratie.
Als je wil kunnen we die hier bespreken, al zal ik je niet op alle vragen antwoord kunnen geven, maar er is hier altijd iemand die het wel precies weet.

Verder kun je wel via je internetverbinding bij de instellingen van je router komen?
Benodigde aanwijzingen daarvoor kun je meestal in de instruktiehandleiding vinden (adres en inlogcode). In de instellingen van je router kun je zien of draadloos aanstaat en ook de andere details zoals IP adresssen, gebruikte coderingen (WPA/WPA2/WEP) en firewall instellingen.
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #2 Gepost op: 2008/07/17, 18:54:47 »
Als ik de netwerkkabel eruit heb, krijg ik de volgende code eruit. Bij lo, eth0 en wmaster0 stond bij de eerste twee commando's 'no wireless extensions', wat me heel normaal lijkt.

iwconfig geeft:
wlan0     IEEE 802.11g  ESSID:"XXXX"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated  
          Tx-Power=27 dBm  
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B  
          Encryption key:6022-21CC-7D
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
iwlist geeft:
wlan0     Scan completed :
          Cell 01 - Address: 00:11:F5:4D:3D:5A
                    ESSID:"XXXX"
                    Mode:Master
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=47/100  Signal level=-75 dBm  
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=0000012157b52ef4
lshw -class network geeft:
 *-network:0
       description: Ethernet interface
       product: 82557/8/9/0/1 Ethernet Pro 100
       vendor: Intel Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       logical name: eth0
       version: 05
       serial: 00:50:8b:6c:e9:10
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k4-NAPI duplex=half firmware=N/A latency=66 link=no maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=10MB/s
  *-network:1
       description: Wireless interface
       product: RT2500 802.11g Cardbus/mini-PCI
       vendor: RaLink
       physical id: f
       bus info: pci@0000:00:0f.0
       logical name: wmaster0
       version: 01
       serial: 00:08:a1:81:6a:47
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=rt2500pci latency=66 module=rt2500pci multicast=yes wireless=IEEE 802.11g
Alles lijkt me op het eerste gezicht in orde. Ik verbaas me alleen over de regel 'Encryption key:off'. Gaat dit over de WEP/WPA-versleuteling? Ik heb de hexadecimale WEP-code in elk geval wel gewoon ingesteld, dus daaraan lijkt het niet te liggen...

Ik krijg steeds meer de indruk dat het aan de router ligt, maar daar heb ik het wachtwoord niet van. Ik zal mijn vader eens vragen. ;)

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #3 Gepost op: 2008/07/17, 19:19:06 »
Gek genoeg stond de router op onbeveiligd, terwijl we dit een paar weken terug wel hadden aangevinkt. Toen was 'ie overigens ook al een keer zomaar op onbeveiligd gesprongen, waarschijnlijk door die stroomstoring.

Commando iwlist geeft nu ook weer 'Encryption key:on'.

De laptop van mijn vader met draadloze verbinding via een USB-stick doet het overigens wel prima (WinXP)... :/

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #4 Gepost op: 2008/07/17, 21:27:02 »
iwconfig en iwlist laten volgens mij tegenstrijdige gegevens zien
Onder wlan0 zie ik: access point not associated. Dat betekent dat hij het accesspoint niet herkent of ermee verbindt. Link quality en signaal level staan (daaronder) op 0 dat komt omdat hij het accesspoint niet herkent denk ik.
Maar bij iwlist is wel een duidelijk signaalnivo vermeld.
Ik vrees dat dit probleem weer met de encryptie te maken heeft.
Als het goed is zie je onder het nm applet (het "molentje") de ESSID van je router ("XXXX") en wordt ook de signaalsterkte aangegeven.
Vraagt hij bij poging tot verbinden wel om een inlogkey?
Probeer eerst zonder encryptie te verbinden. Als dat lukt kun je later encryptie aanzetten.

Uit je opmerking van de verbinding met de laptop van je vader blijkt dat de router blijkbaar wel werkt.
In eerdere postsings kun je lezen dat Ubuntu problemen kan hebben met de (vnl WPA en WPA2) encryptie.
Hoe staan de instellingen bij je vader ingesteld?
Kun je al inloggen in je router om de instellingen te bekijken?

Kortom nog veel vragen hier. Maar misschien eerst stap voor stap melden wat je probeert en met welk resultaat.
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #5 Gepost op: 2008/07/17, 23:01:46 »
De verbinding is WEP-beveiligd. Toen ik voor het eerst de dreaadloze verbinding configureerde, kostte het me een hoop tijd om uit te vinden dat de verbinding niet werkte omdat ik de WEP-sleutel niet had ingevuld. Zonder die code kan ik het dus wel vergeten. Hij vraagt er echter ook niet apart om, maar misschien heeft dat te maken met Xubuntu?

Met de WEP-code ingevuld en encryptie uitgeschakeld werkt de verbinding in elk geval niet. Ik neem aan dat het dan geen verschil maakt of de WEP-code wel of niet is ingevuld, omdat 'ie er dan toch niet naar kijkt.

Ik kan nog steeds niet bij de router komen, en mijn vader kennende zal hij me ook niet zomaar het wachtwoord cadeau doen omdat hij bang is dat ik de boel helemaal overhoop haal... :/

Ik zou nog wel kunnen testen hoe de verbinding is zonder WEP-code ingevuld en zonder versleuteling, maar er staat me iets van bij dat ik dat eerder ook al eens had gedaan. Het vervelendste is nog wel dat ik niet weet of de boel gemolesteerd is door een update van de pc of een stroomstoring bij de router... :(

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #6 Gepost op: 2008/07/18, 10:20:25 »
Het wordt nu toch wel lastig.
Uit je verhaal is me nog niet duidelijk of je nu onder het nm applet wel of niet de router met zijn signaal kunt zien: zie mijn bovenstaand verhaal: ESSID: "XXXX".
Graag dit even bevestigen anders komen we nergens. Blijkbaar zie je hem wel want je hebt een WEP key ingevuld. Dus blijkbaar vraagt/vroeg hij om de code?
Graag even helder en kort de antwoorden op de hierboven (onder: #5) gestelde vragen.
Wat ik niet kan herleiden is of er in je xubuntu instellingen wat verkeerd gaat of dat het door de router komt. Daar gaat het toch allemaal om hier?
Als blijkt dat xubuntu alles goed laat zien moet je in de router gaan zoeken en dat kan alleen door er op in te loggen zoals hierboven beschreven. Als daar bijv WPA aanstaat moet je gewoon de WPA key hebben en danlukt het ook nog niet altijd meteen.
Kortom lastig maar vooral incompleet verhaal.
Misschien eerst het vertrouwen van Pa herwinnen, of Pa zelf laten doen?
En vertel mij niet dat dat niet kan. Ben er ook 61......helaas...maar toch.
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #7 Gepost op: 2008/07/18, 11:23:10 »
Citaat
nm applet (het "molentje")
Ik snap niet precies wat je hiermee bedoelt. Bedoel je dat netwerkicoontje in de systray? Bedoel je wat op onderstaand plaatje staat of bedoel je de netwerktab van het procesbeheer?

Overigens, ik had overal de ESSID gecensureerd met XXXX, maar als de buurman niet meekijkt maakt het ook niet uit of 'ie openbaar is of niet. Overigens weet ik 300% zeker dat de verbinding WEP-beveiligd is en niet WPA, want gisteren hebben mijn vader en ik even in de routerinstellingen gekeken en daar stond zeer zeker WEP, en niks anders. De bijbehorende code is hexadecimaal, dus dat heb ik ook netjes aangegeven.



Ik heb bovenstaand ding zojuist even op 'zwervende modus' gezet, en toen het jmbr-netwerk aangeklikt uit zo'n menuutje (hij herkent 'm dus wel!) en verbinding gemaakt. Hij vroeg daarbij wel om een code. Toen ik die had ingevuld bleef hetzelfde probleem dat ik geen verbinding kon krijgen. Het balkje dat de sterkte aangaf stond ongeveer op de helft, net als een ander netwerk dat hij herkende.

Ik ben nu alleen thuis, dus met mijn vader overleggen over toegang tot de router zal niet gaan. Dit weekend ben ik ook vrij druk bezet, dus het zal wel weer volgende week worden eer ik ermee verder kan...

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #8 Gepost op: 2008/07/18, 12:08:13 »
Samengevat:
het netwerk wordt gezien (met signaalsterkte) door jouw pc, hij vraagt om een code, die staat bij de router op WEP.
Je hebt op je pc de juiste WEP code gebruikt, maar pc wordt niet aangekoppeld.
Je kunt volgende nog proberen:
Voordat je hem in de zwervende modus eerst alle gegevens handmatig invullen en daarna de zwervende modus meteen aanzetten. Bij mij werkte dat, maar daar ging het om WPA.

Ook zou je bovengenoemde netwerkcommando's nog eens kunnen uitvoeren of die nu wel de juiste info geven.
En in je router moet je feitelijk alleen nog controleren of DHCP ook aanstaat. Zo niet dan moet je met een vast IP adres werken.en niet vergeten de instellingen van de firewall in de router te bekijken.
Misschien kun je de tips van Pjotr (link zie boven) nog natrekken, maar dan kom je toch snel uit bij ndiswrapper.

Krijg je wel verbinding als je de live CD van Ubuntu gebruikt? Die pakt namelijk bijna alles met draadloze netwerken

Ik hoop dat het toch gaat lukken. Lees ook andere verhalen op dit forum.
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline bartje_p

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #9 Gepost op: 2008/07/18, 13:31:16 »
Kijk ook eens in de /etc/network/interfaces file. Ik kan me nog herinneren dat ik ook geen verbinding kreeg, maar dat kwam omdat hij "s:" voor de echte wep key plaatste. Dus je kreeg iets als "s:XXXXXXXXXXXXXX".

Bij mij volstond het om de s: weg te halen, daarna deed hij het als een tierelier.

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #10 Gepost op: 2008/07/21, 10:58:16 »
Ik kan nu in de routerinstellingen komen, dus wat dat betreft weer een stap verder.

Ik heb de versleuteling in de router even uitgezet, en vervolgens wat geprobeerd met de netwerkinstellingen met zwervende modus. Nergens resultaat. De versleuteling weer aangezet en het wachtwoord voor de zekerheid maar gekopieerd i.p.v. overgetypt, maar geen resultaat.

Voorzover ik kon ontdekken staat DHCP gewoon aan.

@bartje_p (naamgenoot ;)): ik heb jouw suggestie ook bekeken, maar bij mij stond er helaas geen s: voor. Was het maar zo simpel.

Ik heb nog ergens een CD-RW liggen, waar ik een Ubuntu-ISO op ga branden om te testen of 'ie het dan wel doet. Als dat ook niet werkt, probeer ik met ndiswrapper de boel aan de praat te krijgen.

Gelukkig is ndiswrapper al heel wat gebruiksvriendelijker geworden dan een aantal jaren terug, toen ik met dezelfde wifikaart er ook niet uitkwam. Met ndiswrapper kwam ik ook niet veel verder want ik snapte er geen hol van, waarna ik de boel maar heb opgegeven. Inmiddels is er veel veranderd in de Linux-wifiwereld, met native Linux RT2500-drivers (die in eerste instantie ook prima werkten op deze pc) en nieuwe versies van ndiswrapper, zelfs met een GUI! Dat geeft de burger moed. ;)

Offline Kaaiman

  • Lid
  • Steunpunt: Nee
[8.04] RT2500: wel herkenning, geen verbinding
« Reactie #11 Gepost op: 2008/07/21, 12:09:48 »
Helaas, met de Xubuntu livecd krijg ik ook geen verbinding. Eerst zwervene modus geprobeerd, maar daar ging het volgens mij in een oneindige lus. Toen gewoon de ESSID en de WEP-code ingevuld en op DHCP ingesteld, maar wederom noppes resultaat.

Nu eens kijken of het met ndiswrapper wil...