Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met awn  (gelezen 2457 keer)

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Gepost op: 2008/07/11, 21:17:47 »
Hallo,

Heb sinds kort (na update) een probleem met Avant Window Navigator.
Het programma start wel op, maar zodra ik op de icoontjes klik om het desbetreffende programma te starten, loopt hij vast.
daarna doet hij ook niets meer, icoontje blijft "ingezoomd", programma start niet, die moet ik dan in toepassingen opstarten.
Verder werkt alles gewoon naar behoren.

Owjah, ben nog een redelijke N00B......:)

Offline tabasco

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #1 Gepost op: 2008/07/11, 21:33:22 »
Welkom ribbeltje,
Je zou allereerst kunnen proberen om awn opnieuw te installeren. Dit neemt niet veel tijd in beslag en zou misschien je probleem snel op kunnen lossen.

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #2 Gepost op: 2008/07/11, 21:57:49 »
Sorry, was ik vergeten erbij te vertellen...
Heb em dus al div. keren verwijderd, ook volledig, en opnieuw geinstalleerd, via synaptic.
Maar hij blijft vastlopen, denk dat het probleem dus ergens anders zit?

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #3 Gepost op: 2008/07/12, 10:19:50 »
Valt me ook op da zelfs na volledige verwijdering de instelliongen wel bewaard blijven.
Als ik awn weer installeer geeft hij alle launchers weer die ik ook geinstalleerd had.
Waar kan ik dat vinden, en hoe verwijder ik dus alles.

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Probleem met awn
« Reactie #4 Gepost op: 2008/07/12, 10:59:10 »
Ik ben er niet meer zeker van, maar bestaat er geen mapje ".awn" in je "persoonlijke map"?
Dit is een zogenaamde "verborgen map" die zichtbaar wordt als je "verborgen bestanden weergeven" aanvinkt in het menu "beeld".

Edit:
Dit mapje dus ook even verwijderen en awn opnieuw installeren. In deze map worden namelijk configuratie bestanden bijgehouden.

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline joseph

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #5 Gepost op: 2008/07/12, 11:57:06 »
@ ribbeltje

Toch niet toevallig een ATI kaart.
Sinds een update begin mei kon ik ineens de werkende AWN niet meer gebruiken.
Kan overigens helemaal geen visuele effecten meer gebruiken.

Bij discussie over die update kwam Klaasvaak met een oplossing waarmee die AWN functies kunnen worden vervangen maar grafisch misschien wat minder fraai zijn.
Citaat van: Klaasvaak
ik kan je deels helpen. AWN is gemakkelijk te vervangen door een nieuwe balk aan te maken (ik neem even aan dat je er nog wel een boven hebt staan). Dus rechtermuisknop op die balk, new panel. Die verschijnt waarschijnlijk onderaan.
Dan doe je rechtermuisklik op dat "panel", waarna je op add to panel klikt. Daar kies je iets dat bij mij "vensterlijst" heet (ik weet niet of jij het engels hebt.).
Als laatste kun je bij properties van je nieuwe lijst nog selecteren dat je alle vensters op alle workspaces weer wilt laten geven. Dan heb je weer iets dat voor AWN-vervanger door kan gaan.

Over die drivers heb ik nog steeds niets gevonden. Waarom duurt het zo lang voor een update?
Gewoon wat pionieren met toevoegen van functies en aanpassen eigenschappen totdat je iets heb dat je bevalt.

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #6 Gepost op: 2008/07/12, 15:53:03 »
@scormen:

Heb een aantal mapjes/bestanden gevonden, maar ik krijg ze niet weg.
Hij geeft aan dat ik de eigenaar niet ben, en dus geen rechten heb (staat een slotje bij het pictogram)
Zal dan wel via de terminal moeten, denk ik??
Zoals ik al zei, ben nog niet zo heel erg lang hiermee bezig.
Bevalt me beter dan XP, maar tis nog ff zoeken naar bepaalde dingen :)

@joseph, Tis een Nvidia kaart, en ik wil graag dat awn weer aan het draaien krijgen.
De oplossing van klaasvaak is een mooie, maar het is het probleem verleggen/negeren.
Awn heeft perfect gedraait, en dat moet het weer gaan doen....

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Probleem met awn
« Reactie #7 Gepost op: 2008/07/12, 16:31:33 »
Terminal: sudo nautilus

Navigeer naar File System>>>home>>>[je gebruikersnaam]>>>.awn et voila

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Probleem met awn
« Reactie #8 Gepost op: 2008/07/12, 16:41:22 »
Ik vind het wel eigenaardig dat ribbeltje geen rechten heeft in zen eigen home map?...

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Probleem met awn
« Reactie #9 Gepost op: 2008/07/12, 17:37:44 »
Voor sommige dingen heb je root-rechten nodig in je Home-map.

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #10 Gepost op: 2008/07/12, 18:26:32 »
martin@asus:~$ sudo nautilus
[sudo] password for martin:
Initializing nautilus-share extension
seahorse nautilus module initialized

** (nautilus:7890): WARNING **: Unable to add monitor: De bewerking is niet mogelijk

dit krijg ik, en de files die nog op de computer staan, staan niet onder home/...../.awn, maar in div andere maps.
Heb ze opgezocht met de zoek functie.
En waarom heb ik geen rechten op mijn eigen computer, ben de enigste gebruiker....

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #11 Gepost op: 2008/07/13, 12:40:13 »
Hoe kan ik inloggen als root, heb er wel een password van, en hoe krijg ik die bestanden dan weg?
Kan dat alleen in de terminal?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Probleem met awn
« Reactie #12 Gepost op: 2008/07/13, 12:44:12 »
Dat kan alleen via de terminal ja. Inloggen op de root-account is niet aan te raden.

En dat Unable to add monitor krijg ik ook altijd, is dus niks om je zorgen over te maken.

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #13 Gepost op: 2008/07/13, 17:09:25 »
Ok, ben een middagje bezig geweest, en ben wat meer te weten gekomen over de terminal, en z'n commando's.
Heb de bestanden weten te verwijderen, heb daarna AWN opnieuw geinstalleerd.
Toch startte het programma weer op met de oude instellingen, en weer liep de boel vast!!??
Wat kan dat zijn, ben nu zelf een beetje door de mogelijkheden heen......
En waar worden die evt. oude instellingen bewaard?

assem046

  • Gast
Probleem met awn
« Reactie #14 Gepost op: 2008/07/13, 17:51:49 »
Welke versie van AWN gebruik je?

Offline tabasco

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #15 Gepost op: 2008/07/13, 18:02:57 »
Heb je dit al geprobeerd?
Citaat
How do I reset AWN's preferences?

In order to reset all of AWN's preferences to their defaults, run the following at the command prompt:

gconftool-2 --recursive-unset /apps/avant-window-navigator
De settings directory van AWN zit overigens in ~/.config/awn

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #16 Gepost op: 2008/07/13, 18:03:58 »
versie 0.2.1

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #17 Gepost op: 2008/07/13, 18:51:24 »
@ tabasco,

Heb de boel gereset, hielp niet.
Heb em ook gedowngrade, hielp ook niet...:(

Op de site van awn gekeken, blijkt, met wat ik er van begrijp, dat het een bug is, denk ik....geloof ik....

http://www.planetblur.org/hosted/awnforum/
snap nog niet zo heel veel van dat technische gelul. :)

Offline tabasco

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #18 Gepost op: 2008/07/13, 18:59:33 »
Ja inderdaad, dit schijnt een workaround te zijn:
https://bugs.launchpad.net/awn/+bug/245448/comments/3
Maar dat heb je al geprobeerd begrijp ik?
(Zowel voor avant-window-navigator en libawn0 ?)

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #19 Gepost op: 2008/07/13, 19:28:17 »
Tadaa, is geloof ik opgelost!!

Heb awn en libawn0 gedowngrade in synaptic, en de versies vastgezet.
Het programma functioneerd tot nu toe weer normaal.
Wacht nog ff een dagje met markeren als opgelost, vertrouw het nog niet helemaal.....;)

@ All, thnx voor het meedenken en de pointers.
Veel bijgeleerd....:)

Offline tabasco

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #20 Gepost op: 2008/07/13, 19:32:04 »
Goed om te horen! Wat ging er eerder mis?

Offline ribbeltje

  • Lid
  • Steunpunt: Nee
Probleem met awn
« Reactie #21 Gepost op: 2008/07/13, 19:40:46 »
Had in eerste instantie alleen awn gedowngrade, toen ik libawn0 ook terugdraaide werkte de boel opeens weer.
Zit dus duidelijk een bug in de upgrade.

Maarja, probleem opgelost, en een boel info en kennis rijker!!
Moet maar es vaker een probleem tegenkomen, leer je nog es wat van...;)

iig thanx to all!!