Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: fout bij aktiveren van XKB-configuratie  (gelezen 1232 keer)

Offline yamaja

  • Lid
  • Steunpunt: Nee
fout bij aktiveren van XKB-configuratie
« Gepost op: 2006/08/26, 14:49:45 »
Hallo
Ik heb pas onlangs ubuntu op mijn pc gezet en net nu ik er een klein beetje mee overweg kan krijg ik met het probleem van de x-server te maken.
Na veel zoeken en proberen is het mij ten slotte toch gelukt om alles terug normaal te  krijgen. Of toch bijna....
Bij het opstarten krijg ik de volgende melding

Er is een fout opgetreden bij het activeren van de XKB-configuratie.
Dit kan onder verschillende omstandigheden voorkomen:
- een fout in de libxklavier-bibliotheek
- een fout in de X-server (xkbcomp, xmodmap-hulpprogramma's)
- X server met incompatibele libxkbfile-implementatie

X-server versiegegevens:
The X.Org Foundation
70000000

Indien u deze situatie als fout rapporteert, voegt u dan alstublieft toe:
- Het resultaat van xprop -root | grep XKB
- Het resultaat van gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Verder werkt alles normaal uitgezonderd dat ik de Alt Gr -toets niet meer kan gebruiken.

Wanneer ik probeer via" toetsenbordvoorkeuren" de instelling van mijn toetsenbord aan te passen krijg ik ook bovenstaande foutmelding.(Heb Belgisch azerty-toetsenbord)

Hoe krijg ik dit alles terug ok,

Pol

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
fout bij aktiveren van XKB-configuratie
« Reactie #1 Gepost op: 2006/08/26, 15:29:48 »
Open een terminal
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf2 (dit maakt een backup)
sudo gedit /etc/X11/xorg.conf

Vervang desbetreffende section voor keyboard door

Section "InputDevice"
   Identifier  "Generic Keyboard"
   Driver      "kbd"
   Option       "CoreKeyboard"
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "be"
EndSection

save

ctrl+alt+backspace
log in
Nog foutmelding?

Offline yamaja

  • Lid
  • Steunpunt: Nee
fout bij aktiveren van XKB-configuratie
« Reactie #2 Gepost op: 2006/08/28, 10:54:40 »
aanpassingen doorgevoerd
Echter nog steeds dezelfde foutmelding
Bij mij staat er nu:

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "be"
    Option        "XkbVariant" "be"
    Option        "XkbOptions" "be"

Moeten/mogen die 2 laatste optie daar staan ?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
fout bij aktiveren van XKB-configuratie
« Reactie #3 Gepost op: 2006/08/28, 15:24:00 »
Die laatste 2 opties weghalen, die zijn toch zoiezo fout. be is voor XkbLayout.

XkbVariant en XkbOptions zijn om andere dingen toe te voegen zoals nodeadkeys etc.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline yamaja

  • Lid
  • Steunpunt: Nee
fout bij aktiveren van XKB-configuratie
« Reactie #4 Gepost op: 2006/08/28, 19:44:45 »
Joepie... of toch bijna...

Mijn Alt Gr-toets doet het weer.
Ik krijg nog wel altijd dezelfde foutmelding
Er is een fout opgetreden bij het activeren van de XKB-configuratie.
Dit kan onder verschillende omstandigheden voorkomen:
- een fout in de libxklavier-bibliotheek
- een fout in de X-server (xkbcomp, xmodmap-hulpprogramma's)
- X server met incompatibele libxkbfile-implementatie

X-server versiegegevens:
The X.Org Foundation
70000000

Indien u deze situatie als fout rapporteert, voegt u dan alstublieft toe:
- Het resultaat van xprop -root | grep XKB
- Het resultaat van gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Resultaat van bovenstaande is:

pol@pol-desktop:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "be", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "be", "", ""

pol@pol-desktop:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [belgian,be]
 model = chicony9885
 options = [grp grp:alts_toggle]
 overrideSettings = true

Wat is er nog fout?
Toch al bedankt
Pol