Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Slotjes wegkrijgen bij mappen in bestandsbeheer  (gelezen 6018 keer)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Gepost op: 2008/07/06, 10:39:09 »
Hallo,


mijn vriend zijn laptop is verkocht, hij gaat een nieuwe kopen en ik zou eerst alles van zijn laptop (zijn home) op onze externe harde schijf willen zetten. Zodat nadien alle gegevens van de laptop hebben als we die aan de persoon geven die hem kocht. Ik zie echter overal slotjes bij staan als ik op het bestandssysteem heb geklikt. Daar zie je een boel mappen staan en daar is die home bij, ook daar staat een slotje bij. Weet iemand hoe ik dat moet verwijderen? Dat is iets met rechten denk ik. Enkele maanden geleden hebben we wel problemen gehad op de laptop met iets, daar had ik een onderwerp over lopen op het forum hier (fout met rechten) en toen heb ik een andere gebruikersnaam gemaakt en de originele gebruiker verwijderd omdat het anders niet opgelost geraakte.
Hoe krijg ik nu die slotjes weg zodat ik zonder problemen heel de home op de externe harde schijf kan zetten?

Groetjes,

Els

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #1 Gepost op: 2008/07/06, 11:17:12 »
In een terminal "gksudo nautilus" typen. Nadat je je wachtwoord hebt ingetypt, opent zich nautilus met de root-rechten. Dat betekent dat je in dat nautilusvenster alles kan kopieren/verwijderen, zonder last te hebben van de genoemde rechten. Op deze manier moet je sowieso alles kunnen kopieren ;)

Al is het probleem van de slotjes zo nog niet opgelost, ondanks dat je zo alles wel kan kopieren. Als je met de rechtermuisknop op de home-map klikt, zou je bij tabblad rechten alles goed in kunnen stellen.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #2 Gepost op: 2008/07/06, 11:24:51 »
Waarschijnlijk kun je het als volgt oplossen:
-open Nautilus met root-rechten (gksudo nautilus)
-navigeer naar je home-map
-selecteer alles (ctrl + a)
-rechtsklikken > properties > permissions
-zorg ervoor dat je het als volgt instelt:
owner: gebruikersnaam
folder access: create and delete files
file access: --
group: gebruikersnaam
folder access: access files
file access: --
others:
folder access: access files
file access: --
ok
sluit nu de nautilus met root-rechten af
nu zou een nautilus met normale rechten geen slotjes meer moeten weergeven, het kan zijn dat je in de venster hierboven ook nog apply permissions to enclosed files moet selecteren.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #3 Gepost op: 2008/07/06, 11:30:45 »
Die slotjes zijn inderdaad omdat de gegevens niet van de huidige gebruiker zijn. Ik zie niet in waarom je ze weg wil doen, want je moet die gegevens toch niet bewerken? Nog een voordeel: je zal ze niet accidenteel wissen. Bovendien kan je de gegevens nog steeds als gewone gebruiker kopieren, bijvoorbeeld naar die nieuwe laptop. Met andere woorden, dank zij die slotjes zijn die gegevens tamelijk veilig! Advies: laat die slotjes maar netjes staan.

Als je de schijf zal aan de nieuwe laptop hangen, dan zullen er mogelijk nog steeds slotjes op staan. Kopieer de gegevens dan naar die laptop en verander daarna de eigenaar van die gekopieerde gegevens. Dat laatste moet je als systeembeheerder doen, bijvoorbeeld zoals kebabfish zegt, met "gksudo nautilus". Gebruik dergelijke nautilus met root bevoegdheden zo weinig mogelijk. Handiger om in één keer een ganse directory van eigenaar te veranderen is de commandolijn: "sudo chown ..."

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #4 Gepost op: 2008/07/06, 11:30:57 »
Hallo,


ik krijg deze foutmelding als ik dat commando ingeef in de terminal:

wernerz@werner-laptop:~$ gksudo nautilus
Initializing nautilus-share extension

** (nautilus:9726): WARNING **: Unable to add monitor: De bewerking is niet mogelijk
SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSNautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' gaf fout 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Bestand of map bestaat niet
Please ask your system administrator to enable user sharing.

Weet iemand wat dat is of wat ik daarmee moet doen?

Groetjes,

Els

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #5 Gepost op: 2008/07/06, 13:14:11 »
Citaat van: Els1980
Weet iemand wat dat is of wat ik daarmee moet doen?
Els
Als ik jou was zou ik daar helemaal niets mee doen. Het is toch alleen maar de bedoeling om data van de laptop op een externe harde schijf te zetten? Alles wat je wilt bewaren gewoon kopiëren naar die externe en daarna kun je de harde schijf van de laptop (grondig) wissen voordat ie naar de nieuwe eigenaar gaat.
Als je het zo doet, bespaar je jezelf een hoop tijd met zoeken naar de oplossing voor die foutmelding. ;)

Offline Guy Stevens

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #6 Gepost op: 2008/07/06, 15:49:32 »
En wat als dan de backup wordt terug gezet op de nieuwe laptop? Blijf je dan niet het probleem hebben met de rechten?

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #7 Gepost op: 2008/07/06, 16:21:56 »
Hallo,


het is de bedoeling dat we die gegevens overzetten naar de nieuwe laptop want er zitten wat tekstbestanden enzo in de home die we bij willen houden. Kan het nu wel of geen kwaad dat die slotjes er bij staan? Of kan ik beter alleen de documenten en mails op de externe harde schijf zetten en de rest met die slotjes laten staan? Er staat ook een slotje bij mijn home, ik weet niet in hoeverre dat een probleem is.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #8 Gepost op: 2008/07/06, 16:30:00 »
Citaat van: Els1980
Hallo,


het is de bedoeling dat we die gegevens overzetten naar de nieuwe laptop want er zitten wat tekstbestanden enzo in de home die we bij willen houden. Kan het nu wel of geen kwaad dat die slotjes er bij staan?
Kan geen kwaad hoor. Het enige punt is: je kunt ze niet verwijderen. Als je ze ook wilt verwijderen, moet je de slotjes eraf halen. Aleen kopieren heeft die bewerking niet nodig.

Citaat van: Els1980
Of kan ik beter alleen de documenten en mails op de externe harde schijf zetten en de rest met die slotjes laten staan? Er staat ook een slotje bij mijn home, ik weet niet in hoeverre dat een probleem is.
Zoals gezegd: geen probleem.

Je kunt de betreffende gegevens gewoon kopieren.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #9 Gepost op: 2008/07/06, 16:42:48 »
Hallo,


hier nog een foutmelding die ik kreeg:

wernerz@werner-laptop:~$ gksudo nautilus
Initializing nautilus-share extension

** (nautilus:7082): WARNING **: Unable to add monitor: De bewerking is niet mogelijk
SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSNautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' gaf fout 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Bestand of map bestaat niet
Please ask your system administrator to enable user sharing.

Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' gaf fout 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Bestand of map bestaat niet
Please ask your system administrator to enable user sharing.

Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' gaf fout 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Bestand of map bestaat niet
Please ask your system administrator to enable user sharing.


--- Hash table keys for warning below:
--> file:///

(nautilus:7082): Eel-WARNING **: "nautilus-metafile.c: metafiles" hash table still has 1 element at quit time (keys above)

(nautilus:7082): Eel-WARNING **: "nautilus-directory.c: directories" hash table still has 1 element at quit time
seahorse nautilus module shutdown
wernerz@werner-laptop:~$

Ik weet niet of het veel uitmaakt dat die slotjes er bij blijven staan. Van de home heb ik het slotje weg kunnen krijgen, als ik op een andere map met een slotje klik staat er als eigenaar root en daar kan ik niks aan veranderen zo te zien.

Groetjes,

Els

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #10 Gepost op: 2008/07/06, 19:04:57 »
Hallo,


nu heb ik dat slotje kunnen wegkrijgen bij de home en nu heeft hij die foutmelding weer bij het opstarten.

dit is de foutmelding:

"Uw bestand $HOME.dmrc heeft onjuiste toegangsrechten en wordt niet gebruikt. Hierdoor wordt de standaardsessie en -taal niet opgeslagen. Het bestand moet eigendom zijn van de gebruiker en moet de toegangsrechten: 644 hebben. De $HOME map moet eigendom zijn van de gebruiker en mag niet beschrijfbaar zijn door anderer gebruikers.

Ik heb er tot nog toe geen echte oplossing voor gevonden op mijn onderwerp van toen "Fout met rechten". Ik heb van pure miserie een nieuwe gebruiker aan moeten maken maar die heeft amper rechten, te zien aan al de slotjes bij de documenten.

Groetjes,

Els

Offline Drummies

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #11 Gepost op: 2008/07/06, 19:10:27 »
Els1980

in de door jezelf gestarte topic was dit de oplossing

http://translate.google.nl/translate?hl … D%26sa%3DG

http://forum.ubuntu-nl.org/message/275841#p275841
Gestopt als aktief Forumlid 17/10/2011

Offline vanadium

  • Lid
  • Steunpunt: Nee
Slotjes wegkrijgen bij mappen in bestandsbeheer
« Reactie #12 Gepost op: 2008/07/06, 19:19:59 »
Er zijn er al een twee, drietal die je gesignaleerd hebben in jou geval de slotjes te laten staan.

Achtergrond: op computer X heeft jou account "els" userid 1001. De bestanden die je naar de externe schijf kopieert, hebben userid 1001.

Op een andere computer heeft "els" userid 1000. Als je aan die computer je externe schijf koppelt, dan ziet die bestanden die eigenaar zijn van user 1001, niet van "els" met userid 1000. Dus heb je er geen schrijfrechten op.

Punt is dat een gebruiker specifiek is voor één operating system.

Wil je dat gebruiker "els" met uid 1000 op de andere computer eigenaar wordt van de bestanden die voor het ogenblik van user 1001 zijn (die mogelijk niet bestaat op de andere computer), dan moet je de bestanden van eigenaar veranderen.

Ondertussen heb ik wel oplossingen gezien voor je onderwerp van toen, "Fout met rechten". Staat in het vervolg van je draadje:

http://forum.ubuntu-nl.org/message/275835#p275835

Soms is het hijacken van een thread toch nog goed ...

Blijf zoveel mogelijk van de rechten van je ganse home directory af. Je loopt kans (zoals je zelf al enkele keren ervaarde) de werking van je systeem te beschadigen. Rechten veranderen van een datadirectory die enkel gebruikersgegevens bevat, daarentegen, beschadigt de werking van je systeem niet. Het geeft je enkel al dan niet toegang tot de data.