Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen PCM alsa (gnome-volume-control)  (gelezen 1915 keer)

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Gepost op: 2008/07/05, 17:22:20 »
Bij gnome-volume-control - en dan de alsa driver, daar heb ik alleen "Master" staan, maar dit werkt niet om de volume mee te beheren, zou PCM moeten zijn denk ik.



Betreft 8.04.1

Bij OSS staat volume, microfoon en cd.. die ik dus bij alsa wil zien.

Iemand met de oplossing?

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #1 Gepost op: 2008/07/05, 17:27:31 »
Al bij edit > preferences gekeken?

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #2 Gepost op: 2008/07/05, 17:31:21 »
Ja, daar staat ook alleen Master.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #3 Gepost op: 2008/07/05, 19:07:16 »
En na vlc geïnstalleerd is alleen OSS nog beschikbaar. Al het andere is verdwenen. Feest.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #4 Gepost op: 2008/07/05, 19:10:27 »
sudo apt-get install alsa-base
dpkg --configure alsa-base

Anders kan je ook nog altijd gnome-volume-control opnieuw installeren.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #5 Gepost op: 2008/07/05, 19:16:49 »
Citaat
sudo apt-get install alsa-base
dpkg --configure alsa-base
dennis@dennis-laptop:~$ sudo apt-get install alsa-base
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Statusinformatie wordt gelezen... Klaar
alsa-base is reeds de nieuwste versie.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
dennis@dennis-laptop:~$ sudo dpkg --configure alsa-base
dpkg: fout bij afhandelen van alsa-base (--configure):
 pakket alsa-base is reeds geïnstalleerd en geconfigureerd
Fouten gevonden tijdens behandelen van:
 alsa-base
dennis@dennis-laptop:~$
Edit: kmix geprobeerd, die geeft ook enkel oss weer.

Edit 2: onder Systeem-voorkeuren-geluid ook enkel oss.

Ik ga nu (weer) http://kubasik.net/blog/2008/03/31/sound-problems-in-ubuntu-hardy/ uitvoeren....

Edit 3: misschien ook handig te vermelden dat ik last heb van deze bug: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/192382

Edit 4: na de stappen van kubasik uitgevoerd te hebben krijg ik het volgende:


En nu heb ik helemaal geen geluid meer.

Wat ik hier allemaal doe is al voor de tweede keer. De vorige keer heb ik na deze laatste stap een herinstallatie gedaan.

Overigens, ik meen dat ik op de live-cd ook geen PCM controller had...

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #6 Gepost op: 2008/07/05, 20:25:45 »
Misschien zit hier iets in voor jou: http://forum.ubuntu-nl.org/message/201612#p201612
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #7 Gepost op: 2008/07/05, 21:25:47 »
Dank je voor je bericht.

Was ondertussen zelf aan de slag gegaan, en heb van de site van alsa de utils en plugin tar- bestanden gedownload, gecompileerd en geïnstalleerd.

Toen kreeg ik een nieuwe alsa kaart, MET pcm erbij!
Enkel geen geluid...
Heb toen de suggestie uitgevoerd zoals beschreven in je link, maar zonder resultaat.
Vervolgens alles uit mijn home map verwijderd (stonden geen eigen bestanden in, alleen de verborgen mappen.
En na de herstart klonk het ubuntu opstart geluid!!!

En jawel hoor, ik kan het volume weer aanpassen, geluid op internet doet het..

Daar ben ik dus blij mee.

Maar goed, ik spring nog geen gat in de lucht, ik kijk het eerst nog even aan om ie het morgen blijft doen, als ik mn zooi pakketjes ga installeren.

Ik houdt jullie op de hoogte, en nog bedankt voor de reacties.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Geen PCM alsa (gnome-volume-control)
« Reactie #8 Gepost op: 2008/07/06, 22:57:37 »
Ik had de regel options snd-hda-intel model=toshiba weggehaald. En toen had ik ineens geen geluid meer

Ben er dus achter gekomen dat die regel wel degelijk nodig is op mijn laptop. Mag ik je daarom nogmaals bedanken voor de link.