Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Letters niet scherp  (gelezen 870 keer)

Koblens

  • Gast
Letters niet scherp
« Gepost op: 2008/07/05, 15:25:41 »
Ubuntu 8.04 geinstalleerd maar krijg de letters niet mooi scherp. Vooral in Firefox is dat storend. Heb al van alles geprobeerd mbv dit forum (oa drivers verwijderen om Ubuntu zelf een geschikte driver te laten gebruiken) maar helaas nog geen resultaat. Mijn xorg.conf ziet er nu als volgt uit. Iemand een idee?

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   Fontpath   "/usr/share/fonts/X11/misc"
   Fontpath   "/usr/share/fonts/X11/cyrillic"
   Fontpath   "/usr/share/fonts/X11/100dpi/:unscaled"
   Fontpath   "/usr/share/fonts/X11/75dpi/:unscaled"
   Fontpath   "/usr/share/fonts/X11/Type1"
   Fontpath   "/usr/share/fonts/X11/100dpi"
   Fontpath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   Fontpath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load      "bitmap"
   Load      "ddc"
   Load      "dri"
   Load      "extmod"
   Load      "freetype"
   Load      "glx"
   Load      "int10"
   Load      "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "stylus"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "eraser"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "cursor"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI RADEON X1300"
   Busid      "PCI:1:0:0"
   Option      "UseFBDev"   "true"
EndSection

Section "Monitor"
   Identifier   "IYAMA PLE1900WS"
   Option      "DPMS"
   Horizsync   30-80
   Vertrefresh   50-75
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI RADEON X1300"
   Monitor      "IYAMA PLE1900WS"
   Defaultdepth   24
   SubSection "Display"
      Depth   1
      Modes      "1440x900"   "1280x1024"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   4
      Modes      "1440x900"   "1280x1024"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   8
      Modes      "1440x900"   "1280x1024"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   15
      Modes      "1440x900"   "1280x1024"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   16
      Modes      "1440x900"   "1280x1024"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   24
      Modes      "1440x900"   "1280x1024"   "1024x768"   "800x600"   "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   Inputdevice   "stylus"   "SendCoreEvents"
   Inputdevice   "cursor"   "SendCoreEvents"
   Inputdevice   "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Letters niet scherp
« Reactie #1 Gepost op: 2008/07/05, 15:33:18 »
Je hebt een "ouderwetse" xorg.conf, en dat is nogal merkwaardig. In 8.04 zou die veel beknopter moeten zijn en veel minder moeten regelen. Want 8.04 gebruikt een nieuw systeem voor herkenning van videokaart en beeldscherm.

Hoe komt dat?

Overigens heeft jouw probleem niet te maken met de xorg. Met het aanzetten van de subpixels, het installeren van True Type lettertypes en eventueel de alleen-tekstvergroting in Firefox, kom je er al, denk ik.

Kijk eens in deze lijst:
http://computertip.googlepages.com/directdoen
(vooral de nummers 3, 6 en 7).

Groet, Pjotr.

Koblens

  • Gast
Letters niet scherp
« Reactie #2 Gepost op: 2008/07/05, 16:02:25 »
Dankjewel voor je reactie.
Geen idee waarom mijn xorg.conf er zo uit ziet. Ik heb inderdaad ook gelezen dat het er in 8.04 anders uit "hoort" te zien. Waarom dat bij mij niet zo is weet ik niet.

Ik had al je tips al uitgeprobeerd voor ik mijn vraag gepost heb. Het gladmaken van de subpixels gaf het beste resultaat (hoewel ik geen LCD scherm heb) maar het is nog niet zo scherp als in Windows.  Nog andere mogelijkheden die ik kan proberen?

Offline joop905

  • Lid
  • Steunpunt: Nee
Letters niet scherp
« Reactie #3 Gepost op: 2008/07/05, 17:26:04 »
probeer het eens met msttcorefonts

sudo apt-get install msttcorefonts

GrJ.

Koblens

  • Gast
Letters niet scherp
« Reactie #4 Gepost op: 2008/07/05, 19:23:40 »
Tx. Uiteindelijk heeft het international forum uitkomst geboden (zoeken op 'fonts'). Het is voornamelijk een kwestie van spelen met de font-settings in zowel Firefox als Ubuntu. Er zijn veel verschillende instellingsmogelijkheden maar na een tijdje prutsen is het nu een stuk beter....

Gr, K