Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: server opstart probleem  (gelezen 901 keer)

vincent074

  • Gast
server opstart probleem
« Gepost op: 2008/07/04, 15:13:33 »
halo,

ik ben nieuw hier en heb me aangemeld op dit forum omdat ik een probleem heb met mijn ubuntu 8.04 LTS server versie.

ik heb dit geinstaleert op mijn server pc, dit is een compaq P4 met een scsi en een ide schijf.
hier meer info over mijn server:
http://www.sndhm.net/docs/compaq/products/servers/proliantml310/11446_div.html
http://www.sndhm.net/docs/compaq/products/servers/proliantml310/

de installatie ging zonder problemen.
maar toen die klaar was en ik moest rebooten kreeg ik de bekende 'non disk' error.

ik heb verschillende dingen geprobeert zoals de file system verandere naar ext2 ipv ext3 en toen dat niet werkte had ik het veranderd naar fs Reiser.
ik probeerde wat dingen aan te passen in de bios, maar dit hielp helaas ook niet.

alvast bedankt voor de hulp

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
server opstart probleem
« Reactie #1 Gepost op: 2008/07/04, 16:44:40 »
Volgens de Ubuntu site is deze server zelfs gecertificeerd om goed te werken met Ubuntu: http://webapps.ubuntu.com/certification/hardware/200712-184/

Heb je de BIOS wel ingesteld om op te starten van de goede harde schijf?
En welke foutmelding krijg je precies? Als ik zoek op google krijg ik dit:
"Uw zoekbewerking - proliant ml310 ubuntu "non disk" - heeft geen overeenkomstige documenten opgeleverd"
Zo bekend is die foutmelding dus niet, of je hebt een spelfout gemaakt.

vincent074

  • Gast
server opstart probleem
« Reactie #2 Gepost op: 2008/07/04, 19:21:08 »
ja sorry ik wist niet meer precies wat er stond, maar het kwam er dus op neer dat er geen harde schijf in zat waar van die kon booten. ik zal hem wel weer eventjes aan sluiten om te bekijken wat die 'precies' voor een melding geeft.

vincent074

  • Gast
server opstart probleem
« Reactie #3 Gepost op: 2008/07/06, 16:42:19 »
ik heb wat nieuwe dingen geprobeert en het vorige probleem even opgeschreven.

de server geeft het volgende weer tijdens het booten:
'non-system disk or disk error
replace and strike any key when ready'

ik ben er achter gekomen dat je tijdens de schijf indeling onder de installatie de optie 'opstartbaar-vlag' aan moet zetten.

toen ik dit gedaan had en vervolgens reboote leek het even of die opstarte maar hij bleef hangen op 'attempting to boot from hard disk ( c: )
ik heb het zelfde geprobeert via de linux cd, hier kun je de optie 'opstarten van eerste hardeschijf' kiezen, toen ik dit deed kwam die met een soort gelijke melding 'booting from local disk'  vervolgens bleef die hier ook hangen.

wat ik hier boven heb uitgelegd heb ik geprobeert op de scsi schijf want als ik op de IDE schijf linux ging instaleren probeert die niet eens te booten van de harddisk en slaat die het gewoon over, in de bios is ook nergens te vinden of aan te passen dat die van IDE opstart.

tot slot is het mischien wel handig om te weten dat ik gebruik maak SCSI controller: HP smart array 532 controller

alvast bedankt voor de hulp

EDIT: ik ben er achter gekomen dat het met RAID te maken heeft, heb het nog niet opgelost maar zal wel posten wat het is voor het geval andere mensen het zelfde probleem ooit krijgen.

EDIT2:  het bleek dus tog niet door RAID te komen, maar door die HP smart array 532 controller
ik zat veels te moeilijk te denken, ik heb deze verwijderd en de scsi direct op het moederbord aangesloten, na een firsse installatie deed hij het eindelijk :)